bash-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598
  1. %define bashversion 5.1
  2. %define patchlevel 16
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 1%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Packager: daisuke
  12. License: GPLv3+
  13. Source0: http://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-001
  17. Patch2: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-002
  18. Patch3: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-003
  19. Patch4: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-004
  20. Patch5: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-005
  21. Patch6: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-006
  22. Patch7: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-007
  23. Patch8: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-008
  24. Patch9: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-009
  25. Patch10: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-010
  26. Patch11: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-011
  27. Patch12: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-012
  28. Patch13: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-013
  29. Patch14: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-014
  30. Patch15: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-015
  31. Patch16: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash51-016
  32. # Other patches
  33. Patch102: bash-2.03-paths.patch
  34. Patch103: bash-2.03-profile.patch
  35. Patch104: bash-2.05a-interpreter.patch
  36. Patch105: bash-2.05b-debuginfo.patch
  37. Patch107: bash-2.05b-pgrp_sync.patch
  38. Patch110: bash-3.2-audit.patch
  39. Patch111: bash-3.2-ssh_source_bash.patch
  40. Patch113: bash-infotags.patch
  41. Patch114: bash-requires.patch
  42. Patch115: bash-setlocale.patch
  43. Patch116: bash-tty-tests.patch
  44. # 484809, check if interp section is NOBITS
  45. Patch117: bash-4.0-nobits.patch
  46. # Do the same CFLAGS in generated Makefile in examples
  47. Patch118: bash-4.1-examples.patch
  48. # Builtins like echo and printf won't report errors
  49. # when output does not succeed due to EPIPE
  50. Patch119: bash-4.1-broken_pipe.patch
  51. # Enable system-wide .bash_logout for login shells
  52. Patch120: bash-4.2-rc2-logout.patch
  53. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  54. Patch121: bash-4.2-coverity.patch
  55. # 799958, updated info about trap
  56. Patch123: bash-4.2-manpage_trap.patch
  57. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  58. Patch125: bash-4.2-size_type.patch
  59. # 1112710 - mention ulimit -c and -f POSIX block size
  60. Patch128: bash-4.3-man-ulimit.patch
  61. # 1102815 - fix double echoes in vi visual mode
  62. Patch135: bash-4.3-noecho.patch
  63. #1241533,1224855 - bash leaks memory when LC_ALL set
  64. Patch138: bash-4.3-memleak-lc_all.patch
  65. # bash-4.4 builds loadable builtin examples by default
  66. # this patch disables it
  67. Patch140: bash-4.4-no-loadable-builtins.patch
  68. Buildroot: %{_tmppath}/%{name}-%{version}-root
  69. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  70. Obsoletes: bash <= 1.14.7
  71. Obsoletes: bash2
  72. %description
  73. Bash is a GNU project sh-compatible shell or command language
  74. interpreter. Bash (Bourne Again shell) incorporates useful features
  75. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  76. can be run by bash without modification.
  77. Bash offers several improvements over sh, including command line
  78. editing, unlimited size command history, job control, shell
  79. functions and aliases, indexed arrays of unlimited size and
  80. integer arithmetic in any base from two to 64. Bash is ultimately
  81. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  82. Tools standard.
  83. %package doc
  84. Summary: Documentation for the GNU Bourne Again shell (bash).
  85. Summary(ja): GNU Bourne Again シェル向けドキュメント
  86. Group: documentation
  87. Requires: %{name} = %{version}-%{release}
  88. Obsoletes: bash2-doc
  89. %description doc
  90. This is a separate documentation package for the GNU Bourne
  91. Again shell.
  92. %debug_package
  93. %prep
  94. %setup -q -n %{name}-%{bashversion}
  95. # Official upstream patches
  96. %patch1 -p0 -b .001
  97. %patch2 -p0 -b .002
  98. %patch3 -p0 -b .003
  99. %patch4 -p0 -b .004
  100. %patch5 -p0 -b .005
  101. %patch6 -p0 -b .006
  102. %patch7 -p0 -b .007
  103. %patch8 -p0 -b .008
  104. %patch9 -p0 -b .009
  105. %patch10 -p0 -b .010
  106. %patch11 -p0 -b .011
  107. %patch12 -p0 -b .012
  108. %patch13 -p0 -b .013
  109. %patch14 -p0 -b .014
  110. %patch15 -p0 -b .015
  111. %patch16 -p0 -b .016
  112. # Other patches
  113. %patch102 -p1 -b .paths
  114. %patch103 -p1 -b .profile
  115. %patch104 -p1 -b .interpreter
  116. %patch105 -p1 -b .debuginfo
  117. %patch107 -p1 -b .pgrp_sync
  118. %patch110 -p1 -b .audit
  119. %patch111 -p1 -b .ssh_source_bash
  120. %patch113 -p1 -b .infotags
  121. %patch114 -p1 -b .requires
  122. %patch115 -p1 -b .setlocale
  123. %patch116 -p1 -b .tty_tests
  124. %patch117 -p1 -b .nobits
  125. %patch118 -p1 -b .examples
  126. %patch119 -p1 -b .broken_pipe
  127. %patch120 -p1 -b .logout
  128. %patch121 -p1 -b .coverity
  129. %patch123 -p1
  130. %patch125 -p1 -b .size_type
  131. %patch128 -p1 -b .ulimit
  132. %patch135 -p1 -b .noecho
  133. %patch138 -p1 -b .lc_all
  134. %patch140 -p1 -b .no_loadable_builtin
  135. echo %{version} > _distribution
  136. echo %{release} |sed 's/vl.*//' > _patchlevel
  137. %build
  138. %configure --with-bash-malloc=no
  139. make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
  140. %install
  141. rm -rf %{buildroot}
  142. # Fix bug #83776
  143. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  144. make DESTDIR=$RPM_BUILD_ROOT install
  145. pushd $RPM_BUILD_ROOT
  146. mkdir ./bin
  147. mv ./usr/bin/bash ./bin/bash
  148. ln -s bash ./bin/sh
  149. rm -f .%{_infodir}/dir
  150. popd
  151. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  152. # make manpages for bash builtins as per suggestion in DOC/README
  153. pushd doc
  154. sed -e '
  155. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  156. /^\.SH NAME/d
  157. s/^bash, //
  158. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  159. s/,//g
  160. b
  161. }
  162. d
  163. ' builtins.1 > man.pages
  164. for i in echo pwd test kill; do
  165. perl -pi -e "s,$i,,g" man.pages
  166. perl -pi -e "s, , ,g" man.pages
  167. done
  168. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  169. for i in `cat man.pages` ; do
  170. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  171. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  172. done
  173. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  174. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  175. # Not for printf, false and true (conflict with coreutils)
  176. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  177. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  178. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  179. popd
  180. %find_lang %{name}
  181. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  182. %clean
  183. rm -rf %{buildroot}
  184. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  185. # to prevent prereq loops
  186. # post is in lua so that we can run it without any external deps. Helps
  187. # for bootstrapping a new install.
  188. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  189. %post -p <lua>
  190. bashfound = false;
  191. shfound = false;
  192. f = io.open("/etc/shells", "r");
  193. if f == nil
  194. then
  195. f = io.open("/etc/shells", "w");
  196. else
  197. repeat
  198. t = f:read();
  199. if t == "/bin/bash"
  200. then
  201. bashfound = true;
  202. end
  203. if t == "/bin/sh"
  204. then
  205. shfound = true;
  206. end
  207. until t == nil;
  208. end
  209. f:close()
  210. f = io.open("/etc/shells", "a");
  211. if not bashfound
  212. then
  213. f:write("/bin/bash\n")
  214. end
  215. if not shfound
  216. then
  217. f:write("/bin/sh\n")
  218. end
  219. f:close()
  220. %files -f %{name}.lang
  221. %defattr(-,root,root)
  222. %license COPYING
  223. %doc CHANGES
  224. %doc examples
  225. %config(noreplace) /etc/bashrc
  226. /bin/bash
  227. /bin/sh
  228. %{_infodir}/bash.info*
  229. %{_mandir}/*/*
  230. %{_mandir}/*/..1*
  231. %{_bindir}/bashbug
  232. %files doc
  233. %defattr(-,root,root)
  234. %doc COMPAT NEWS NOTES POSIX RBASH
  235. %doc examples/functions/ examples/misc/
  236. %doc examples/scripts*/
  237. %doc examples/startup-files/ examples/complete/ examples/loadables/
  238. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  239. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  240. %changelog
  241. * Fri Jan 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.16-1
  242. - updated to 5.1 patch level 16.
  243. * Wed Dec 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.12-1
  244. - updated to 5.1 patch level 12.
  245. * Thu Sep 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.8-1
  246. - updated to 5.1 patch level 8.
  247. - updated patches.
  248. * Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.18-1
  249. - updated to 5.0 patch level 18.
  250. * Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
  251. - updated to 5.0 patch level 16.
  252. * Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.11-1
  253. - updated to 5.0 patch level 11.
  254. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
  255. - updated to 5.0 patch level 9.
  256. - dropped Patch101, 106, 108, 109, 112, 122, 134, 137 and 139.
  257. - imported Patch140 from rawhide.
  258. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.46-1
  259. - updated to 4.3 patch level 46.
  260. * Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
  261. - updated to 4.3 patch level 42.
  262. - imported patch 128-139 from RawHide.
  263. * Fri Oct 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
  264. - updated to 4.3 patch level 29.
  265. - removed patch1000 (included in 4.3.26).
  266. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
  267. - added patch1000 to fix CVE-2014-7169.
  268. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
  269. - updated to 4.3 patch level 25.
  270. * Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
  271. - update to 4.3 patch level 18
  272. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  273. - update to 4.3 patch level 11
  274. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  275. - update to 4.2 patch level 45
  276. - import some patch from fedora package (122-127)
  277. - patch122: Don't call malloc in signal handler
  278. - patch123: #799958, updated info about trap
  279. - patch124: #695656, block the signal and unblock it after the
  280. new handler is installed
  281. - patch125: Use unsigned type for size
  282. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  283. - patch126: #903833, Fix missing close(), fixes fd leaks
  284. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  285. - remove postun lua script because bash will be never uninstalled
  286. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  287. - update to 4.2 patch level 37
  288. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  289. - update to 4.2 patch level 20
  290. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  291. - update to 4.2 patch level 8
  292. - use lua script in post/postun
  293. - update patches from fedora
  294. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  295. - update to 4.1 patch level 7
  296. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  297. - check if /bin/grep exists on %%post script
  298. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  299. - rebuilt with gcc-4.4.3-3 on ppc
  300. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  301. - rebuilt with new toolchain
  302. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  303. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  304. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  305. - add Requires(post): grep
  306. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  307. - remove obsolete /bin/bash2 entry from /etc/shells
  308. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  309. - add Requires(post): ncurses (should be added by find-requires..)
  310. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  311. - add upstream patch (from 040 to 048)
  312. - build against ncurses-devel (libtinfo)
  313. - spec in utf-8
  314. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  315. - added upstream patch (from 026 to 039)
  316. - added Japanese summary
  317. - applied new versioning policy
  318. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  319. - rebuilt with libtermcap-devel
  320. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  321. - new upstream release
  322. - add upstream patch (from 001 to 025)
  323. - remove Provides: bash2
  324. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  325. - rebuilt with new toolchain
  326. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  327. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  328. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  329. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  330. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  331. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  332. - update to 2.05b
  333. - rebuild with new toolchains
  334. - add make check
  335. - add %postun script based on Fedora development
  336. - README file moved doc package
  337. - update Patch5 and Patch8 from Fedora development
  338. - change Patch6
  339. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  340. - add Patch11--39 from Fedora development 2.05b-36
  341. * Tim Waugh <twaugh@redhat.com>
  342. - Fix parameter expansion in multibyte locales (bug #112657).
  343. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  344. bug #110777).
  345. - Apply upstream patches (bug #109269 among others).
  346. - Fix bash.info (bug #83776).
  347. - Add bash205b-007 patch to fix bug #106876.
  348. - Avoid crashing on multibyte input when locale is set incorrectly
  349. (bug #74266).
  350. - LFS support (bug #103627).
  351. - Fix completion display when multibyte or control characters are to be
  352. shown (bug #90201).
  353. - Fix a warning message (bug #79629).
  354. - Don't build with AFS support (bug #86514).
  355. - Don't explicitly strip binaries (bug #85995).
  356. - Really fix bug #83331 for good.
  357. - Fix builtins.1.
  358. - Actually apply the patch (bug #83331).
  359. - Fix history/UTF-8 bug (bug #83331).
  360. - More tab-completion fixing (bug #72512).
  361. - Force pgrp synchronization (bug #81653).
  362. - Prevent prompt overwriting output (bug #74383).
  363. - Fix '-rbash' (bug #78455).
  364. - Add readline-init patch (bug #74925).
  365. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  366. - Ship '.' man page, which doesn't get picked up by glob.
  367. - Locale shell variables fix (bug #74701).
  368. * Elliot Lee <sopwith@redhat.com>
  369. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  370. cross compiles.
  371. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  372. - update to 2.05
  373. - add README.jpatch to %doc
  374. - remove patch4 (bash2): revert command name in man pages to "bash"
  375. - fix perl command to remove man pages conflict with sh-utils
  376. - remove section of config.h.in from patch0 to prevent remake of configure
  377. - change patch9: define in config-top.h to avoid conflict with patch100
  378. - remove patches 7, 10 & 101
  379. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  380. - made a link for man sh
  381. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  382. - added missing %%post and %%triggerpostun section
  383. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  384. - 2.04-1vl12
  385. - now bash2 is finally bash
  386. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  387. - build for Playstation2
  388. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  389. - 2.04-1vl10
  390. - Provides: bash = %%{version}
  391. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  392. - added Provides: bash
  393. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  394. - Obsoletes: bash
  395. - changed Copyright to License
  396. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  397. - 2.04-1vl7
  398. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  399. - corrected: bashrc-vine -> bashrc
  400. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  401. - combined bash-1.x and bash-2.x packages
  402. - added some patches from bash-2.04-13mdk
  403. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  404. - fix spec macros
  405. - added tests
  406. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  407. - build with gcc-2.95.3
  408. - partially used rpmmacros
  409. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  410. - minor bug fix in spec file
  411. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  412. - 2.04-1vl3
  413. - modified %install and %files section to handle compressed man page(s)
  414. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  415. - added pcomplete patch to fix complete if the candidate list is NULL.
  416. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  417. - updated to 2.04
  418. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  419. - Remove annoying ^H's from documentation
  420. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  421. - patch to detect what executables are required by a script.
  422. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  423. - auto rebuild in the new build environment (release 4)
  424. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  425. - strip binaries.
  426. - include bash-doc correctly.
  427. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  428. - fixed post/postun /etc/shells work.
  429. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  430. - updated again text in the spec file
  431. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  432. - updated text in spec file.
  433. - update to 2.03.
  434. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  435. - build it as bash2 instead of bash
  436. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  437. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  438. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  439. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  440. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  441. - patch for the arm
  442. - use $RPM_ARCH-redhat-linux as the build target
  443. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  444. - rewrite %pre, axe %postun (to avoid prereq loops)
  445. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  446. - resurrect for RH 6.0.
  447. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  448. - update to 2.02.1
  449. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  450. - Package for 5.2.
  451. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  452. - added POSIX.NOTES doc file
  453. - some extraneous doc files removed
  454. - minor .spec file changes
  455. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  456. - upgraded to version 2.02
  457. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  458. - glibc & signal patches no longer required
  459. - added documentation subpackage (doc)
  460. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  461. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  462. is based on a change made in bash 2.0. Should fix some early exit
  463. problems with suspends and fg.
  464. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  465. - added %clean
  466. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  467. - added comment explaining why install-info isn't used
  468. - added mips patch
  469. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  470. - added BuildRoot
  471. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  472. - built against glibc