unixODBC-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316
  1. Name: unixODBC
  2. Version: 2.3.11
  3. Release: 1%{?_dist_release}
  4. Summary: A complete ODBC Driver Manager for Linux
  5. Summary(ja): Linux 用 ODBC ドライバマネージャー
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. # Programs are GPL, libraries are LGPL, except News Server library is GPL.
  10. License: GPLv2+ and LGPLv2+
  11. URL: http://www.unixODBC.org/
  12. Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
  13. Source1: odbcinst.ini
  14. Source4: conffile.h
  15. Source5: README.dist
  16. Patch8: so-version-bump.patch
  17. Patch9: keep-typedefs.patch
  18. Conflicts: iodbc
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
  21. BuildRequires: readline-devel
  22. %description
  23. Install unixODBC if you want to access databases through ODBC.
  24. You will also need the mysql-connector-odbc package if you want to access
  25. a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
  26. %package devel
  27. Summary: Development files for programs which will use the unixODBC library.
  28. Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
  29. Group: programming
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. The unixODBC package can be used to access databases through ODBC
  33. drivers. If you want to develop programs that will access data through
  34. ODBC, you need to install this package.
  35. %debug_package
  36. %prep
  37. %setup -q
  38. %patch8 -p1
  39. %patch9 -p1
  40. chmod 0644 Drivers/MiniSQL/*.c
  41. chmod 0644 Drivers/nn/*.c
  42. chmod 0644 Drivers/template/*.c
  43. chmod 0644 doc/ProgrammerManual/Tutorial/*.html
  44. chmod 0644 doc/lst/*
  45. chmod 0644 include/odbcinst.h
  46. %build
  47. autoreconf -ivf
  48. # unixODBC 2.2.14 is not aliasing-safe
  49. CFLAGS="%{optflags} -fno-strict-aliasing"
  50. CXXFLAGS="$CFLAGS"
  51. export CFLAGS CXXFLAGS
  52. %configure --with-gnu-ld=yes --enable-threads=yes \
  53. --enable-drivers=yes --enable-driverc=yes
  54. # Get rid of the rpaths
  55. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  56. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  57. make all
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. make DESTDIR=$RPM_BUILD_ROOT install
  61. install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
  62. # multilib header hacks
  63. # we only apply this to known Red Hat multilib arches, per bug #181335
  64. case `uname -i` in
  65. i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
  66. mv $RPM_BUILD_ROOT%{_includedir}/unixODBC/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixODBC/unixodbc_conf_`uname -i`.h
  67. rm -f unixodbc_conf.h
  68. sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
  69. install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixODBC/
  70. ;;
  71. *)
  72. ;;
  73. esac
  74. # add some explanatory documentation
  75. cp %{SOURCE5} README.dist
  76. # remove obsolete Postgres drivers from the package (but not the setup code)
  77. rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
  78. # make directory for unversioned plugins
  79. mkdir $RPM_BUILD_ROOT%{_libdir}/%{name}
  80. # copy text driver documentation into main doc directory
  81. # currently disabled because upstream no longer includes text driver
  82. # mkdir -p doc/Drivers/txt
  83. # cp -pr Drivers/txt/doc/* doc/Drivers/txt
  84. # don't want to install doc Makefiles as docs
  85. find doc -name 'Makefile*' | xargs rm
  86. # we do not want to ship static libraries
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  88. # remove unpackaged files from the buildroot
  89. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  90. rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
  91. rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
  92. # initialize lists of .so files
  93. find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
  94. find $RPM_BUILD_ROOT%{_libdir} -name "*.so" | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %files -f base-so-list
  98. %license COPYING
  99. %doc README AUTHORS ChangeLog NEWS doc
  100. %doc README.dist
  101. %config(noreplace) %{_sysconfdir}/odbc*
  102. %{_bindir}/odbcinst
  103. %{_bindir}/isql
  104. %{_bindir}/dltest
  105. %{_bindir}/iusql
  106. %{_bindir}/odbc_config
  107. %{_bindir}/slencheck
  108. %{_mandir}/man*/*
  109. %files devel -f devel-so-list
  110. %{_includedir}/*
  111. %{_libdir}/pkgconfig/*.pc
  112. %changelog
  113. * Fri Sep 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.11-1
  114. - new upstream release.
  115. - updated Patch8.
  116. * Sat Mar 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.9-1
  117. - new upstream release.
  118. - dropped scriptlets.
  119. - updated odbcinst.ini.
  120. * Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 2.3.7-2
  121. - rebuild with readline-8.0
  122. * Wed Dec 12 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.7-1
  123. - new upstream release.
  124. - dropped Patch6: fixed in upstream.
  125. * Sat Jan 20 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.5-1
  126. - new upstream release.
  127. * Tue Jan 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
  128. - new upstream release.
  129. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
  130. - rebuilt with readline 6.3
  131. - removed kde-subpackage-related BuildRequires
  132. - added Japanese summary
  133. * Tue Jul 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
  134. - new upstream release.
  135. - gui was discontinued in upstream.
  136. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
  137. - rebuild with VineSeed environment
  138. * Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
  139. - add --with-qt-includes option for configure
  140. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
  141. - updated to 2.2.14
  142. * Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
  143. - applied new versioning policy
  144. - removed *.la files from devel package
  145. * Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
  146. - updated to 2.2.12
  147. - rebuilt with new toolchain
  148. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
  149. - use installed libltdl
  150. - added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
  151. * Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
  152. - rebuilt with readline 5.1
  153. * Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
  154. - updated to 2.2.11
  155. - not libtoolize
  156. * Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
  157. - added Patch100 to fix typo in doc/Makefile.am from failure on compiling
  158. * Fri Jun 6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
  159. - source upgrade
  160. - remove patch (no need)
  161. - run libtoolize etc for VineSeed
  162. * Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
  163. - enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
  164. * Sun Feb 9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
  165. - source upgrade
  166. - change spec to build both VineSeed and Vine2.5/2.6
  167. - add patch from rawhide 2.2.3-6
  168. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
  169. - Requires: libjpeg (not libjpeg-6b)
  170. * Sun Oct 6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
  171. - source upgrade
  172. - add BuildPrereq: autoconf253 automake15
  173. - add PreReq: ldconfig
  174. - fix %files section and clean up spec
  175. - for unixODBC-kde package
  176. - add Requires: unixODBC = %{version}
  177. - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
  178. - delete .desktop files
  179. * Thu Apr 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
  180. - rebuild with KDE3
  181. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
  182. - updated unixODBC-2.2.0
  183. - fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
  184. * Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
  185. - remove -kde package on alpha
  186. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
  187. - Rebuild for Vine.
  188. * Sun Jun 24 2001 Than Ngo <than@redhat.com>
  189. - rebuild against qt-2.3.1, kde-2.1.x
  190. * Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
  191. - Better default odbcinst.ini
  192. - Minor cleanups
  193. * Wed Jun 6 2001 Trond Eivind Glomsrød <teg@redhat.com>
  194. - 2.0.7
  195. * Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
  196. - Fix for isql segfault on EOF/ctrl-d exit
  197. * Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
  198. - 2.0.6
  199. - add patch for 64 bit archs (dword shouldn't be "long int")
  200. * Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
  201. - rebuild
  202. * Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  203. - 1.8.13
  204. * Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
  205. - enable GUI now that we have KDE compiled with the standard
  206. compiler
  207. - move the applnk entries to the KDE package
  208. * Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  209. - add the missing shared libs to the non-devel package
  210. * Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
  211. - 1.8.12 fixes problems with the postgresql driver
  212. * Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
  213. - disable KDE subpackage to avoid the mess that is C++ binary
  214. compatibility
  215. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  216. - automatic rebuild
  217. * Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
  218. - improved QTDIR detection
  219. * Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  220. - 1.8.10
  221. - use %%{_tmppath}
  222. - update URL
  223. - including two missing libraries
  224. * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
  225. - 1.8.9
  226. * Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
  227. - adopted for Winston, changed to Red Hat packaging standards
  228. * Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
  229. - added a unixODBC-devel RPM to the group, added KDE links and icons to system
  230. - all of which came from recommendations from Fredrick Meunier
  231. - <Fredrick.Meunier@computershare.com.au>
  232. * Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
  233. - unixODBC-1.8.7
  234. - moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.