file-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435
  1. %define __libtoolize :
  2. Summary: A utility for determining file types.
  3. Summary(ja): ファイルの種類を判別するユーティリティー
  4. Name: file
  5. Version: 5.40
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: BSD
  12. URL: http://www.darwinsys.com/file/
  13. # master site is toooooooooooooooooo slow
  14. # Source0: ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
  15. %define altver %(echo %{version} | sed -e 's/\\./_/')
  16. Source0: https://github.com/file/file/archive/FILE%{altver}.tar.gz#/file-FILE%{altver}.tar.gz
  17. # Addtional magic file for Vine
  18. Source10: magic.printer-j
  19. # Upstream says it's up to distributions to add a way to support local-magic.
  20. Patch0: file-localmagic.patch
  21. # not yet upstream
  22. Patch3: file-4.17-rpm-name.patch
  23. Patch4: file-5.04-volume_key.patch
  24. # Vine
  25. Patch1000: file-5.14-magicbuild-fix.patch
  26. Buildroot: %{_tmppath}/%{name}-%{version}-root
  27. #BuildRequires: automake
  28. #BuildRequires: autoconf
  29. BuildRequires: zlib-devel
  30. Obsoletes: file-static
  31. %description
  32. The file command is used to identify a particular file according to the
  33. type of data contained by the file. File can identify many different
  34. file types, including ELF binaries, system libraries, RPM packages, and
  35. different graphics formats.
  36. You should install the file package, since the file command is such a
  37. useful utility.
  38. %description -l ja
  39. file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
  40. どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
  41. ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
  42. を含む、多くの異なるファイルの種類を見分けることができます。
  43. %package devel
  44. Summary: Libraries and header files for file development
  45. Summary(ja): libmagic の開発用ファイル
  46. Group: programming
  47. Requires: %{name} = %{version}-%{release}
  48. %description devel
  49. The file-devel package contains the header files and libmagic library
  50. necessary for developing programs using libmagic.
  51. %package -n python-magic
  52. Summary: Python bindings for the libmagic API
  53. Group: programming
  54. BuildRequires: python-devel
  55. BuildRequires: python-setuptools
  56. BuildRequires: python-rpm-macros
  57. Requires: %{name} = %{version}-%{release}
  58. %description -n python-magic
  59. This package contains the Python bindings to allow access to the
  60. libmagic API. The libmagic library is also used by the familiar
  61. file(1) command.
  62. %package -n python3-magic
  63. Summary: Python bindings for the libmagic API
  64. Group: programming
  65. BuildRequires: python3-devel
  66. BuildRequires: python3-setuptools
  67. BuildRequires: python3-rpm-macros
  68. Requires: %{name} = %{version}-%{release}
  69. %description -n python3-magic
  70. This package contains the Python bindings to allow access to the
  71. libmagic API. The libmagic library is also used by the familiar
  72. file(1) command.
  73. %debug_package
  74. %prep
  75. %setup -q -n file-FILE%{altver}
  76. autoreconf -ivf
  77. # Don't use -b -- it will lead to problems when compiling magic file!
  78. %patch0 -p1
  79. %patch3 -p1
  80. %patch4 -p1
  81. # Vine
  82. %patch1000 -p1
  83. cat %{SOURCE10} >> ./magic/Localstuff
  84. iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
  85. touch -r doc/libmagic.man doc/libmagic.man_
  86. mv doc/libmagic.man_ doc/libmagic.man
  87. %build
  88. autoreconf
  89. CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
  90. %configure --enable-fsect-man5 --disable-rpath
  91. # remove hardcoded library paths from local libtool
  92. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  93. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  94. export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
  95. make
  96. cd python
  97. %py_build
  98. %py3_build
  99. %install
  100. rm -rf $RPM_BUILD_ROOT
  101. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  102. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  103. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
  104. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
  105. mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
  106. mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
  107. make install DESTDIR=$RPM_BUILD_ROOT
  108. cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  109. ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  110. ##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  111. ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
  112. cd python
  113. %py_install
  114. %py3_install
  115. %{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
  116. # LIBTOOL=/usr/bin/libtool
  117. #ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  118. #ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  119. #ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  120. #{ cd ${RPM_BUILD_ROOT}
  121. # strip .%{_bindir}/file
  122. # cp %SOURCE1 .%{_datadir}/magic.mime
  123. #}
  124. # remove unuse files
  125. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  126. %clean
  127. rm -rf $RPM_BUILD_ROOT
  128. %files
  129. %defattr(-,root,root)
  130. %license COPYING
  131. %doc ChangeLog README
  132. %{_bindir}/*
  133. %{_libdir}/libmagic.so.*
  134. %{_datadir}/file/*
  135. %{_datadir}/magic*
  136. %{_datadir}/misc/*
  137. %{_mandir}/man[15]/*
  138. %files devel
  139. %defattr(-,root,root,-)
  140. %{_libdir}/*.so
  141. %{_libdir}/pkgconfig/*
  142. %{_includedir}/magic.h
  143. %{_mandir}/man3/*
  144. %files -n python-magic
  145. %defattr(-, root, root, -)
  146. %license python/LICENSE
  147. %doc python/README* python/example.py
  148. %{python_sitelib}/magic.py
  149. %{python_sitelib}/magic.pyc
  150. %{python_sitelib}/magic.pyo
  151. %{python_sitelib}/*egg-info
  152. %files -n python3-magic
  153. %defattr(-, root, root, -)
  154. %license python/LICENSE
  155. %doc python/README* python/example.py
  156. %{python3_sitelib}/*
  157. %changelog
  158. * Wed Apr 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.40-1
  159. - new upstream release.
  160. - dropped ldconfig scriptlets.
  161. * Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.39-1
  162. - new upstream release.
  163. - dropped Patch14 and 9000: fixed in upstream.
  164. * Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-2
  165. - added Patch9000.
  166. * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-1
  167. - new upstream release.
  168. - added python3 support.
  169. - updated Patch0.
  170. - dropped Patch1, 5-17 and 100: fixed in upstream.
  171. - imported Patch14 from rawhide.
  172. * Thu Jul 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.28-1
  173. - new upstream release.
  174. - dropped Patch200: fixed in upstream.
  175. - updated patches.
  176. - imported Patch15,17 and 100.
  177. * Sat Nov 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.20-1
  178. - new upstream release
  179. - update/drop patches based on fc22
  180. * Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.14-7
  181. - reflected 6.0 updates and bumped release
  182. * Thu Sep 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-6
  183. - drop patch230 (moved to patch320)
  184. - add Patch240 for fix CVE-2014-0207
  185. - add Patch250 for fix CVE-2014-0237
  186. - add Patch260 for fix CVE-2014-0238
  187. - add Patch270 for fix CVE-2014-3478
  188. - add Patch280 for fix CVE-2014-3479
  189. - add Patch290 for fix CVE-2014-3480
  190. - add Patch300 for fix CVE-2014-3487
  191. - add Patch310 for fix CVE-2014-3538
  192. - add Patch320 for fix CVE-2014-3587
  193. These patches are from debian/ubuntu, thanks.
  194. * Thu Aug 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-5
  195. - add patch230 for fix CVE-2014-3587 (cdf_read_property_info)
  196. * Thu Mar 27 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-4
  197. - add patch110,220 for fix regression of CVE-2014-2270
  198. * Wed Mar 12 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-3
  199. - add patch210 for fix CVE-2014-2270
  200. * Thu Feb 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-2
  201. - add patch200 for fix CVE-2014-1943
  202. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.14-2
  203. - rebuild with VineSeed environment
  204. * Sun Sep 22 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-1
  205. - new upstream reelase
  206. - add patch100 to fix build error
  207. - remove -static subpackage and add Obs: file-static
  208. - fix old changelog date...
  209. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
  210. - new upstream reelase
  211. - drop all local patches
  212. - import fedora patches
  213. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
  214. - rebuild with python-2.7.2
  215. * Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
  216. - rebuild package
  217. - fix Patch100
  218. * Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
  219. - new upstream release
  220. - updated Vine patches (but Patch100 has not been ported yet...)
  221. - split to devel and static subpackcages
  222. * Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
  223. - rebuilt with rpm-4.8.1
  224. - add environment variable LIBTOOL for make command
  225. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
  226. - spec in utf-8
  227. - removed *.la
  228. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
  229. - applied new versioning policy
  230. * Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
  231. - new upstream release
  232. - import debian/fedora patches
  233. - drop obsolete vine magic.
  234. * Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
  235. - rebuild for VineSeed with new tool chain
  236. * Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
  237. - add patch110 for fix CVE-2007-2799
  238. - add zlib-devel to BuildPreReq tag
  239. * Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
  240. - add patch100 for fix CVE-2007-1536
  241. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
  242. - changed Group to Applications/System
  243. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
  244. - new upstream release
  245. - update vine patches
  246. * Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
  247. - update Patch10, use 'size_t' in src/jcode.[ch]
  248. * Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
  249. - update to 4.03
  250. - update Patch0, 1, 10 for 4.03
  251. - s/Copyright/License/
  252. * Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
  253. - update to 4.02
  254. - update Vine patches for 4.02
  255. * Sun Mar 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
  256. - new upstream release
  257. - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
  258. - remove unneeded patches.
  259. - update Vine patches for 3.41
  260. * Mon Apr 1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
  261. - added NPDL2 data [Vine:02348]
  262. * Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
  263. - update to 3.37
  264. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  265. - 3.35-0vl3
  266. - disable some entries in elf for problems on big-endian archs
  267. * Wed Jun 6 2001 Jun Nishii <jun@vinelinux.org>
  268. - file-3.35-0vl1
  269. - ver.up
  270. - added %doc
  271. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  272. - file-3.33-1vl4
  273. - more fix and clean up jtext patch (file-3.33-vinejtext.patch)
  274. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  275. - file-3.33-1vl3
  276. - fix again jtext patch (file-3.33-vinejtext.patch)
  277. - added file-3.33-vinenames.patch to avoid miss-judgement
  278. * Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
  279. - file-3.33-1vl2
  280. - update jtext patch (file-3.33-vinejtext.patch)
  281. * Mon Jan 8 2001 Jun Nishii <jun@vinelinux.org>
  282. - file-3.33-1vl1
  283. - modify description-ja and spec
  284. * Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  285. - file-3.28-2vl2
  286. - fixed %files section to handle compressed man pages
  287. * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
  288. - marged RH 3.28-2 and Vine 3.27-3vl3
  289. * Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
  290. - add ia64 patch from rth
  291. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  292. - handle compressed manpages
  293. - update to 3.28
  294. * Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
  295. - Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
  296. * Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
  297. - patch dues not apply bug.
  298. * Thu Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
  299. - not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
  300. - ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
  301. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  302. - identify ELF stripped files correctly (#4665).
  303. - use SPARC (not sparc) consistently throughout (#4665).
  304. - add entries for MS Office files (#4665).
  305. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  306. - diddle magic so that *.tfm files are identified correctly.
  307. * Tue Jul 6 1999 Jeff Johnson <jbj@redhat.com>
  308. - update to 3.27.
  309. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  310. - experimental support for realmedia files added
  311. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  312. - auto rebuild in the new build environment (release 5)
  313. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  314. - strip binary.
  315. * Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  316. - add SPARC V9 magic.
  317. * Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
  318. - update to 3.26.
  319. * Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
  320. - update to 3.25.
  321. - detect gimp XCF versions.
  322. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  323. - translations modified for de, fr, tr
  324. * Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
  325. - updated to 3.24
  326. - buildrooted
  327. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  328. - built against glibc
  329. * Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
  330. - Fixed problems caused by 64 bit time_t.
  331. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  332. - Improved recognition of Linux kernel images.