kdevelop-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445
  1. %define beta 0
  2. %define seed %(grep -c Seed /etc/vine-release)
  3. %define kde_ver 3.5.5
  4. Name: kdevelop
  5. Version: 3.5.4
  6. %if %{beta}
  7. Release: 1.%{beta}%{?_dist_relase}
  8. %else
  9. Release: 1%{?_dist_release}
  10. %endif
  11. Summary: Integrated Development Environment for C++/C
  12. Summary(ja): C++/C 向け統合開発環境
  13. %if %{beta}
  14. Source: ftp://ftp.kde.org/pub/kde/unstable/%{kde_ver}-%{beta}/src/%{name}-%{version}-%{beta}.tar.bz2
  15. %else
  16. Source: ftp://ftp.kde.org/pub/kde/stable/%{kde_ver}/src/%{name}-%{version}.tar.bz2
  17. %endif
  18. Source1: kdevelop
  19. Source2: kdevelop-htdig.conf
  20. URL: http://www.kdevelop.org/
  21. Group: Applications/Development
  22. License: GPL
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: qt-devel >= 3.3.2
  25. BuildRequires: kdelibs-devel >= %{kde_ver}
  26. BuildRequires: libpng-devel >= 1.2.5
  27. BuildRequires: libtool libmng-devel libjpeg-devel zlib-devel
  28. BuildRequires: flex db4-devel gettext apache2-devel subversion-devel
  29. Requires: make, perl >= 5.004
  30. Requires: flex >= 2.5.4
  31. Requires: qt >= 3.3.2, qt-designer >= 3.3.2, kdelibs-devel >= %{kde_ver}
  32. Requires: libmng libjpeg libpng zlib
  33. Requires: kdbg kdoc kdegraphics kdeutils kdesdk htdig ctags
  34. %if %{seed}
  35. BuildPrereq: apr-devel apr-util-devel
  36. Requires: apr apr-util
  37. %else
  38. BuildPrereq: apache2-apr-devel
  39. Requires: apache2-apr
  40. %endif
  41. %description
  42. The KDevelop Integrated Development Environment provides many features
  43. that developers need as well as providing a unified interface to programs
  44. like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
  45. All development tools needed for C++ programming like Compiler,
  46. Linker, automake and autoconf; KAppWizard, which generates complete,
  47. ready-to-go sample applications; Classgenerator, for creating new
  48. classes and integrating them into the current project; File management
  49. for sources, headers, documentation etc. to be included in the
  50. project; The creation of User-Handbooks written with SGML and the
  51. automatic generation of HTML-output with the KDE look and feel;
  52. Automatic HTML-based API-documentation for your project's classes with
  53. cross-references to the used libraries; Internationalization support
  54. for your application, allowing translators to easily add their target
  55. language to a project;
  56. KDevelop also includes WYSIWYG (What you see is what you get)-creation
  57. of user interfaces with a built-in dialog editor; Debugging your
  58. application by integrating KDbg; Editing of project-specific pixmaps
  59. with KIconEdit; The inclusion of any other program you need for
  60. development by adding it to the "Tools"-menu according to your
  61. individual needs.
  62. %prep
  63. %setup -q
  64. %build
  65. export KDEDIR=%{_prefix}
  66. QTDIR="" && source /etc/profile.d/qt.sh
  67. FLAGS="$RPM_OPT_FLAGS -DNDEBUG -DNO_DEBUG -D_GNU_SOURCE"
  68. CXXFLAGS="$FLAGS" CFLAGS="$FLAGS" \
  69. ./configure --prefix=$KDEDIR \
  70. --with-qtdoc-dir=$QTDIR/doc/html/ \
  71. --with-xinerama \
  72. --with-pythondir=%{_prefix} \
  73. --enable-new-ldflags \
  74. --disable-dependency-tracking \
  75. %if %{seed}
  76. --with-apr-config=%{_bindir}/apr-1-config \
  77. --with-apu-config=%{_bindir}/apu-1-config \
  78. %endif
  79. --enable-final \
  80. --disable-rpath
  81. make %{?_smp_mflags}
  82. %install
  83. rm -rf $RPM_BUILD_ROOT
  84. make DESTDIR=$RPM_BUILD_ROOT install
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %files
  88. %defattr(-,root,root)
  89. %doc %{_datadir}/doc/HTML/en/*
  90. %{_bindir}/*
  91. %{_includedir}*
  92. %{_libdir}/*
  93. %{_datadir}/applications/*
  94. %{_datadir}/apps/*
  95. %config %{_datadir}/config/*
  96. %{_datadir}/desktop-directories/*
  97. %{_datadir}/icons/*
  98. %{_datadir}/mimelnk/*
  99. %{_datadir}/services/*
  100. %{_datadir}/servicetypes/*
  101. %changelog
  102. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
  103. - new upstream release
  104. - applied new versioning policy, spec in UTF-8
  105. - changed Group to Applications/Development
  106. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
  107. - rebuild for VineSeed
  108. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
  109. - new upstream release
  110. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
  111. - rebuild for VineSeed
  112. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
  113. - new upstream release
  114. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
  115. - rebuild for VineSeed
  116. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
  117. - new upstream release
  118. - use ap?-config for Vine3.x and use ap?-1-config for VineSeed
  119. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  120. - rebuild for VineSeed
  121. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  122. - new upstream release
  123. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  124. - rebuild for VineSeed
  125. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  126. - new upstream release
  127. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
  128. - rebuild for VineSeed
  129. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
  130. - new upstream release
  131. - add BuildPrereq: apache2-devel subversion-devel
  132. * Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
  133. - new upstream release
  134. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
  135. - new upstream release
  136. - delete Patch0
  137. * Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
  138. - new upstream release
  139. - add Patch0
  140. - update %%files
  141. * Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
  142. - rebuild for VineSeed
  143. * Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  144. - new upstream release
  145. * Tue Jul 5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
  146. - rebuild for VineSeed
  147. * Tue Jul 5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  148. - new upstream release
  149. - add --disable-rpath to configure option
  150. - remove BuildPrereq: qt-static
  151. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
  152. - rebuild for VineSeed
  153. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
  154. - new upstream release
  155. - update %%files
  156. - add +w to %%{_prefix}/kdevbdb/*
  157. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
  158. - rebuild for VineSeed
  159. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  160. - new upstream release
  161. - update %%files
  162. * Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  163. - source upgrade
  164. - add BuildPrereq: qt-static
  165. * Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  166. - rebuild with qt32
  167. * Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  168. - source upgrade
  169. - remove lines about vine26
  170. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  171. - source upgrade
  172. - add Requires: ctags
  173. * Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
  174. - source upgrade
  175. - remove all patches
  176. - remove c references
  177. - add Requires: htdig
  178. * Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
  179. - change spec to build both VineSeed and Vine2.5/2.6
  180. - change configure options
  181. - add %%clean section
  182. - add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
  183. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
  184. - source upgrade
  185. - change spec to build both VineSeed and Vine2.5/2.6
  186. - change configure option (add -enable--final, remove -enable--debug)
  187. - update %%files section
  188. * Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
  189. - source upgrade
  190. - remove patch1 (rejected)
  191. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
  192. - BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
  193. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
  194. - source upgrade
  195. - revised Source1
  196. - remove Patch1 and Patch4
  197. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
  198. - merged with rawhide 2.1.1-3
  199. - clean up spec
  200. - add BuildPrereq: objprelink (i386 only)
  201. - remove Obsoletes: kdevelop-c_c++_ref
  202. - add BuildPrereq: autoconf252 automake15
  203. - There is Vine's previous changes, hacked for Vine
  204. -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
  205. - build for VineSeed
  206. - delete Epoch
  207. - update Patch1 and delete Patch2
  208. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  209. - automated rebuild
  210. * Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
  211. - don't forcibly strip binaries
  212. * Sun Jun 2 2002 Than Ngo <than@redhat.com> 2.1.1-1
  213. - 2.1.1
  214. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  215. - automated rebuild
  216. * Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
  217. - Use automake15
  218. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
  219. - Change sonames
  220. * Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
  221. - final
  222. * Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
  223. - update
  224. * Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
  225. - update to 2.1rc3
  226. * Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
  227. - update to 2.1rc2
  228. * Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
  229. - rebuild against new kdelibs
  230. * Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
  231. - fixed Strange characters appear in the output window (bug #59217)
  232. - fixed return-line feed sign in Kdevelop setup tool (bug #55032)
  233. * Wed Mar 8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
  234. - update to 2.1beta2
  235. * Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
  236. - rebuild against new kdelibs
  237. * Wed Jan 9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
  238. - update to 2.1 beta1
  239. - fix build against gcc 3
  240. - fix some typo bugs
  241. - get rid of libkfile
  242. - update c_cpp_reference to 2.0.1
  243. * Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
  244. - add patch to show non lattin1 font in build-in editor correct (bug #54457)
  245. * Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
  246. - fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
  247. - backport some major bugfixes from 2.0.1
  248. * Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
  249. - Don't crash on startup
  250. * Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
  251. - Fix file list
  252. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
  253. - Update
  254. * Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  255. - Yet another respin - printing was broken.
  256. * Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  257. - Update the C/C++ reference guide docs. The older version had a
  258. couple of examples that won't work with gcc 2.96-*
  259. * Thu Feb 22 2001 Than Ngo <than@redhat.com>
  260. - fix version number
  261. * Wed Feb 21 2001 Than Ngo <than@redhat.com>
  262. - 1.4-respin
  263. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  264. - 1.4
  265. * Wed Feb 14 2001 Than Ngo <than@redhat.com>
  266. - update (only bugfixes)
  267. - fix up kdelibs documentation path
  268. - fix a dependency problem with kde-i18n package (Bug #27675)
  269. - add qt-designer into requires
  270. * Sun Feb 11 2001 Than Ngo <than@redhat.com>
  271. - fixed to build on s390
  272. * Tue Feb 06 2001 Than Ngo <than@redhat.com>
  273. - update, only bugfixes
  274. * Wed Jan 24 2001 Than Ngo <than@redhat.com>
  275. - hacked for building of KDE references
  276. * Tue Jan 23 2001 Than Ngo <than@redhat.com>
  277. - work-around to build on alpha
  278. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  279. - Update
  280. * Wed Jan 10 2001 Than Ngo <than@redhat.com>
  281. - update new snapshot, only require KDE2/Qt2
  282. * Fri Dec 22 2000 Than Ngo <than@redhat.com>
  283. - fixed dependency problem with kde-i18n
  284. * Thu Dec 21 2000 Than Ngo <than@redhat.com>
  285. - updated to 1.4beta1 with KDE2 support
  286. - fixed to build on s390
  287. - fixed some broken codes
  288. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  289. - fixed for building on ia64
  290. * Wed Nov 15 2000 Than Ngo <than@redhat.com>
  291. - build snapshot 20001112, it works now with KDE2 and kde1-compat
  292. - fix libtool to build on sparc and alpha
  293. - don't use make -j
  294. * Sun Aug 13 2000 Than Ngo <than@redhat.com>
  295. - fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
  296. * Tue Aug 01 2000 Than Ngo <than@redhat.de>
  297. - add missing ldconfig in %post and %postun section (Bug #14924)
  298. - add missing C references stuff to kdevelop
  299. * Sun Jul 30 2000 Than Ngo <than@redhat.de>
  300. - rebuilt against compat-egcs-c++, put KDE1 under /usr
  301. - cleanup specfile
  302. * Tue Jul 25 2000 Than Ngo <than@redhat.de>
  303. - fix dependency problem
  304. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  305. - rebuilt against compat-libstdc++
  306. * Mon Jul 17 2000 Than Ngo <than@redhat.de>
  307. - install under /usr/share instead /usr/lib/kde1-compat/share,
  308. fix dependency problem
  309. * Sat Jul 15 2000 Than Ngo <than@redhat.de>
  310. - rebuilt with egcs-c++-1.1.2
  311. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  312. - automatic rebuild
  313. * Mon Jul 03 2000 Than Ngo <than@redhat.de>
  314. - fix docdir
  315. - add requires kdebase
  316. * Sun Jul 02 2000 Than Ngo <than@redhat.de>
  317. - rebuilt with kde1-compat
  318. * Sun Jun 18 2000 Than Ngo <than@redhat.de>
  319. - rebuilt in the new build environment, fix docdir
  320. - FHS packaging
  321. * Thu Jun 08 2000 Than Ngo <than@redhat.de>
  322. - update to 1.2
  323. - move from powertools to main CD
  324. - use %%configure
  325. * Mon Apr 3 2000 Ngo Than <than@redhat.de>
  326. - fix up reference (Bug #10368)
  327. * Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  328. - Fix up documentation path (Bug #7291)
  329. - Update to current stable branch - this should fix up the debugger problem
  330. - clean up spec file
  331. * Fri Jan 6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  332. - Update to current stable branch
  333. - Adapt to 6.2 Qt libraries
  334. - Use BuildPrereq
  335. * Wed Jan 05 2000 Ngo Than <than@redhat.de>
  336. - added patch for alpha
  337. * Tue Dec 21 1999 Ngo Than <than@redhat.de>
  338. - updated kdevelop-1.0 release
  339. * Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
  340. - kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
  341. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  342. - initial packaging for 6.1.