gsm-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Shared libraries for GSM speech compressor
  3. Name: gsm
  4. Version: 1.0.22
  5. Release: 1%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: MIT
  10. URL: http://www.quut.com/gsm/
  11. Source: http://www.quut.com/gsm/%{name}-%{version}.tar.gz
  12. Patch0: gsm-makefile.patch
  13. Patch1: gsm-warnings.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  16. %global majorver %(echo %{shortver} | sed -e 's/\.[0-9]*$//')
  17. %global minorver %(echo %{shortver} | sed -e 's/^[0-9]*\.//')
  18. %global patchlevel %(echo %{version} | sed -e 's/^[0-9]*\.[0-9]*\.//')
  19. %define srcver %{shortver}-pl%{patchlevel}
  20. %define soname %{version}
  21. %description
  22. Contains runtime shared libraries for libgsm, an implementation of
  23. the European GSM 06.10 provisional standard for full-rate speech
  24. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  25. excitation/long term prediction) coding at 13 kbit/s.
  26. GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
  27. rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
  28. with typical UNIX applications, our implementation turns frames of 160
  29. 16-bit linear samples into 33-byte frames (1650 Bytes/s).
  30. The quality of the algorithm is good enough for reliable speaker
  31. recognition; even music often survives transcoding in recognizable
  32. form (given the bandwidth limitations of 8 kHz sampling rate).
  33. The interfaces offered are a front end modelled after compress(1), and
  34. a library API. Compression and decompression run faster than realtime
  35. on most SPARCstations. The implementation has been verified against the
  36. ETSI standard test patterns.
  37. %package tools
  38. Summary: GSM speech compressor tools
  39. Group: multimedia
  40. %description tools
  41. Contains command line utilities for libgsm, an implementation of
  42. the European GSM 06.10 provisional standard for full-rate speech
  43. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  44. excitation/long term prediction) coding at 13 kbit/s.
  45. %package devel
  46. Summary: Header files and development libraries for libgsm
  47. Group: programming
  48. Requires: %{name} = %{version}-%{release}
  49. %description devel
  50. Contains header files and development libraries for libgsm, an
  51. implementation of the European GSM 06.10 provisional standard for
  52. full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
  53. (residual pulse excitation/long term prediction) coding at 13 kbit/s.
  54. # compat32
  55. %package -n compat32-%{name}
  56. Summary: Shared libraries for GSM speech compressor
  57. Group: system,legacy
  58. Requires: %{name} = %{version}-%{release}
  59. %description -n compat32-%{name}
  60. Contains runtime shared libraries for libgsm, an implementation of
  61. the European GSM 06.10 provisional standard for full-rate speech
  62. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  63. excitation/long term prediction) coding at 13 kbit/s.
  64. GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
  65. rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
  66. with typical UNIX applications, our implementation turns frames of 160
  67. 16-bit linear samples into 33-byte frames (1650 Bytes/s).
  68. The quality of the algorithm is good enough for reliable speaker
  69. recognition; even music often survives transcoding in recognizable
  70. form (given the bandwidth limitations of 8 kHz sampling rate).
  71. The interfaces offered are a front end modelled after compress(1), and
  72. a library API. Compression and decompression run faster than realtime
  73. on most SPARCstations. The implementation has been verified against the
  74. ETSI standard test patterns.
  75. %package -n compat32-%{name}-devel
  76. Summary: Header files and development libraries for libgsm
  77. Group: programming,legacy
  78. Requires: compat32-%{name} = %{version}-%{release}
  79. Requires: %{name}-devel = %{version}-%{release}
  80. %description -n compat32-%{name}-devel
  81. Contains header files and development libraries for libgsm, an
  82. implementation of the European GSM 06.10 provisional standard for
  83. full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
  84. (residual pulse excitation/long term prediction) coding at 13 kbit/s.
  85. %debug_package
  86. %prep
  87. %setup -n gsm-%{srcver} -q
  88. %autopatch -p1
  89. %build
  90. export LDFLAGS="%{?__global_ldflags}"
  91. %make_build all SO_MAJOR=%{majorver} SO_MINOR=%{minorver} SO_PATCH=%{patchlevel}
  92. %install
  93. export LDFLAGS="%{?__global_ldflags}"
  94. mkdir -p %{buildroot}{%{_bindir},%{_includedir}/gsm,%{_libdir},%{_mandir}/{man1,man3}}
  95. %make_install \
  96. INSTALL_ROOT=%{buildroot}%{_prefix} \
  97. GSM_INSTALL_INC=%{buildroot}%{_includedir}/gsm \
  98. GSM_INSTALL_LIB=%{buildroot}%{_libdir} \
  99. SO_MAJOR=%{majorver} SO_MINOR=%{minorver} SO_PATCH=%{patchlevel}
  100. # some apps look for this in /usr/include
  101. ln -s gsm/gsm.h %{buildroot}%{_includedir}
  102. echo ".so toast.1" > %{buildroot}%{_mandir}/man1/tcat.1
  103. echo ".so toast.1" > %{buildroot}%{_mandir}/man1/untoast.1
  104. %check
  105. ls %{buildroot}%{_libdir}
  106. # This is to ensure that the patch creates the proper library version.
  107. [ -f %{buildroot}%{_libdir}/libgsm.so.%{version} ]
  108. export LDFLAGS="%{?__global_ldflags}"
  109. make addtst
  110. %files
  111. %defattr(-,root,root,-)
  112. %license COPYRIGHT
  113. %doc ChangeLog MACHINES README
  114. %{_libdir}/libgsm.so.*
  115. %files tools
  116. %{_bindir}/tcat
  117. %{_bindir}/toast
  118. %{_bindir}/untoast
  119. %{_mandir}/man1/toast.1*
  120. %{_mandir}/man1/tcat.1.gz
  121. %{_mandir}/man1/untoast.1.gz
  122. %files devel
  123. %defattr(-,root,root,-)
  124. %dir %{_includedir}/gsm
  125. %{_includedir}/gsm/gsm.h
  126. %{_includedir}/gsm.h
  127. %{_libdir}/libgsm.so
  128. %{_mandir}/man3/*
  129. # compat32
  130. %if %{build_compat32}
  131. %files -n compat32-%{name}
  132. %defattr(-,root,root,-)
  133. %{_libdir}/libgsm.so.*
  134. %files -n compat32-%{name}-devel
  135. %defattr(-,root,root,-)
  136. %{_libdir}/libgsm.so
  137. %endif
  138. %changelog
  139. * Sat Jul 06 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.22-1
  140. - new upstream release.
  141. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-1
  142. - new upstream release.
  143. - updated Patch0 and 1.
  144. - dropped Patch2.
  145. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.14-1
  146. - new upstream release
  147. - update Patch1 (%%{name}-1.0.14-warnings.patch)
  148. * Mon Jul 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.13-1
  149. - new upstream release.
  150. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.12-3
  151. - create compat32 sub package
  152. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-2
  153. - rebuilt with current VineSeed
  154. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  155. - initial build for Vine Linux
  156. * Mon Feb 11 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.0.12-6
  157. - Rebuild for GCC 4.3
  158. * Sun Aug 26 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-5
  159. - install symlinks instead of binaries in -devel
  160. * Sat Aug 25 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-4
  161. - rebuild for BuildID
  162. - specfile cleanups
  163. * Sun May 13 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-3
  164. - fix parallel make
  165. * Fri May 11 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-2
  166. - fix some warnings
  167. - fix 64bit testsuite issue as described at gsm homepage
  168. - add compatibility header symlink
  169. - split off binaries into a separate package
  170. * Sun Apr 15 2007 Michael Schwendt <mschwendt[AT]users.sf.net> 1.0.12-1
  171. - Update to Release 1.0 Patchlevel 12.
  172. - Build with -fPIC not just for non-ix86.
  173. - Add check section to ensure proper library version.
  174. - Remove static library.
  175. * Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.0.10-12
  176. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  177. * Tue Sep 26 2006 Thomas Vander Stichele <thomas at apestaart dot org>
  178. - 1.0.10-11
  179. - rebuild for FC6
  180. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  181. - switch to new release field
  182. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  183. - add dist
  184. * Mon Jun 27 2005 David Woodhouse <dwmw2@infradead.org>
  185. - 1.0.10-0.lvn.10: Clean up installation
  186. * Sat Jun 25 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
  187. - 1.0.10-0.lvn.9: mv libgsm.a only when needed
  188. * Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
  189. - 1.0.10-0.lvn.8: Use -fPIC on non ix86
  190. * Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
  191. - 1.0.10-0.lvn.7: moved to rpm.livna.org
  192. * Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
  193. - 1.0.10-0.fdr.7: applied patch from Ville, remove epoch since it's allowed
  194. * Sat Sep 13 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  195. - 0:1.0.10-0.fdr.6: remove second makeinstall
  196. * Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  197. - 0:1.0.10-0.fdr.5
  198. - added back epochs, I surrender
  199. - fix RPM_OPT_FLAGS hackery
  200. * Fri Jul 18 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  201. - 1.0.10-0.fdr.4: remove epoch mentions
  202. * Sat Jul 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  203. - 1.0.10-0.fdr.3
  204. - pull in RPM_OPT_FLAGS in patch instead of using perl to wedge it in
  205. - fix group
  206. - -p'ize ldconfig
  207. * Tue Jun 10 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  208. - 1.0.10-0.fdr.2
  209. - Fix libgsm.so.* being files instead of symlinks
  210. * Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  211. - 0:1.0.10-0.fdr.1: initial RPM release