perl-Test-UseAllModules-vl.spec 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. %define pkgname Test-UseAllModules
  2. # Basic Information
  3. Name: perl-%{pkgname}
  4. Version: 0.13
  5. Release: 1%{?_dist_release}
  6. License: Artistic or GPL
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/%{pkgname}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: yasumichi
  13. Summary: do use_ok() for all the MANIFESTed modules
  14. #Summary(ja): ここに日本語で概要を記述してください
  15. # Dependency
  16. Requires: perl
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. BuildRequires: perl
  19. %description
  20. I'm sick of writing 00_load.t (or something like that) that'll do use_ok()
  21. for every module I write. I'm sicker of updating 00_load.t when I add
  22. another file to the distro. This module reads MANIFEST to find modules to be
  23. tested and does use_ok() for each of them. Now all you have to do is update
  24. MANIFEST. You don't have to modify the test any more (hopefully).
  25. #%%description -l ja
  26. #ここに日本語で詳細を記述してください。
  27. %prep
  28. %setup -q -n Test-UseAllModules-0.13
  29. %build
  30. perl Makefile.PL
  31. %{__make}
  32. %install
  33. %{__rm} -rf ${RPM_BUILD_ROOT}
  34. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  35. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  36. sed "s@^$RPM_BUILD_ROOT@@g" |
  37. grep -v ^%{_mandir} |
  38. grep -v perllocal.pod |
  39. grep -v "\.packlist" > %{name}.files
  40. if [ "$(cat %{name}.files)X" = "X" ] ; then
  41. echo "ERROR: EMPTY FILE LIST"
  42. exit -1
  43. fi
  44. # remove unnecessary files.
  45. %{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  46. %{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Test/UseAllModules/.packlist
  47. %clean
  48. %{__rm} -rf ${RPM_BUILD_ROOT}
  49. %files -f %{name}.files
  50. %defattr(-,root,root)
  51. %doc Changes README
  52. %{_mandir}/*/*
  53. %changelog
  54. * Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-1
  55. - initial build for Vine Linux