python-rpm-macros-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164
  1. %{!?rpmmacrodir:%global rpmmacrodir %{_sysconfdir}/rpm}
  2. Name: python-rpm-macros
  3. Version: 3
  4. Release: 24%{?_dist_release}
  5. Summary: The unversioned Python RPM macros
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. Packager: tomop
  9. License: MIT
  10. Source0: macros.python
  11. Source1: macros.python-srpm
  12. Source2: macros.python2
  13. Source3: macros.python3
  14. Source4: macros.platform-python
  15. BuildArch: noarch
  16. # For %%python3_pkgversion used in %%python_provide
  17. Requires: python-srpm-macros
  18. Obsoletes: python-macros < 3
  19. Provides: python-macros = %{version}-%{release}
  20. %description
  21. This package contains the unversioned Python RPM macros, that most
  22. implementations should rely on.
  23. You should not need to install this package manually as the various
  24. python?-devel packages require it. So install a python-devel package instead.
  25. %package -n python-srpm-macros
  26. Summary: RPM macros for building Python source packages
  27. %description -n python-srpm-macros
  28. RPM macros for building Python source packages.
  29. %package -n python2-rpm-macros
  30. Summary: RPM macros for building Python 2 packages
  31. # Would need to be different for each release - worth it?
  32. #Conflicts: python2-devel < 2.7.11-3
  33. %description -n python2-rpm-macros
  34. RPM macros for building Python 2 packages.
  35. %package -n python3-rpm-macros
  36. Summary: RPM macros for building Python 3 packages
  37. # Would need to be different for each release - worth it?
  38. #Conflicts: python3-devel < 3.5.1-3
  39. %description -n python3-rpm-macros
  40. RPM macros for building Python 3 packages.
  41. #%package -n platform-python-rpm-macros
  42. #Summary: RPM macros for building Platform-Python packages
  43. #%description -n platform-python-rpm-macros
  44. #RPM macros for building Platform-Python packages.
  45. %prep
  46. %build
  47. %install
  48. mkdir -p %{buildroot}/%{rpmmacrodir}
  49. install -m 644 %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
  50. %{buildroot}/%{rpmmacrodir}/
  51. %files
  52. %{rpmmacrodir}/macros.python
  53. %files -n python-srpm-macros
  54. %{rpmmacrodir}/macros.python-srpm
  55. %files -n python2-rpm-macros
  56. %{rpmmacrodir}/macros.python2
  57. %files -n python3-rpm-macros
  58. %{rpmmacrodir}/macros.python3
  59. #%files -n platform-python-rpm-macros
  60. #%{rpmmacrodir}/macros.platform-python
  61. %changelog
  62. * Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-24
  63. - fixed a path to install.
  64. * Tue Sep 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-23
  65. - initial build for Vine Linux.
  66. * Wed Aug 02 2017 Tomas Orsava <torsava@redhat.com> - 3-22
  67. - Add platform-python macros (https://fedoraproject.org/wiki/Changes/Platform_Python_Stack)
  68. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-21
  69. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  70. * Fri Mar 03 2017 Michal Cyprian <mcyprian@redhat.com> - 3-20
  71. - Revert "Switch %%__python3 to /usr/libexec/system-python"
  72. after the Fedora Change https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
  73. was postponed
  74. * Fri Feb 17 2017 Michal Cyprian <mcyprian@redhat.com> - 3-19
  75. - Switch %%__python3 to /usr/libexec/system-python
  76. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-18
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  78. * Mon Jan 23 2017 Michal Cyprian <mcyprian@redhat.com> - 3-17
  79. - Add --no-deps option to py_install_wheel macros
  80. * Tue Jan 17 2017 Tomas Orsava <torsava@redhat.com> - 3-16
  81. - Added macros for Build/Requires tags using Python dist tags:
  82. https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  83. * Thu Nov 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-15
  84. - Make expanded macros start on the same line as the macro
  85. * Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-14
  86. - Fix %%py3_install_wheel (bug #1395953)
  87. * Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-13
  88. - Add missing sleeps to other build macros
  89. - Fix build_egg macros
  90. - Add %%py_build_wheel and %%py_install_wheel macros
  91. * Tue Nov 15 2016 Orion Poplawski <orion@cora.nwra.com> 3-12
  92. - Add %%py_build_egg and %%py_install_egg macros
  93. - Allow multiple args to %%py_build/install macros
  94. - Tidy up macro formatting
  95. * Wed Aug 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-11
  96. - Use %%rpmmacrodir
  97. * Tue Jul 12 2016 Orion Poplawski <orion@cora.nwra.com> 3-10
  98. - Do not generate useless Obsoletes with %%{?_isa}
  99. * Fri May 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-9
  100. - Make python-rpm-macros require python-srpm-macros (bug #1335860)
  101. * Thu May 12 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-8
  102. - Add single-second sleeps to work around setuptools bug.
  103. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3-7
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  105. * Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-6
  106. - Fix typo in %%python_provide
  107. * Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-5
  108. - Handle noarch python sub-packages (bug #1290900)
  109. * Wed Jan 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-4
  110. - Fix python2/3-rpm-macros package names
  111. * Thu Jan 7 2016 Orion Poplawski <orion@cora.nwra.com> 3-3
  112. - Add empty %%prep and %%build
  113. * Mon Jan 4 2016 Orion Poplawski <orion@cora.nwra.com> 3-2
  114. - Combined package
  115. * Wed Dec 30 2015 Orion Poplawski <orion@cora.nwra.com> 3-1
  116. - Initial package