openssh-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781
  1. %define ver 6.5p1
  2. %define rel 1%{_dist_release}
  3. # SELinux
  4. %define WITH_SELINUX 0
  5. # OpenSSH privilege separation requires a user & group ID
  6. %define sshd_uid 74
  7. %define sshd_gid 74
  8. # Version of ssh-askpass
  9. %define aversion 1.2.4.1
  10. # Do we want to disable building of gnome-askpass? (1=yes 0=no)
  11. %define no_gnome_askpass 0
  12. # Use GTK2 for gnome-ssh-askpass
  13. %define gtk2 1
  14. # Build position-independent executables (requires toolchain support)?
  15. %define pie 1
  16. # Do we want to link against a static libcrypto? (1=yes 0=no)
  17. %define static_libcrypto 0
  18. # Do we want smartcard support (1=yes 0=no)
  19. %define scard 0
  20. # Disable IPv6 (avoids DNS hangs on some glibc versions)
  21. %define noip6 0
  22. # Do we want kerberos5 support (1=yes 0=no)
  23. %define kerberos5 0
  24. # Reserve options to override askpass settings with:
  25. # rpm -ba|--rebuild --define 'skip_xxx 1'
  26. %{?skip_gnome_askpass:%define no_gnome_askpass 1}
  27. # Options for static OpenSSL link:
  28. # rpm -ba|--rebuild --define "static_openssl 1"
  29. %{?static_openssl:%define static_libcrypto 1}
  30. # Options for Smartcard support: (needs libsectok and openssl-engine)
  31. # rpm -ba|--rebuild --define "smartcard 1"
  32. %{?smartcard:%define scard 1}
  33. # Option to disable ipv6
  34. # rpm -ba|--rebuild --define "noipv6 1"
  35. %{?noipv6:%define noip6 1}
  36. # Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
  37. %define rescue 0
  38. %{?build_rescue:%define rescue 1}
  39. # Turn off some stuff for resuce builds
  40. %if %{rescue}
  41. %define kerberos5 0
  42. %endif
  43. Summary: The OpenSSH implementation of SSH.
  44. Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
  45. Name: openssh
  46. Version: %{ver}
  47. Release: %{rel}
  48. URL: http://www.openssh.com/portable.html
  49. Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
  50. Patch0: openssh-6.4p1-vine.patch
  51. Patch4: openssh-6.2p1-vendor.patch
  52. Patch12: openssh-selinux.patch
  53. Patch20: openssh-3.9p1-gssapimitm.patch
  54. Patch21: openssh-3.9p1-safe-stop.patch
  55. Patch24: openssh-5.7p1-fromto-remote.patch
  56. Patch26: openssh-5.2p1-pam-no-stack.patch
  57. # Patch27: openssh-5.1p1-log-in-chroot.patch
  58. Patch30: openssh-5.6p1-exit-deadlock.patch
  59. # Patch31: openssh-3.9p1-skip-used.patch
  60. Patch35: openssh-5.1p1-askpass-progress.patch
  61. # Vine Source
  62. Source100: sshd.init
  63. Source110: sshd.sysconfig
  64. # Vine Patch
  65. Patch100: openssh-norootlogin.patch
  66. License: BSD
  67. Group: Applications/Internet
  68. BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
  69. Obsoletes: ssh
  70. BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
  71. BuildRequires: util-linux
  72. BuildRequires: db4-devel
  73. BuildRequires: pam-devel
  74. BuildRequires: zlib-devel
  75. %if ! %{no_gnome_askpass}
  76. BuildRequires: libX11-devel
  77. BuildRequires: gtk2-devel
  78. %endif
  79. BuildRequires: xorg-x11-xauth
  80. BuildRequires: groff
  81. BuildRequires: libedit-devel
  82. Vendor: Project Vine
  83. Distribution: Vine Linux
  84. Packager: daisuke
  85. %package clients
  86. Summary: OpenSSH clients.
  87. Summary(ja): OpenSSH Secure Shell プロトコルクライアント
  88. Requires: openssh = %{version}-%{release}
  89. Group: Applications/Internet
  90. Obsoletes: ssh-clients
  91. Obsoletes: openssh-contrib
  92. %package server
  93. Summary: The OpenSSH server daemon.
  94. Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
  95. Group: System Environment/Daemons
  96. Obsoletes: ssh-server
  97. Requires(post): openssh = %{version}-%{release}
  98. Requires(post): chkconfig
  99. Requires(pre): shadow-utils
  100. Requires(post): initscripts >= 5.20
  101. Requires: pam
  102. %package askpass-gnome
  103. Summary: A passphrase dialog for OpenSSH, X, and GNOME.
  104. Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
  105. Group: Applications/Internet
  106. Requires: openssh = %{version}-%{release}
  107. Obsoletes: ssh-extras
  108. Obsoletes: openssh-askpass < 5.5p1-3vl6
  109. Provides: openssh-askpass = %{version}-%{release}
  110. %description
  111. SSH (Secure SHell) is a program for logging into and executing
  112. commands on a remote machine. SSH is intended to replace rlogin and
  113. rsh, and to provide secure encrypted communications between two
  114. untrusted hosts over an insecure network. X11 connections and
  115. arbitrary TCP/IP ports can also be forwarded over the secure channel.
  116. OpenSSH is OpenBSD's version of the last free version of SSH, bringing
  117. it up to date in terms of security and features, as well as removing
  118. all patented algorithms to separate libraries.
  119. This package includes the core files necessary for both the OpenSSH
  120. client and server. To make this package useful, you should also
  121. install openssh-clients, openssh-server, or both.
  122. #'
  123. %description -l ja
  124. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  125. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  126. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  127. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  128. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  129. な通信路の中を通すことができます。
  130. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  131. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  132. アルゴリズムは分割したライブラリにわかれています。
  133. このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
  134. コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
  135. openssh-clients および/または openssh-server が必要です。
  136. %description clients
  137. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  138. into and executing commands on a remote machine. This package includes
  139. the clients necessary to make encrypted connections to SSH servers.
  140. You'll also need to install the openssh package on OpenSSH clients.
  141. #'
  142. %description -l ja clients
  143. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  144. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  145. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  146. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  147. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  148. な通信路の中を通すことができます。
  149. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  150. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  151. アルゴリズムは分割したライブラリにわかれています。
  152. このパッケージは OpenSSH をクライアントとして使用する場合に
  153. 必要なものを含んでいます。
  154. %description server
  155. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  156. into and executing commands on a remote machine. This package contains
  157. the secure shell daemon (sshd). The sshd daemon allows SSH clients to
  158. securely connect to your SSH server. You also need to have the openssh
  159. package installed.
  160. %description -l ja server
  161. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  162. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  163. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  164. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  165. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  166. な通信路の中を通すことができます。
  167. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  168. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  169. アルゴリズムは分割したライブラリにわかれています。
  170. このパッケージは OpenSSH をサーバとして使用する場合に必要な
  171. デーモンなどを含んでいます。
  172. %description askpass-gnome
  173. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  174. into and executing commands on a remote machine. This package contains
  175. an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
  176. environment.
  177. %description -l ja askpass-gnome
  178. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  179. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  180. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  181. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  182. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  183. な通信路の中を通すことができます。
  184. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  185. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  186. アルゴリズムは分割したライブラリにわかれています。
  187. このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
  188. %prep
  189. %setup -q
  190. %patch0 -p1 -b .vine
  191. %patch4 -p1 -b .vendor
  192. %if %{WITH_SELINUX}
  193. #SELinux
  194. %patch12 -p1 -b .selinux
  195. %endif
  196. %patch21 -p1 -b .safe-stop
  197. %patch24 -p1 -b .fromto-remote
  198. %patch26 -p1 -b .stack
  199. # %patch27 -p1 -b .log-chroot
  200. %patch30 -p1 -b .exit-deadlock
  201. %patch35 -p1 -b .progress
  202. %patch100 -p1 -b .norootlogin
  203. autoreconf
  204. %build
  205. CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
  206. %if %{rescue}
  207. CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
  208. %endif
  209. %if %{pie}
  210. %ifarch s390 s390x sparc sparc64
  211. CFLAGS="$CFLAGS -fPIE"
  212. %else
  213. CFLAGS="$CFLAGS -fpie"
  214. %endif
  215. export CFLAGS
  216. LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
  217. %endif
  218. %configure \
  219. --sysconfdir=%{_sysconfdir}/ssh \
  220. --libexecdir=%{_libexecdir}/openssh \
  221. --datadir=%{_datadir}/openssh \
  222. --with-tcp-wrappers \
  223. --with-default-path=/usr/local/bin:/bin:/usr/bin \
  224. --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
  225. --with-privsep-path=%{_var}/empty/sshd \
  226. --enable-vendor-patchlevel="VL-%{version}-%{release}" \
  227. --with-libedit \
  228. --with-xauth=/usr/bin/xauth \
  229. %if %{scard}
  230. --with-smartcard \
  231. %endif
  232. %if %{noip6}
  233. --with-ipv4-default \
  234. %endif
  235. %if %{rescue}
  236. --without-pam --with-md5-passwords
  237. %else
  238. --with-pam
  239. %endif
  240. %if %{static_libcrypto}
  241. perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
  242. %endif
  243. make
  244. %if %{gtk2}
  245. gtk2=yes
  246. %else
  247. gtk2=no
  248. %endif
  249. %if ! %{no_gnome_askpass}
  250. pushd contrib
  251. if [ $gtk2 = yes ]; then
  252. make gnome-ssh-askpass2
  253. mv gnome-ssh-askpass2 gnome-ssh-askpass
  254. else
  255. make gnome-ssh-askpass1
  256. mv gnome-ssh-askpass1 gnome-ssh-askpass
  257. fi
  258. popd
  259. %endif
  260. %install
  261. rm -rf $RPM_BUILD_ROOT
  262. mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
  263. mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
  264. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
  265. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
  266. make install DESTDIR=$RPM_BUILD_ROOT
  267. touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
  268. install -d $RPM_BUILD_ROOT/etc/pam.d/
  269. install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
  270. install -d $RPM_BUILD_ROOT/etc/sysconfig/
  271. install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
  272. install -m644 contrib/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
  273. install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
  274. install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
  275. %if ! %{scard}
  276. rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
  277. %endif
  278. %if ! %{no_gnome_askpass}
  279. install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
  280. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  281. install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  282. %endif
  283. %if %{no_gnome_askpass}
  284. rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
  285. %endif
  286. # for contrib package
  287. install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
  288. install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
  289. mv contrib/README contrib/README.contrib
  290. perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
  291. %clean
  292. rm -rf $RPM_BUILD_ROOT
  293. %triggerun server -- ssh-server
  294. if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
  295. touch /var/run/sshd.restart
  296. fi
  297. %triggerun server -- openssh-server < 2.5.0p1
  298. # Count the number of HostKey and HostDsaKey statements we have.
  299. gawk 'BEGIN {IGNORECASE=1}
  300. /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
  301. END {exit sawhostkey}' /etc/ssh/sshd_config
  302. # And if we only found one, we know the client was relying on the old default
  303. # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
  304. # specified. Now that HostKey is used for both SSH1 and SSH2 keys, specifying
  305. # one nullifies the default, which would have loaded both.
  306. if [ $? -eq 1 ] ; then
  307. echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
  308. echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
  309. fi
  310. %triggerpostun server -- ssh-server
  311. if [ "$1" != 0 ] ; then
  312. /sbin/chkconfig --add sshd
  313. if test -f /var/run/sshd.restart ; then
  314. rm -f /var/run/sshd.restart
  315. # /sbin/service sshd start > /dev/null 2>&1 || :
  316. /sbin/service sshd start
  317. fi
  318. fi
  319. %pre server
  320. %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
  321. %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
  322. -g sshd -M -r sshd 2>/dev/null || :
  323. %post server
  324. /sbin/chkconfig --add sshd
  325. %postun server
  326. # /sbin/service sshd condrestart > /dev/null 2>&1 || :
  327. /sbin/service sshd condrestart
  328. exit 0
  329. %preun server
  330. if [ "$1" = 0 ]
  331. then
  332. /sbin/service sshd stop > /dev/null 2>&1 || :
  333. /sbin/chkconfig --del sshd
  334. fi
  335. %files
  336. %defattr(-,root,root)
  337. %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
  338. %attr(0755,root,root) %{_bindir}/scp
  339. %attr(0644,root,root) %{_mandir}/man1/scp.1*
  340. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  341. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
  342. %attr(644,root,root) %{_mandir}/man5/moduli.5*
  343. %if ! %{rescue}
  344. %attr(0755,root,root) %{_bindir}/ssh-keygen
  345. %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
  346. %attr(0755,root,root) %dir %{_libexecdir}/openssh
  347. %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
  348. %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
  349. %endif
  350. %if %{scard}
  351. %attr(0755,root,root) %dir %{_datadir}/openssh
  352. %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
  353. %endif
  354. %files clients
  355. %defattr(-,root,root)
  356. %attr(0755,root,root) %{_bindir}/ssh
  357. %attr(0644,root,root) %{_mandir}/man1/ssh.1*
  358. %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
  359. %attr(0644,root,root) %{_mandir}/man1/slogin.1*
  360. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
  361. %attr(-,root,root) %{_bindir}/slogin
  362. %if ! %{rescue}
  363. %attr(0755,root,root) %{_bindir}/ssh-agent
  364. %attr(0755,root,root) %{_bindir}/ssh-add
  365. %attr(0755,root,root) %{_bindir}/ssh-keyscan
  366. %attr(0755,root,root) %{_bindir}/sftp
  367. %attr(0755,root,root) %{_bindir}/ssh-copy-id
  368. %attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
  369. %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
  370. %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
  371. %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
  372. %attr(0644,root,root) %{_mandir}/man1/sftp.1*
  373. %attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
  374. %attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
  375. %endif
  376. %if ! %{rescue}
  377. %files server
  378. %defattr(-,root,root)
  379. %dir %attr(0711,root,root) %{_var}/empty/sshd
  380. %dir %attr(0755,root,root) %{_var}/empty/sshd/etc
  381. %ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
  382. %attr(0755,root,root) %{_sbindir}/sshd
  383. %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
  384. %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
  385. %attr(0644,root,root) %{_mandir}/man8/sshd.8*
  386. %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
  387. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  388. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
  389. %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
  390. %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
  391. %attr(0755,root,root) %config /etc/sysconfig/sshd
  392. %endif
  393. %if ! %{no_gnome_askpass}
  394. %files askpass-gnome
  395. %defattr(-,root,root)
  396. %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
  397. %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
  398. %endif
  399. %changelog
  400. * Tue Feb 04 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 6.5p1-1
  401. - update to 6.5p1
  402. - update sshd_config
  403. - generate ED25519 host key.
  404. * Tue Nov 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.4p1-1
  405. - update to 6.4p1
  406. * Mon May 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p2-1
  407. - update to 6.2p2
  408. * Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p1-1
  409. - update to 6.2p1
  410. * Fri Nov 2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.1p1-1
  411. - new upstream release
  412. - add -with-xauth option in configure
  413. - patch4, 30, 35 are updated from fc18
  414. * Mon May 07 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0p1-1
  415. - new upstream release
  416. * Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9p1-1
  417. - new upstream release
  418. * Sun May 8 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-1
  419. - new upstream release
  420. * Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
  421. - add our own sshd.init based on fedora's sshd.init
  422. - generate ECDSA host key.
  423. * Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
  424. - new upstream release
  425. * Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
  426. - new upstream release
  427. * Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
  428. - new upstream release
  429. - obsolete contrib subpackage, move ssh-copy-id to client subpackage
  430. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
  431. - rebuilt with openssl 1.0.0c
  432. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
  433. - drop x11-askpass, add Obsoletes: openssh-askpass
  434. - add BR: groff
  435. - enable --with-libedit option, add BR: libedit-devel
  436. - remove unrecognized option '--with-rsh'
  437. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
  438. - add BR: xorg-x11-xauth for X11 forwarding support
  439. * Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
  440. - new upstream release
  441. - update patch0,2
  442. - drop patch3,22
  443. * Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
  444. - new upstream release
  445. * Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
  446. - new upstream release
  447. * Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
  448. - rebuild with xorg-x11-7.3
  449. * Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
  450. - new upstream release with security fix (CVE-2008-1483)
  451. - drop patch31 which is included in new release (This was for CVE-2008-1483)
  452. * Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
  453. - new upstream release with security fix ("ForceCommand" Directive)
  454. - turn on daemon restart message
  455. - new versioning policy
  456. * Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
  457. - add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
  458. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
  459. - new upstream release
  460. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
  461. - build with -fpie/-pie by default.
  462. - enable ipv6 by default.
  463. * Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
  464. - new upstream release
  465. * Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
  466. - new upstream release
  467. * Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
  468. - new upstream release
  469. * Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
  470. - new upstream release
  471. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
  472. - new upstream release
  473. - remove build6x stuff
  474. - remove libgnome-devel from BuildRequires
  475. - cleanup BuildRequires
  476. - drop Patch200, it is merged in upstream.
  477. - import patches(25-35) from FC-devel
  478. * Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
  479. - SECURITY FIX: CVE-2006-0225
  480. - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
  481. - update BuildPreReq: s/XFree86-devel/XOrg-devel/
  482. - fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
  483. - When GNOME2 is used, using libgnome-devel
  484. - add BuildPreReq: gtk2-devel for GNOME2
  485. * Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
  486. - rebuild with gtk+-2.8 final
  487. * Sun Sep 4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
  488. - new upstream release
  489. - build with gtk+-2.7
  490. * Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
  491. - new upstream release
  492. * Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
  493. - cleanup obsolete patches and added patches from fedora
  494. * Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
  495. - new upstream release
  496. * Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
  497. - new upstream release
  498. * Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
  499. - new upstream release
  500. * Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
  501. - rebuild with openssl-0.9.7d
  502. * Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
  503. - new upstream release
  504. * Thu Oct 2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
  505. - create contrib package
  506. * Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
  507. - new upstream release
  508. - fix security issue: http://www.openssh.com/txt/sshpam.adv
  509. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
  510. - new upstream release
  511. - fix security issue: http://www.openssh.com/txt/buffer.adv
  512. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
  513. - new upstream release
  514. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
  515. - rebuild with gtk2
  516. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
  517. - new upstream release
  518. * Sun Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
  519. - rebuild with new tool chain
  520. * Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
  521. - new upstream release
  522. - merge with upstream spec (drop anonymous mmap patch, suid of ssh)
  523. * Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
  524. - change some defines in spec files
  525. * Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
  526. - add patch110 ( 3.4p1 does not include mmap-fallback patch )
  527. * Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
  528. - new upstream release
  529. - security fix
  530. - drop patch10
  531. * Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
  532. - add patch from Solar Designer to make privsep work with a 2.2 kernel.
  533. * Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
  534. - new upstream release
  535. - add {sshd,ssh}_config.5 manpages
  536. - add ssh-keysign
  537. * Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
  538. - new upstream release
  539. * Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
  540. - new upstream release
  541. - drop patch1
  542. * Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
  543. - new upstream release
  544. - merged with rawhide release.
  545. - drop Patch101 (merged in upstream)
  546. * Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
  547. - seurity patch for off-by-one bug
  548. * Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
  549. - merged with Rawhide 3.0.2p1-2
  550. * Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
  551. - updated to 3.0.2p1
  552. * Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
  553. - updated to 3.0.1p1
  554. * Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
  555. - updated to 3.0p1
  556. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
  557. - add japanese summery and descriptions.
  558. - update x11-askpass 1.2.5
  559. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
  560. - update to openssh-2.9.9p2
  561. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
  562. - rebuilt with openssl-0.9.6b
  563. * Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
  564. - do not Permit RootLogin
  565. * Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
  566. - update to openssh-2.5.2p2
  567. * Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
  568. - update to openssh-2.5.2p1
  569. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  570. - update to openssh-2.5.1p2
  571. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  572. - update to openssh-2.5.1p1
  573. * Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
  574. - update to openssh-2.5.1p1
  575. * Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
  576. - remove suid bit from ssh
  577. * Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
  578. - moved man dir to /usr/share/man
  579. * Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
  580. - fixed askpass's link in ssh-add
  581. - partially used rpmmacros
  582. * Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
  583. - update to 2.3.0p1
  584. - update x11-askpass 1.0.3
  585. * Wed Oct 18 2000 Damien Miller <djm@mindrot.org>
  586. - Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
  587. Redhat 7.0 spec file
  588. * Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
  589. - rebuild for Vine Linux
  590. * Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
  591. - Use RPM configure macro
  592. * Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
  593. - Some surgery to sshd.init (generate keys at runtime)
  594. - Cleanup of groups and removal of keygen calls
  595. * Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
  596. - Make building of X11-askpass and gnome-askpass optional
  597. * Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
  598. - Glob manpages to catch compressed files
  599. * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
  600. - Updated for new location
  601. - Updated for new gnome-ssh-askpass build
  602. * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
  603. - Added Jim Knoble's <jmknoble@pobox.com> askpass
  604. * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
  605. - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
  606. * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
  607. - Added 'Obsoletes' directives
  608. * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
  609. - Use make install
  610. - Subpackages
  611. * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
  612. - Added links for slogin
  613. - Fixed perms on manpages
  614. * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
  615. - Renamed init script
  616. * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
  617. - Back to old binary names
  618. * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
  619. - Use autoconf
  620. - New binary names
  621. * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
  622. - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.