acl-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327
  1. Name: acl
  2. Summary: Access control list utilities
  3. Version: 2.2.52
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Base
  6. License: GPLv2+
  7. URL: http://oss.sgi.com/projects/xfs/
  8. Source: http://download.savannah.gnu.org/releases-noredirect/acl/acl-%{version}.src.tar.gz
  9. # fix a typo in setfacl(1) man page (#675451)
  10. Patch1: 0001-acl-2.2.49-bz675451.patch
  11. # prepare the test-suite for SELinux and arbitrary umask
  12. Patch3: 0003-acl-2.2.52-tests.patch
  13. # Install the libraries to the appropriate directory
  14. Patch4: 0004-acl-2.2.52-libdir.patch
  15. # fix SIGSEGV of getfacl -e on overly long group name
  16. Patch5: 0005-acl-2.2.52-getfacl-segv.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: gawk
  19. BuildRequires: gettext
  20. BuildRequires: libattr-devel >= 2.4.1
  21. BuildRequires: libtool
  22. Requires: libacl = %{version}-%{release}
  23. %description
  24. This package contains the getfacl and setfacl utilities needed for
  25. manipulating access control lists.
  26. %package -n libacl
  27. Summary: Dynamic library for access control list support
  28. License: LGPLv2+
  29. Group: System Environment/Libraries
  30. Requires(post): /sbin/ldconfig
  31. Requires(postun): /sbin/ldconfig
  32. %description -n libacl
  33. This package contains the libacl.so dynamic library which contains
  34. the POSIX 1003.1e draft standard 17 functions for manipulating access
  35. control lists.
  36. %package -n libacl-devel
  37. Summary: Access control list static libraries and headers.
  38. License: LGPLv2+
  39. Group: Development/Libraries
  40. Requires: libacl = %{version}-%{release}
  41. Requires: libattr-devel
  42. %description -n libacl-devel
  43. This package contains static libraries and header files needed to develop
  44. programs which make use of the access control list programming interface
  45. defined in POSIX 1003.1e draft standard 17.
  46. %prep
  47. %setup -q
  48. %patch1 -p1
  49. %patch3 -p1
  50. %patch4 -p1
  51. %patch5 -p1
  52. %build
  53. touch .census
  54. # acl abuses libexecdir
  55. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  56. make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
  57. %install
  58. rm -rf %{buildroot}
  59. make install DESTDIR=%{buildroot}
  60. make install-dev DESTDIR=%{buildroot}
  61. make install-lib DESTDIR=%{buildroot}
  62. mv -f %{buildroot}%{_datadir}/doc/acl ./doc-nover
  63. # get rid of libacl.a and libacl.la
  64. rm -f %{buildroot}/%{_lib}/libacl.a
  65. rm -f %{buildroot}/%{_lib}/libacl.la
  66. rm -f %{buildroot}%{_libdir}/libacl.a
  67. rm -f %{buildroot}%{_libdir}/libacl.la
  68. # fix links to shared libs and permissions
  69. rm -f %{buildroot}%{_libdir}/libacl.so
  70. mkdir -p %{buildroot}%{_libdir}
  71. ln -sf ../../%{_lib}/libacl.so %{buildroot}%{_libdir}/libacl.so
  72. chmod 0755 %{buildroot}/%{_lib}/libacl.so.*.*.*
  73. %find_lang %{name}
  74. %check
  75. if ./setfacl/setfacl -m u:`id -u`:rwx .; then
  76. make tests || exit $?
  77. if test 0 = `id -u`; then
  78. make root-tests || exit $?
  79. fi
  80. else
  81. echo '*** ACLs are probably not supported by the file system,' \
  82. 'the test-suite will NOT run ***'
  83. fi
  84. %clean
  85. rm -rf %{buildroot}
  86. %post -n libacl
  87. /sbin/ldconfig
  88. %postun -n libacl
  89. /sbin/ldconfig
  90. %files -f %{name}.lang
  91. %defattr(-,root,root)
  92. %doc doc-nover/*
  93. %{_bindir}/chacl
  94. %{_bindir}/getfacl
  95. %{_bindir}/setfacl
  96. %{_mandir}/man1/chacl.1*
  97. %{_mandir}/man1/getfacl.1*
  98. %{_mandir}/man1/setfacl.1*
  99. %{_mandir}/man5/acl.5*
  100. %files -n libacl-devel
  101. %defattr(-,root,root)
  102. /%{_lib}/libacl.so
  103. %{_includedir}/acl
  104. %{_includedir}/sys/acl.h
  105. %{_libdir}/libacl.*
  106. %{_mandir}/man3/acl_*
  107. %files -n libacl
  108. %defattr(-,root,root)
  109. /%{_lib}/libacl.so.*
  110. %changelog
  111. * Fri Jul 4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-1
  112. - new upstream release.
  113. - replaced patches to the newest rawhide's.
  114. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
  115. - updated to 2.2.49
  116. - added Patch2-7 from Fedora
  117. * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
  118. - add function acl_extended_file_nofollow() (#692982)
  119. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
  120. - fix typos in setfacl(1) man page (#675451)
  121. * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
  122. - remove dependency of libacl-devel on nfs-utils-lib and openldap
  123. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
  124. - let acl depend on the same version of libacl (#595674)
  125. * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
  126. - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
  127. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
  128. - initial build for Vine Linux
  129. * Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
  130. - new upstream version
  131. * Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
  132. - Fixed segfault when using only "--" as parameter
  133. - Resolves: #430458
  134. * Wed Nov 7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
  135. - Fixed setfacl exitcodes
  136. - Resolves: #368451
  137. * Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
  138. - New version
  139. - dropped walk patch
  140. * Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
  141. - Rewriten path_max patch to support long UTF8 names
  142. - Resolves #287701, #183181
  143. * Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
  144. - Removed NFS4 ACL patch since it was rejected by upstream.
  145. * Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
  146. - disable nfs patch; linking libacl against libs in /usr will lead to breakage
  147. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
  148. - Build Require gawk
  149. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
  150. - Rebuild for selinux ppc32 issue.
  151. * Mon Aug 27 2007 Steve Dickson <steved@redhat.com> 2.2.39-5
  152. - Added NFS v4 ACL support
  153. * Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
  154. - Updated man page for getfacl
  155. * Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
  156. - Added support fort short params to getfacl
  157. - Resolves: #204087
  158. * Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
  159. - new improved walk patch with fixed getfacl exit code (rhbz#232884)
  160. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
  161. - fix buildroot
  162. - remove trailing dot from summary
  163. - -devel requires same version of libacl
  164. - escape macro in changelog
  165. - make .so symlink relative
  166. * Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
  167. - Apply patch to make order consistent.
  168. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
  169. - rebuild
  170. * Wed Jul 5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
  171. - new version 2.2.39
  172. - fixed usage of long UTF-8 filenames (#183181)
  173. Thanks to Andrey for the initial patch.
  174. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
  175. - rebuild for -devel deps
  176. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
  177. - bump again for double-long bug on ppc(64)
  178. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
  179. - rebuilt for new gcc4.1 snapshot and glibc changes
  180. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
  181. - new version 2.2.34
  182. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  183. - rebuilt
  184. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
  185. - fixed permissions of libacl
  186. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
  187. - spec file cleanup
  188. - mark po files as lang specific
  189. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  190. - 2.2.32
  191. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
  192. - update to 2.2.31
  193. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
  194. - get rid of *.la files
  195. - remove duplicate doc files
  196. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
  197. - Rebuild
  198. * Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
  199. - make the libs executable so that we find their dependencies (#132696)
  200. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
  201. - libacl-devel Requires: libattr-devel for libattr.la
  202. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
  203. - Requires libtool >= 1.5 for building
  204. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
  205. - Make libacl.so.* executable.
  206. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
  207. - Update to latest upstream version.
  208. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
  209. - Close bug #125300 (Steve Grubb: build requires libtool,gettext)
  210. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  211. - rebuilt
  212. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
  213. - Add missing %%defattr
  214. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
  215. - Add /usr/include/acl to files manifest
  216. - Fix location of doc files, add main doc dir to files manifest
  217. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  218. - rebuilt
  219. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  220. - rebuilt
  221. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
  222. - Fix libtool invocation
  223. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
  224. - Update to acl-2.2.7
  225. * Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
  226. - include patch from Jay Berkenbilt to print better error messages
  227. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
  228. - udpate/rebuild
  229. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
  230. - set execute bits on library so that requires are generated.
  231. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
  232. - Correct patch in previous fix so that shared libraries go in /lib*
  233. instead of /usr/lib*
  234. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
  235. - Fix multilibbing
  236. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
  237. - Added fix to install libs in correct directory on 64bit machine
  238. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
  239. - Made the package only own the one directory that is unique to it:
  240. /usr/include/acl
  241. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
  242. - Initial Red Hat package
  243. Made as few changes as possible relative to upstream packaging to
  244. make it easier to maintain long-term. This means that some of
  245. the techniques used here are definitely not standard Red Hat
  246. techniques. If you are looking for an example package to fit
  247. into Red Hat Linux transparently, this would not be the one to
  248. pick.
  249. - acl-devel -> libacl-devel