attr-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Utilities for managing filesystem extended attributes
  3. Name: attr
  4. Version: 2.4.47
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. URL: http://oss.sgi.com/projects/xfs/
  8. Group: System Environment/Base
  9. Source: http://download.savannah.gnu.org/releases-noredirect/attr/attr-%{version}.src.tar.gz
  10. # silence compile-time warnings
  11. Patch1: 0001-attr-2.4.47-warnings.patch
  12. # install /etc/xattr.conf
  13. Patch2: 0002-attr-2.4.47-xattr-conf.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gettext
  16. BuildRequires: libtool
  17. Requires: libattr = %{version}-%{release}
  18. Conflicts: xfsdump < 2.0.0
  19. %description
  20. A set of tools for manipulating extended attributes on filesystem
  21. objects, in particular getfattr(1) and setfattr(1).
  22. An attr(1) command is also provided which is largely compatible
  23. with the SGI IRIX tool of the same name.
  24. %package -n libattr
  25. Summary: Dynamic library for extended attribute support
  26. Group: System Environment/Libraries
  27. License: LGPLv2+
  28. %description -n libattr
  29. This package contains the libattr.so dynamic library which contains
  30. the extended attribute system calls and library functions.
  31. %package -n libattr-devel
  32. Summary: Extended attribute static libraries and headers
  33. Group: Development/Libraries
  34. License: LGPLv2+
  35. Requires: libattr = %{version}-%{release}
  36. %description -n libattr-devel
  37. This package contains the libraries and header files needed to
  38. develop programs which make use of extended attributes.
  39. For Linux programs, the documented system call API is the
  40. recommended interface, but an SGI IRIX compatibility interface
  41. is also provided.
  42. Currently only ext2, ext3 and XFS support extended attributes.
  43. The SGI IRIX compatibility API built above the Linux system calls is
  44. used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
  45. You should install libattr-devel if you want to develop programs
  46. which make use of extended attributes. If you install libattr-devel,
  47. you'll also want to install attr.
  48. # compat32
  49. %package -n compat32-libattr
  50. Summary: Dynamic library for extended attribute support
  51. Group: System Environment/Libraries
  52. License: LGPLv2+
  53. %description -n compat32-libattr
  54. This package contains the libattr.so dynamic library which contains
  55. the extended attribute system calls and library functions.
  56. %package -n compat32-libattr-devel
  57. Summary: Extended attribute static libraries and headers
  58. Group: Development/Libraries
  59. License: LGPLv2+
  60. Requires: libattr-devel = %{version}-%{release}
  61. Requires: compat32-libattr = %{version}-%{release}
  62. %description -n compat32-libattr-devel
  63. This package contains the libraries and header files needed to
  64. develop programs which make use of extended attributes.
  65. For Linux programs, the documented system call API is the
  66. recommended interface, but an SGI IRIX compatibility interface
  67. is also provided.
  68. Currently only ext2, ext3 and XFS support extended attributes.
  69. The SGI IRIX compatibility API built above the Linux system calls is
  70. used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
  71. You should install libattr-devel if you want to develop programs
  72. which make use of extended attributes. If you install libattr-devel,
  73. you'll also want to install attr.
  74. %prep
  75. %setup -q
  76. %patch1 -p1
  77. %patch2 -p1
  78. %build
  79. # attr abuses libexecdir
  80. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  81. make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
  82. %install
  83. rm -rf %{buildroot}
  84. make install DESTDIR=%{buildroot}
  85. make install-dev DESTDIR=%{buildroot}
  86. make install-lib DESTDIR=%{buildroot}
  87. # get rid of libattr.a and libattr.la
  88. rm -f %{buildroot}/%{_lib}/libattr.a
  89. rm -f %{buildroot}/%{_lib}/libattr.la
  90. rm -f %{buildroot}%{_libdir}/libattr.a
  91. rm -f %{buildroot}%{_libdir}/libattr.la
  92. # fix links to shared libs and permissions
  93. rm -f %{buildroot}%{_libdir}/libattr.so
  94. mkdir -p %{buildroot}%{_libdir}
  95. ln -sf ../../%{_lib}/libattr.so %{buildroot}%{_libdir}/libattr.so
  96. chmod 0755 %{buildroot}/%{_lib}/libattr.so.*.*.*
  97. # remove documents without version
  98. rm -rf %{buildroot}%{_datadir}/doc/attr
  99. %find_lang %{name}
  100. %check
  101. if ./setfattr/setfattr -n user.name -v value .; then
  102. make tests || exit $?
  103. # FIXME: root-tests are not ready for the SELinux
  104. #if test 0 = `id -u`; then
  105. # make root-tests || exit $?
  106. #fi
  107. else
  108. echo '*** xattrs are probably not supported by the file system,' \
  109. 'the test-suite will NOT run ***'
  110. fi
  111. %clean
  112. rm -rf %{buildroot}
  113. %post -n libattr
  114. /sbin/ldconfig
  115. %postun -n libattr
  116. /sbin/ldconfig
  117. %post -n compat32-libattr
  118. /sbin/ldconfig
  119. %postun -n compat32-libattr
  120. /sbin/ldconfig
  121. %files -f %{name}.lang
  122. %defattr(-,root,root)
  123. %doc doc
  124. %{_bindir}/attr
  125. %{_bindir}/getfattr
  126. %{_bindir}/setfattr
  127. %{_mandir}/man1/attr.1*
  128. %{_mandir}/man1/getfattr.1*
  129. %{_mandir}/man1/setfattr.1*
  130. %{_mandir}/man5/attr.5*
  131. %files -n libattr-devel
  132. %defattr(-,root,root)
  133. /%{_lib}/libattr.so
  134. %{_includedir}/attr
  135. %{_libdir}/libattr.*
  136. %{_mandir}/man2/*attr.2*
  137. %{_mandir}/man3/attr_*.3.*
  138. %files -n libattr
  139. /%{_lib}/libattr.so.*
  140. %config(noreplace) %{_sysconfdir}/xattr.conf
  141. # compat32
  142. %if %{build_compat32}
  143. %files -n compat32-libattr-devel
  144. %defattr(-,root,root)
  145. /%{_lib}/libattr.so
  146. %{_libdir}/libattr.*
  147. %files -n compat32-libattr
  148. /%{_lib}/libattr.so.*
  149. %config(noreplace) %{_sysconfdir}/xattr.conf
  150. %endif
  151. %changelog
  152. * Fri Jul 4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-1
  153. - new upstream release.
  154. - replaced patches to the newest rawhide's.
  155. * Sat Apr 9 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.44-1
  156. - new upstream release
  157. - remove static library from devel package
  158. - added Patch2-9
  159. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.44-8
  160. - fix typos in attr(1) man page (#669095)
  161. * Wed Dec 22 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-6
  162. - setfattr.1: document supported encodings of values (#587516)
  163. - getfattr: encode NULs properly with --encoding=text (#650539)
  164. - getfattr: return non-zero exit code on failure (#660619)
  165. - walk_tree: do not follow symlink to directory with -h (#660613)
  166. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-5
  167. - let attr depend on the same version of libattr (#595689)
  168. - silence compile-time warnings
  169. * Wed Feb 18 2009 Zdenek Prikryl <zprikryl@redhat.com> 2.4.43-2
  170. - Fixed memory leaks (#485473)
  171. * Wed Jul 15 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.43-2
  172. - added compat32 package for x86_64 arch support
  173. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.43-1
  174. - new upstream release
  175. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.41-2
  176. - initial build for Vine Linux
  177. * Wed Feb 13 2008 Zdenek Prikryl <zprikryl@redhat.com> 2.4.41-1
  178. - New version 2.4.41
  179. - Removed useless attr-2.0.8-docperms.patch
  180. * Wed Oct 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.39-1
  181. - New version 2.4.39
  182. - Resolves #284121
  183. * Tue Oct 30 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-2
  184. - Removed explicit Requires(post + postun)
  185. - Resolves #225290
  186. * Tue Jul 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-1
  187. - New version 2.4.38
  188. - Resolves #245415
  189. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.4.32-2
  190. - add disttag
  191. - remove trailing dot from summary
  192. - fix buildroot
  193. - -devel package requires same libattr version
  194. - change prereq to Requires(post)
  195. - escape macro in changelog
  196. - replace absolute link with relative link (libattr.so)
  197. - use %%doc macro
  198. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.32-1.1
  199. - rebuild
  200. * Wed Jul 5 2006 Thomas Woerner <twoerne@redhat.com> 2.4.32-1
  201. - new version 2.4.32
  202. - fixes segmentation fault in attr, which affects #189106
  203. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.4.28-2
  204. - rebuild for -devel deps
  205. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.2
  206. - bump again for double-long bug on ppc(64)
  207. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.1
  208. - rebuilt for new gcc4.1 snapshot and glibc changes
  209. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.4.28-1
  210. - new version 2.4.28
  211. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  212. - rebuilt
  213. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.4.24-2
  214. - spec file cleanup
  215. - mark po files as lang specific
  216. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  217. - 2.4.24
  218. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.23-1
  219. - update to 2.4.23
  220. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.16-6
  221. - get rid of *.la files
  222. - remove duplicate doc files
  223. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.4.16-4
  224. - Rebuild
  225. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.16-3
  226. - Build requires libtool >= 1.5
  227. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-2
  228. - Make libattr.so.* executable.
  229. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-1
  230. - Update to latest upstream version.
  231. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.4.1-6
  232. - Fix bug #125304 (Steve Grubb: build requires gettext)
  233. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  234. - rebuilt
  235. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-4
  236. - Add missing %%defattr
  237. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-3
  238. - Add /usr/include/attr to files manifest
  239. - Fix location of doc files, add main doc dir to files manifest
  240. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  241. - rebuilt
  242. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  243. - rebuilt
  244. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.4.1-2
  245. - Fix libtool
  246. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.4.1-1
  247. - update to attr-2.4.1
  248. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.0-1
  249. - update/rebuild
  250. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.8-6
  251. - set execute bits on library so that requires are generated.
  252. * Thu Nov 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.8-5
  253. - Redo multilib patch to work everywhere
  254. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.8-4
  255. - Added fix to install libs in correct directory on 64bit machine
  256. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-3
  257. - Made the package only own the one directory that is unique to it:
  258. /usr/include/attr
  259. * Wed Jun 26 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-2
  260. - get perl out of base with attr-2.0.8-docperms.patch
  261. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-1
  262. - Initial Red Hat package
  263. Made as few changes as possible relative to upstream packaging to
  264. make it easier to maintain long-term. This means that some of
  265. the techniques used here are definitely not standard Red Hat
  266. techniques. If you are looking for an example package to fit
  267. into Red Hat Linux transparently, this would not be the one to
  268. pick.
  269. - attr-devel -> libattr-devel