thunderbird-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767
  1. # do not include minor version number in MOZILLA_FIVE_HOME
  2. %define tbmajor 3.1
  3. %define tbversion %{tbmajor}.2
  4. %define tbrelease 2%{?_dist_release}
  5. # The tarball is pretty inconsistent with directory structure.
  6. # Sometimes there is a top level directory. That goes here.
  7. #
  8. # IMPORTANT: If there is no top level directory, this should be
  9. # set to the cwd, ie: '.'
  10. #%define tarballdir .
  11. %define tarballdir comm-1.9.2
  12. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  13. %define moz_objdir objdir-tb
  14. %define version_internal 3.1
  15. %define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
  16. %define desktop_file_utils_version 0.6
  17. %define nspr_version 4.8
  18. %define nss_version 3.12.6
  19. %define cairo_version 1.6.0
  20. %define freetype_version 2.1.9
  21. %define sqlite_version 3.6.14
  22. %define libnotify_version 0.4
  23. %define build_vineseed 0
  24. %define build_vine5 0
  25. %if "%{?_dist_release}" == "vl6"
  26. %define build_vineseed 1
  27. %endif
  28. %if "%{?_dist_release}" == "vl5"
  29. %define build_vine5 1
  30. %endif
  31. Summary: Thunderbird Community Edition, Mail/newsgroup client
  32. Summary(ja): Thunderbirdコミュニティエディション, メール・ニュースクライアント
  33. Name: thunderbird
  34. Version: %{tbversion}
  35. Release: %{tbrelease}
  36. URL: http://www.mozilla.org/projects/thunderbird/
  37. License: MPL
  38. Group: Applications/Internet
  39. Source0: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
  40. #Source1010: mozconfig-thunderbird-vine3
  41. #Source1020: mozconfig-thunderbird-vine4
  42. Source1030: mozconfig-thunderbird-vine5
  43. Source1040: mozconfig-thunderbird-vine6
  44. Source12: thunderbird-vine-default-prefs.js
  45. Source20: thunderbird.desktop
  46. Source21: thunderbird.vine.sh.in
  47. #Source22: thunderbird.png
  48. Source30: thunderbird-open-browser.sh
  49. Source40: thunderbird-unofficial-brandig-tb-brand.properties
  50. Source41: thunderbird-unofficial-brandig-tb-brand.dtd
  51. Source100: find-external-requires
  52. # locale sources
  53. %define MOZ_BUILD_LOCALES "ja"
  54. # get from mercurial repository with command,
  55. # mkdir l10n
  56. # hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
  57. Source1000: thunderbird-%{tbversion}-ja.tar.bz2
  58. # upstream patch
  59. # Fix for version issues
  60. Patch0: thunderbird-version.patch
  61. # Fix for jemalloc
  62. Patch1: mozilla-jemalloc.patch
  63. # Fix for installation fail when building with dynamic linked libraries
  64. Patch2: thunderbird-shared-error.patch
  65. # Fixes gcc complain that nsFrame::delete is protected
  66. Patch4: xulrunner-1.9.2.1-build.patch
  67. # customization patches
  68. #Patch22: firefox-1.0-psfonts.patch
  69. #Patch24: thunderbird-2.0-default-applications.patch
  70. #Patch25: thunderbird-1.1-software-update.patch
  71. Patch26: firefox-1.5-default-a4-paper.patch
  72. # font system fixes
  73. #Patch81: firefox-nopangoxft.patch
  74. ## Vine patch
  75. # http://bugzilla.mozilla.org/show_bug.cgi?id=179248
  76. Patch1000: thunderbird-3.1-sjisalias.patch
  77. # use /proc/net/netstat for random seed instead of netstat command.
  78. #Patch1010: firefox-nss-no_netstat.patch
  79. # workaround gcc visibility hidden bugs (see gcc#26905)
  80. Patch1020: firefox-2.0.0.3-visibility.patch
  81. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  82. BuildRequires: pango-devel
  83. BuildRequires: cairo-devel >= %{cairo_version}
  84. %if %{build_vineseed}
  85. BuildRequires: nspr-devel >= %{nspr_version}
  86. BuildRequires: nss-devel >= %{nss_version}
  87. %endif
  88. BuildRequires: pixman-devel
  89. BuildRequires: libpng-devel
  90. BuildRequires: libjpeg-devel
  91. BuildRequires: gtk2-devel
  92. BuildRequires: zlib-devel, gzip, zip, unzip
  93. BuildRequires: libIDL-devel
  94. BuildRequires: freetype2-devel >= %{freetype_version}
  95. ## disabled libnotify support
  96. ## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
  97. #BuildRequires: libnotify-devel >= %{libnotify_version}
  98. BuildRequires: bzip2-devel
  99. BuildRequires: gnome-vfs2-devel
  100. BuildRequires: libgnome-devel
  101. BuildRequires: libgnomeui-devel
  102. BuildRequires: krb5-devel
  103. BuildRequires: pango-devel
  104. BuildRequires: libXt-devel
  105. BuildRequires: libXrender-devel
  106. # hunspell is in plus category for vine
  107. #BuildRequires: hunspell-devel
  108. BuildRequires: sqlite3-devel >= %{sqlite_version}
  109. BuildRequires: startup-notification-devel
  110. BuildRequires: desktop-file-utils
  111. BuildRequires: alsa-lib-devel
  112. Requires: sqlite3 >= %{sqlite_version}
  113. Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
  114. Requires(postun): desktop-file-utils >= %{desktop_file_utils_version}
  115. Obsoletes: MozillaThunderbird
  116. Provides: MozillaThunderbird = %{version}
  117. Packager: daisuke, ryoichi, kazutaka
  118. AutoProv: 0
  119. %define _use_internal_dependency_generator 0
  120. %define __find_requires %{SOURCE100}
  121. %description
  122. Thunderbird is a standalone mail and newsgroup client.
  123. %description -l ja
  124. Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
  125. #===============================================================================
  126. %prep
  127. %setup -q %{name}-%{version} -c -b 1000
  128. cd %{tarballdir}
  129. # Fix for version issue
  130. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
  131. > version.patch
  132. %{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
  133. %patch1 -p0 -b .jemalloc
  134. %patch2 -p1 -b .shared-error
  135. %patch4 -p1 -b .protected
  136. cd mozilla
  137. #%patch22 -p1
  138. #%patch24 -p1
  139. #%patch25 -p0
  140. %patch26 -p1 -b .default-a4
  141. %patch1000 -p1 -b .sjis-alias
  142. cd -
  143. %{__rm} -f .mozconfig
  144. %if %{build_vine5}
  145. %{__cp} %{SOURCE1030} .mozconfig
  146. %endif
  147. %if %{build_vineseed}
  148. %{__cp} %{SOURCE1040} .mozconfig
  149. # cannot build with xulrunner (yet)
  150. # see tracking bugs.
  151. # https://bugzilla.mozilla.org/show_bug.cgi?id=306324
  152. # https://bugzilla.mozilla.org/show_bug.cgi?id=377319
  153. #echo "ac_add_options --with-libxul-sdk=`pkg-config --variable=sdkdir libxul`" >> .mozconfig
  154. %endif
  155. # setup unofficial branding name
  156. %{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
  157. %{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
  158. #===============================================================================
  159. %build
  160. cd %{tarballdir}
  161. INTERNAL_GECKO=%{version_internal}
  162. MOZ_APP_DIR=%{mozappdir}
  163. #MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
  164. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  165. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  166. export CFLAGS="$RPM_OPT_FLAGS"
  167. export CXXFLAGS="$CFLAGS"
  168. export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
  169. %ifarch ppc ppc64 s390 s390x
  170. %define moz_make_flags -j1
  171. %else
  172. %define moz_make_flags %{?_smp_mflags}
  173. %endif
  174. export PREFIX='%{_prefix}'
  175. export LIBDIR='%{_libdir}'
  176. export LDFLAGS="-Wl,-rpath,%{mozappdir}"
  177. export MAKE="gmake %{moz_make_flags}"
  178. %{__make} -f client.mk build
  179. # build locales
  180. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  181. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  182. for dir in $LOCALEDIRS
  183. do
  184. for lang in %{MOZ_BUILD_LOCALES} ; do
  185. make -C $dir/locales AB_CD=$lang
  186. done
  187. done
  188. #===============================================================================
  189. %install
  190. %{__rm} -rf $RPM_BUILD_ROOT
  191. cd %{tarballdir}
  192. INTERNAL_GECKO=%{version_internal}
  193. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  194. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  195. cd %{moz_objdir}
  196. DESTDIR=$RPM_BUILD_ROOT make install
  197. # install unofficial icons
  198. cd -
  199. %{__cp} mail/branding/unofficial/mailicon16.png \
  200. $RPM_BUILD_ROOT/%{mozappdir}/icons/
  201. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
  202. %{__cp} mail/branding/unofficial/mailicon16.png \
  203. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  204. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
  205. %{__cp} mail/branding/unofficial/mailicon22.png \
  206. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  207. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
  208. %{__cp} mail/branding/unofficial//mailicon24.png \
  209. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  210. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  211. %{__cp} mail/branding/unofficial/mailicon32.png \
  212. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  213. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
  214. %{__cp} mail/branding/unofficial/mailicon48.png \
  215. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  216. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
  217. %{__cp} mail/branding/unofficial/mailicon256.png \
  218. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  219. desktop-file-install --vendor vine \
  220. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  221. --add-category Application \
  222. --add-category Network \
  223. %{SOURCE20}
  224. # set up the thunderbird start script
  225. rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  226. %{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
  227. $RPM_BUILD_ROOT%{_bindir}/thunderbird
  228. %{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  229. install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  230. %{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  231. %{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
  232. -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
  233. $RPM_BUILD_ROOT/vine-default-prefs
  234. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
  235. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
  236. %{__rm} $RPM_BUILD_ROOT/vine-default-prefs
  237. %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
  238. # own mozilla plugin dir (#135050)
  239. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  240. # own extension directories
  241. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
  242. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
  243. # install locales
  244. for lang in %{MOZ_BUILD_LOCALES} ; do
  245. %{__install} -p -D -m 664 %{moz_objdir}/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
  246. done
  247. %clean
  248. %{__rm} -rf $RPM_BUILD_ROOT
  249. #===============================================================================
  250. %post
  251. update-desktop-database &> /dev/null || :
  252. touch --no-create %{_datadir}/icons/hicolor
  253. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  254. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  255. fi
  256. %postun
  257. update-desktop-database &> /dev/null || :
  258. touch --no-create %{_datadir}/icons/hicolor
  259. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  260. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  261. fi
  262. %files
  263. %defattr(-,root,root,-)
  264. %attr(755,root,root) %{_bindir}/thunderbird
  265. %attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
  266. %{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  267. %{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  268. %{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  269. %{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  270. %{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  271. %{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  272. %{mozappdir}
  273. #===============================================================================
  274. %changelog
  275. * Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
  276. - change mozconfig (Source1030 & 1040): add --enable-jsd
  277. * Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
  278. - new upstream release
  279. * Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
  280. - new upstream release with security fix
  281. - add Patch0 from fedora development: fix version issue
  282. - remove BuildRequires: hunspell-devel
  283. - update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
  284. * Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
  285. - add BuildRequires: alsa-lib-devel
  286. - remove BuildRequires: libnotify-devel
  287. (workaround for known bug)
  288. - update mozconfig to add --disable-libnotify option
  289. * Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
  290. - new upstream release
  291. - update spec entirely
  292. - import patches from fedora (Patch1, 2 & 4)
  293. - drop outdated patches (Patch22, 24)
  294. - update Sources:
  295. - mozconfig (Source1030 & Source1040)
  296. - default prefs.js (Source12)
  297. - unofficial branding (Source40 & Source41)
  298. - japanese translation (Source1000)
  299. - update Patch1000 (sjis-alias)
  300. * Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
  301. - new upstream release
  302. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
  303. - new upstream release
  304. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
  305. - don't install official branding logos
  306. * Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
  307. - add necessary icons in %%{tbdir}/chrome/icons/default
  308. - add Packager tag
  309. * Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
  310. - new upstream release
  311. * Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
  312. - new upstream release
  313. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
  314. - new upstream release
  315. * Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
  316. - new upstream release
  317. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
  318. - rebuilt for VineSeed
  319. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
  320. - new upstream release
  321. * Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
  322. - new upstream release
  323. - built for Vine Linux 4.x
  324. - dropped Patch1020 (merged into upstream)
  325. * Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
  326. - added Patch1020 for workaround gcc visibility hidden bugs
  327. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
  328. - build with new environment/toolchain
  329. - add build options to build with external nss/nspr libraries
  330. ac_add_options --with-system-nspr
  331. ac_add_options --with-system-nss
  332. * Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
  333. - new upstream release
  334. * Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
  335. - new upstream release
  336. * Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
  337. - new upstream release
  338. * Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
  339. - new upstream release
  340. * Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
  341. - new upstream release
  342. - merge changes from firefox
  343. - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
  344. * Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
  345. - new upstream release
  346. - build en-US locale
  347. - merge changes from firefox
  348. - add upstream patches
  349. - disable pango rendering by default
  350. (workaround fix slow rendering in some page)
  351. * Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
  352. - initial build for Vine Linux based on FC package
  353. - update to 1.5RC2
  354. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
  355. - Fix issue with popup dialogs and other actions causing lockups
  356. * Sat Nov 5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
  357. - Update to 1.5 rc1
  358. * Sat Oct 8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
  359. - Update to 1.5 beta2
  360. * Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
  361. - Update to 1.5 beta1
  362. - Bring the install phase of the spec file up to speed
  363. * Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
  364. - Rebuild
  365. * Sat Aug 6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
  366. - Add patch to make file chooser dialog modal
  367. * Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
  368. - Update to 1.0.6
  369. * Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
  370. - 1.0.6 Release Candidate
  371. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
  372. - Use system NSPR
  373. - Fix crash on 64bit platforms (#160330)
  374. * Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com> 1.0.2-7
  375. - Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
  376. references, fixing the "no fonts" problem.
  377. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
  378. - Change the Exec line in the desktop file to `thunderbird`
  379. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
  380. - Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
  381. * Mon May 9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
  382. - Add temporary workaround to not create files in the user's $HOME (#149664)
  383. * Wed May 4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
  384. - Don't have downloads "disappear" when downloading to desktop (#139015)
  385. - Fix for some more cursor issues in textareas (149991, 150002, 152089)
  386. - Add upstream patch to fix bidi justification of pango
  387. - Add patch to fix launching of helper applications
  388. - Add patch to properly link against libgfxshared_s.a
  389. - Fix multilib conflicts
  390. * Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
  391. - correct confusing PANGO vars in startup script
  392. * Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
  393. - Thunderbird 1.0.2
  394. * Tue Mar 8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
  395. - Add patch to compile against new fortified glibc macros
  396. * Sat Mar 5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
  397. - Rebuild against GCC 4.0
  398. - Add execshield patches
  399. - Minor specfile cleanup
  400. * Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
  401. - Rebuild
  402. * Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
  403. - Add RPM version to useragent
  404. * Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
  405. - Port over pango patches from firefox
  406. * Wed Dec 8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
  407. - Thunderbird 1.0
  408. * Mon Dec 6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
  409. - Fix advanced prefs
  410. * Fri Dec 3 2004 Christopher Aillon <caillon@redhat.com>
  411. - Make this run on s390(x) now for real
  412. * Wed Dec 1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
  413. - Update to 1.0 rc1
  414. * Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
  415. - Add patches to build and run on s390(x)
  416. * Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
  417. - Rebuild to fix file chooser
  418. * Fri Nov 5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
  419. - Update to 0.9
  420. * Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
  421. - Prevent inlining of stack direction detection (#135255)
  422. * Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
  423. - More file chooser fixes (same as in firefox)
  424. - Fix for upstream 28327.
  425. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  426. - Update the pango patch
  427. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  428. - Pull over patches from firefox build:
  429. - disable default application dialog
  430. - don't include software update since it doesn't work
  431. - make external app support work
  432. * Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
  433. - Use pango for rendering
  434. * Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
  435. - Fix for 64 bit crash at startup (b.m.o #256603)
  436. * Sat Oct 9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
  437. - Add patches to fix xremote (#135036)
  438. * Fri Oct 8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
  439. - Add patch to fix button focus issues (#133507)
  440. - Add patch for fix IMAP race issues (bmo #246439)
  441. * Fri Oct 1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
  442. - filter out library Provides: and internal Requires:
  443. * Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
  444. - Backport the GTK+ File Chooser.
  445. - Add fix for JS math on x86_64 systems
  446. - Add pkgconfig patch
  447. * Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
  448. - Update to 0.8.0
  449. - Remove enigmail
  450. - Update BuildRequires
  451. - Remove gcc34 and extension manager patches -- they are upstreamed.
  452. - Fix for gnome-vfs2 error at component registration
  453. * Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
  454. - Build with --disable-xprint
  455. * Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
  456. - remove all Xvfb-related hacks
  457. * Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
  458. - actually apply psfonts
  459. - add mozilla gnome-uriloader patch to prevent build failure
  460. * Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
  461. - rawhide import
  462. - apply NetBSD's freetype 2.1.8 patch
  463. - apply psfonts patch
  464. - remove BR on /usr/bin/ex, breaks beehive
  465. * Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
  466. - oops, fix %%install
  467. * Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
  468. - update to Thunderbird 0.7.3 and Enigmail 0.85.0
  469. - remove XUL.mfasl on startup, add Debian enigmail patches
  470. - add Xvfb hack for -install-global-extension
  471. * Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
  472. - update to 0.7.2, just because it's there
  473. - update gcc-3.4 patch (Kaj Niemi)
  474. - add EM registration patch and remove instdir hack
  475. * Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
  476. - re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
  477. * Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
  478. - update to 0.7.1
  479. - remove Enigmail
  480. * Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
  481. - re-enable Enigmail 0.84.1
  482. - add gcc-3.4 patch (Kaj Niemi)
  483. - use official branding (with permission)
  484. * Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
  485. - update to 0.7
  486. - temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
  487. - specify libdir, change BR for apt (V. Skytt辰, #1617)
  488. * Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
  489. - temporary workaround for enigmail skin "modern" bug
  490. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
  491. - update to Enigmail 0.84.0
  492. - update launch script
  493. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
  494. - installation directory now versioned
  495. - allow root to run the program (for installing extensions)
  496. - remove unnecessary %%pre and %%post
  497. - remove separators, update mozconfig and launch script (M. Schwendt, #1460)
  498. * Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
  499. - include Enigmail, re-add release notes
  500. - delete %{_libdir}/thunderbird in %%pre
  501. * Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
  502. - update to Thunderbird 0.6
  503. * Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
  504. - update to Thunderbird 0.6 RC1
  505. - add new icon, remove release notes
  506. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
  507. - update to latest CVS, update mozconfig and %%build accordingly
  508. - update to Enigmail 0.83.6
  509. - remove x-remote and x86_64 patches
  510. - build with -Os
  511. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
  512. - update x-remote patch
  513. - more startup script fixes
  514. * Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
  515. - startup script fixes, and a minor cleanup
  516. * Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
  517. - Minor cleanups
  518. * Sun Apr 04 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.8
  519. - minor improvements to open-browser.sh and startup script
  520. - update to latest version of Blizzard's x-remote patch
  521. * Thu Mar 25 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.7
  522. - update open-browser.sh, startup script, and BuildRequires
  523. * Sun Mar 14 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.6
  524. - update open-browser script, modify BuildRequires (Warren)
  525. - add Blizzard's x-remote patch
  526. - initial attempt at x-remote-enabled startup script
  527. * Sun Mar 07 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.5
  528. - refuse to run with excessive privileges
  529. * Fri Feb 27 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.4
  530. - add Mozilla x86_64 patch (Oliver Sontag)
  531. - Enigmail source filenames now include the version
  532. - modify BuildRoot
  533. * Thu Feb 26 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.3
  534. - use the updated official tarball
  535. * Wed Feb 18 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.2
  536. - fix %%prep script
  537. * Mon Feb 16 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.1
  538. - update Enigmail to 0.83.3
  539. - use official source tarball (after removing the CRLFs)
  540. - package renamed to thunderbird
  541. * Mon Feb 09 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.0
  542. - update to 0.5
  543. - check for lockfile before launching
  544. * Fri Feb 06 2004 David Hill <djh[at]ii.net>
  545. - update to latest cvs
  546. - update to Enigmail 0.83.2
  547. * Thu Jan 29 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.5
  548. - update to Enigmail 0.83.1
  549. - removed Mozilla/Firebird script patching
  550. * Sat Jan 03 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.4
  551. - add startup notification to .desktop file
  552. * Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
  553. - open-browser.sh release 3
  554. - patch broken /usr/bin/mozilla script during install
  555. - dir ownership
  556. - XXX: Source fails build on x86_64... fix later
  557. * Tue Dec 23 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.2
  558. - update to Enigmail 0.82.5
  559. - add Warren's open-browser.sh (#1113)
  560. * Tue Dec 09 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.1
  561. - use Thunderbird's mozilla-xremote-client to launch browser
  562. * Sun Dec 07 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.0
  563. - update to 0.4
  564. - make hyperlinks work (with recent versions of Firebird/Mozilla)
  565. * Thu Dec 04 2003 David Hill <djh[at]ii.net>
  566. - update to 0.4rc2
  567. * Wed Dec 03 2003 David Hill <djh[at]ii.net>
  568. - update to 0.4rc1 and Enigmail 0.82.4
  569. * Thu Nov 27 2003 David Hill <djh[at]ii.net>
  570. - update to latest CVS and Enigmail 0.82.3
  571. * Sun Nov 16 2003 David Hill <djh[at]ii.net>
  572. - update to latest CVS (0.4a)
  573. - update Enigmail to 0.82.2
  574. - alter mozconfig for new build requirements
  575. - add missing BuildReq (#987)
  576. * Thu Oct 16 2003 David Hill <djh[at]ii.net> 0:0.3-0.fdr.0
  577. - update to 0.3
  578. * Sun Oct 12 2003 David Hill <djh[at]ii.net> 0:0.3rc3-0.fdr.0
  579. - update to 0.3rc3
  580. - update Enigmail to 0.81.7
  581. * Thu Oct 02 2003 David Hill <djh[at]ii.net> 0:0.3rc2-0.fdr.0
  582. - update to 0.3rc2
  583. * Wed Sep 17 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.2
  584. - simplify startup script
  585. * Wed Sep 10 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.1
  586. - add GPG support (Enigmail 0.81.6)
  587. - specfile fixes (#679)
  588. * Thu Sep 04 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.0
  589. - update to 0.2
  590. * Mon Sep 01 2003 David Hill <djh[at]ii.net>
  591. - initial RPM
  592. (based on the fedora MozillaFirebird-0.6.1 specfile)