parole-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216
  1. # by default don't build the browser plugin
  2. # use bcond_without to change the default
  3. #%bcond_with mozilla
  4. %define PAROLE_BIN %{_libexecdir}/%{name}
  5. Name: parole
  6. Version: 0.8.0
  7. Release: 1%{?_dist_release}
  8. Summary: Media player for the Xfce desktop
  9. Summary(ja): Xfce デスクトップのメディアプレーヤー
  10. Group: Applications/Multimedia
  11. License: GPLv2+
  12. URL: http://goodies.xfce.org/projects/applications/parole
  13. Source0: http://archive.xfce.org/src/apps/parole/0.8/%{name}-%{version}.tar.bz2
  14. Source10: parole.sh
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: clutter-devel >= 1.16.4
  17. BuildRequires: clutter-gtk-devel >= 1.4.4
  18. BuildRequires: dbus-devel >= 0.60
  19. BuildRequires: dbus-glib-devel >= 0.70
  20. BuildRequires: desktop-file-utils
  21. BuildRequires: gettext
  22. BuildRequires: glib2-devel >= 2.32.0
  23. BuildRequires: gstreamer1-devel
  24. BuildRequires: gstreamer1-plugins-base-devel
  25. BuildRequires: gtk3-devel >= 3.2.0
  26. BuildRequires: gtk-doc
  27. BuildRequires: intltool
  28. BuildRequires: libnotify-devel >= 0.4.1
  29. BuildRequires: libxfce4ui-devel >= 4.11.0
  30. BuildRequires: libxfce4util-devel >= 4.10.0
  31. BuildRequires: taglib-devel >= 1.4
  32. BuildRequires: xfce4-dev-tools
  33. BuildRequires: xfconf-devel >= 4.10.0
  34. #%if %{with mozilla}
  35. #BuildRequires: xulrunner-devel
  36. #%endif
  37. Requires: gstreamer1-plugins-good
  38. # required by SOURCE10
  39. Requires: synaptic zenity
  40. Obsoletes: %{name}-mozplugin
  41. %description
  42. Parole is a modern simple media player based on the GStreamer framework and
  43. written to fit well in the Xfce desktop. Parole features playback of local
  44. media files, DVD/CD and live streams. Parole is extensible via plugins.
  45. The project still in its early developments stage, but already contains the
  46. following features:
  47. * Audio playback
  48. * Video playback with optional subtitle
  49. * Playback of live sources
  50. %description -l ja
  51. Parole は GStreamer フレームワークに基づき Xfce デスクトップに
  52. 馴染むよう書かれたモダンでシンプルなメディアプレーヤーです。
  53. Parole はローカルメディアファイル、DVD/CD、ライブストリームの再生を
  54. 特色とします。
  55. Parole はプラグインを介して拡張が可能です。
  56. このプロジェクトはまだ開発の初期段階ですが、
  57. 既に以下の機能がふくまれています。
  58. * オーディオの再生
  59. * 任意のサブタイトルがあるビデオの再生
  60. * ライブストリームの再生
  61. %package devel
  62. Summary: Development files for %{name}
  63. Summary(ja): %{name} の開発ファイル
  64. Group: Development/Libraries
  65. Requires: %{name} = %{version}-%{release}
  66. %description devel
  67. The %{name}-devel package contains header files for developing plugins for
  68. %{name}.
  69. %description devel -l ja
  70. %{name}-devel パッケージ は %{name} のプラグインを開発するための
  71. ヘッダファイルを含みます。
  72. %prep
  73. %setup -q
  74. #%patch1 -p1
  75. %build
  76. #/autogen.sh
  77. %configure --disable-static --enable-gtk-doc --enable-clutter
  78. make %{?_smp_mflags} V=1
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  83. ## wrapper install
  84. mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
  85. mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{PAROLE_BIN}
  86. install -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
  87. %find_lang %{name}
  88. desktop-file-install \
  89. --delete-original \
  90. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  91. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %post
  95. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  96. update-mime-database %{_datadir}/mime &> /dev/null || :
  97. %postun
  98. if [ $1 -eq 0 ] ; then
  99. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  100. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  101. fi
  102. update-mime-database %{_datadir}/mime &> /dev/null || :
  103. %posttrans
  104. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  105. %files -f %{name}.lang
  106. %defattr(-,root,root,-)
  107. %doc AUTHORS COPYING README TODO THANKS
  108. %{PAROLE_BIN}
  109. %{_bindir}/%{name}
  110. %dir %{_libdir}/%{name}-0
  111. %{_libdir}/%{name}-0/*.so
  112. %{_datadir}/appdata/%{name}.appdata.xml
  113. %{_datadir}/applications/%{name}.desktop
  114. %{_datadir}/icons/hicolor/*
  115. %{_datadir}/%{name}
  116. %files devel
  117. %defattr(-,root,root,-)
  118. %doc %{_datadir}/gtk-doc/html/Parole-Plugins/
  119. %{_includedir}/%{name}
  120. %changelog
  121. * Sun Mar 1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.0-1
  122. - new upstream release
  123. - updated to SOURCE10
  124. - built with libxfce4util 4.12.1 and gstreamer1-plugins
  125. * Sat Jul 12 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.4-1
  126. - new upstream release
  127. * Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  128. - new upstream release
  129. * Fri Aug 24 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.0.3-1
  130. - new upstream release
  131. - deleted Patch1
  132. - added BuildRequires: xfce4-dev-tools, libxfce4ui-devel >= 4.8.0
  133. - changed BuildRequires
  134. - gtk2-devel >= 2.16.0 to 2.20.0
  135. - glib2-devel >= 2.16.0 to 2.32.0
  136. - gstreamer-plugins-base-devel >= 0.10.11 to 0.10.24
  137. - libxfcegui4-devel >= 4.6.0 to 4.8.0
  138. - libxfce4util-devel >= 4.6.0 to 4.8.0
  139. * Fri Jun 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-3
  140. - rebuilt with new libxfce4util
  141. * Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-2
  142. - added Obsoletes tag: %%{name}-mozplugin
  143. - added wrapper script to detect nonfree package installed
  144. * Fri Sep 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-1
  145. - new upstream release
  146. - obsoleted -mozplugin package
  147. * Tue Jan 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.2-1
  148. - new upstream release
  149. * Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.1-2
  150. - new upstream release
  151. * Tue Jan 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0-1
  152. - new upstream release
  153. - added BuildRequires: glib2-devel >= 2.16.0, libxfce4util-devel >= 4.6.0
  154. * Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.99-1
  155. - new upstream release
  156. - added BuildRequires: gstreamer-devel
  157. - splitted mozplugin package
  158. * Sun Nov 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.91-1
  159. - new upstream release
  160. - dropt all pathces
  161. * Thu Oct 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.90-1
  162. - initial build for VineSeed
  163. * Thu Oct 08 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-2
  164. - BuildRequire taglib-devel and fix libnotify requirement
  165. * Wed Oct 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-1
  166. - Update to 0.1.90
  167. - Loads of additional translations
  168. * Fri Sep 18 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1-0.1
  169. - Initial package