xorg-x11-drv-intel-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate 20110817
  4. Summary: Xorg X11 Intel video driver
  5. Summary(ja): Xorg X11 Intel ビデオドライバ
  6. Name: xorg-x11-drv-intel
  7. Epoch: 1
  8. Version: 2.19.0
  9. Release: 3%{?_dist_release}
  10. URL: http://intellinuxgraphics.org/
  11. License: MIT
  12. Group: User Interface/X Hardware Support
  13. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  14. Source2: intel.xinf
  15. Source3: intel-gpu-tools-%{gputoolsdate}.tar.bz2
  16. # Clamp VGA pixel clock to 250MHz,
  17. # anything higher's going to look awful anyway. (#559426)
  18. Patch10: intel-2.11.0-vga-clock-max.patch
  19. # import from ubuntu/debian package
  20. Patch101: intel-2.15.0-copy-fb.patch
  21. # vine patch
  22. ExclusiveArch: %{ix86} x86_64 ia64
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. BuildRequires: autoconf, automake, libtool
  25. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  26. BuildRequires: libXvMC-devel
  27. BuildRequires: libGL-devel >= 7.10
  28. BuildRequires: libdrm-devel >= 2.4.25
  29. BuildRequires: kernel-headers >= 2.6.33
  30. BuildRequires: libudev-devel
  31. BuildRequires: libxcb-devel >= 1.5
  32. BuildRequires: xcb-util-devel
  33. Requires: hwdata
  34. Requires: xorg-x11-server-Xorg
  35. Requires: xcb-util
  36. Obsoletes: xorg-x11-drv-i810
  37. Provides: xorg-x11-drv-i810
  38. #Conflicts: kudzu < 1.2.42-1
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. %description
  42. X.Org X11 Intel video driver.
  43. %package devel
  44. Summary: Xorg X11 Intel video driver XvMC development package
  45. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  46. Group: Development/System
  47. Requires: %{name} = %{epoch}:%{version}-%{release}
  48. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  49. %description devel
  50. X.Org X11 Intel video driver XvMC development package.
  51. %package -n intel-gpu-tools
  52. Summary: Debugging tools for Intel graphics chips
  53. Group: Development/Tools
  54. %description -n intel-gpu-tools
  55. Debugging tools for Intel graphics chips
  56. %prep
  57. %setup -q -n xf86-video-intel-%{version} -b3
  58. %patch10 -p1 -b .vga-clock
  59. #%patch101 -p1 -b .copy-fb
  60. %build
  61. autoreconf -vi
  62. %configure \
  63. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  64. --enable-dri --enable-xvmc \
  65. --enable-uxa
  66. make
  67. pushd ../intel-gpu-tools-%{gputoolsdate}
  68. autoreconf -v --install
  69. %configure
  70. make
  71. popd
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. make install DESTDIR=$RPM_BUILD_ROOT
  75. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  76. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  77. pushd ../intel-gpu-tools-%{gputoolsdate}
  78. make install DESTDIR=$RPM_BUILD_ROOT
  79. popd
  80. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %triggerpostun -- XOrg < 7.0
  84. if (grep -q i810 /etc/X11/xorg.conf)
  85. then
  86. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  87. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  88. fi ||:
  89. %files
  90. %defattr(-,root,root,-)
  91. %{driverdir}/intel_drv.so
  92. %{_datadir}/hwdata/videoaliases/intel.xinf
  93. %{_libdir}/libI810XvMC.so.*
  94. %{_libdir}/libIntelXvMC.so.*
  95. %{_mandir}/man4/i*
  96. %files devel
  97. %defattr(-,root,root,-)
  98. %{_libdir}/libI810XvMC.so
  99. %{_libdir}/libIntelXvMC.so
  100. %files -n intel-gpu-tools
  101. %defattr(-,root,root,-)
  102. %{_bindir}/intel_*
  103. %{_mandir}/man1/intel_*.1*
  104. %changelog
  105. * Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
  106. - rebuild with xcb-util-0.3.9
  107. * Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
  108. - disable sna, enable uxa
  109. * Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
  110. - new upstream release
  111. * Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
  112. - rebuild with xserver-1.12.0
  113. * Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  114. - new upstream release
  115. - enable sna
  116. * Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
  117. - disable sna/vmap
  118. * Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  119. - new upstram release
  120. - disable copy-fb patch
  121. * Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
  122. - rebuild with xserver-1.11.1.902
  123. * Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
  124. - add --enable-sna --enable-vmap
  125. * Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  126. - new upstream release
  127. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
  128. - rebuild with xcb-util-0.3.8
  129. - drop Patch200
  130. * Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
  131. - update to disable copy_fb on sandybridge/ivybridge
  132. * Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
  133. - update intel.xinf
  134. - add patch10 from fedora
  135. - Clamp VGA pixel clock to 250MHz,
  136. anything higher's going to look awful anyway. (#559426)
  137. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  138. - drop patch1-3 and replaced with new patch1 from git master
  139. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  140. - update intel-gpu-tools
  141. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  142. - add Patch1-3 from upstream
  143. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  144. - new upstream release
  145. - drop upstream patches: 107-115
  146. - temporary disabled patch101
  147. - BR: libdrm >= 2.4.25
  148. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  149. - add Patch101-115 from ubuntu/debian package
  150. - Patch101: Plymouth integration patch
  151. - Patch107: Check null return from uxa_acquire_solid()
  152. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  153. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  154. - Patch110,114: Cherry picks to fix a large number of build warnings.
  155. - Patch111: Fix clipped window plane offset
  156. - Patch112: Fix issue where vertical green line and strange colors
  157. shows up when playing gstreamer with certain videos,
  158. when dragged. (LP 460677)
  159. - Patch113: Fixes GPU lockup during login with
  160. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  161. error messages listed in the gpu dump text. (LP 710321)
  162. - Patch115: Don't fill up Xorg.0.log with
  163. "get vblank counter failed: Invalid argument" warnings.
  164. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  165. - rebuild with xserver-1.10.0
  166. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  167. - new upstream release
  168. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  169. - new upstream release
  170. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  171. - rebuild with xserver-1.9.2
  172. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  173. - new upstream release
  174. - add Patch40: fix uxa planemask (backported)
  175. - add Patch61: add support for backlight on macbooks
  176. - add Patch62: disable page flipping for stability
  177. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  178. - new upstream release
  179. - drop patch70
  180. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  181. - rebuild again with xserver-1.8rc
  182. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  183. - add intel-gpu-tools as sub-package
  184. - rebuild with libdrm-2.4.18
  185. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  186. - new upstream release
  187. - import Patch1,2,60,70 from fedora
  188. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  189. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  190. - add BR; libudev-devel and autoreconf for Patch60
  191. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  192. - rebuild with libdrm-2.4.17
  193. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  194. - new upstream release
  195. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  196. - new upstream release (hopefully fixes severe issues w/ efifb)
  197. - drop all patches already upstreamed; import Patch20/21 from Fedora
  198. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  199. - import Patch121,122 from ubuntu
  200. - build with libdrm-2.4.12 which fixes vt switch crash
  201. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  202. - apply patch114 to fix Xv with non-GEM kernel
  203. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  204. - update to 2.6.3
  205. - add patch106,107,115,118,119,120 from ubuntu
  206. - add Patch106: remove triple buffering
  207. - add Patch107: remove page flipping
  208. - add Patch115: fix crash Xv overlay
  209. - add Patch118: drop legacy3d
  210. - add Patch119: fix crashes in drm bo
  211. - add Patch120: fix vt switch
  212. - add patch130-134 from upstream git
  213. - add Patch130: fix another vt switch leak
  214. - add Patch131: Create known output configuration at EnterVT time
  215. - add Patch132: fix leak of some 965 render state on VT switch
  216. - add Patch133: fix crash with fake bufmgr and UXA
  217. - add Patch134: fix EnterVT/LeaveVT
  218. - add Patch135: add new chip supoprt
  219. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  220. - revert to 2.6.1, add Epoch
  221. - add Patch103-121 from ubuntu
  222. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  223. - new upstream release
  224. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  225. - new upstream release
  226. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  227. - new upstream release
  228. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  229. - add Patch5 - Dont die on irq handler failure
  230. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  231. - new upstream release
  232. - add BR: libdrm-devel >= 2.4.0-3
  233. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  234. - import Patch10,11,12 from ubuntu
  235. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  236. - new upstream release
  237. - add triggerpostun script to replace i810 driver to intel driver
  238. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  239. - new upstream release
  240. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  241. - new upstream release
  242. - rename i810.xinf to intel.xinf
  243. - update intel.xinf (add Intel 4 series)
  244. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  245. - rebuild with new xserver
  246. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  247. - new upstream release
  248. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  249. - new upstream release
  250. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  251. - new upstream release
  252. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  253. - initial build for Vine Linux
  254. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  255. - Rebuild for new server ABI.
  256. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  257. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  258. - hook up ch7017 (bz#408471)
  259. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  260. - xf86-video-intel 2.2.0
  261. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  262. - xf86-video-intel 2.1.99.
  263. - Drop the i810 driver. Time to move on.
  264. - Require xserver 1.4.99.1
  265. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  266. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  267. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  268. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  269. for textured Xv to use as an offscreen pixmap so xv actually works under
  270. compiz - granted it may be unusably slow but at least stuff shows up.
  271. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  272. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  273. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  274. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  275. - intel-2.1.1-quirk-update.patch - update quirks from master
  276. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  277. - i810.xinf: Flip everything over to -intel by default now. Still install
  278. i810 driver just in case.
  279. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  280. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  281. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  282. - xf86-video-intel 2.1.1.
  283. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  284. - xf86-video-intel 2.1.0.
  285. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  286. - Update Requires and BuildRequires.
  287. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  288. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  289. 965GME, G33, Q33, and Q35 chips.
  290. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  291. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  292. DRI clients are active, for better battery life.
  293. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  294. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  295. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  296. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  297. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  298. rename this at some point.
  299. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  300. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  301. 915GM.
  302. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  303. - i810.xinf: More intel whitelisting (#214011, #234877)
  304. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  305. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  306. - i810.xinf: Point 965GM support at the intel driver since it's not present
  307. in old i810.
  308. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  309. - xf86-video-intel-1.9.93 (RC3).
  310. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  311. - fix typo with 945GM pci id from my laptop
  312. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  313. - xf86-video-intel 1.9.92 (RC2).
  314. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  315. - Updated modesetting driver to one that will actually work with a 1.3 server.
  316. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  317. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  318. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  319. code anywhere
  320. - Disown the module
  321. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  322. - update modesetting driver to git snapshot from today
  323. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  324. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  325. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  326. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  327. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  328. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  329. actually require kudzu to run.
  330. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  331. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  332. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  333. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  334. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  335. driver match the corresponding terrible heuristic in the server.
  336. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  337. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  338. correctly distinguish between Mac Mini and Macbook Pro.
  339. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  340. - i810.xinf: PCI IDs for i965.
  341. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  342. - i810.xinf: Uppercase PCI IDs.
  343. * Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  344. - Update i810 to 1.6.5, should fix DRI.
  345. - Add kuzdu requires.
  346. - i810.xinf: Start whitelisting devices over to intel.
  347. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  348. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  349. you know, load.
  350. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  351. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  352. LFP special casing in favor of the blacklist.
  353. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  354. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  355. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  356. and is selected with Driver "intel" in xorg.conf. Individual devices will
  357. whitelist over to "intel" until that branch gets merged into head.
  358. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  359. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  360. the BIOS is known to lie.
  361. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  362. - Today's snapshot: I2C bus creation fix.
  363. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  364. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  365. clock when computing the modes list.
  366. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  367. in centimeters as the size of the display in pixels.
  368. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  369. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  370. probing.
  371. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  372. - Update again for a mode comparison bugfix.
  373. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  374. - Update to today's git; crash fixes, better pre-915 support, slightly better
  375. autoconfigurability.
  376. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  377. - rebuild
  378. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  379. - Fix Revision number to match naming policy.
  380. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  381. - Add back modesetting changes.
  382. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  383. - Roll back modesetting changes and build for fc5 aiglx repo.
  384. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  385. - Snapshot of the git modesetting branch.
  386. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  387. - Update i810.xinf to include entries for E7221 and 945GM.
  388. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  389. - Add with_dri macro to spec file, and conditionalize build time DRI support
  390. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  391. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  392. to pick up proto-devel as well.
  393. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  394. - Rebuild for 7.1 ABI fix.
  395. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  396. - Bump for fc5-bling build.
  397. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  398. - Update to 1.6.0 from 7.1RC1.
  399. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  400. - Add patch to add missing #include's, specifically assert.h.
  401. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  402. - Update to CVS snapshot of 20060322.
  403. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  404. - rebuilt for new gcc4.1 snapshot and glibc changes
  405. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  406. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  407. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  408. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  409. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  410. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  411. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  412. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  413. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  414. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  415. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  416. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  417. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  418. - Fix *.la file removal.
  419. - Added 'devel' subpackage for XvMC .so
  420. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  421. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  422. - Update BuildRoot to use Fedora Packaging Guidelines.
  423. - Deglob file manifest.
  424. - Limit "ExclusiveArch" to x86, x86_64, ia64
  425. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  426. - Initial spec file for i810 video driver generated automatically
  427. by my xorg-driverspecgen script.