libpq-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818
  1. #%define rel 0
  2. %define beta 0
  3. %{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
  4. %define ssl 1
  5. %define kerberos 0
  6. %define nls 1
  7. %define pam 1
  8. %define pq_soname 5
  9. %define ecpg_soname 6
  10. Summary: The shared libraries required for any PostgreSQL clients.
  11. Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
  12. Name: libpq
  13. Version: 15.3
  14. Release: 1%{?_dist_release}
  15. %define pgver %(echo %{version} | cut -d. -f1)
  16. Group: system
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. License: BSD
  20. URL: https://www.postgresql.org/
  21. Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
  22. Source5: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
  23. Source6: README.rpm-dist
  24. Buildroot: %{_tmppath}/%{name}-%{version}-root
  25. Buildrequires: perl build-essential
  26. Buildrequires: libedit-devel
  27. Buildrequires: zlib-devel >= 1.0.4
  28. BuildRequires: bison, flex, pam-devel
  29. %if %ssl
  30. Buildrequires: openssl-devel
  31. %endif
  32. %if %kerberos
  33. Buildrequires: krb5-devel
  34. %endif
  35. %if %nls
  36. Buildrequires: gettext >= 0.10.35
  37. %endif
  38. %if %pam
  39. Buildrequires: pam-devel
  40. %endif
  41. %description
  42. The %{name} package provides the essential shared libraries for any
  43. PostgreSQL client program or interface. You will need to install this package
  44. to use any other PostgreSQL package or any clients that need to connect to a
  45. PostgreSQL server.
  46. %description -l ja
  47. %{name} パッケージは、すべての PostgreSQL クライアントプログラ
  48. ムやインターフェースのための中核的な共有ライブラリを提供します。
  49. PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
  50. ントを使う場合には、このパッケージをインストールする必要があります。
  51. %package -n libpq%{pq_soname}
  52. Summary: The shared libraries required for any PostgreSQL clients.
  53. Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
  54. Group: system
  55. Requires(post): /sbin/ldconfig
  56. Requires(postun): /sbin/ldconfig
  57. Obsoletes: postgresql7-libs
  58. Obsoletes: postgresql8-libs
  59. Obsoletes: postgresql-libs < 9.3.0
  60. Conflicts: postgresql-libs >= 9.3.0
  61. %description -n libpq%{pq_soname}
  62. The %{name} package provides the essential shared libraries for any
  63. PostgreSQL client program or interface. You will need to install this package
  64. to use any other PostgreSQL package or any clients that need to connect to a
  65. PostgreSQL server.
  66. %description -n libpq%{pq_soname} -l ja
  67. %{name} パッケージは、すべての PostgreSQL クライアントプログラ
  68. ムやインターフェースのための中核的な共有ライブラリを提供します。
  69. PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
  70. ントを使う場合には、このパッケージをインストールする必要があります。
  71. %package devel
  72. Summary: PostgreSQL development header files and libraries.
  73. Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
  74. Group: programming
  75. Requires: libpq%{pq_soname} = %{version}
  76. Obsoletes: postgresql7-devel
  77. Obsoletes: postgresql8-devel
  78. Obsoletes: postgresql-devel < 9.3.0
  79. %description devel
  80. The %{name}-devel package contains the header files and libraries
  81. needed to compile C or C++ applications which will directly interact
  82. with a PostgreSQL database management server and the ecpg Embedded C
  83. Postgres preprocessor. You need to install this package if you want to
  84. develop applications which will interact with a PostgreSQL server.
  85. %description -l ja devel
  86. %{name}-devel パッケージには、PostgreSQL データベースと直接に会話
  87. するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
  88. ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
  89. が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
  90. したい場合にはこのパッケージをインストールしてください。
  91. %debug_package
  92. %prep
  93. %setup -q -n postgresql-%{version}
  94. %build
  95. CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
  96. CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
  97. # Strip out -ffast-math from CFLAGS....
  98. CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
  99. ./configure \
  100. --prefix=%{_prefix} \
  101. --libdir=%{_libdir} \
  102. --disable-rpath \
  103. %if %beta
  104. --enable-debug \
  105. --enable-cassert \
  106. %endif
  107. %if %ssl
  108. --with-openssl \
  109. %endif
  110. %if %pam
  111. --with-pam \
  112. %endif
  113. %if %kerberos
  114. --with-krb5=/usr/kerberos \
  115. %endif
  116. %if %nls
  117. --enable-nls \
  118. %endif
  119. --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
  120. --mandir=%{_mandir} \
  121. --with-docdir=%{_docdir} \
  122. --includedir=%{_includedir}/pgsql \
  123. --datadir=%{_datadir}/pgsql
  124. # workaround for bug with parallel build
  125. make %{?_smp_mflags} -C ./src/interfaces all ||:
  126. make %{?_smp_mflags} -C ./src/interfaces all
  127. make %{?_smp_mflags} -C ./src/bin/pg_config all
  128. make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
  129. make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
  130. %install
  131. rm -rf $RPM_BUILD_ROOT
  132. make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
  133. make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
  134. make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
  135. # copy over Makefile.global to the include dir....
  136. install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
  137. install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
  138. # install missing header
  139. mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
  140. install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
  141. install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
  142. install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
  143. install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
  144. install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
  145. install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
  146. install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
  147. # Fix some more documentation
  148. ##gzip doc/internals.ps
  149. cp %{SOURCE6} README.rpm-dist
  150. ##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
  151. ##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
  152. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
  153. install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
  154. %find_lang libpq5-%{pgver}
  155. %find_lang ecpg-%{pgver}
  156. %find_lang ecpglib%{ecpg_soname}-%{pgver}
  157. #%find_lang pg_config-%{pgver}
  158. cat libpq5-%{pgver}.lang > libpq.lst
  159. cat ecpg-%{pgver}.lang >> libpq.lst
  160. cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
  161. #cat pg_config-%{pgver}.lang > devel.lst
  162. rm -rf %{buildroot}%{_libdir}/lib*.a
  163. rm -rf %{buildroot}%{_datadir}/pgsql
  164. find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
  165. rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
  166. find %{buildroot}%{_includedir}/pgsql -type f | perl -pi -e 's|^%{buildroot}||g'> devel.lst
  167. %clean
  168. rm -rf $RPM_BUILD_ROOT
  169. %files -n libpq%{pq_soname} -f libpq.lst
  170. %defattr(-,root,root)
  171. %license COPYRIGHT
  172. %doc HISTORY INSTALL README*
  173. %{_libdir}/libecpg.so.*
  174. %{_libdir}/libecpg_compat.so.*
  175. %{_libdir}/libpgtypes.so.*
  176. %{_libdir}/libpq.so.*
  177. %files devel -f devel.lst
  178. %defattr(-,root,root)
  179. %{_bindir}/ecpg
  180. %{_bindir}/pg_config
  181. %{_libdir}/libecpg.so
  182. %{_libdir}/libecpg_compat.so
  183. %{_libdir}/libpgtypes.so
  184. %{_libdir}/libpq.so
  185. %{_libdir}/pkgconfig/*
  186. %dir %{_includedir}/pgsql
  187. %{_datadir}/locale/*/LC_MESSAGES/*.mo
  188. %{_mandir}/man1/ecpg.*
  189. #%{_mandir}/man1/pg_config.*
  190. %changelog
  191. * Fri May 12 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.3-1
  192. - new upstream release.
  193. * Fri Feb 10 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.2-1
  194. - new upstream release.
  195. * Fri Oct 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0-1
  196. - new upstream release.
  197. * Fri Nov 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.1-1
  198. - new upstream release.
  199. * Tue Oct 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.4-1
  200. - new upstream release.
  201. * Sun May 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.2-1
  202. - new upstream release.
  203. - dropped ldconfig scriptlets.
  204. * Mon Oct 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0-1
  205. - new upstream release.
  206. * Fri Feb 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.2-1
  207. - new upstream release.
  208. * Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0-1
  209. - new upstream release.
  210. * Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.5-1
  211. - new upstream release.
  212. * Fri Mar 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.3-1
  213. - new upstream release.
  214. * Fri Apr 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.2-1
  215. - new upstream release.
  216. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.1-1
  217. - new upstream release.
  218. * Sat Jan 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.0-1
  219. - new upstream release.
  220. * Fri Oct 9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.5-1
  221. - new upstream release.
  222. * Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
  223. - new upstream release.
  224. * Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
  225. - new upstream release.
  226. * Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
  227. - added all headers for a strange client.
  228. * Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
  229. - add pgconfig
  230. - add pg_config*.h and libpq/libpq-fs.h
  231. * Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
  232. - add postgres_ext.h and pg_config_ext.h
  233. * Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
  234. - new upstream release
  235. * Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
  236. - made to build client libraries only.
  237. * Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
  238. - new upstream release
  239. * Thu Feb 7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
  240. - new upstream release
  241. - add Vendor and Distribution tags
  242. * Mon Jan 7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
  243. - build with Tcl/Tk 8.5.7-1
  244. - fix init script (Source3): fix su(1) paramaters.
  245. * Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
  246. - new upstream release
  247. - move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
  248. - remove *_and_*.so from -contrib (included in -server)
  249. * Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
  250. - updated postgresql to 9.0.4
  251. * Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
  252. - updated postgresql to 9.0.3
  253. - separated postgresql-jdbc package
  254. * Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
  255. - updated postgresql to 8.4.7 (contains a variety of fixes)
  256. * Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
  257. - updated postgresql to 8.4.6
  258. - updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
  259. - updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
  260. - updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
  261. * Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
  262. - rebuilt with openssl-1.0.0c
  263. * Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
  264. - updated postgresql to 8.4.5
  265. * Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
  266. - updated postgresql to 8.4.4
  267. * Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
  268. - updated postgresql to 8.4.3
  269. - s/BuildPrereq/Buildrequires/
  270. * Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
  271. - updated postgresql to 8.4.2
  272. - rebuilt with new environment
  273. * Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
  274. - updated postgresql to 8.4.1
  275. * Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
  276. - moved dict_snowball.so from conrib to server
  277. * Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
  278. - updated postgresql to 8.4.0
  279. - updated jdbc3,4 to 701
  280. - dropt postgresql-8.3.3-nls.patch (fixed)
  281. - dropt postgresql-7.4-ecpg-patch (no effect)
  282. * Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
  283. - changed libs Group to System Environment/Libraries
  284. * Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
  285. - updated postgresql to 8.3.7
  286. * Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
  287. - remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
  288. * Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
  289. - new upstream release (postgresql to 8.3.5, jdbc to 604)
  290. * Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
  291. - applied new versioning policy, and spec in utf-8
  292. - updated postgresql to 8.3.3
  293. - updated jdbcver to 603
  294. - added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
  295. - added a script to replace PGVERSION in postgresql.init
  296. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
  297. - rebuild with tcl/tk-8.4.18
  298. * Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
  299. - updated postgresql to 8.2.6
  300. - included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
  301. * Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
  302. - updated PGVERSION to 8.2 in postgresql.init (sorry;)
  303. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
  304. - rebuild with tcl/tk-8.4.16
  305. * Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
  306. - updated postgresql to 8.2.5
  307. - updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
  308. - updated nls-patch to 8-2-0
  309. - dropt postgresql-8.1.4-Pg.patch.gz
  310. * Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
  311. - for VineSeed
  312. - updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
  313. - JDBC driver updated to 410
  314. * Sun Jul 1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
  315. - rebuilt for VineSeed
  316. - fixed install script
  317. * Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
  318. - upstream release
  319. - fix missing %defattr in %files server
  320. * Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
  321. - fix version number in postgresql.init
  322. * Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
  323. - upstream release
  324. - drop rpm-pgsql-8.0.0.patch
  325. - add Requires: perl-DBD-Pg for contrib
  326. - add postgresql-8.1.4-Pg.patch.gz
  327. - update nls patches
  328. - new JDBC driver
  329. * Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
  330. - added build options --without perl, --without python
  331. - rebuilt for x86_64 architecture support
  332. * Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
  333. - drop Provides: on postgresql-libs
  334. - drop Requires: libpq.so on postgresql-server
  335. * Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
  336. - change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
  337. * Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
  338. - upstream release
  339. - update nls patches
  340. * Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
  341. - upstream release
  342. - update nls patches
  343. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
  344. - rebuilded with python-2.4.1-0vl1
  345. * Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
  346. - Dropped PyGreSQL-3.4.tgz.
  347. - Dropped PyGreSQL-3.4-setup-2.patch.
  348. - Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
  349. - Dropped pyver and pynextver macros.
  350. - Changed macro name "python" to "plpython" like plperl.
  351. - Added "Obsoletes: postgresql-python"
  352. * Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
  353. - Major version up
  354. - Obsoletes: postgresql7
  355. - update nls patch(es)
  356. - modify %postun not to delete postgres account on upgrade
  357. * Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
  358. - upstream release (release as a new package)
  359. - Conflicts: postgresql
  360. - update nls patch(es)
  361. - (this package revision was rejected by Vine Project)
  362. * Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
  363. - upstream release
  364. - new JDBC driver
  365. - add BuildRequires: bison, flex, pam-devel
  366. - drop postgresql-7.4.5-tempfile.patch (repaired)
  367. * Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
  368. - Added a security fix patch postgresql-7.4.5-tempfile.patch
  369. from Gentoo Linux (CAN-2004-0977).
  370. - Changed Patch4:
  371. from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
  372. It is possible to compile this package without pre-installed postgresql.
  373. - Removed Patch5 because Patch4 was changed.
  374. * Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
  375. - upstream release
  376. * Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
  377. - upstream release
  378. - new jdbc driver
  379. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
  380. - rebuild with python-2.3.3-0vl1
  381. * Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
  382. - changed mode to 644 at Makefile.global, Makefile.shlib
  383. * Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
  384. - updated python install section
  385. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
  386. - added PyGreSQL-3.4.tgz and set python flag
  387. - added PyGreSQL-3.4-setup.patch
  388. - added PyGreSQL-3.4-pgmodule.patch
  389. - rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
  390. * Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
  391. - rebuild with new openssl
  392. * Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
  393. - upstream release
  394. - change all of %{?foo:%define foo 0} -like descriptions to simple
  395. %define format for latest rpm to build.
  396. * Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
  397. - rebuild on latest tcl package environment.
  398. * Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
  399. - fixed lacking files at server's %files
  400. * Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
  401. - include JDBC driver for 7.4
  402. - fix typo in postgresql-7.4-psql-patch
  403. * Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
  404. - upstream release
  405. - change '--includedir=' option to avoid conflicting with unixODBC
  406. - add postgresql-7.4-ecpg-patch
  407. * Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
  408. - upstream release
  409. * Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
  410. - drop previous version of libpq's trash
  411. * Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
  412. - upstream release with new nls patch
  413. - fix postgresql-bashprofile (value of PGDATA)
  414. - fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
  415. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
  416. - rebuild with tcltk8.4 and readline-4.3
  417. * Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
  418. - upstream release
  419. * Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
  420. - upstream release
  421. - remove garbage changelog
  422. * Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
  423. - upstream release based on 7.3-2PGDG
  424. - add nls patch
  425. * Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
  426. - 7.3-2PGDG
  427. - Fix typo in initscript. Argh!!
  428. * Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
  429. - 7.3-0.5PGDG
  430. - Jerk out all perl client stuff and kludgage
  431. - Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
  432. - Eliminate locale and multibyte explicit enables -- they are both defaults now
  433. - Eliminate pgaccess code; it's not a part of the main tarball anymore
  434. - Eliminate ODBC stuff -- it's also separate now. Use unixODBC instead.
  435. - Eliminated separate tk client package -- rolled the tk client into the tcl client.
  436. - Moved pltcl into the pl subpackage.
  437. - Added plpython to the pl subpackage.
  438. - /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
  439. * Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
  440. - 7.3-0.1PGDG (not released)
  441. - Integrate 7.3 jar's courtesy Joe Conway
  442. - Integrate multi-postmaster initscript courtesy Karl DeBisschop
  443. - Some renames and restructures.
  444. - Stripped out the last dregs of the postgresql-dump migration script.
  445. - Conflicts with less than 7.3.
  446. - (See below for old changelogs from VineSeed)
  447. * Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
  448. - updated to 7.2.3.
  449. * Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
  450. - absorbed previous patch8 into original nlspatch
  451. - fixed configure options (--enable-nls and --enable-locale to be antinomy)
  452. * Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
  453. - add patch8 (ja.po for psql was invalid)
  454. * Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
  455. - updated to 7.2.2.
  456. - improved nlspatch to enable japanese SQL help in psql.
  457. * Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
  458. - fixed garbage chars in description(ja).
  459. * Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
  460. - imported & replaced changelog (following VineSeed's).
  461. add some stuff to '%%files'.
  462. * Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
  463. - Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
  464. nls patch, pg_dump patch, date_part patch by Jun Kuwamura
  465. * Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  466. - replace nls patch.
  467. - add *.mo to '%%files'.
  468. * Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  469. - fix initscript
  470. * Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  471. - add /usr/bin/pg_id to the package (fix)
  472. * Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
  473. - updated 7.2
  474. - added nls.patch
  475. - fixed spec file
  476. - added New JDBC
  477. -- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
  478. * Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
  479. - updated 7.1.3
  480. * Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
  481. - 7.1.2-7vl3
  482. - merge 7.1.2-7vl2 and 7.1.2-7
  483. * Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  484. - 7.1.2-7vl2
  485. - fixed spec typo (%%{_includesir} -> %%{_includedir})
  486. * Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
  487. - updated 7.1.2 (used postgresql-7.1.2-7)
  488. - used psqlj patch for 7.1.2
  489. - used jumbo-20010801.patch.gz
  490. * Mon Aug 6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
  491. - Add patches from 7.1-stable branch. This should fix #50799 and #50797
  492. - Enable kerberos authentication (#50644)
  493. - handle stop with stale pid file (#50499)
  494. - make the test subpackage (not built by default) own /usr/lib/pgsql/test
  495. * Mon Jul 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  496. - Make the -devel subpackage depend on -libs, not the main package
  497. * Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  498. - Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
  499. * Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  500. - add changes for s390x
  501. * Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  502. - Many path fixes for contrib packages
  503. - Newer intarray
  504. - Don't use nested ifs for tkpkg/pgaccess
  505. - Turn off test package for Red Hat Linux - it makes most sense just to use
  506. this during development
  507. - One "pgacess" -> "pgaccess"
  508. * Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
  509. - -4PGDG
  510. - patchset update for pg_regress.sh
  511. - can the dot in the release -- confused too many people and some programs.
  512. - -3.PGDG
  513. - updated README.rpm-dist
  514. - updated patch to 7.1.2, fixing some places where /usr/share/pgsql
  515. was still being used where /usr/lib/pgsql was intended.
  516. - PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
  517. * Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
  518. - sync
  519. - Run chkconfig --add on server install
  520. - Move the prereqs on useradd on chkconfig to the server package
  521. - don't disable the %%clean section
  522. * Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
  523. - Sync up with Trond Eivind's set.
  524. * Thu Jun 7 2001 Trond Eivind Glomsr <teg@redhat.com>
  525. - Don't create postgres' .bashrc from the server post script: include it instead
  526. - Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
  527. - Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
  528. libs
  529. - Source the i18n data from the .bashrc instead of in the initscript
  530. * Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
  531. - Handle i18n for database startup - backend needs to have the same locale everytime,
  532. but this certainly can't be hardcoded to C either
  533. - Fix stop, restart in initscript (#42217)
  534. - Make database init _much_ less verbose
  535. - other minor fixes to the initscript
  536. * Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
  537. - 7.1.2
  538. * Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
  539. - 7.1.2-0.1.1.PGDG PRERELEASE
  540. - Changed versioning and release numbering a little for better flexibility,
  541. -- particularly for distribution packagers.
  542. - Release numbering comment at top of spec, where it's more useful.
  543. - Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
  544. changlog, and the last 6.5.3's specfile for the changelog prior to
  545. 7.0.
  546. * Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
  547. - 7.1.1-4.PGDG
  548. - _really_ got Python version agnosticism working.
  549. * Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
  550. - 7.1.1-3.PGDG Release
  551. - Python version agnosticism.....
  552. * Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  553. - Use openssl
  554. - Make it obsolete subpackages if they aren't built
  555. * Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
  556. - 7.1.1-2.PGDG Release.
  557. - Appended .PGDG to release string to differentiate our RPM set from the others.
  558. - /bin/sh fix in initscript
  559. - README.rpm-dist updates.
  560. * Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
  561. - Rebuild with new readline
  562. * Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
  563. - Initial 7.1.1
  564. * Mon May 7 2001 Trond Eivind Glomsr <teg@redhat.com>
  565. - Specify shell when running commands through su in the initscript, to avoid problems
  566. when people switch the postgres user to use tcsh
  567. * Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  568. - JDBC driver for Postgresql 7.1
  569. * Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  570. - slightly different versioning scheming, will go back to the official
  571. later when I'm sure the package is ready to use
  572. * Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
  573. - 7.1 RELEASE
  574. - 7.1-1 RPM RELEASE
  575. - Change to COPTS -- strip out -ffastmath -- Considered Harmful.
  576. - Back to old versioning scheme, kept teg's other fixes.
  577. - README.rpm-dist updated.
  578. - PGVERSION updated all-around (hopefully!)
  579. - Couple of fixes from Peter E.
  580. - Rearrange dependencies -- only the -libs subpackage is required for most stuff
  581. - Removed broken and confusing logrotate script.
  582. * Mon Apr 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  583. - chown considered harmful - removed
  584. - fix dangling symlimks (pg_crc.c)
  585. - libpq.so changes for maximum compatiblity
  586. - different versioning scheme, to avoid trouble later
  587. - remove temporary perl file from the file list
  588. - fix spelling error in tcl description
  589. - mark odbcinst.ini as a config file
  590. - use %%defattr on packages which didn't have it
  591. * Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
  592. - Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
  593. - Packaging reorg: added contrib and docs subpackages.
  594. - Removed sgml source docs from main package --> docs subpackage.
  595. - Removed contrib tree from main package --> contrib subpackage.
  596. - Contrib tree is now prebuilt -- HOWEVER, very little install work is
  597. currently done with this.
  598. * Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
  599. - Quickie RC3. There will be a 7.1RC3-2 shortly with other stuff.
  600. * Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
  601. - RC2
  602. - eliminate versioning information for ancilliary files in prep for CVS.
  603. - Fix docs mixup.
  604. * Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
  605. - RC1 quickie.
  606. * Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
  607. - Beta 6 initial build.
  608. - Use make install-all-headers instead of cpio hack for devel headers.
  609. - Split out the libs into the libs subpackage.
  610. - Updated initscript to use pg_ctl to stop
  611. - Updated initscript to initdb and start postmaster with LC_ALL=C to
  612. prevent index corruption.
  613. * Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
  614. - Beta4
  615. - Return to 'pgsql' directories instead of 'postgresql'
  616. - Better perl patches.
  617. * Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
  618. - Edit patches to get rid of some cruft.
  619. - Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
  620. - Moved pg_id to server
  621. - added Makefile.global and pg_config to devel
  622. - Corrected /usr/include/pgsql to /usr/include/postgresql
  623. - Fixed some configure options. Will be trying the configure macro next release
  624. - Since it is terminally ill in this version pg_upgrade is _gone_.
  625. - Thanks to Peter E for a good review.
  626. * Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
  627. - Running regression. 1 on the release-o-meter.
  628. - Minor patches to get regression running right.
  629. - Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
  630. * Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
  631. - Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
  632. - The 7.1 build is different from the 7.0 build -- see the configure line.
  633. - NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
  634. - by request, conditional packages are now supported. See the top of the spec.
  635. - Fixed the server postinstall problems.
  636. * Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
  637. - First 7.1 beta test-build