netatalk-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456
  1. %bcond_with systemd
  2. %bcond_with tracker
  3. %global tracker_api 3.0
  4. ################################################# BASIC PACKAGE INFORMATION
  5. Summary: AFP fileserver for Macintosh clients
  6. Summary(ja): Macintoshクライアント向けのAFPファイルサーバー
  7. Name: netatalk
  8. Version: 3.1.15
  9. Release: 1%{_dist_release}%{?with_systemd:.systemd}
  10. Group: servers
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: shaolin, tomop
  14. License: GPLv2+
  15. URL: http://netatalk.sourceforge.net/
  16. %define altver %(echo %{version} | tr . -)
  17. Source0: https://github.com/Netatalk/Netatalk/releases/download/netatalk-%{altver}/netatalk-%{version}.tar.gz
  18. Source1: netatalk.pam-system-auth
  19. Source2: netatalk.conf
  20. Patch0: netatalk-3.0.1-basedir.patch
  21. Patch1: netatalk-systemd-execstartpre.patch
  22. ############################################################## REQUIREMENTS
  23. BuildRequires: cracklib openssl-devel pam quota libtool automake
  24. BuildRequires: autoconf libdb-devel pam-devel libgcrypt-devel
  25. BuildRequires: avahi-devel libacl-devel openldap-devel
  26. BuildRequires: dbus-devel dbus-glib-devel glib2-devel
  27. BuildRequires: libevent-devel libtdb-devel libmariadb-devel
  28. %if %{with tracker}
  29. BuildRequires: tracker-devel
  30. %endif
  31. Requires: dbus-python3
  32. Requires: dconf
  33. %if %{with systemd}
  34. BuildRequires: systemd
  35. %{?systemd_requires}
  36. %else
  37. Requires(post): /sbin/chkconfig
  38. Requires(preun): /sbin/chkconfig
  39. Requires(preun): /sbin/service
  40. Requires(postun): /sbin/service
  41. %endif
  42. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  43. %description
  44. Netatalk is a freely-available Open Source AFP fileserver. A *NIX/*BSD
  45. system running Netatalk is capable of serving many Macintosh clients
  46. simultaneously as an AppleShare file server (AFP).
  47. %description -l ja
  48.  Netatalkは自由に利用可能なオープンソースAFPファイルサーバーです。
  49. Netatalkを実行している*NIX/*BSDシステムでは、多くのMacintoshクライ
  50. アントに対してAppleShareファイルサーバー(AFP)としてサービスを提供
  51. 可能です。
  52. %package devel
  53. Summary: Headers for Netatalk development
  54. Summary(ja): Netatalk開発用ヘッダファイル
  55. Group: programming
  56. %description devel
  57. This package contains the header files for Netatalk.
  58. %debug_package
  59. %prep
  60. %setup -q
  61. %autopatch -p1
  62. autoreconf -fiv
  63. rm -frv libevent/
  64. ln -s ./NEWS ChangeLog
  65. # Avoid re-running the autotools
  66. touch -r aclocal.m4 configure configure.ac macros/gssapi-check.m4
  67. # fix permissions
  68. find include \( -name '*.h' -a -executable \) -exec chmod -x {} \;
  69. # Don't call systemctl daemon-reload during the build
  70. sed -i 's\-systemctl daemon-reload\\g' distrib/initscripts/Makefile.in
  71. %build
  72. %configure \
  73. --disable-silent-rules \
  74. --disable-static \
  75. --enable-shared \
  76. --localstatedir=%{_localstatedir}/lib \
  77. --with-pkgconfdir=%{_sysconfdir}/netatalk \
  78. --with-cracklib \
  79. --with-pam \
  80. --with-shadow \
  81. --with-uams-path=%{_libdir}/netatalk \
  82. --enable-shared \
  83. --enable-krbV-uam \
  84. --enable-overwrite \
  85. --with-gnu-ld \
  86. %if %{with systemd}
  87. --with-lockfile=/run/lock/netatalk/netatalk \
  88. --with-init-style=redhat-systemd \
  89. --with-init-dir=%{_unitdir} \
  90. %else
  91. --with-init-style=redhat-sysv \
  92. %endif
  93. --with-libgcrypt \
  94. --without-libevent \
  95. --without-tdb \
  96. --with-pam-confdir=%{_sysconfdir}/pam.d \
  97. --with-dbus-sysconf-dir=%{_sysconfdir}/dbus-1/system.d \
  98. -with-spotlight \
  99. %if %{with tracker}
  100. --with-tracker-pkgconfig-version=%{tracker_api}
  101. %endif
  102. make %{?_smp_mflags} all
  103. %install
  104. ### INSTALL (USING "make install") ###
  105. rm -rf ${RPM_BUILD_ROOT}
  106. make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
  107. # install our tmpfiles config
  108. install -Dpm644 %{SOURCE2} %{buildroot}%{_tmpfilesdir}/netatalk.conf
  109. # install example config files in doc
  110. mkdir -p config.example
  111. cp -fp config/afp.conf config.example
  112. cp -fp config/extmap.conf config.example
  113. mkdir -p $RPM_BUILD_ROOT/usr/share/netatalk
  114. cp -fp %{SOURCE1} config.example
  115. # XXX bad hack until this file is updated in glibc-headers:
  116. rm -f $RPM_BUILD_ROOT/usr/include/netatalk/at.h
  117. # Clean up .a and .la files
  118. find $RPM_BUILD_ROOT -name \*.a -exec rm {} \;
  119. find $RPM_BUILD_ROOT -name \*.la -exec rm {} \;
  120. # Fix python shebang
  121. sed -i 's\^#!/usr/bin/env python$\#!%{__python3}\' %{buildroot}/usr/bin/afpstats
  122. %clean
  123. rm -rf ${RPM_BUILD_ROOT}
  124. %post
  125. if [ -e /var/netatalk/afp_signature.conf -a ! -e /var/lib/netatalk/afp_signature.conf ]; then
  126. mv -f /var/netatalk/afp_signature.conf /var/lib/netatalk/
  127. fi
  128. if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/lib/netatalk/afp_signature.conf ]; then
  129. mv -f /etc/netatalk/afp_signature.conf /var/lib/netatalk/
  130. fi
  131. if [ -e /var/netatalk/afp_voluuid.conf -a ! -e /var/lib/netatalk/afp_voluuid.conf ]; then
  132. mv -f /var/netatalk/afp_voluuid.conf /var/lib/netatalk/
  133. fi
  134. if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/lib/netatalk/afp_voluuid.conf ]; then
  135. mv -f /etc/netatalk/afp_voluuid.conf /var/lib/netatalk/
  136. fi
  137. %if %{with systemd}
  138. %systemd_post %{name}.service
  139. %else
  140. /sbin/chkconfig --add netatalk
  141. %endif
  142. %preun
  143. %if %{with systemd}
  144. %systemd_preun %{name}.service
  145. %else
  146. if [ "$1" = "0" -o -x /bin/systemctl ] ; then
  147. # check for existence due to renaming initscript
  148. if [ -x %{_initrddir}/netatalk ] ; then
  149. /sbin/service netatalk stop > /dev/null 2>&1
  150. /sbin/chkconfig --del netatalk
  151. fi
  152. fi
  153. %endif
  154. %postun
  155. %if %{with systemd}
  156. %systemd_postun_with_restart %{name}.service
  157. %else
  158. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  159. /sbin/service netatalk condrestart > /dev/null 2>&1 || :
  160. fi
  161. %endif
  162. %files
  163. %defattr(-,root,root)
  164. %license COPYING COPYRIGHT
  165. %doc README.md NEWS
  166. %doc config.example
  167. %if %{with systemd}
  168. %{_unitdir}/netatalk.service
  169. %{_tmpfilesdir}/netatalk.conf
  170. %else
  171. %attr(755,root,root) %{_initrddir}/netatalk
  172. %endif
  173. %dir %{_sysconfdir}/netatalk
  174. %config(noreplace) %{_sysconfdir}/netatalk/afp.conf
  175. %config(noreplace) %{_sysconfdir}/netatalk/extmap.conf
  176. %config(noreplace) %{_sysconfdir}/netatalk/dbus-session.conf
  177. %config(noreplace) %{_sysconfdir}/pam.d/netatalk
  178. %config(noreplace) %{_sysconfdir}/dbus-1/system.d/netatalk-dbus.conf
  179. %{_sbindir}/*
  180. %{_bindir}/*
  181. %exclude %{_bindir}/netatalk-config
  182. %{_mandir}/man*/*
  183. %exclude %{_mandir}/man*/netatalk-config*
  184. %{_datadir}/netatalk
  185. %{_libdir}/*.so
  186. %{_libdir}/*.so.*
  187. %dir %{_libdir}/netatalk
  188. %{_libdir}/netatalk/*.so
  189. %{_localstatedir}/lib/netatalk
  190. %files devel
  191. %defattr(-,root,root)
  192. %license COPYING COPYRIGHT
  193. %dir %{_includedir}/atalk
  194. %attr(0644,root,root) %{_includedir}/atalk/*
  195. %{_datadir}/aclocal/netatalk.m4
  196. %{_bindir}/netatalk-config
  197. %{_mandir}/man*/netatalk-config.1*
  198. %changelog
  199. * Sat Apr 29 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.15-1
  200. - new upstream release.
  201. * Wed Jan 11 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.14-1
  202. - new upstream release.
  203. * Fri Nov 11 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.13-3
  204. - rebuilt with openldap-2.6.3.
  205. * Thu Nov 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.13-2
  206. - imported Patch4 and 6 from rawhide.
  207. * Thu Nov 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.13-1
  208. - new upstream release.
  209. * Tue Oct 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-5
  210. - rebuilt with openssl-3.0.0.
  211. * Tue Mar 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-4
  212. - disabled tracker.
  213. * Sat Mar 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-3
  214. - rebuilt with current environment.
  215. - cleaned up BR.
  216. * Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-2
  217. - rebuilt with libevent-2.1.11.
  218. - added systemd support (disabled as default).
  219. * Mon Jan 07 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-1
  220. - new upstream release.
  221. * Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.11-2
  222. - rebuilt with openssl-1.1.1 and libevent-2.1.8.
  223. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.11-1
  224. - new upstream release.
  225. * Wed Jul 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.9-1
  226. - new upstream release.
  227. - dropped Patch1: fixed in upstream.
  228. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-2
  229. - added Patch1.
  230. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-1
  231. - new upstream release.
  232. * Tue Jun 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
  233. - new upstream release.
  234. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.2.2-2
  235. - rebuilt with libgcrypt 1.6.0 and libdb 5.3.28
  236. * Thu Apr 26 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.2-1
  237. - new upstream release.
  238. - added build option 'force_uidgid'.
  239. * Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
  240. - new upstream release
  241. - fix configure options; add missing BRs
  242. * Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
  243. - now back from the upstream confusion (and one more or two...)
  244. new upstream release 2.2.0 at the official site
  245. * Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
  246. - fix Patch10 to follow HAT-san's strong and confident objection
  247. (no need to set ATALK_NAME explicitly in netatalk.conf)
  248. * Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
  249. - new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
  250. - add Source100 to add one missing header file in the tarball
  251. - revise Patch10
  252. - explicitly specify --disable-ddp for the first time
  253. * Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
  254. - new upstream release
  255. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
  256. - rebuild with openssl-1.0.0c
  257. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
  258. - fix Patch10 & update description - upon HAT-san's suggestions
  259. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
  260. - new upstream release
  261. - update Vine patch
  262. * Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
  263. - new upstream release
  264. * Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
  265. - new upstream release
  266. * Sun Mar 8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
  267. - rebuilt both for VineSeed / VinePlus-4.0
  268. * Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
  269. - updated to the cjk-6 patch
  270. - Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
  271. - Patch14 updated for db46
  272. * Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
  273. - remove openslp dependency
  274. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
  275. - add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
  276. - TODO: remember to revise this fix after VineSeed changes default locale
  277. from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
  278. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
  279. - revise description (thanks HAT-san for pointing this out)
  280. - run libtoolize/aclocal/auto{make,conf,header} before doing configure
  281. (without this, uams_* modules won't get .so suffix)
  282. * Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
  283. - Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
  284. (Patch10 now includes all the modifications and more fixes)
  285. * Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
  286. - add patch13 and patch14 for db-4.3.
  287. - move files in %%_libexecdir to %%libdir.
  288. * Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
  289. - updated to 2.0.3 release w/ cjk patches (see the above Patch section)
  290. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  291. - security fix: added Patch10 (CAN-2004-0974)
  292. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  293. - configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
  294. * Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
  295. - updated to 2.0 with cjk patch
  296. (see the above Patch section for details)
  297. * Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
  298. - merge the patch repairing bug for System 7.5.5
  299. - (patch6 netatalk-1.5.3.oldsys.patch)
  300. - made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
  301. - patch6 addupted no matter noeuc is, license GPL, URL in comment
  302. * Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
  303. - euc and kana patch originally by
  304. - Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
  305. - applied to netatalk-1.5.2 by me
  306. - README.vine
  307. - omit VERSION from doc, omit perl from require
  308. * Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
  309. - this package is removed because the release number duplicated
  310. * Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
  311. - move acleandir.rc to the doc directory, remove executable flag.
  312. * Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
  313. - updated to new upstream release
  314. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
  315. - added Japanese Summary for devel and corrected Group
  316. * Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
  317. - Oops, check /var/lock/atalkd instead of /var/run/atd.pid
  318. (say atd.pid doesn't have anything to do with netatalk!!)
  319. * Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
  320. - updated to new upstream release
  321. * Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
  322. - install man pages into %%{_mandir}
  323. - PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
  324. - let pre script exit 0
  325. * Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
  326. - spec cleanup
  327. - backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
  328. - restart atalk daemons in the %%post section
  329. * Sun Feb 3 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  330. - v1.5.1.1-0vl1
  331. * Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  332. - v1.5.0-0vl1
  333. - release 1.5.0 for sourceforge
  334. * Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  335. - v1.5pre6-1rh7
  336. - pre-release 6 for sourceforge
  337. * Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  338. - v1.5pre5-1
  339. - pre-release 5 for sourceforge
  340. * Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  341. - v1.5pre5-0
  342. - pre-release 5 for sourceforge (prebuild)
  343. * Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  344. - v1.5pre4-1
  345. - pre-release 4 for sourceforge
  346. - modified/split mandrake spec for redhat 7 build
  347. * Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  348. - v1.5pre3-1mdk
  349. - pre-release 3 for sourceforge
  350. - moved away from 1.4.99 ...
  351. * Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  352. - v1.4.99-0.20001108mdk
  353. - pre-release 2 for sourceforge
  354. * Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  355. - v1.4.99-0.20000927mdk
  356. - pre-release 1 for sourceforge