calibre-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: calibre
  3. Summary: E-book converter and library management
  4. Version: 0.7.18
  5. Release: 3%{?_dist_release}
  6. Group: Applications/Multimedia
  7. License: GPLv3
  8. URL: http://calibre-ebook.com/
  9. # SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. # Upstream packages some unfree fonts which we cannot redistribute.
  11. # While we're at it, also delete the liberation fonts which we already have.
  12. #
  13. # Download the upstream tarball and invoke this script while in the tarball's
  14. # directory:
  15. # ./generate-tarball.sh %{version}
  16. Source0: %{name}-%{version}-nofonts.tar.xz
  17. Source1: generate-tarball.sh
  18. Patch0: %{name}-manpages.patch
  19. Patch1: %{name}-no-update.patch
  20. Patch2: %{name}-0.6.53-mounthelper.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: python >= 2.6
  23. BuildRequires: python-devel >= 2.6
  24. BuildRequires: ImageMagick-devel >= 6.5.9
  25. BuildRequires: python-setuptools
  26. BuildRequires: qt4-devel >= 4.6.0
  27. BuildRequires: PyQt4-devel >= 4.7.0
  28. BuildRequires: poppler-qt4-devel >= 0.12
  29. BuildRequires: podofo-devel
  30. BuildRequires: desktop-file-utils
  31. BuildRequires: python-mechanize >= 0.1.1
  32. BuildRequires: python-lxml >= 2.2.1
  33. BuildRequires: python-cssutils >= 0.9.6
  34. BuildRequires: python-dateutil >= 1.4.1
  35. BuildRequires: python-imaging >= 1.1.6
  36. BuildRequires: xdg-utils >= 1.0.2
  37. BuildRequires: python-BeautifulSoup >= 3.0.5
  38. BuildRequires: xz
  39. BuildRequires: unzip
  40. BuildRequires: libwmf-devel >= 0.2.8
  41. BuildRequires: chmlib-devel >= 0.40
  42. Requires: PyQt4
  43. Requires: pyPdf
  44. Requires: python-cherrypy
  45. Requires: python-cssutils
  46. Requires: ImageMagick
  47. Requires: python-odf
  48. Requires: python-django-tagging
  49. Requires: python-lxml
  50. Requires: python-imaging
  51. Requires: python-mechanize
  52. Requires: python-dateutil
  53. Requires: python-genshi
  54. Requires: python-BeautifulSoup
  55. ## vine
  56. Requires: TrueType-liberation
  57. %description
  58. Calibre is meant to be a complete e-library solution. It includes library
  59. management, format conversion, news feeds to ebook conversion as well as
  60. e-book reader sync features.
  61. Calibre is primarily a ebook cataloging program. It manages your ebook
  62. collection for you. It is designed around the concept of the logical book,
  63. i.e. a single entry in the database that may correspond to ebooks in several
  64. formats. It also supports conversion to and from a dozen different ebook
  65. formats.
  66. Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
  67. RTF, TXT, PDF and LRS.
  68. %prep
  69. %setup -q -n %{name}
  70. # don't append calibre1 to the name of the manpages. No need to compress either
  71. # upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
  72. %patch0 -p1 -b .manpages
  73. # don't check for new upstream version (that's what packagers do)
  74. %patch1 -p1 -b .no-update
  75. # Enable mount helper
  76. %patch2 -p1 -b .mounthelper
  77. # dos2unix newline conversion
  78. %{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
  79. # remove shebangs
  80. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
  81. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
  82. %{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
  83. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
  84. %{__sed} -i -e '/^#!\//, 1d' resources/recipes/*
  85. %{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
  86. %{__chmod} -x src/calibre/*/*/*/*.py
  87. %{__chmod} -x src/calibre/*/*/*.py
  88. %{__chmod} -x src/calibre/*/*.py
  89. %{__chmod} -x src/calibre/*.py
  90. %{__chmod} -x resources/recipes/*
  91. %build
  92. OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
  93. %install
  94. %__rm -rf %{buildroot}
  95. %__mkdir -p %{buildroot}%{_datadir}
  96. # create directories for xdg-utils
  97. %__mkdir_p %{buildroot}%{_datadir}/icons
  98. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
  99. %__mkdir_p %{buildroot}%{_datadir}/packages
  100. %__mkdir_p %{buildroot}%{_datadir}/mime
  101. %__mkdir_p %{buildroot}%{_datadir}/mime/packages
  102. %__mkdir_p %{buildroot}%{_datadir}/applications
  103. %__mkdir_p %{buildroot}%{_datadir}/desktop-directories
  104. # create directory for calibre environment module
  105. # the install script assumes it's there.
  106. %__mkdir_p %{buildroot}%{python_sitelib}
  107. XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
  108. XDG_UTILS_INSTALL_MODE="system" \
  109. LIBPATH="%{_libdir}" \
  110. python setup.py install --root=%{buildroot}%{_prefix} \
  111. --prefix=%{_prefix} \
  112. --libdir=%{_libdir} \
  113. --staging-libdir=%{buildroot}%{_libdir}
  114. # remove shebang from init_calibre.py here because
  115. # it just got spawned by the install script
  116. %{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
  117. # icons
  118. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  119. %__cp -p resources/images/library.png \
  120. %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
  121. %__cp -p resources/images/viewer.png \
  122. %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
  123. # every file is empty here
  124. find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
  125. # packages aren't allowed to register mimetypes like this
  126. %__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
  127. desktop-file-validate \
  128. %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
  129. desktop-file-validate \
  130. %{buildroot}%{_datadir}/applications/calibre-gui.desktop
  131. desktop-file-validate \
  132. %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
  133. %__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
  134. %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
  135. # mimetype icon for lrf
  136. %__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
  137. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
  138. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
  139. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
  140. %__cp -p resources/images/mimetypes/lrf.png \
  141. %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
  142. %__cp -p resources/images/viewer.png \
  143. %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
  144. # don't put bash completions in /usr/etc
  145. %__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
  146. # these are provided as separate packages
  147. %__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
  148. %__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
  149. %__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
  150. # link to system fonts after we have deleted (see Source0) the non-free ones
  151. # http://bugs.calibre-ebook.com/ticket/3832
  152. %__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
  153. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
  154. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
  155. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
  156. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
  157. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
  158. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
  159. # http://bugs.calibre-ebook.com/ticket/3770#comment:7
  160. # man pages
  161. %__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
  162. # move locales
  163. %__mv %{buildroot}%{_datadir}/%{name}/localization/locales \
  164. %{buildroot}%{_datadir}/locale
  165. for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/messages.mo; do
  166. lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
  167. %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/messages.mo \
  168. %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}.mo
  169. done;
  170. for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/iso639.mo; do
  171. lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
  172. %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/iso639.mo \
  173. %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_iso639.mo
  174. done;
  175. for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/qt.qm; do
  176. lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
  177. %__mv $file %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_$lang.qm
  178. done;
  179. %find_lang %{name} --with-qt --all-name
  180. # locales should be looked for in the proper place
  181. %{__sed} -i -e "s:P('localization/locales:('/usr/share/locale:" \
  182. -e "s/messages.mo/calibre.mo/" \
  183. -e "s/iso639.mo/calibre_iso639.mo/" \
  184. %{buildroot}%{_libdir}/%{name}/%{name}/utils/localization.py
  185. %{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
  186. %clean
  187. %{__rm} -rf %{buildroot}
  188. %post
  189. touch --no-create %{_datadir}/icons/hicolor || :
  190. %postun
  191. if [ $1 -eq 0 ] ; then
  192. update-desktop-database &> /dev/null ||:
  193. update-mime-database %{_datadir}/mime &> /dev/null || :
  194. touch --no-create %{_datadir}/icons/hicolor || :
  195. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  196. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  197. fi
  198. fi
  199. %posttrans
  200. update-desktop-database -q &> /dev/null
  201. update-mime-database %{_datadir}/mime >& /dev/null
  202. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  203. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  204. fi
  205. %files -f %{name}.lang
  206. %defattr(-,root,root,-)
  207. %doc COPYRIGHT LICENSE Changelog.yaml
  208. %{_bindir}/*
  209. %config(noreplace) %{_sysconfdir}/bash_completion.d/
  210. %{_libdir}/%{name}
  211. %{_datadir}/%{name}
  212. %{_datadir}/pixmaps/*
  213. %{_datadir}/applications/*
  214. %{_datadir}/mime/packages/*
  215. %{_datadir}/icons/hicolor/scalable/mimetypes/*
  216. %{_datadir}/icons/hicolor/scalable/apps/*
  217. %{python_sitelib}/init_calibre.py*
  218. %{_mandir}/man1/*
  219. %changelog
  220. * Tue Oct 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.18-3
  221. - rebuilt with poppler-0.14.2
  222. * Sat Oct 2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.18-2
  223. - rebuilt with ImageMagick-6.6.4.8
  224. - added %%posttrans section
  225. * Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
  226. - new upstream release
  227. - Fix svg/png changes.
  228. * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
  229. - initial build based on Fedora development
  230. * Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
  231. - Update to 0.7.15
  232. * Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
  233. - rebuild (poppler)
  234. * Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
  235. - Update to 0.7.14
  236. * Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
  237. - Update to 0.7.13
  238. * Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
  239. - Update to 0.7.12
  240. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
  241. - Update to 0.7.11
  242. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
  243. - Rebuilt for python2.7
  244. * Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
  245. - Update to 0.7.10
  246. * Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
  247. - Update to 0.7.9
  248. * Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
  249. - Update to 0.7.8
  250. - build tar.xz instead of tar.bz2
  251. * Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
  252. - Update to 0.7.7
  253. * Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
  254. - Update to 0.7.6
  255. * Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
  256. - Update to 0.7.5
  257. * Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
  258. - Update to 0.7.4
  259. * Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
  260. - rebuilt with podofo 0.8.1
  261. * Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
  262. - Update to 0.7.1
  263. - Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
  264. * Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
  265. - Update to 0.7.0
  266. * Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
  267. - Update to 0.6.55
  268. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
  269. - Update to 0.6.54
  270. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
  271. - Update to 0.6.53
  272. * Wed May 5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
  273. - Rebuild against new poppler
  274. * Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
  275. - new upstream release 0.6.47
  276. - new chmlib requirement
  277. - create directory for calibre's environment module
  278. - use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
  279. - remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
  280. * Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
  281. - new upstream release 0.6.42
  282. - remove shebang from default_tweaks.py
  283. * Mon Feb 1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
  284. - new upstream release 0.6.37
  285. * Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
  286. - new upstream release 0.6.36
  287. - fixed a cssprofiles issue with loading the profiles
  288. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
  289. - added -cssprofiles patch to cvs
  290. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
  291. - remove python-cssutils 0.9.6 dependency
  292. * Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
  293. - new upstream release
  294. - fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
  295. - removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
  296. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
  297. - fix for package tagged without adding new patch to cvs
  298. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
  299. - new upstream release 0.6.32
  300. - project website has changed
  301. - added python-BeautifulSoup BuildRequire
  302. - new patch to fix full buildpath in binary files
  303. * Sun Dec 6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
  304. - New upstream version
  305. - Regenerated no-update patch because of code relocation
  306. * Wed Dec 2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
  307. - New upstream release
  308. * Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
  309. - New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
  310. * Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
  311. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
  312. - patch to stop checking for new upstream version
  313. * Sat Nov 7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
  314. - new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
  315. - added python-BeautifulSoup requirement
  316. * Wed Nov 4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
  317. - new upstream version:
  318. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
  319. - upstream now ships correct .desktop files
  320. - fixed missing dependency: PyQt4
  321. - fixed calibre-gui icon
  322. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
  323. - removed unfree fonts from source package
  324. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
  325. - readability enhancements
  326. - added python-genshi requires
  327. - removed libwmf require since ImageMagick provides libwmf-lite as a
  328. dependency and that's what we actually need
  329. * Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
  330. - new upstream version:
  331. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
  332. - delete fonts, calibre can find the system fonts
  333. - specify libdir as an install option, so calibre will link properly
  334. even on 64bit
  335. * Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
  336. - updated requires list
  337. - new upstream release
  338. - can override CFLAGS now
  339. - removed trac and genshi duplicates
  340. - use xdg env variables to do desktop integration in the buildroot
  341. - added xdg-utils buildrequire
  342. - install udev rules in /usr/lib even on 64bit and don't own the whole dir
  343. - removed wrongly used Version field from .desktop files
  344. * Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
  345. - mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
  346. - removed unneeded INSTALL file
  347. - marked bash completion file as config(noreplace) and take ownership of the dir
  348. * Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
  349. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
  350. - the install process changed significantly
  351. - locales were added
  352. * Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
  353. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
  354. - minor path fixes
  355. - rearranged files section
  356. * Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
  357. - handle desktop files
  358. - don't compress manpages and don't list them as duplicates
  359. - added lrfviewer icon
  360. * Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
  361. - Initial RPM release