netatalk-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337
  1. %define _sysconfdir /etc
  2. ################################################# BASIC PACKAGE INFORMATION
  3. Summary: AppleTalk and AppleShare/IP services for Linux
  4. Summary(ja): Linux 用 AppleTalk, AppleShare/IP サービス
  5. Name: netatalk
  6. Version: 2.2.0
  7. Release: 1%{_dist_release}
  8. License: GPLv2+
  9. Group: System Environment/Daemons
  10. ## this version 2.2.0 obtained at:
  11. ## http://www003.upp.so-net.ne.jp/hat/netatalk/
  12. Source0: %{name}-%{version}.tar.bz2
  13. ## the above tarball somewhat misses the following header file
  14. ## this extracted from https://github.com/jrmithdobbs/netatalk-2-2-0-p6
  15. ## commit 6e40f7d3bdf47b6356e0
  16. Source100: jrmithdobbs-netatalk-2-2-0-p6-6e40f7d_fce_api_internal.h
  17. URL: http://netatalk.sourceforge.net/
  18. Obsoletes: netatalk-1.4b2+asun
  19. # patch for default config file
  20. Patch10: netatalk-2.2.0-config-utf8.patch
  21. ############################################################## REQUIREMENTS
  22. Requires(pre): chkconfig, /sbin/ldconfig, grep, textutils
  23. Requires: cracklib, openssl, tcp_wrappers, pam, perl
  24. BuildRequires: openssl-devel, avahi-devel, pam-devel, db4-devel, quota
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: shaolin
  29. %description
  30. Netatalk is a freely-available Open Source AFP fileserver. It also provides a
  31. kernel level implementation of the AppleTalk Protocol Suite. A *NIX/*BSD system
  32. running Netatalk is capable of serving many Macintosh clients simultaneously
  33. as an AppleShare file server (AFP), AppleTalk router, *NIX/*BSD print server,
  34. and for accessing AppleTalk printers via Printer Access Protocol (PAP).
  35. Included are a number of minor printing and debugging utilities.
  36. %description -l ja
  37. このパッケージを使うことで, Linux 上で AppleTalk プロトコルを
  38. 扱うことができ, Macintosh と通信が可能になります.
  39. Linux 上で AppleTalk や AFP over TCP の Mac 向けファイルサーバを
  40. 稼働させることができるデーモンプログラムが収められています.
  41. %package devel
  42. Group: Development/Libraries
  43. Summary: Headers for AppleTalk development
  44. Summary(ja): AppleTalk 開発用ヘッダファイル
  45. %description devel
  46. This package contains the header files for building AppleTalk networking
  47. programs.
  48. %prep
  49. %setup -q
  50. %patch10 -p1 -b .cjk-config
  51. if [ ! -f "etc/afpd/fce_api_internal.h" ] ; then
  52. install -m 0644 %{SOURCE100} etc/afpd/fce_api_internal.h
  53. fi
  54. %build
  55. touch AUTHORS
  56. ln -s NEWS ChangeLog
  57. rm -f README.cjk4.cjk
  58. libtoolize --force
  59. aclocal -I macros
  60. automake --add-missing
  61. autoconf
  62. autoheader
  63. CFLAGS="${RPM_OPT_FLAGS} -fomit-frame-pointer -fsigned-char" \
  64. ./configure \
  65. --prefix=%{_prefix} \
  66. --libdir=%{_libdir} \
  67. --libexecdir=%{_libdir}/netatalk \
  68. --sysconfdir=%{_sysconfdir} \
  69. --mandir=%{_mandir} \
  70. --localstatedir=%{_var} \
  71. --enable-shared \
  72. --enable-zeroconf \
  73. --disable-srvloc \
  74. --enable-afp3 --disable-ddp \
  75. --with-cnid-dbd-backend \
  76. --with-cnid-cdb-backend \
  77. --with-cnid-default-backend=dbd \
  78. --with-uams-path=%{_libdir}/netatalk \
  79. --enable-redhat \
  80. --with-cracklib \
  81. --with-pam \
  82. --with-shadow \
  83. --with-tcp-wrappers \
  84. --with-ssl \
  85. --enable-pgp-uam
  86. make all
  87. %install
  88. ### INSTALL (USING "make install") ###
  89. rm -rf ${RPM_BUILD_ROOT}
  90. mkdir -p ${RPM_BUILD_ROOT}{%{_prefix},%{_sysconfdir}/netatalk/msg}
  91. make DESTDIR=$RPM_BUILD_ROOT install
  92. ## netatalk/at.h is now provided by glibc
  93. rm -f $RPM_BUILD_ROOT%{_prefix}/include/netatalk/at.h
  94. ## for Bonjour (requires nss-mdns)
  95. #install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services
  96. #install -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services/
  97. %pre
  98. ### COPY OLD PREFERENCE FILES ###
  99. if [ -d /etc/atalk ] ; then
  100. mkdir -p /etc/netatalk/
  101. cp -a /etc/atalk /etc/netatalk/00_OLD_VERSION_PREFS
  102. fi
  103. exit 0
  104. %post
  105. ### RUN CHKCONFIG ###
  106. /sbin/chkconfig --add netatalk
  107. /sbin/ldconfig
  108. if test -r /var/lock/atalkd ; then
  109. /etc/rc.d/init.d/netatalk restart >&2
  110. fi
  111. %preun
  112. ### RUN CHKCONFIG ###
  113. /sbin/chkconfig --del netatalk
  114. %triggerpostun -- netatalk <= 1.4b2+asun2.1.3-7vl6
  115. /sbin/chkconfig --add netatalk
  116. %clean
  117. rm -rf ${RPM_BUILD_ROOT}
  118. %files
  119. %defattr(-,root,root)
  120. %doc AUTHORS CONTRIBUTORS COPYING COPYRIGHT
  121. %doc ChangeLog NEWS README* TODO
  122. %doc doc/[A-L,N-Z]*
  123. %config(noreplace) /etc/netatalk/Apple*
  124. %config(noreplace) /etc/netatalk/*.conf
  125. %config /etc/pam.d/netatalk
  126. %config /etc/rc.d/init.d/netatalk
  127. %dir %{_sysconfdir}/netatalk
  128. %dir %{_sysconfdir}/netatalk/msg
  129. #%{_sysconfdir}/avahi/services/afpd.service
  130. %{_bindir}/*
  131. %{_sbindir}/*
  132. %{_libdir}/netatalk/*
  133. %exclude %{_libdir}/netatalk/*.a
  134. %exclude %{_libdir}/netatalk/*.la
  135. %{_mandir}/*/*
  136. %files devel
  137. %defattr(-,root,root)
  138. %{_libdir}/*.a
  139. %{_libdir}/*.la
  140. %{_libdir}/netatalk/*.a
  141. %{_libdir}/netatalk/*.la
  142. %dir %{_includedir}/atalk
  143. %{_includedir}/atalk/*.h
  144. %dir %{_includedir}/netatalk
  145. %{_includedir}/netatalk/*.h
  146. %{_datadir}/aclocal/netatalk.m4
  147. %changelog
  148. * Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
  149. - new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
  150. - add Source100 to add one missing header file in the tarball
  151. - revise Patch10
  152. - explicitly specify --disable-ddp for the first time
  153. * Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
  154. - new upstream release
  155. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
  156. - rebuild with openssl-1.0.0c
  157. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
  158. - fix Patch10 & update description - upon HAT-san's suggestions
  159. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
  160. - new upstream release
  161. - update Vine patch
  162. * Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
  163. - new upstream release
  164. * Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
  165. - new upstream release
  166. * Sun Mar 8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
  167. - rebuilt both for VineSeed / VinePlus-4.0
  168. * Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
  169. - updated to the cjk-6 patch
  170. - Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
  171. - Patch14 updated for db46
  172. * Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
  173. - remove openslp dependency
  174. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
  175. - add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
  176. - TODO: remember to revise this fix after VineSeed changes default locale
  177. from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
  178. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
  179. - revise description (thanks HAT-san for pointing this out)
  180. - run libtoolize/aclocal/auto{make,conf,header} before doing configure
  181. (without this, uams_* modules won't get .so suffix)
  182. * Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
  183. - Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
  184. (Patch10 now includes all the modifications and more fixes)
  185. * Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
  186. - add patch13 and patch14 for db-4.3.
  187. - move files in %%_libexecdir to %%libdir.
  188. * Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
  189. - updated to 2.0.3 release w/ cjk patches (see the above Patch section)
  190. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  191. - security fix: added Patch10 (CAN-2004-0974)
  192. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  193. - configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
  194. * Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
  195. - updated to 2.0 with cjk patch
  196. (see the above Patch section for details)
  197. * Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
  198. - merge the patch repairing bug for System 7.5.5
  199. - (patch6 netatalk-1.5.3.oldsys.patch)
  200. - made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
  201. - patch6 addupted no matter noeuc is, license GPL, URL in comment
  202. * Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
  203. - euc and kana patch originally by
  204. - Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
  205. - applied to netatalk-1.5.2 by me
  206. - README.vine
  207. - omit VERSION from doc, omit perl from require
  208. * Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
  209. - this package is removed because the release number duplicated
  210. * Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
  211. - move acleandir.rc to the doc directory, remove executable flag.
  212. * Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
  213. - updated to new upstream release
  214. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
  215. - added Japanese Summary for devel and corrected Group
  216. * Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
  217. - Oops, check /var/lock/atalkd instead of /var/run/atd.pid
  218. (say atd.pid doesn't have anything to do with netatalk!!)
  219. * Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
  220. - updated to new upstream release
  221. * Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
  222. - install man pages into %%{_mandir}
  223. - PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
  224. - let pre script exit 0
  225. * Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
  226. - spec cleanup
  227. - backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
  228. - restart atalk daemons in the %%post section
  229. * Sun Feb 3 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  230. - v1.5.1.1-0vl1
  231. * Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  232. - v1.5.0-0vl1
  233. - release 1.5.0 for sourceforge
  234. * Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  235. - v1.5pre6-1rh7
  236. - pre-release 6 for sourceforge
  237. * Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  238. - v1.5pre5-1
  239. - pre-release 5 for sourceforge
  240. * Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  241. - v1.5pre5-0
  242. - pre-release 5 for sourceforge (prebuild)
  243. * Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  244. - v1.5pre4-1
  245. - pre-release 4 for sourceforge
  246. - modified/split mandrake spec for redhat 7 build
  247. * Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  248. - v1.5pre3-1mdk
  249. - pre-release 3 for sourceforge
  250. - moved away from 1.4.99 ...
  251. * Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  252. - v1.4.99-0.20001108mdk
  253. - pre-release 2 for sourceforge
  254. * Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  255. - v1.4.99-0.20000927mdk
  256. - pre-release 1 for sourceforge