nginx-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. %define nginx_user nginx
  4. %define nginx_group %{nginx_user}
  5. %define nginx_home %{_localstatedir}/lib/nginx
  6. %define nginx_home_tmp %{nginx_home}/tmp
  7. %define nginx_home_cache %{nginx_home}/cache
  8. %define nginx_logdir %{_localstatedir}/log/nginx
  9. %define nginx_confdir %{_sysconfdir}/nginx
  10. %define nginx_datadir %{_datadir}/nginx
  11. %define nginx_webroot %{nginx_datadir}/html
  12. Summary: Robust, small and high performance http and reverse proxy server
  13. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  14. Name: nginx
  15. Version: 1.2.0
  16. Release: 1%{?_dist_release}
  17. Group: System Environment/Daemons
  18. # BSD License (two clause)
  19. # http://www.freebsd.org/copyright/freebsd-license.html
  20. License: BSD
  21. URL: http://nginx.net/
  22. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  23. Source1: %{name}.init
  24. Source2: %{name}.logrotate
  25. Source3: nginx-virtual.conf.template
  26. Source4: nginx-ssl.conf
  27. Source5: %{name}.sysconfig
  28. Source10: nginx-vine.conf
  29. Source11: nginx-default-vine
  30. Source20: proxy_cache.conf
  31. Source100: nginx-index.html
  32. Source101: poweredby-vine.png
  33. Source102: nginx-logo.png
  34. Source103: nginx-50x.html
  35. Source104: nginx-404.html
  36. %define ngx_fancyindex_version 0.3
  37. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
  38. %define nginx_accept_language_module_version 02262ce
  39. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  40. %define passenger_version 3.0.12
  41. Source1020: passenger-%{passenger_version}.tar.gz
  42. %define upstream_fair_version 2131c73
  43. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  44. %define mod_wsgi_version 6975f0ec7eeb
  45. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  46. # removes -Werror in upstream build scripts. -Werror conflicts with
  47. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  48. Patch0: nginx-auto-cc-gcc.patch
  49. # configuration patch to match all the Vine Linux paths for logs, pid files
  50. # etc.
  51. Patch1: nginx-conf.patch
  52. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  53. BuildRequires: pcre-devel
  54. BuildRequires: zlib-devel
  55. BuildRequires: openssl-devel
  56. BuildRequires: gd-devel
  57. BuildRequires: perl
  58. BuildRequires: perl(ExtUtils::Embed)
  59. BuildRequires: libxml2-devel
  60. BuildRequires: libxslt-devel
  61. BuildRequires: curl-devel
  62. %if "%{?_dist_release}" == "vl4"
  63. Requires: perl >= 5.8.6
  64. %else
  65. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  66. %endif
  67. # for /usr/sbin/useradd
  68. Requires(pre): shadow-utils
  69. Requires(post): chkconfig
  70. # for /sbin/service
  71. Requires(preun): chkconfig, initscripts
  72. Requires(postun): initscripts
  73. Provides: webserver
  74. Vendor: Project Vine
  75. Distribution: Vine Linux
  76. Packager: daisuke
  77. %description
  78. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  79. proxy server written by Igor Sysoev.
  80. %description -l ja
  81. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  82. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  83. - HTTP(S) サーバ
  84. - HTTP(S) リバースプロキシサーバ
  85. - IMAP/POP3 プロキシサーバ
  86. %package passenger
  87. Summary: Nginx with mod_passenger support
  88. Summary(ja): Passenger サポート入りの Nginx
  89. Group: System Environment/Daemons
  90. BuildRequires: ruby, rubygems, rubygem-rake
  91. Requires: nginx
  92. %description passenger
  93. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  94. This package contains nginx server with passenger support.
  95. %description -l ja passenger
  96. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  97. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  98. - HTTP(S) サーバ
  99. - HTTP(S) リバースプロキシサーバ
  100. - IMAP/POP3 プロキシサーバ
  101. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  102. %prep
  103. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  104. %patch0 -p0
  105. %patch1 -p1
  106. %build
  107. # nginx does not utilize a standard configure script. It has its own
  108. # and the standard configure options cause the nginx configure script
  109. # to error out. This is is also the reason for the DESTDIR environment
  110. # variable. The configure script(s) have been patched (Patch1 and
  111. # Patch2) in order to support installing into a build environment.
  112. export DESTDIR=%{buildroot}
  113. ## build with passenger
  114. ./configure \
  115. --user=%{nginx_user} \
  116. --group=%{nginx_group} \
  117. --prefix=%{nginx_datadir} \
  118. --sbin-path=%{_sbindir}/%{name} \
  119. --conf-path=%{nginx_confdir}/%{name}.conf \
  120. --error-log-path=%{nginx_logdir}/error.log \
  121. --http-log-path=%{nginx_logdir}/access.log \
  122. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  123. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  124. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  125. --pid-path=%{_localstatedir}/run/%{name}.pid \
  126. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  127. --with-file-aio \
  128. --with-ipv6 \
  129. --with-http_ssl_module \
  130. --with-http_realip_module \
  131. --with-http_addition_module \
  132. --with-http_xslt_module \
  133. --with-http_image_filter_module \
  134. --with-http_sub_module \
  135. --with-http_dav_module \
  136. --with-http_flv_module \
  137. --with-http_gzip_static_module \
  138. --with-http_random_index_module \
  139. --with-http_secure_link_module \
  140. --with-http_stub_status_module \
  141. --with-http_perl_module \
  142. --with-mail \
  143. --with-mail_ssl_module \
  144. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  145. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  146. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  147. %if %{with wsgi}
  148. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  149. %endif
  150. --add-module=passenger-%{passenger_version}/ext/nginx \
  151. %ifarch i686
  152. --with-cpu-opt=pentiumpro \
  153. --with-zlib-asm=pentiumpro \
  154. --with-md5-asm \
  155. --with-sha1-asm \
  156. %endif
  157. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  158. make %{?_smp_mflags}
  159. mv objs/nginx objs/nginx.passenger
  160. ## build without passenger
  161. ./configure \
  162. --user=%{nginx_user} \
  163. --group=%{nginx_group} \
  164. --prefix=%{nginx_datadir} \
  165. --sbin-path=%{_sbindir}/%{name} \
  166. --conf-path=%{nginx_confdir}/%{name}.conf \
  167. --error-log-path=%{nginx_logdir}/error.log \
  168. --http-log-path=%{nginx_logdir}/access.log \
  169. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  170. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  171. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  172. --pid-path=%{_localstatedir}/run/%{name}.pid \
  173. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  174. --with-file-aio \
  175. --with-ipv6 \
  176. --with-http_ssl_module \
  177. --with-http_realip_module \
  178. --with-http_addition_module \
  179. --with-http_xslt_module \
  180. --with-http_image_filter_module \
  181. --with-http_sub_module \
  182. --with-http_dav_module \
  183. --with-http_flv_module \
  184. --with-http_gzip_static_module \
  185. --with-http_random_index_module \
  186. --with-http_secure_link_module \
  187. --with-http_stub_status_module \
  188. --with-http_perl_module \
  189. --with-mail \
  190. --with-mail_ssl_module \
  191. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  192. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  193. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  194. %if %{with wsgi}
  195. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  196. %endif
  197. %ifarch i686
  198. --with-cpu-opt=pentiumpro \
  199. --with-zlib-asm=pentiumpro \
  200. --with-md5-asm \
  201. --with-sha1-asm \
  202. %endif
  203. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  204. make %{?_smp_mflags}
  205. %install
  206. rm -rf %{buildroot}
  207. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  208. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  209. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  210. find %{buildroot} -type f -empty -exec rm -f {} \;
  211. find %{buildroot} -type f -exec chmod 0644 {} \;
  212. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  213. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  214. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  215. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  216. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  217. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  218. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  219. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  220. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  221. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  222. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  223. %{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf
  224. %{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf.default
  225. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  226. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  227. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  228. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  229. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  230. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  231. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  232. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  233. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  234. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  235. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  236. %if %{with wsgi}
  237. %{__install} -p -m 0644 \
  238. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  239. %{buildroot}%{nginx_confdir}
  240. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  241. %endif
  242. # upstream fair module document
  243. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  244. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  245. # convert to UTF-8 all files that give warnings.
  246. for textfile in CHANGES
  247. do
  248. mv $textfile $textfile.old
  249. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  250. rm -f $textfile.old
  251. done
  252. %clean
  253. rm -rf %{buildroot}
  254. %pre
  255. if [ $1 == 1 ]; then
  256. %{_sbindir}/useradd -c "Nginx user" -s /bin/false -r -d %{nginx_home} %{nginx_user} 2>/dev/null || :
  257. fi
  258. %post
  259. if [ $1 == 1 ]; then
  260. /sbin/chkconfig --add %{name}
  261. fi
  262. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  263. %post passenger
  264. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  265. %preun
  266. if [ $1 = 0 ]; then
  267. /sbin/service %{name} stop >/dev/null 2>&1
  268. /sbin/chkconfig --del %{name}
  269. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  270. fi
  271. %preun passenger
  272. if [ $1 = 0 ]; then
  273. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  274. fi
  275. %postun
  276. if [ $1 == 2 ]; then
  277. /sbin/service %{name} upgrade || :
  278. fi
  279. %files
  280. %defattr(-,root,root,-)
  281. %doc LICENSE CHANGES README
  282. %doc README.upstream_fair
  283. %doc %{?with_wsgi:README.mod_wsgi}
  284. %{nginx_datadir}/
  285. %{_sbindir}/%{name}.normal
  286. %{_mandir}/man3/%{name}.3pm.gz
  287. %{_initrddir}/%{name}
  288. %dir %{nginx_confdir}
  289. %dir %{nginx_confdir}/conf.d
  290. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  291. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  292. %config(noreplace) %{nginx_confdir}/sites.d/*
  293. %config(noreplace) %{nginx_confdir}/win-utf
  294. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  295. %config(noreplace) %{nginx_confdir}/mime.types.default
  296. %config(noreplace) %{nginx_confdir}/fastcgi_params
  297. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  298. %config(noreplace) %{nginx_confdir}/koi-win
  299. %config(noreplace) %{nginx_confdir}/koi-utf
  300. %config(noreplace) %{nginx_confdir}/%{name}.conf
  301. %config(noreplace) %{nginx_confdir}/mime.types
  302. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  303. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  304. %config(noreplace) %{nginx_confdir}/scgi_params
  305. %config(noreplace) %{nginx_confdir}/scgi_params.default
  306. %config(noreplace) %{nginx_confdir}/uwsgi_params
  307. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  308. %if %{with wsgi}
  309. %config(noreplace) %{nginx_confdir}/wsgi_vars
  310. %endif
  311. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  312. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  313. %dir %{perl_vendorarch}/auto/%{name}
  314. %{perl_vendorarch}/%{name}.pm
  315. %{perl_vendorarch}/auto/%{name}/%{name}.so
  316. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  317. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  318. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  319. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  320. %files passenger
  321. %defattr(-,root,root,-)
  322. %doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
  323. %doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
  324. %doc passenger-%{passenger_version}/doc/Architectural\ overview.*
  325. %doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
  326. %doc passenger-%{passenger_version}/doc/template
  327. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  328. %doc passenger-%{passenger_version}/doc/images
  329. %{_sbindir}/%{name}.passenger
  330. %changelog
  331. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  332. - update to 1.2.0
  333. - update passenger to 3.0.12
  334. - drop http_upstream_keepalive
  335. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  336. - new upstream release
  337. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  338. - update to 1.0.12
  339. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  340. - update to 1.0.11
  341. - update passenger to 3.0.11
  342. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  343. - update to 1.0.10
  344. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  345. - update passenger to 3.0.9
  346. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  347. - update to 1.0.6
  348. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  349. - update to 1.0.4
  350. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  351. - add gnosek-nginx-upstream-fair module
  352. - add ngx_http_upstream_keepalive module
  353. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  354. - add nginx-passenger sub pakckage
  355. - use alternatives to choose nginx with or without passenger
  356. - add BR: ruby, rubygems, rubygem-rake
  357. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  358. - update to 1.0.2
  359. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  360. - update to 1.0.1
  361. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  362. - add bcond_with wsgi for mod_wsgi
  363. - add bcond_with passenger
  364. - you need to install rake.gem to build with this option.
  365. - add Provides: webserver
  366. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  367. - new upstream release 1.0.0!
  368. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  369. - rebuild with perl-5.12.3
  370. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  371. - update to 0.8.54
  372. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  373. - update to 0.8.53
  374. - add nginx_accept_language_module
  375. * Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  376. - update to 0.8.50
  377. - update ngx-fancyindex to 0.3
  378. - add BR: libxml2-devel, libxslt-devel
  379. - add scgi_params* and uwsgi_params* to %%files
  380. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  381. - update to 0.8.35 (development version)
  382. - add sites.d/ to store vitualhost settings
  383. - split out default server settings to sites.d/default
  384. - add fancyindex module
  385. * Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  386. - new upstream release
  387. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  388. - update to 0.7.62 (included security fix: VU#180065)
  389. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  390. - fix typo
  391. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  392. - add translated descriptions
  393. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  394. - update 404.html/50x.html to use powered by vine logo.
  395. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  396. - initial build for Vine Linux
  397. - update to 0.7.61
  398. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  399. - init script updates from Gena Makhomed
  400. - remove nginx-upstream-fair
  401. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  402. - update to 0.6.36
  403. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  404. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  405. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  406. - rebuild
  407. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  408. - update to 0.6.35
  409. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  410. - rebuild with new openssl
  411. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  412. - update to 0.6.34
  413. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  414. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  415. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  416. - update to 0.6.33
  417. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  418. - update to 0.6.32
  419. - nginx now supports DESTDIR so removed the patches that enabled it
  420. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  421. - init script fixes
  422. - resolve 'listen 80 default' [#447873]
  423. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  424. - update to 0.6.31
  425. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  426. - upate to new upstream stable branch 0.6
  427. - added 3rd party module nginx-upstream-fair
  428. - added default webpages
  429. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  430. - update init script to match recommended guidelines
  431. - add /etc/nginx/conf.d support [#443280]
  432. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  433. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  434. - add Requires for versioned perl (libperl.so)
  435. - drop silly file Requires
  436. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  437. - Autorebuild for GCC 4.3
  438. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  439. - update to 0.5.35
  440. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  441. - update to 0.5.34
  442. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  443. - Rebuild for deps
  444. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  445. - update to 0.5.33
  446. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  447. - updated to 0.5.32
  448. - fixed rpmlint UTF-8 complaints.
  449. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  450. - added --with-http_stub_status_module build option.
  451. - added --with-http_sub_module build option.
  452. - added use of pcre-config --cflags
  453. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  454. - Update to 0.5.31
  455. - specify license is BSD
  456. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  457. - Add BuildRequires: perl-devel - fixing rawhide build
  458. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  459. - Update to 0.5.30
  460. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  461. - Update to 0.5.29
  462. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  463. - Update to 0.5.28
  464. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  465. - Update to 0.5.27
  466. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  467. - Update to 0.5.26
  468. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  469. - Update to 0.5.19
  470. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  471. - Update to 0.5.17
  472. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  473. - Update to 0.5.16
  474. - add ownership of /usr/share/nginx/html (#233950)
  475. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  476. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  477. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  478. - fixed package review bugs (#233522) given by kevin@tummy.com
  479. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  480. - create patches to assist with building for Fedora
  481. - initial packaging for Fedora