texlive-macros-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392
  1. ## -*- coding: utf-8-unix -*-
  2. %define tex_destdir %{_datadir}
  3. %define texmf %{_prefix}/share/texmf
  4. %define texlive_src %{tex_destdir}/texlive-sources
  5. %define build_tex_destdir %{buildroot}%{tex_destdir}
  6. %define build_texmf %{buildroot}%{texmf}
  7. %define build_texlive_src %{buildroot}%{tex_destdir}-sources
  8. %define knjfonts kanjifonts-3.1
  9. %define jsclasses_ver 110510
  10. %define jlisting_ver 0.2
  11. %define bkmk2uni convert-bkmk2uni
  12. %define exec_texhash [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
  13. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys 2> /dev/null
  14. %define list_macros \
  15. jsclasses-%{jsclasses_ver} \
  16. jlisting-%{jlisting_ver}
  17. Summary: A collection of useful macro packages for texlive package
  18. Summary(ja): texlive パッケージで使うマクロパッケージ集
  19. Name: texlive-macros
  20. Version: 2011
  21. Release: 3%{?_dist_release}
  22. License: distributable
  23. Group: Applications/Publishing
  24. ## Vine Linux
  25. Source0: %{knjfonts}.tar.bz2
  26. Source1: sample.tex
  27. ## jsclasses
  28. Source10: http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/jsclasses-%{jsclasses_ver}.zip
  29. Source11: http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/index.html
  30. ## jlisting
  31. Source20: http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
  32. Requires: perl
  33. Requires: texlive-common = %{version}
  34. BuildRequires: texlive-common = %{version}
  35. BuildRequires: nkf unzip
  36. Buildroot: %{_tmppath}/%{name}-%{version}-root
  37. BuildArch: noarch
  38. Obsoletes: tetex-macros
  39. Obsoletes: pLaTeX2e_Macros
  40. Distribution: Vine Linux
  41. Vendor: Project Vine
  42. Packager: munepi
  43. %description
  44. A collection of useful macro packages for texlive package, including
  45. kanjifonts-3.1 (for Ricoh Fonts/DynaLab Fonts and JIS font metric)
  46. %{list_macros}
  47. # This package contained a perl script
  48. # http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
  49. %description -l ja
  50. texlive パッケージで使うマクロパッケージ集です。
  51. 以下のマクロを収録しています。
  52. kanjifonts-3.1 (Vine Linux 3.1R 付属のリコーフォント/ダイナフォントやJISフォントメトリックを使う)
  53. %{list_macros}
  54. # このパッケージには prosper, powerdot 用に
  55. # PDF ブックマークの文字化けを修正するための perl スクリプト
  56. # http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
  57. # を同梱しています.
  58. %prep
  59. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
  60. %setup -q -c -n %{name}-%{version}
  61. %__mkdir_p jsclasses
  62. (cd jsclasses
  63. %__mkdir_p jsclasses
  64. %__unzip -a -qq %{SOURCE10}
  65. %__cp -p %{SOURCE11} ./jsclasses/README.html
  66. )
  67. # get rid of unwanted files
  68. find . -type d -name CVS | xargs -r %__rm -frv
  69. find . -type f -name .cvsignore | xargs -r %__rm -fv
  70. (cd jsclasses
  71. %__mkdir_p tmp
  72. for i in *.*; do nkf $i > tmp/$i; done
  73. %__mv tmp/* .
  74. %__rm -rf tmp
  75. )
  76. %build
  77. (cd jsclasses
  78. for i in jsclasses okumacro okuverb morisawa; do
  79. platex ${i}.dtx && platex ${i}.dtx || exit 1
  80. done
  81. for i in jsclasses okumacro okuverb; do
  82. dvipdfmx $i || exit 1
  83. done
  84. %__cp *.dvi *.pdf jsclasses
  85. )
  86. %install
  87. %__rm -rf %{buildroot}
  88. %__mkdir_p %{build_texmf}/packages/
  89. ## install kanjifonts
  90. %__mkdir_p %{build_texmf}/tex/platex/kanjifonts
  91. %__mv %{knjfonts}/*.sty %{build_texmf}/tex/platex/kanjifonts
  92. %__mv %{knjfonts}/*.def %{build_texmf}/tex/platex/kanjifonts
  93. # nkf --utf8 %{SOURCE25} | \
  94. # sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
  95. # %{buildroot}%{_bindir}/%{bkmk2uni}
  96. # chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
  97. ## install jsclasses
  98. (cd jsclasses
  99. %__mkdir_p %{build_texmf}/tex/platex/jsclasses
  100. %__cp -fp *.dtx *.ins *.cls *.sty %{build_texmf}/tex/platex/jsclasses/
  101. )
  102. ## install jlisting
  103. %__mkdir_p %{build_texmf}/tex/latex/jlisting
  104. %__install -m 644 %{SOURCE20} %{build_texmf}/tex/latex/jlisting/
  105. bunzip2 %{build_texmf}/tex/latex/jlisting/jlisting.sty.bz2
  106. %post
  107. %{exec_texhash}
  108. # %{exec_updmap}
  109. exit 0
  110. %postun
  111. if [ "$1" = 0 ]; then
  112. %{exec_texhash}
  113. # %{exec_updmap}
  114. fi
  115. exit 0
  116. %clean
  117. %__rm -rf $RPM_BUILD_ROOT
  118. %files
  119. %defattr(-,root,root)
  120. %doc %{knjfonts}
  121. %doc jsclasses/jsclasses
  122. #%{_bindir}/%{bkmk2uni}
  123. %{texmf}/tex/platex/kanjifonts/kanjifonts.sty
  124. %{texmf}/tex/platex/kanjifonts/*.def
  125. %{texmf}/tex/platex/jsclasses
  126. %{texmf}/tex/latex/jlisting
  127. %changelog
  128. * Thu Feb 9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
  129. - move jlisting package to %%{texmf}/tex/latex/jlisting
  130. * Thu Dec 1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  131. - updated jsclasses to 110510
  132. - mistook to change %%jsclasses_ver at 2011-1
  133. * Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  134. - TeX Live 2011
  135. - updated jsclasses to 110510
  136. * Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  137. - dropped BuildRequires: jvf
  138. - for vl5, added Conflicts: tetex-macros
  139. * Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  140. - removed %%{exec_updmap} in %%post and %%postun
  141. * Tue May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  142. - ported from tetex-macros-3.0-7
  143. - TeX Live 2009
  144. * Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
  145. - added BuildRequires: unzip
  146. - updated jsclasses to 090826
  147. - updated pict2e to 0.2x
  148. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
  149. - dropped epsbox.sty, eclepsf.sty
  150. (bacause there style files for platex209 are obsolete)
  151. * Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
  152. - added jlisting v0.2
  153. - defined list_macros
  154. - used %%{list_macros} in %%description and %%description -l ja
  155. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
  156. - dropped convert-euc.txt
  157. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
  158. - updated prosper
  159. - added some contrib themes from CTAN
  160. - added prosper.cls v1.6 from CVS HEAD
  161. - added a perl script: convert-euc.txt
  162. - added powerdot v1.3
  163. - added xkeyval v2.5d
  164. - added beamer v3.07
  165. - added pgf v2.00
  166. - added pict2e v0.2w
  167. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
  168. - updated jsclasses to 20090222
  169. - updated jsclasses/index.html to 2009-02-22
  170. - removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
  171. * Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
  172. - applied new versioning policy, spec in utf-8
  173. * Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
  174. - update jsclasses/index.html to 2006-11-06.
  175. * Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
  176. - update jsclasses/index.html to 2006-02-12.
  177. * Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
  178. - update jsclasses/index.html to 2005-10-26.
  179. * Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
  180. - update jsclasses/index.html to 2005-4-30.
  181. - added breqn
  182. * Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
  183. - update jsclasses/index.html to 2004-12-29.
  184. * Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
  185. - add missing files in kanjifonts-3.0
  186. * Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
  187. - update to kanjifonts.sty-3.0.
  188. * Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
  189. - update jsclasses/index.html to 2004-11-03.
  190. * Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
  191. - update jsclasses/index.html to 2004-09-27.
  192. * Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
  193. - update jsclasses/index.html to 2004-02-25.
  194. - added eclepsf.sty.
  195. - removed epsf.sty (symlink to epsbox.sty).
  196. - removed geometry, which is in tetex-2.0.
  197. * Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
  198. - update jsclasses/index.html to 2003-04-18.
  199. - added morisawa.dvi.
  200. * Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
  201. - update jsclasses/index.html to 2003-03-06
  202. * Mon Feb 3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
  203. - remove natbib, which is in tetex-2.0
  204. - let version number same as tetex
  205. - added Requires: tetex
  206. * Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
  207. - update jsclasses/index.html to 2003-01-16
  208. * Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
  209. - update jsclasses to 2003-01-05
  210. - update index.html to 2003-01-12
  211. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
  212. - update jsclasses and index.html to 2002-11-27
  213. * Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
  214. - update jsclasses and index.html to 2002-11-01
  215. * Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
  216. - oops, packager was incorrect
  217. * Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
  218. - update jsclasses to 2002-06-29
  219. - update index.html to 2002-07-03
  220. * Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
  221. - update jsclasses to 2002-04-21
  222. - update index.html to 2002-04-09
  223. * Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
  224. - added MORISAWA basic 5 fonts
  225. * Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
  226. - update to kanjifonts-1.1
  227. * Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
  228. - update jsclasses and index.html to 2002-02-07
  229. * Tue Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
  230. - update jsclasses and index.html to 2002-01-27
  231. - fix typo in changelog
  232. * Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
  233. - update jsclasses and index.html to 2002-01-18
  234. * Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
  235. - update index.html (jsclasses)
  236. * Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
  237. - update jsclasses to 2001-11-29
  238. * Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
  239. - fixed spec file for Prosper and jsclasses
  240. - use RPM macro in %files
  241. - added BuildPrereq: jvf
  242. * Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
  243. - move revtex4 to texmacro-aps package
  244. * Sun Sep 9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
  245. - added prosper jsclasses
  246. * Mon Sep 6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
  247. - added revtex4 natbib
  248. * Mon Sep 3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
  249. - remove prereq tetex to avoid dependency-loop
  250. * Wed Aug 1 2001 Jun Nishii <jun@vinelinux.org>
  251. - tetex-macros-1.0-0vl1
  252. * Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
  253. - 2.0-2
  254. - added kanjifonts-1.0 and removed jisfontsmetric
  255. * Sun Jan 9 2000 Jun Nishii <jun@vinelinux.org>
  256. - 2.0-1
  257. - install ldf in babel
  258. * Sat Jan 8 2000 Jun Nishii <jun@vinelinux.org>
  259. - added jisfontmetric.tex
  260. * Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
  261. - change group.
  262. * Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
  263. - added babel
  264. * Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
  265. - added hoekwater
  266. * Mon Aug 3 1999 Jun Nishii <jun@flatout.org>
  267. - added psfrag
  268. * Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
  269. - added psnfss
  270. - Change directory tree according to the suggestion by Dr.Okumura.
  271. - remove many files from packages directory except documentations
  272. - disable mktexlsr and erase ls-R
  273. * Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
  274. - added url.sty
  275. * Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
  276. - pLaTeX2e_Macros-1-2
  277. - added fancyhdr.sty, boxedminipage.sty
  278. - added graphics.cfg, color.cfg (use dvips as default)
  279. - symlink from epsbox to epsf
  280. * Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
  281. - pLaTeX2e_Macros-1-1
  282. (rename as pLaTeX2e_Macros from pLaTeX-Classes)
  283. - added def files of graphics
  284. - added tools and hyperref
  285. - check the existence of mktexlsr
  286. * Tue Oct 5 1998 Jun Nishii <jun@flatout.org>
  287. - buildarch: noarch
  288. - added requires
  289. * Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
  290. - tiny bug fix and add %defattr
  291. * Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
  292. - first version fo platex-19980901