gnumeric-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465
  1. %define gnumeric_version %{version}-bonobo
  2. %define goffice_version 0.8.14
  3. Summary: A spreadsheet program for GNOME.
  4. Summary(ja): GNOME スプレッドシート
  5. Name: gnumeric
  6. Version: 1.10.14
  7. Release: 1%{?_dist_release}
  8. License: GPLv2
  9. Group: Applications/Productivity
  10. URL: http://www.gnome.org/projects/gnumeric
  11. Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.10/%{name}-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. # default font: VL Gothic
  14. Patch0: gnumeric-1.10.13-vlgothic.patch
  15. Distribution: Vine Linux
  16. Vendor: Project Vine
  17. BuildRequires: gtk2-devel >= 2.10.0
  18. BuildRequires: libglade2-devel >= 2.3.6
  19. BuildRequires: libgnomeprint-devel >= 2.8.2
  20. BuildRequires: libgnomeprintui-devel >= 2.8.2
  21. BuildRequires: libart_lgpl-devel >= 2.3.11
  22. BuildRequires: libxml2-devel >= 2.4.12
  23. BuildRequires: libgsf-devel >= 1.13.2
  24. BuildRequires: goffice-devel >= %{goffice_version}
  25. BuildRequires: libbonobo-devel libgnomeui-devel
  26. BuildRequires: libffi-devel
  27. #BuildPreReq: libgda-devel >= 1.9.100
  28. #BuildPreReq: libgnomedb-devel >= 1.9.100
  29. BuildRequires: perl python-devel
  30. BuildRequires: automake autoconf libtool docbook-utils
  31. BuildRequires: intltool >= 0.28 desktop-file-utils
  32. BuildRequires: libSM-devel
  33. Requires: gtk2 >= 2.10.0
  34. Requires: libglade2 >= 2.3.6
  35. Requires: libgnomeprint >= 2.8.2
  36. Requires: libgnomeprintui >= 2.8.2
  37. Requires: libgsf >= 1.14.6
  38. Requires: perl python
  39. Requires: GConf2 scrollkeeper
  40. # no longer devel package
  41. #Provides: %{name}-devel
  42. Obsoletes: %{name}-devel
  43. %description
  44. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  45. applications and desktop tools to be used in conjunction with a window
  46. manager for the X Window System.
  47. This is the Gnumeric, a spreadsheet for GNOME. It aims to be a drop in
  48. replacement for commercial spreadsheets. It provides import/export from
  49. MS Excel files and many other formats (csv, latex, xbase, applix).
  50. %description -l ja
  51. GNOME (GNU Network Object Model Environment)は
  52. Xウィンドウシステム用の、ウィンドウマネージャと連結した
  53. GUIアプリケーションおよびデスクトップツールのセットです。
  54. これは Gnumeric, GNOMEスプレッドシート・プログラムです。
  55. 商用のスプレッドシート・プログラムを代替できるものを目指しています。
  56. MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
  57. を読込み、出力できます.
  58. # %package devel
  59. #Summary: Files necessary to develop gnumeric-based applications.
  60. #Group: Development/Libraries
  61. #Requires: %{name} = %{PACKAGE_VERSION}
  62. #%#description devel
  63. #The gnumeric-devel package includes files necessary to develop gnumeric-based
  64. #applications.
  65. #Install gnumeric-devel if you want to develop programs which will use gnumeric.
  66. %prep
  67. %setup -q
  68. %patch0 -p1 -b vlgothic
  69. %build
  70. %ifarch alpha
  71. MYARCH_FLAGS="--host=alpha-redhat-linux"
  72. %endif
  73. export mllibname=%{_lib}
  74. %configure --with-gnome \
  75. --with-gda --without-gb --with-perl --with-python \
  76. --disable-schemas-install
  77. make
  78. %install
  79. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  80. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  81. make DESTDIR=$RPM_BUILD_ROOT install
  82. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  83. ./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
  84. desktop-file-install --vendor gnome --delete-original \
  85. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  86. --add-category Office \
  87. --add-category Application \
  88. --add-category Spreadsheet \
  89. --remove-mime-type="zz-application/zz-winassoc-xls" \
  90. $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  91. %find_lang %{name}
  92. %find_lang %{name}-functions
  93. cat %{name}-functions.lang >> %{name}.lang
  94. rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
  95. rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
  96. rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  97. rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
  98. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  99. %clean
  100. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  101. %post
  102. /sbin/ldconfig
  103. scrollkeeper-update > /dev/null 2>&1 || :
  104. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  105. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
  106. touch --no-create %{_datadir}/icons/hicolor || :
  107. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  108. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  109. fi
  110. %pre
  111. if [ "$1" -gt 1 ]; then
  112. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  113. gconftool-2 --makefile-uninstall-rule \
  114. %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
  115. fi
  116. %preun
  117. if [ "$1" -eq 0 ]; then
  118. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  119. gconftool-2 --makefile-uninstall-rule \
  120. %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
  121. fi
  122. %postun
  123. /sbin/ldconfig
  124. scrollkeeper-update > /dev/null 2>&1 || :
  125. touch --no-create %{_datadir}/icons/hicolor || :
  126. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  127. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  128. fi
  129. %files -f %{name}.lang
  130. %defattr (-, root, root)
  131. %doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
  132. %config %{_sysconfdir}/gconf/schemas/*
  133. %{_bindir}/*
  134. %{_libdir}/lib*.so*
  135. %{_libdir}/gnumeric
  136. %{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
  137. #{_libdir}/bonobo/servers/*
  138. %{_datadir}/applications/*.desktop
  139. %{_datadir}/glib-2.0/schemas/*.xml
  140. %{_datadir}/gnome/help/gnumeric
  141. %{_datadir}/gnumeric
  142. %{_datadir}/pixmaps/*
  143. #{_datadir}/mime-info/*
  144. #{_datadir}/mc/templates/*
  145. %{_datadir}/omf/*
  146. %{_datadir}/icons/hicolor/*
  147. %{_mandir}/man*/*
  148. %exclude %{_datadir}/pixmaps/win32-gnumeric.ico
  149. #%{_libexecdir}/gnumeric-component
  150. #%#dir %{_libdir}/gnumeric
  151. #%#dir %{_libdir}/gnumeric/%{bonobover}
  152. #%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
  153. #%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
  154. # This is really silly. The .la files are useless for plugins.
  155. #%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
  156. #%#{_libdir}/gnumericConf.sh
  157. #%#if %{bonobo}
  158. #%#dir %{_datadir}/gnumeric
  159. #%#dir %{_datadir}/gnumeric/%{bonobover}
  160. #%#{_datadir}/gnumeric/%{bonobover}/idl
  161. #%#endif
  162. %changelog
  163. * Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
  164. - new upstream release
  165. * Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
  166. - new upstream release
  167. - add Patch0 (gnumeric-1.10.13-vlgothic.patch)
  168. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
  169. - new upstream release
  170. * Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
  171. - new upstream release
  172. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
  173. - new upstream release
  174. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
  175. - new upstream release
  176. - add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
  177. (fix error of MIME type)
  178. * Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  179. - new upstream release
  180. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
  181. - new upstream release
  182. * Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  183. - new upstream release
  184. - fix %post and %postun
  185. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  186. - new upstream release
  187. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
  188. - new upstream release
  189. - add BuildRequires: libSM-devel
  190. - fix BuildRequires: goffice-devel >= 0.8.1
  191. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
  192. - spec in UTF-8 (fixed)
  193. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
  194. - spec in UTF-8
  195. - added BuildRequires: libffi-devel
  196. - added %%pre, %%preun section
  197. * Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
  198. - new upstream release
  199. - built with libgda-3.1.4, libgnomedb-3.1.2
  200. - applied new versioning policy
  201. * Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
  202. - new upstream release
  203. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
  204. - rebuild
  205. * Fri May 5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
  206. - new upstream release
  207. * Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
  208. - new upstream release
  209. - updated build dependancies
  210. - rebuilt with libgsf-1.14.0
  211. - built with libgda and libgnomedb again
  212. * Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
  213. - new upstream release
  214. - updated build dependancies
  215. - not compile with libgda and libgnomedb in this version
  216. * Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
  217. - new upstream release
  218. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
  219. - rebuild with libgda 1.2.0 and libgnome 1.2.0
  220. * Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
  221. - new upstream release
  222. * Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
  223. - new upstream release
  224. * Thu Dec 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
  225. - new upstream release
  226. * Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
  227. - rebuild with gnome-2.8 environment and libgsf-1.10.1
  228. * Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
  229. - new upstream release
  230. - added BuildRequires: desktop-file-utils
  231. * Thu May 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
  232. - new upstream release
  233. - Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
  234. * Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  235. - new upstream release
  236. * Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
  237. - new upstream release
  238. * Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  239. - new upstream release
  240. * Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  241. - new upstream release
  242. * Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
  243. - new upstream release
  244. - clean up spec file (a little bit!)
  245. * Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  246. - new upstream release
  247. * Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
  248. - new upstream release
  249. - to use intltool-0.28
  250. * Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
  251. - new upstream release
  252. - rebuild with new toolchains
  253. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
  254. - new upstream release
  255. - build with new libgnomeprint, libgnomeprintui
  256. * Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  257. - new upstream release
  258. * Thu Oct 2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
  259. - rebuild with newer libgda, libgnomedb
  260. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  261. - updated to 1.2.0 (stable release)
  262. - guile support is temporarily off this version.
  263. * Mon Sep 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
  264. - update to 1.1.20 (gtk+-2 port)
  265. - based on Redhat Rawhide 1.1.20-1
  266. * Thu May 1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
  267. - update to 1.0.13
  268. - rebuild with gal 0.24
  269. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
  270. - guile support on
  271. - rebuild with new gal, bonobo, libgda
  272. * Fri Feb 7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
  273. - New upstream release, remove xmliobackward.patch
  274. * Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
  275. - xml-io back to 1.0.10 because japanese corrups with new xml_parser
  276. * Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
  277. - New upstream release, fix for xml importing files with non ASCII characters.
  278. - Without guile, changelog.archive, requires, build scripts, description
  279. * Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
  280. - files: add gnumericConf.sh, which was missing
  281. * Mon Nov 4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
  282. - New upstream release.
  283. - BuildPrereq oaf-devel
  284. * Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
  285. - New upstream release.
  286. * Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
  287. - New upstream release.
  288. - Default font and Japanese fonts in excel
  289. - requires
  290. * Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
  291. - New upstream release.
  292. - fixed plugins, apply patch2, remove patch3
  293. - files - no longer devel package
  294. - function-reference.html in help file
  295. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
  296. - New upstream release.
  297. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
  298. - New upstream release.
  299. - Fixed several owner dir.
  300. * Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
  301. - Build against with new gal
  302. * Mon Jan 7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
  303. - New upstream release.
  304. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
  305. - New upstream release.
  306. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
  307. - New upstream release.
  308. - Applied XIM over-the-spot patch.
  309. - Fixed directories owner.
  310. * Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
  311. - New upstream release.
  312. - Enable Bonobo.
  313. - Merged several RH patches.
  314. - Added BuildPreReq tags.
  315. * Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
  316. - Fixed packaging mistake.
  317. * Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
  318. - Rebuild for GAL 0.7
  319. * Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
  320. - New upstream release.
  321. - Use rpmmacros.
  322. * Mon Feb 5 2001 Jun Nishii <jun@vinelinux.org>
  323. - 0.56-0vl2
  324. - update ja.po
  325. - avoid core dump when inserting a row
  326. * Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  327. - updated to 0.56
  328. - remake spec with the orginal gnumeric spec file.
  329. - added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
  330. * Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  331. - updated to 0.53
  332. - remake SPEC based on gnumeric original.
  333. - added libxml183 patch for libxml 1.8.3
  334. * Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
  335. - Removed gnome-gnumeric-xl.png since it is nowhere to be found.
  336. - Added --without-bonobo and --without-gb.
  337. - Added %define for sysconfdir
  338. * Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
  339. - Updated version requirements for gnome-print, and gnome-libs.
  340. * Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
  341. - Added in some auto-detect the language files logic (rpm 3.0.xx only)
  342. * Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
  343. - Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
  344. * Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
  345. - Updated to 0.47
  346. * Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
  347. - Updated the libglade dependancy.
  348. - Remove req for guile. We can build without it.
  349. * Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
  350. - Added small fix so glade generated dialogs appear.
  351. * Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
  352. - Added the gnome-print requirement.
  353. - Updated the file list to try and quiet down the updating.
  354. - added the sysconfdir
  355. * Tue Mar 9 1999 Gregory McLean <gregm@comstar.net>
  356. - Updated the spec file.
  357. * Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
  358. - Version 0.2