tamago-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define _libdir %{_prefix}/lib
  4. %define origver 4.0.6
  5. %define origname tamago
  6. %define egg_anthy_version 20070606
  7. Summary: Tamago Version 4 -- EGG Input Method Architecture for Emacsen
  8. Summary(ja): たまご第4版
  9. Name: %{origname}
  10. Version: %{origver}
  11. Release: 10.egganthy%{egg_anthy_version}%{?_dist_release}
  12. Source0: ftp://ftp.m17n.org/pub/%{origname}/%{origname}-%{origver}.tar.gz
  13. Source1: %{origname}-install.sh
  14. Source2: %{origname}-remove.sh
  15. Source3: http://cgi18.plala.or.jp/nyy/canna/egg-canna.el
  16. Source4: egg-anthy.tar.gz
  17. Source10: vine-default-%{origname}.el
  18. Source11: %{origname}-init.el
  19. Patch0: tamago-4.0.6-cvshead.patch
  20. Patch3: tamago-4.0.6-eggrc.patch
  21. Patch4: tamago-4.0.6-makefile.patch
  22. Patch5: tamago-4.0.6-canna-unix-domain-socket.patch
  23. Patch10: tamago-emcws.patch
  24. Patch20: tamago-4.0.6-vine-romakana.patch
  25. Patch30: tamago-4.0.6-egg-helper-path.patch
  26. Patch40: tamago-4.0.6-wnn8_rev2.patch
  27. ### for emacs
  28. ### from http://www.m17n.org/mlarchive/mule-ja/200703/msg00018.html
  29. Patch50: tamago-4.0.6-emacs23.patch
  30. License: GPL
  31. Group: Applications/Editors/Emacs
  32. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  33. Requires: emacsen
  34. Requires: emacsen-common
  35. BuildPreReq: apel
  36. %prereq_ge apel
  37. Obsoletes: tamago-el
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. %description
  41. EGG Emacs20(Emacs21) Input Method Architecture.
  42. Egg can use FreeWnn (jserver, cserver, tserver) and Wnn6 as server doing
  43. character string conversion with the back end.
  44. And this package includes egg-anthy. Egg can use Anthy.
  45. %description -l ja
  46. GNU Emacs 20.5 以降で多言語入力環境を提供します。
  47. バックエンドサーバとしては、FreeWnn (jserver,
  48. cserver, tserver), Wnn6, SJ3 Ver.2,canna に対応。
  49. また、本パッケージには egg-anthy も同梱しているため、Anthy にも対応。
  50. %prep
  51. %setup -n %{origname}-%{origver} -a 4
  52. %patch0 -p1
  53. %patch3 -p1
  54. #% patch4 -p1
  55. %patch5 -p1
  56. # cp %{SOURCE3} .
  57. %__cp -a %{SOURCE10} %{SOURCE11} .
  58. #% patch10 -p1
  59. %patch20 -p1
  60. %patch30 -p1
  61. %patch40 -p1
  62. %patch50 -p1
  63. # rename canna stuff
  64. #mv egg/canna.el egg/canna-tamago.el
  65. # copy egg-anthy stuff
  66. cp egg-anthy-%{egg_anthy_version}/*.el egg/
  67. %build
  68. %configure
  69. gcc %{optflags} -o helper/egg-helper helper/egg-helper.c
  70. %install
  71. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  72. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  73. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
  74. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
  75. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
  76. #
  77. # install el files
  78. #
  79. cp -r eggrc *.el egg its* Makefile \
  80. $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{origname}/
  81. #
  82. # install egg-helper
  83. #
  84. install -d $RPM_BUILD_ROOT%{_libexecdir}
  85. install -m 755 helper/egg-helper $RPM_BUILD_ROOT%{_libexecdir}
  86. #
  87. # install script( bytecompile el and install elc , remove )
  88. #
  89. %_installemacsenscript %{origname} %{SOURCE1}
  90. %_removeemacsenscript %{origname} %{SOURCE2}
  91. #
  92. # install info file
  93. #
  94. mkdir -p ${RPM_BUILD_ROOT}/usr/info
  95. %post
  96. #
  97. # bytecompile and install
  98. #
  99. if [ "$1" = 2 ]; then
  100. %_emacsenPackageRemove %{origname}
  101. fi
  102. %_addemacsenlist %{origname}
  103. %_emacsenPackageInstall %{origname}
  104. %preun
  105. if [ "$1" = 0 ]; then
  106. %_emacsenPackageRemove %{origname}
  107. %_removeemacsenlist %{origname}
  108. fi
  109. %clean
  110. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  111. %files
  112. %defattr(-,root,root)
  113. %doc README.ja.txt COPYING AUTHORS ChangeLog* PROBLEMS TODO
  114. %doc egg-anthy-%{egg_anthy_version}/egg-anthy.readme doc/
  115. %{_datadir}/emacs/site-lisp/%{origname}/
  116. %{_libdir}/emacsen-common/packages/install/%{origname}
  117. %{_libdir}/emacsen-common/packages/remove/%{origname}
  118. %{_libexecdir}/egg-helper
  119. %changelog
  120. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.6-10.egganthy20070606
  121. - new release number for RPM package
  122. - update description
  123. * Sun Jun 6 2010 IWAI, Masaharu <iwai@alib.jp> 4.0.6-9
  124. - update to egg-anthy 20070606
  125. - update vine-default-tamago.el: connect to anthy with utf-8
  126. * Sat May 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-8
  127. - update vine-default-tamago.el to support emacs >= 23.1.96
  128. * Mon Nov 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-7
  129. - update patch40 (tamago-4.0.6--wnn8_rev2.patch)
  130. - fix bugs on 64bit architecture.
  131. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-6
  132. - applied tamago-4.0.6-emacs23.patch
  133. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-5
  134. - updated tamago-install.sh
  135. - *-init.el: changed from hard copy to symbolic link
  136. on /etc/emacs-XX.YY/site-start.d
  137. * Wed Apr 22 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-4
  138. - no applied:
  139. - egg-canna.el
  140. - tamago-4.0.6-makefile.patch
  141. - tamago-emcws.patch
  142. - added vine-default-tamago.el and tamago-init.el
  143. - updated tamago-install.sh for vine-default-tamago.el
  144. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-3
  145. - change from noarch to per-arch for egg-helper.
  146. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.6-2vl5
  147. - applied new versioning policy
  148. - added %%define _libdir %%{_prefix}/lib
  149. * Sat Apr 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl26
  150. - add Patch40 to support wnn7 and wnn8 (taken from debian package)
  151. * Fri Dec 29 2006 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl25
  152. - restration(cp %{SOURCE3} .)for compilation complete(and use it for emacs-21.4)
  153. * Sat Nov 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl24
  154. - add Patch5
  155. tamago-canna backend connect to cannaserver using UNIX domain
  156. socket by default. (taken from debian package)
  157. - add Patch30 to change egg-helper path.
  158. * Thu Sep 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl23
  159. - modified its/hira.el to add some roma-kana conversion map.
  160. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.6-1vl22
  161. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  162. * Sat Jun 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl21
  163. - update to cvs head
  164. - add egg-anthy
  165. http://anthy.sourceforge.jp/cgi-bin/hiki/hiki.cgi?Emacs%A4%AB%A4%E9
  166. - add documents to %%files
  167. - use License: instead of Copyright:
  168. * Fri May 16 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl20
  169. - update tamago-install.sh
  170. - rm -f ${ELDIR}/*.elc, egg/*.elc, its/*.elc
  171. - rm -f ${ELCDIR}/*.el, egg/*.el, its/*.el
  172. * Fri May 9 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-1vl19
  173. - update tamago-remove.sh: delete ${SITELISP}/egg
  174. * Wed Apr 30 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.0.6-1vl18
  175. - rebuild
  176. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl17
  177. - add patch10 to use with emcws
  178. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl16
  179. - remove conflicts to emacs-dl-*
  180. - rename canna.el to canna-tamago.el (we use emcws for canna)
  181. * Wed Sep 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl14
  182. - modified patch3 for Canna-3.5b2-41
  183. * Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl13
  184. - added patch4
  185. * Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl12
  186. - update source3
  187. * Mon Jul 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl11
  188. - added patch3
  189. * Fri Jun 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl10
  190. - update patch2
  191. - added source3
  192. * Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.6-1vl9
  193. - tamago-el -> tamago again
  194. - spec file cleaned up
  195. * Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl8
  196. - fixed install time no-compile bug( edit tamago-{install,remove}.sh )
  197. * Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl5
  198. - support emacsen
  199. * Sun Dec 17 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl3
  200. - canna support patch upgrade.
  201. * Sat Dec 16 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl2
  202. - version 4.0.6
  203. - merge canna support patch.
  204. * Fri Jan 14 2000 Kazuhisa TAKEI<ktakei@jaist.ac.jp>
  205. - version 4.0.5