memtest86+-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225
  1. # Prevent stripping
  2. %define __spec_install_post /usr/lib/rpm/brp-compress
  3. # Turn off debuginfo package
  4. %define debug_package %{nil}
  5. Summary: Stand-alone memory tester for x86 and x86-64 computers
  6. Summary(ja): x86 および x86_64 用のスタンドアロンメモリ検査ツール
  7. Name: memtest86+
  8. Version: 4.20
  9. Release: 1%{?_dist_release}
  10. License: GPL
  11. ExclusiveArch: %{ix86} x86_64
  12. Group: System Environment/Base
  13. Source0: http://www.memtest.org/download/1.20/memtest86+-%{version}.tar.gz
  14. URL: http://www.memtest.org
  15. Source1: new-memtest-pkg
  16. Source2: memtest-setup
  17. Requires(preun): coreutils
  18. %ifarch x86_64
  19. BuildRequires: compat32-glibc-devel
  20. %endif
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  22. Obsoletes: memtest86
  23. %description
  24. Memtest86+ is a thorough stand-alone memory test for x86 and x86-64
  25. architecture computers. BIOS based memory tests are only a quick
  26. check and often miss many of the failures that are detected by
  27. Memtest86+.
  28. Run 'memtest-setup' to add to your GRUB or lilo boot menu.
  29. %prep
  30. %setup -q
  31. %build
  32. # Regular build flags not wanted for this binary
  33. # Note: i486 minimum runtime arch
  34. make
  35. %install
  36. rm -rf $RPM_BUILD_ROOT
  37. mkdir -p $RPM_BUILD_ROOT/boot
  38. mkdir -p $RPM_BUILD_ROOT/sbin
  39. mkdir -p $RPM_BUILD_ROOT%{_sbindir}
  40. install -m644 memtest.bin $RPM_BUILD_ROOT/boot/memtest86+-%{version}
  41. install -m755 %{SOURCE1} $RPM_BUILD_ROOT/sbin/new-memtest-pkg
  42. install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sbindir}/memtest-setup
  43. %clean
  44. rm -rf $RPM_BUILD_ROOT
  45. %files
  46. %defattr(-,root,root,-)
  47. %doc README
  48. /boot/memtest86+-%{version}
  49. /sbin/new-memtest-pkg
  50. %{_sbindir}/memtest-setup
  51. %preun
  52. /sbin/new-memtest-pkg --remove %{version}
  53. %changelog
  54. * Wed Jun 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.20-1
  55. - new upstream release
  56. * Sun Jan 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10-1
  57. - new upstream release
  58. - add BuildRequires: compat32-glibc-devel (x86_64 only)
  59. * Sat May 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11-1
  60. - new upstream release
  61. * Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.65-1vl5
  62. - applied new versioning policy, spec in utf-8
  63. * Fri Aug 18 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.65-0vl1
  64. - initial build for Vine Linux
  65. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.65-4.1
  66. - rebuild
  67. * Tue Jun 27 2006 Florian La Roche <laroche@redhat.com> - 1.65-4
  68. - make sure coreutils is installed for the preun script
  69. * Thu Jun 08 2006 Jesse Keating <jkeating@redhat.com> - 1.65-3
  70. - rebuilt for new buildsystem
  71. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.65-2.2
  72. - rebuilt for new gcc4.1 snapshot and glibc changes
  73. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  74. - rebuilt
  75. * Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
  76. - make sure 32bit glibc-devel is installed (#170614)
  77. * Sat Oct 01 2005 Warren Togami <wtogami@redhat.com> - 1.65-1
  78. - 1.65
  79. * Wed Jun 29 2005 Warren Togami <wtogami@redhat.com> - 1.60-1
  80. - 1.60
  81. * Mon Mar 28 2005 Warren Togami <wtogami@redhat.com> - 1.55.1-1
  82. - 1.55.1 fixes K8
  83. * Sun Mar 27 2005 Warren Togami <wtogami@redhat.com> - 1.55-1
  84. - 1.55
  85. * Wed Mar 16 2005 Elliot Lee <sopwith@redhat.com>
  86. - rebuilt
  87. * Sat Feb 19 2005 Warren Togami <wtogami@redhat.com> - 1.51-1
  88. - 1.51
  89. * Fri Jan 21 2005 Warren Togami <wtogami@redhat.com> - 1.50-1
  90. - 1.50
  91. * Sun Nov 28 2004 Warren Togami <wtogami@redhat.com> - 1.40-1
  92. - 1.40
  93. - remove arch patch, now upstream
  94. * Tue Oct 26 2004 Warren Togami <wtogami@redhat.com> - 1.27-1
  95. - 1.27
  96. * Mon Oct 25 2004 Jeremy Katz <katzj@redhat.com> - 1.26-3
  97. - allow building on all x86 arches
  98. - pass appropriate compiler options to build on x86_64 as well (#136939)
  99. * Wed Sep 02 2004 Warren Togami <wtogami@redhat.com> 1.26-1
  100. - update to 1.26
  101. * Sat Aug 28 2004 Warren Togami <wtogami@redhat.com> 1.25-1
  102. - update to 1.25
  103. * Mon Jun 28 2004 Warren Togami <wtogami@redhat.com>
  104. - update to 1.20
  105. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  106. - rebuilt
  107. * Sun May 16 2004 Warren Togami <wtogami@redhat.com> 1.15-1
  108. - update to 1.15
  109. * Sun Feb 29 2004 Warren Togami <wtogami@redhat.com> 1.11-2
  110. - switch to memtest86+ 1.11
  111. - add boot loader setup script
  112. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  113. - rebuilt
  114. * Tue Oct 21 2003 Mike A. Harris <mharris@redhat.com> 3.0-3
  115. - Pedantic spec file cleanups - s/Copyright/License/ and use _libdir instead of
  116. /usr/lib everywhere (even though it's currently x86 only)
  117. * Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 3.0-2
  118. - fix perms (#107610)
  119. - doesn't really require dev86 to build
  120. * Thu Jul 21 2003 Michael Fulbright <msf@redhat.com>
  121. - initial integration into distribution. Removed the scripts to install a
  122. entry in the boot loader for memtest for the moment, and relocated to under
  123. /usr/lib.
  124. * Thu Apr 17 2003 Joe Szep <jszep@bu.edu>
  125. - rebuilt for Doolittle final
  126. * Mon Feb 3 2003 Matthew Miller <mattdm@bu.edu>
  127. - rebuild for doolittle
  128. - patches to make build -- new gcc growing pains, I guess
  129. * Tue Jul 30 2002 Matthew Miller <mattdm@bu.edu>
  130. - added grubby stuff
  131. * Tue Jul 30 2002 Dave Heistand <davidbh@bu.edu>
  132. - updated source to v 3
  133. * Thu Mar 7 2002 Dave Heistand <davidbh@bu.edu>
  134. - updated source to 2.9, also changed setup -n
  135. - to use %{version}.
  136. * Thu Nov 1 2001 Matthew Miller <mattdm@bu.edu>
  137. - v 2.8a
  138. - removed lilo-configuring scripts. need to figure out the best way to
  139. work with grub and RH 7.2 / BU Linux 2.5
  140. - group -> System Environment/Base
  141. * Mon Aug 20 2001 Matthew Miller <mattdm@bu.edu>
  142. - v 2.7
  143. * Wed Feb 14 2001 Matthew Miller <mattdm@bu.edu>
  144. - v 2.5
  145. * Fri Oct 06 2000 Matthew Miller <mattdm@bu.edu>
  146. - v 2.4
  147. * Thu Mar 23 2000 Matthew Miller <mattdm@bu.edu>
  148. - changed so that lilo.conf isn't written if it already exists. This is
  149. important if you're including memtest86 in a distribution
  150. - GPG key available from http://www.bu.edu/dsgsupport/linux/BULinux-GPG-KEY
  151. - changed name of lilo.conf backup file to something less likely to conflict
  152. with other backups
  153. * Wed Mar 01 2000 Matthew Miller <mattdm@bu.edu>
  154. - Updated to version 2.2
  155. - Cosmetic changes to spec file
  156. - updated Source: to reflect actual author's url
  157. * Fri Dec 25 1998 Peter Soos <sp@osb.hu>
  158. - Corrected the file attributes
  159. * Mon Aug 17 1998 Peter Soos <sp@osb.hu>
  160. - Moved to 1.4a
  161. * Mon Jun 22 1998 Peter Soos <sp@osb.hu>
  162. - Moved to 1.4
  163. * Wed Dec 31 1997 Peter Soos <sp@osb.hu>
  164. - Initial version