wine-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751
  1. %define pkg_major_version 1.2.3
  2. %define pkg_name wine
  3. %define pkg_release 1%{?_dist_release}
  4. # NEW Release: numbering rule. -- Release: 1%{?_dist_release}
  5. # spec file for package wine.. # base (SUSE10 and fedora core 9)
  6. Summary: Allows running Windows 16/32/64 bit programs on Unix.
  7. Summary(ja): Unix で 16/32/64ビットWindoowsプログラムを実行させます
  8. Name: %{pkg_name}
  9. Version: %{pkg_major_version}
  10. Release: %{pkg_release}
  11. URL: http://www.winehq.org/
  12. License: LGPLv2+
  13. Group: Applications/System
  14. #--------------------------------------------------------------------
  15. Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
  16. #--------------------------------------------------------------------
  17. Source1: wine.init
  18. Source3: wine-README-Fedora
  19. Source4: wine-32.conf
  20. # desktop stuff
  21. Source100: wine-notepad.desktop
  22. Source101: wine-regedit.desktop
  23. Source102: wine-uninstaller.desktop
  24. Source103: wine-winecfg.desktop
  25. Source104: wine-winefile.desktop
  26. Source105: wine-winemine.desktop
  27. Source106: wine-winhelp.desktop
  28. Source107: wine-wineboot.desktop
  29. # desktop dir
  30. Source200: wine.menu
  31. Source201: wine.directory
  32. # mime types
  33. Source300: wine-mime-msi.desktop
  34. # explain how to use wine with pulseaudio
  35. Source402: README-FEDORA-PULSEAUDIO
  36. Patch400: http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
  37. Patch401: http://art.ified.ca/downloads/winepulse-0.30.patch
  38. Patch402: http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
  39. Patch0: wine-prefixfonts.patch
  40. Patch1: wine-1.1.28-rpath.patch
  41. # fix #448338
  42. ## Patch2: wine-desktop-mime.patch
  43. # enable FontSmoothing by deafult
  44. Patch1000: wine-1.1.23-vine.patch
  45. # ADD ja
  46. Source801: wine_README.ja
  47. Source802: README-FEDORA-PULSEAUDIO.ja
  48. Source803: wine-README-Fedora.ja
  49. Source804: wine_README_add.ja
  50. Source805: fonts-replace-list.txt
  51. Source806: ja_fonts_replace-js2ipa.reg
  52. Source807: ja_fonts_replace-js2vl.reg
  53. Source808: ja_fonts_replace-ms2ipa.reg
  54. Source809: ja_fonts_replace-ms2vl.reg
  55. Vendor: Project Vine
  56. Distribution: Vine Linux
  57. Packager: daisuke, Takemikaduchi
  58. ExclusiveArch: %{ix86} x86_64
  59. #--------------------------------------------------------------------
  60. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  61. #--------------------------------------------------------------------
  62. ## FedoraCore ##
  63. BuildRequires: bison, flex
  64. BuildRequires: audiofile, audiofile-devel
  65. BuildRequires: alsa-lib-devel
  66. BuildRequires: freeglut-devel, lcms-devel
  67. ## BuildRequires: libieee1284-devel
  68. BuildRequires: libjpeg-devel, libpng-devel
  69. BuildRequires: libstdc++3-devel, libstdc++34-devel
  70. BuildRequires: libusb-devel
  71. BuildRequires: libxml2-devel, libxslt-devel
  72. BuildRequires: openldap-devel, ncurses-devel
  73. BuildRequires: unixODBC-devel, openssl-devel
  74. BuildRequires: sane-devel
  75. BuildRequires: zlib-devel
  76. BuildRequires: desktop-file-utils
  77. BuildRequires: fontforge
  78. ## BuildRequires: gphoto2, gphoto2-devel
  79. ## BuildRequires: jack-audio-connection-kit-devel
  80. ## BuildRequires: isdn4k-utils-devel
  81. BuildRequires: cups-devel
  82. BuildRequires: dbus-devel, hal-devel
  83. ## Requires: %{_bindir}/xmessage
  84. ## X modular(fc) > X 7.2
  85. BuildRequires: libX11-devel
  86. BuildRequires: mesa-libGL-devel, mesa-libGLU-devel
  87. BuildRequires: libXxf86dga-devel, libXxf86vm-devel
  88. BuildRequires: libXrandr-devel
  89. BuildRequires: libXrender-devel
  90. BuildRequires: libXext-devel
  91. BuildRequires: libXinerama-devel
  92. BuildRequires: libXcomposite-devel
  93. BuildRequires: libXmu-devel
  94. BuildRequires: libXi-devel
  95. BuildRequires: libXcursor-devel
  96. BuildRequires: fontconfig-devel
  97. BuildRequires: giflib-devel
  98. BuildRequires: libtiff-devel
  99. BuildRequires: pkgconfig
  100. BuildRequires: libicu-devel
  101. BuildRequires: freetype2-devel
  102. %ifarch x86_64
  103. BuildRequires: compat32-glibc-devel
  104. BuildRequires: compat32-glibc-devel
  105. BuildRequires: compat32-libX11-devel
  106. BuildRequires: compat32-libxcb-devel
  107. BuildRequires: compat32-freetype2-devel
  108. BuildRequires: compat32-libSM-devel
  109. BuildRequires: compat32-libXext-devel
  110. BuildRequires: compat32-libXrender-devel
  111. BuildRequires: compat32-mesa-libGL-devel
  112. BuildRequires: compat32-mesa-libGLU-devel
  113. BuildRequires: compat32-libxml2-devel
  114. BuildRequires: compat32-libxslt-devel
  115. BuildRequires: compat32-openssl-devel
  116. BuildRequires: compat32-libjpeg-devel
  117. BuildRequires: compat32-libpng-devel
  118. BuildRequires: compat32-zlib-devel
  119. BuildRequires: compat32-alsa-lib-devel
  120. ## extension
  121. BuildRequires: compat32-libXcursor-devel
  122. BuildRequires: compat32-libXi-devel
  123. BuildRequires: compat32-libXxf86vm-devel
  124. BuildRequires: compat32-libXrandr-devel
  125. BuildRequires: compat32-libXinerama-devel
  126. BuildRequires: compat32-libXcomposite-devel
  127. BuildRequires: compat32-ncurses-devel
  128. BuildRequires: compat32-fontconfig-devel
  129. BuildRequires: compat32-libtiff-devel
  130. BuildRequires: compat32-openldap-devel
  131. Requires: compat32-freetype2
  132. %endif
  133. Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
  134. Requires(post): desktop-file-utils >= 0.8
  135. Requires(preun): /sbin/chkconfig, /sbin/service
  136. Requires(postun): /sbin/ldconfig
  137. Requires(postun): desktop-file-utils >= 0.8
  138. #--------------------------------------------------------------------
  139. %description
  140. (WINE Is Not an Emulator)
  141. While Wine is usually thought of as a Windows(TM) emulator,
  142. the Wine developers would prefer that users thought of
  143. Wine as a Windows compatibility layer for UNIX.
  144. This package includes a program loader, which allows
  145. unmodified Windows 3.x/9x/NT binaries to run on x86 and
  146. x86_64 Unixes.
  147. Wine does not require MS Windows, but it can use native
  148. system .dll files if they are available.
  149. %description -l ja
  150. (WINE Is Not an Emulator)
  151. WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
  152. 開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
  153. 互換レイヤー」と考えてくれる事を好むでしょう。
  154. このパッケージはプログラムローダーを含み、これは未修正の
  155. Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
  156. させます。
  157. WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
  158. Windows システムの .dll ファイルが存在するのならば、それを使用する
  159. 事もできます
  160. #--------------------------------------------------------------------
  161. %package devel
  162. Summary: Wine development environment
  163. Summary(ja): WINE の開発ファイルです
  164. Group: System Environment/Libraries
  165. Requires: wine = %{version}-%{release}
  166. %description devel
  167. This RPM contains the header files and development tools
  168. for the WINE libraries.
  169. %description devel -l ja
  170. WINEの開発用ライブラリやヘッダーファイル、そして開発用の
  171. アプリケーション(例:winebuild)のパッケージです
  172. (development packages)
  173. #--------------------------------------------------------------------
  174. %package init
  175. Summary: WINE binfmt_misc kernel function used for init file.
  176. Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
  177. Group: System Environment/Libraries
  178. Requires: wine = %{version}-%{release}
  179. %description init
  180. WINE binfmt_misc kernel function used for init file.
  181. WIN32-binary attribute run with a Linux-binary run the same way as possible.
  182. (init.d packages)
  183. ** example **
  184. Until now, "$ wine /file/to/path/arege.exe" and then you were running
  185. from the usual binary Linux as "$ /file/to/path/arege.exe"
  186. and just be able to run.
  187. Of course, please be mindful of security.
  188. %description init -l ja
  189. カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
  190. 実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
  191. ようにします。
  192. (init.d packages)
  193. ※ 例 ※
  194. これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
  195. が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
  196. だけで実行できるようになります。
  197. 無論、セキュリティに留意して下さい。
  198. #--------------------------------------------------------------------
  199. %prep
  200. %setup -q -n %{name}-%{version}
  201. ## %patch0
  202. ## %patch1 -p1
  203. ## %patch400 -p1
  204. %patch401 -p1
  205. ## %patch402 -p1 -b .add-pa-to-winecfg
  206. %patch1000 -p1
  207. %build
  208. %ifarch x86_64
  209. export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
  210. ./configure \
  211. --prefix=%{_prefix} \
  212. --libdir=%{_libdir} \
  213. --with-x \
  214. --without-jack \
  215. --without-capi
  216. %else
  217. export CFLAGS="$RPM_OPT_FLAGS"
  218. %{configure} \
  219. --prefix=%{_prefix} \
  220. --with-x \
  221. --without-jack \
  222. --without-capi
  223. %endif
  224. grep "have_x=yes" config.log || exit 1
  225. %{__make} depend
  226. %{__make} %{?_smp_mflags}
  227. %install
  228. rm -rf ${RPM_BUILD_ROOT}
  229. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  230. #-----------------------------------------------------------FC9
  231. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
  232. # Allow users to launch Windows programs by just clicking on the .exe file...
  233. mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
  234. install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
  235. # add wine dir to desktop
  236. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
  237. install -p -m 644 %{SOURCE200} \
  238. ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  239. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
  240. install -p -m 644 %{SOURCE201} \
  241. ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
  242. ## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
  243. ## %%{_datadir}/applications
  244. # install desktop files
  245. desktop-file-install \
  246. --vendor=vine \
  247. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  248. %{SOURCE100}
  249. desktop-file-install \
  250. --vendor=vine \
  251. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  252. %{SOURCE101}
  253. desktop-file-install \
  254. --vendor=vine \
  255. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  256. %{SOURCE102}
  257. desktop-file-install \
  258. --vendor=vine \
  259. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  260. %{SOURCE103}
  261. desktop-file-install \
  262. --vendor=vine \
  263. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  264. %{SOURCE104}
  265. desktop-file-install \
  266. --vendor=vine \
  267. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  268. %{SOURCE105}
  269. desktop-file-install \
  270. --vendor=vine \
  271. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  272. %{SOURCE106}
  273. desktop-file-install \
  274. --vendor=vine \
  275. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  276. %{SOURCE107}
  277. desktop-file-install \
  278. --vendor=vine \
  279. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  280. --delete-original \
  281. ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
  282. #mime-types
  283. desktop-file-install \
  284. --vendor=vine \
  285. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  286. %{SOURCE300}
  287. ## other files
  288. cp %{SOURCE3} README-Fedora
  289. cp %{SOURCE803} README-Fedora.ja
  290. cp %{SOURCE801} documentation/README.ja
  291. cp %{SOURCE804} documentation/README_add.ja
  292. cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
  293. mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
  294. install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
  295. # deploy pulseaudio readme (802jp)
  296. cp %{SOURCE402} .
  297. cp %{SOURCE802} .
  298. # check desktop files
  299. %check
  300. desktop-file-validate \
  301. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
  302. desktop-file-validate \
  303. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
  304. desktop-file-validate \
  305. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
  306. desktop-file-validate \
  307. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
  308. desktop-file-validate \
  309. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
  310. desktop-file-validate \
  311. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
  312. desktop-file-validate \
  313. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
  314. desktop-file-validate \
  315. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
  316. desktop-file-validate \
  317. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
  318. #--------------------------------------------------------------------
  319. %clean
  320. rm -rf ${RPM_BUILD_ROOT}
  321. %post
  322. /sbin/ldconfig
  323. update-desktop-database &>/dev/null || :
  324. ### add vinelinux
  325. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  326. echo "WINEのシステムフォントをリプレースするには"
  327. echo " fonts-replace-list.txt をお読み下さい。"
  328. else
  329. echo "You need to Japanese fonts name replace, "
  330. echo "See fonts-replace-list.txt ."
  331. fi
  332. %postun
  333. /sbin/ldconfig
  334. update-desktop-database &>/dev/null || :
  335. %post init
  336. if [ $1 = 1 ]; then
  337. /sbin/chkconfig --add wine
  338. /sbin/chkconfig --level 2345 wine on
  339. /sbin/service wine start &>/dev/null || :
  340. fi
  341. ### add vinelinux
  342. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  343. echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
  344. echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
  345. echo "(ファイル名は /etc/init.d/wine です)"
  346. echo "起動時にファイルシステムのマウントが必要です。"
  347. echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
  348. echo "(削除も手動でお願いします)"
  349. echo ""
  350. echo "# cp /etc/fstab /etc/fstab.before ##バックアップの作成"
  351. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  352. echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
  353. else
  354. echo "WINE binfmt_misc feature from the boot files "
  355. echo "to be installed and enabled 2,3,4,5 runlevel."
  356. echo "(File name in the /etc/init.d/wine )"
  357. echo "Filesystem mounted at boot time is required."
  358. echo "Root privileges using the following command in the /etc/fstab"
  359. echo "please Addenda.(Please delete manually.)"
  360. echo ""
  361. echo "# cp /etc/fstab /etc/fstab.before ##(Create backup)"
  362. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  363. echo "See also(en)http://www.linux.com/articles/56032 "
  364. fi
  365. %preun init
  366. if [ $1 = 0 ]; then
  367. /sbin/service wine stop >/dev/null 2>&1
  368. /sbin/chkconfig --del wine
  369. fi
  370. #--------------------------------------------------------------------
  371. ## deleted /usr/share/applications/wine.desktop
  372. %files
  373. %defattr(-,root,root,-)
  374. %doc ANNOUNCE AUTHORS COPYING.LIB LICENSE LICENSE.OLD
  375. %doc README VERSION
  376. %doc README-FEDORA-PULSEAUDIO
  377. %doc README-FEDORA-PULSEAUDIO.ja
  378. %doc README-Fedora
  379. %doc README-Fedora.ja
  380. %doc documentation/README* documentation/ChangeLog*
  381. %doc documentation/ja_fonts_replace*
  382. %doc documentation/fonts-replace-list.txt
  383. ### %{_bindir}/*
  384. %{_bindir}/msiexec
  385. %{_bindir}/regedit
  386. %{_bindir}/regsvr32
  387. %{_bindir}/wine
  388. %{_bindir}/wineboot
  389. %{_bindir}/wineconsole
  390. ## %{_bindir}/wineprefixcreate
  391. %{_bindir}/winecfg
  392. %{_bindir}/wine-preloader
  393. # winelauncher --> Remove
  394. %{_bindir}/wineserver
  395. %{_bindir}/notepad
  396. %{_bindir}/winedbg
  397. %{_bindir}/winedump
  398. %{_bindir}/winefile
  399. %{_bindir}/winemaker
  400. %{_bindir}/winemine
  401. %{_bindir}/winepath
  402. ## winhelp -> renamed winhlp32.exe
  403. %{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  404. %{_sysconfdir}/ld.so.conf.d/wine-32.conf
  405. %{_libdir}/libwine.so.1*
  406. %dir %{_libdir}/wine
  407. %{_libdir}/wine/*.cpl.so
  408. %{_libdir}/wine/*.exe.so
  409. %{_libdir}/wine/*.exe16.so
  410. %{_libdir}/wine/*.dll.so
  411. %{_libdir}/wine/*.dll16.so
  412. %{_libdir}/wine/*.drv.so
  413. %{_libdir}/wine/*.drv16.so
  414. %{_libdir}/wine/*.mod16.so
  415. ## %{_libdir}/wine/*.*16
  416. %{_libdir}/wine/*.ds.so
  417. %{_libdir}/wine/*.ocx.so
  418. %{_libdir}/wine/*.vxd.so
  419. %{_libdir}/wine/*.acm.so
  420. %{_libdir}/wine/*.sys.so
  421. %{_libdir}/wine/*.tlb.so
  422. %dir %{_libdir}/wine/fakedlls
  423. %{_libdir}/wine/fakedlls/*
  424. %dir %{_datadir}/wine
  425. %{_datadir}/wine/*
  426. %{_datadir}/applications/vine-wine-mime-msi.desktop
  427. %{_datadir}/applications/vine-wine.desktop
  428. %{_datadir}/applications/vine-wine-regedit.desktop
  429. %{_datadir}/applications/vine-wine-uninstaller.desktop
  430. %{_datadir}/applications/vine-wine-winecfg.desktop
  431. %{_datadir}/applications/vine-wine-wineboot.desktop
  432. %{_datadir}/applications/vine-wine-notepad.desktop
  433. %{_datadir}/applications/vine-wine-winefile.desktop
  434. %{_datadir}/applications/vine-wine-winemine.desktop
  435. %{_datadir}/applications/vine-wine-winhelp.desktop
  436. %{_datadir}/desktop-directories/Wine.directory
  437. %{_mandir}/man1/wine.1.*
  438. %{_mandir}/man1/wineserver.1*
  439. ## %{_mandir}/man1/wineprefixcreate.1*
  440. %lang(de) %{_mandir}/de.UTF-8/man1/*.1*
  441. %lang(fr) %{_mandir}/fr.UTF-8/man1/*
  442. #--------------------------------------------------------------------
  443. %files devel
  444. %defattr(-,root,root,-)
  445. %{_bindir}/function_grep.pl
  446. %{_bindir}/widl
  447. %{_bindir}/winebuild
  448. %{_bindir}/winecpp
  449. %{_bindir}/winedump
  450. %{_bindir}/wineg++
  451. %{_bindir}/winegcc
  452. %{_bindir}/winemaker
  453. %{_bindir}/wmc
  454. %{_bindir}/wrc
  455. %{_includedir}/wine
  456. %{_libdir}/*.so
  457. %{_libdir}/wine/*.a
  458. %{_libdir}/wine/*.def
  459. %{_mandir}/man1/widl.1*
  460. %{_mandir}/man1/winebuild.1*
  461. %{_mandir}/man1/winedump.1*
  462. %{_mandir}/man1/winegcc.1*
  463. %{_mandir}/man1/winemaker.1*
  464. %{_mandir}/man1/winedbg.1*
  465. %{_mandir}/man1/wineg++.1*
  466. %{_mandir}/man1/wmc.1*
  467. %{_mandir}/man1/wrc.1*
  468. #--------------------------------------------------------------------
  469. %files init
  470. %defattr(-,root,root,-)
  471. %{_initrddir}/wine
  472. %doc documentation/README_add.ja
  473. #--------------------------------------------------------------------
  474. %changelog
  475. * Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
  476. - update to 1.2.3
  477. - add Requires: compat32-freetype2 (x86_64 only)
  478. * Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
  479. - new upstream release
  480. * Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  481. - new upstream release
  482. - drop Patch1
  483. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
  484. - new upstream release
  485. - fix %configure (add configu:e and gcc option of x86_64)
  486. - fix %install (remove wine.desktop and change make install option)
  487. - add ExclusiveArch: %{ix86} x86_64
  488. - add BuildRequires for x86_64 (compat32 packages)
  489. * Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
  490. - update to 1.2-rc2
  491. - fix spec file
  492. - if [ "$LANG" = "ja_JP.eucJP" ];
  493. + if [ "$LANG" = "ja_JP.UTF-8" ];
  494. - convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
  495. - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
  496. - fix %files
  497. - drop patches (Patch0, Patch400, Patch402)
  498. * Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
  499. - update BRs
  500. - remove freetype-devel
  501. - remove libungif-devel, add giflib-devel
  502. - remove gphoto2-devel, add libgphoto2-devel
  503. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
  504. - update to 1.1.29
  505. * Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
  506. - update to 1.1.28
  507. - update winepulse patches
  508. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
  509. - update to 1.1.23
  510. - spec in utf-8
  511. - add patch1000 to enable FontSmoothing by deafult.
  512. - update pulseaudio patches
  513. - remove invalid Provides: Wine HQ
  514. - remove unneeded patches
  515. * Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
  516. - Wine development release 1.1.0.
  517. - Updated specfile (for VineSeed)
  518. #--------------------------------------------------------------------
  519. * Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
  520. - added "ja_fonts_replace-*.reg" files.
  521. - Updated specfile
  522. * Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
  523. - version upgrade
  524. - Updated specfile
  525. - Update to 1.0
  526. - fix wine.desktop mime types (fc)
  527. - add desktop package including desktop files and binary handler (fc)
  528. - pull in some wine alsa/pulseaudio patches (fc)
  529. -- NEWS "June 17, 2008: Wine 1.0 Released"
  530. -- read http://www.winehq.org/?issue=348
  531. * Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
  532. - Updated specfile
  533. - Update to 1.0-rc4
  534. - NEWS "June 6, 2008: Wine 1.0-rc4 Released"
  535. -- ntdll: Add local defines for VIF and VIP flags.
  536. -- wininet: Include openssl/ssl.h before Windows headers.
  537. -- shell32: Fixed the French about box.
  538. -- ChangeLog: Moved to documentation/ChangeLog.BETA.
  539. -- fonts: Add a non-breaking space glyph to the Tahoma fonts.
  540. -- ....others , read ChangeLog
  541. --- Bug fixes only, we are in code freeze.
  542. * Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
  543. - Updated specfile
  544. - Update to 1.0-rc3
  545. - NEWS "May 30, 2008: Wine 1.0-rc3 Released"
  546. -- The default version is now Windows XP.
  547. -- Many Richedit improvements.
  548. -- Beginning of jscript dll support.
  549. -- Shell folders now respect XDG directory configuration.
  550. -- Many translation updates.
  551. -- Lots of bug fixes.
  552. -- * Bug fixes only, we are in code freeze.
  553. --- kernel32: Add a builtin 16-bit winhelp.exe.
  554. --- This should be moved to winhlp32.exe once we support 16-bit modules in
  555. --- executables.
  556. ---- winhelp -> renamed winhlp32.exe
  557. ---- programs: Remove winelauncher from install rules.
  558. * Mon Apr 04 2008 Seiichirou Babasaki 0.9.59
  559. - Updated specfile
  560. - Update to 0.9.59
  561. - NEWS.. "April 4, 2008: Wine 0.9.59 Released"
  562. -- * Improved support for the .NET framework.
  563. -- * Better services handling through a separate services.exe process.
  564. -- * Support for ATI fragment shader.
  565. -- * Better support for http proxies.
  566. -- * Window management fixes.
  567. -- * Pre-compiled fonts are now available in the source tree.
  568. -- * Lots of bug fixes.
  569. * Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
  570. - Updated specfile (split wine-init package)
  571. - Update to 0.9.58
  572. - NEWS.. "March 21, 2008: Wine 0.9.58 Released"
  573. -- * The default version is now Windows XP.
  574. -- * Many Richedit improvements.
  575. -- * Beginning of jscript dll support.
  576. -- * Shell folders now respect XDG directory configuration.
  577. -- * Many translation updates.
  578. -- * Lots of bug fixes.
  579. * Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
  580. - Updated specfile (*.desktop file %check .)
  581. - Update to 0.9.57
  582. - NEWS.. "March 7, 2008: Wine 0.9.57 Released"
  583. -- * Support for multiple OpenGL pixel formats.
  584. -- * Improved support for color profiles.
  585. -- * Many window management fixes.
  586. -- * Better fullscreen support.
  587. -- * Lots of bug fixes.
  588. * Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
  589. - Updated specfile
  590. - ("Build Tool" from the wine-package to move to devel-packages)
  591. - Update to 0.9.56
  592. - NEWS.. "February 22, 2008: Wine 0.9.56 Released"
  593. -- * Proper handling of OpenGL/Direct3D windows with menu bars.
  594. -- * Stubs for all the d3dx9_xx dlls.
  595. -- * Several graphics optimizations.
  596. -- * Many installer fixes.
  597. -- * Improved MIME message support.
  598. -- * Lots of bug fixes.
  599. * Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
  600. - Updated specfile (cf. VineLinux .spec file format)
  601. - Add Installed messages for "binfmt_misc" .
  602. - *.desktop file "Name" change to japanese. (UTF8)
  603. * Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
  604. - Import WINE - Packager: Babasaki
  605. - Updated specfile (SUSE base + FC9 cfg)
  606. - Update to 0.9.55
  607. - Update to 0.9.54 from FC9
  608. - Update to 0.9.53 from Private package
  609. # FC9 ------------------------------------------------------------- FC9
  610. * Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  611. - 0.9.55-1
  612. - version upgrade
  613. * Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  614. - 0.9.54-1
  615. - version upgrade
  616. - remove default pulseaudio workaround (#429420,#428745)
  617. - improve pulseaudio readme
  618. * Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  619. - 0.9.53-2
  620. - add some missing BR
  621. * Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  622. - 0.9.53-1
  623. - version upgrade
  624. * Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  625. - 0.9.52-2
  626. - fix menu bug (#393641)
  627. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  628. - 0.9.52-1
  629. - version upgrade
  630. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  631. - 0.9.51-3
  632. - add -n Wine to pulseaudio workaround
  633. - try to fix menu bug #393641
  634. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  635. - 0.9.51-2
  636. - add fix for #344281 pulseaudio workaround
  637. - fix #253474: wine-jack should require jack-audio-connection-kit
  638. * Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  639. - 0.9.51-1
  640. - version upgrade
  641. # ---- abbreviatio ----------------------------------------------------#
  642. # ----------and suse.
  643. # * Fri Mar 17 2006 - meissner@suse.de
  644. # - Avoid ulimit leading to out of memory situations by using
  645. # the compat address space layout personality. #152115