ModemManager-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432
  1. %bcond_with systemd
  2. #%define git_snapshot .git20130607
  3. %define git_snapshot %{nil}
  4. #define ppp_version 2.4.7
  5. %define glib2_version 2.40
  6. Name: ModemManager
  7. Summary: Mobile broadband modem management service
  8. Summary(ja): モバイルブロードバンドモデム運用サービス
  9. Version: 1.14.10
  10. Release: 1%{git_snapshot}%{?_dist_release}%{?with_systemd:.systemd}
  11. Group: network,system
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: GPLv2+
  15. URL: https://www.freedesktop.org/wiki/Software/ModemManager/
  16. Source: https://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
  17. Patch0: buildsys-hates-openpty.patch
  18. Patch1: ModemManager-1.8.2-elogind-1.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: glib2-devel >= %{glib2_version}
  21. BuildRequires: automake autoconf intltool libtool
  22. BuildRequires: gobject-introspection-devel
  23. BuildRequires: vala-devel
  24. BuildRequires: vala-tools
  25. BuildRequires: polkit-devel
  26. BuildRequires: gtk-doc
  27. # for xsltproc
  28. BuildRequires: libxslt
  29. %if %{with systemd}
  30. BuildRequires: systemd-devel
  31. %{?systemd_requires}
  32. %else
  33. BuildRequires: libgudev-devel
  34. BuildRequires: elogind-devel
  35. %endif
  36. Requires: dbus-glib
  37. %description
  38. The ModemManager service manages WWAN modems and provides a consistent API for
  39. interacting with these devices to client applications.
  40. %package devel
  41. Summary: Development tools for %{name}
  42. Summary(ja): %{name} の開発環境
  43. Group: programming
  44. Requires: %{name} = %{version}-%{release}
  45. Requires: pkgconfig
  46. %description devel
  47. Header files and libraries for building a extension library for the %{name}.
  48. %package glib
  49. Summary: Libraries for adding ModemManager support to applications that use glib.
  50. Summary(ja): Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
  51. Group: system
  52. Requires: glib2 >= %{glib2_version}
  53. %description glib
  54. This package contains the libraries that make it easier to use some ModemManager
  55. functionality from applications that use glib.
  56. %package glib-devel
  57. Summary: Development tools for %{name}-glib
  58. Summary(ja): %{name}-glib の開発環境
  59. Group: programming
  60. Requires: %{name}-glib = %{version}-%{release}
  61. Requires: %{name}-devel = %{version}-%{release}
  62. Requires: glib2-devel
  63. Requires: pkgconfig
  64. %description glib-devel
  65. Header files and libraries for building a extension library for the %{name}-glib.
  66. %debug_package
  67. %prep
  68. %setup -q
  69. %patch0 -p1 -b .pty
  70. %if !%{with systemd}
  71. %patch1 -p1 -b .elogind
  72. %endif
  73. %build
  74. autoreconf -vif
  75. #pppddir=`ls -1d %{_libdir}/pppd/2*`
  76. %configure \
  77. --disable-static \
  78. --enable-gtk-doc=yes \
  79. --enable-vala=yes \
  80. --enable-more-warnings=yes \
  81. --with-udev-base-dir=/lib/udev \
  82. --without-mbim \
  83. --without-qmi \
  84. --with-dist-version=%{version}-%{release} \
  85. %if %{with systemd}
  86. --with-systemdsystemunitdir=%{_unitdir}
  87. %else
  88. --with-elogind-suspend-resume=yes
  89. %endif
  90. make %{?_smp_mflags}
  91. %check
  92. make check
  93. %install
  94. make install DESTDIR=$RPM_BUILD_ROOT
  95. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  96. #rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  97. %find_lang %{name}
  98. %post
  99. /sbin/ldconfig
  100. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  101. %if %{with systemd}
  102. %systemd_post ModemManager.service
  103. %endif
  104. %if %{with systemd}
  105. %preun
  106. %systemd_preun ModemManager.service
  107. %endif
  108. %postun
  109. /sbin/ldconfig
  110. if [ $1 -eq 0 ]; then
  111. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  112. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  113. fi
  114. %if %{with systemd}
  115. %systemd_postun ModemManager.service
  116. %endif
  117. %posttrans
  118. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  119. %post glib -p /sbin/ldconfig
  120. %postun glib -p /sbin/ldconfig
  121. %files -f %{name}.lang
  122. %defattr(-,root, root,-)
  123. %license COPYING
  124. %doc README
  125. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
  126. %{_libdir}/girepository-1.0/ModemManager-1.0.typelib
  127. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
  128. %attr(0755,root,root) %{_sbindir}/ModemManager
  129. %attr(0755,root,root) %{_bindir}/mmcli
  130. %dir %{_libdir}/%{name}
  131. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  132. %dir %{_datadir}/%{name}
  133. %{_datadir}/%{name}/*
  134. /lib/udev/rules.d/*
  135. %{_datadir}/dbus-1/interfaces/*.xml
  136. %{_datadir}/icons/hicolor/22x22/apps/*.png
  137. %{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
  138. %{_mandir}/man1/*
  139. %{_mandir}/man8/*
  140. %dir %{_datadir}/bash-completion
  141. %dir %{_datadir}/bash-completion/completions
  142. %{_datadir}/bash-completion/completions/*
  143. %if %{with systemd}
  144. %{_unitdir}/*.service
  145. %endif
  146. %files devel
  147. %defattr(-,root,root,-)
  148. %{_includedir}/ModemManager/*.h
  149. %dir %{_datadir}/gtk-doc/html/%{name}
  150. %{_datadir}/gir-1.0/ModemManager-1.0.gir
  151. %{_datadir}/gtk-doc/html/%{name}/*
  152. %{_libdir}/pkgconfig/%{name}.pc
  153. %files glib
  154. %defattr(-,root,root,-)
  155. %{_libdir}/libmm-glib.so.*
  156. %files glib-devel
  157. %defattr(-,root,root,-)
  158. %{_libdir}/libmm-glib.so
  159. %dir %{_includedir}/libmm-glib
  160. %{_includedir}/libmm-glib/*.h
  161. %{_libdir}/pkgconfig/mm-glib.pc
  162. %dir %{_datadir}/vala
  163. %dir %{_datadir}/vala/vapi
  164. %{_datadir}/vala/vapi/libmm-glib.*
  165. %dir %{_datadir}/gtk-doc/html/libmm-glib
  166. %{_datadir}/gtk-doc/html/libmm-glib/*
  167. %changelog
  168. * Mon Feb 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.10-1
  169. - new upstream release.
  170. * Mon Aug 3 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.0-1
  171. - new upstream release.
  172. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
  173. - new upstream release.
  174. * Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
  175. - new upstream release.
  176. - added elogind support.
  177. * Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.12-1
  178. - new upstream release.
  179. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
  180. - new upstream release
  181. - change BuildRequires: libgudev-devel instead of eudev-libgudev1-devel
  182. * Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-3
  183. - fix spec file
  184. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
  185. - fix spec file
  186. * Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
  187. - new upstream release
  188. - add BuildRequires: gobject-introspection-devel, polkit-devel
  189. * Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
  190. - new upstream release
  191. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
  192. - new upstream release
  193. * Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
  194. - new upstream release
  195. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  196. - new upstream release
  197. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  198. - new upstream release
  199. * Tue Oct 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
  200. - moved ModemManager-glib to System Environment/Libraries Group
  201. - removed BR: ppp, ppp-devel and dbus-glib-devel
  202. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  203. - new upstream release
  204. - remove Patch1 (ModemManager-1.0.0-git20130911.patch)
  205. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  206. - add Patch1 (ModemManager-1.0.0-git20130911.patch)
  207. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  208. - new upstream release
  209. - update Patch0
  210. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
  211. - update to 0.7.991 snapshot
  212. - fix spec file based on FC package
  213. * Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
  214. - Update to 0.7.991 snapshot
  215. - Fix SMS validity parsing
  216. - Allow registration changes to 'searching' without disconnecting
  217. - Fix reading SMS messages from some QMI-based devices
  218. - Increase connection timeout for Novatel E362
  219. - Fix PIN retries checking when unlocking Ericsson devices
  220. - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
  221. - add configure option (--enable-gtk-doc=yes, --without-qmi)
  222. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  223. - new upstream release
  224. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  225. - new upstream release
  226. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  227. - delete Patch20
  228. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  229. - update Patch20 (ModemManager-0.4-git20110428.patch)
  230. - delete Patch21,22
  231. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  232. - update to 0.4
  233. - add Patch20 (ModemManager-0.4-git20100720.patch)
  234. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  235. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  236. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  237. - initial build for Vine Linux
  238. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  239. - core: ignore some failures on disconnect (rh #578280)
  240. - core: add support for platform serial devices
  241. - gsm: better Blackberry DUN support
  242. - gsm: periodically poll access technology
  243. - cdma: prevent crash on modem removal (rh #571921)
  244. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  245. - novatel: better signal strength reporting on CDMA cards
  246. - novatel: add access technology and mode preference support on GSM cards
  247. - zte: fix mode preference retrieval
  248. - longcheer: add support for Zoom modems (4595, 4596, etc)
  249. - longcheer: add access technology and mode preference support
  250. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  251. - Silence %%post
  252. - Update scripts
  253. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  254. - gsm: fix parsing Blackberry supported character sets response
  255. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  256. - mbm: fix retrieval of current allowed mode
  257. - gsm: fix initialization issues with some devices (like Blackberries)
  258. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  259. - core: fix detection of some generic devices (rh #579247)
  260. - core: fix detection regression of some Huawei devices in 0.3-5
  261. - cdma: periodically poll registration state and signal quality
  262. - cdma: really fix registration detection on various devices (rh #569067)
  263. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  264. - core: fix PPC/SPARC/etc builds
  265. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  266. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  267. - cdma: handle signal quality requests while connected for more devices
  268. - cdma: handle serving system requests while connected for more devices
  269. - gsm: determine current access technology earlier
  270. - huawei: work around automatic registration issues on some devices
  271. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  272. - core: ensure enabled modems are disabled when MM stops
  273. - core: better capability detection for Blackberry devices (rh #573510)
  274. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  275. - gsm: don't block modem when it requires PIN2
  276. - option: fix access technology updates
  277. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  278. - mbm: add device IDs for C3607w
  279. - mbm: fail earlier during connection failures
  280. - mbm: fix username/password authentication when checked by the network
  281. - hso: implement asynchronous signal quality updates
  282. - option: implement asynchronous signal quality updates
  283. - novatel: correctly handle CDMA signal quality
  284. - core: basic PolicyKit support
  285. - core: fix direct GSM registration information requests
  286. - core: general GSM PIN/PUK unlock fixes
  287. - core: poll GSM registration state internally for quicker status updates
  288. - core: implement GSM 2G/3G preference
  289. - core: implement GSM roaming allowed/disallowed preference
  290. - core: emit signals on access technology changes
  291. - core: better handling of disconnections
  292. - core: fix simple CDMA status requests
  293. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  294. - core: startup speed improvements
  295. - core: GSM PIN checking improvements
  296. - huawei: fix EVDO-only connections on various devices (rh #553199)
  297. - longcheer: add support for more devices
  298. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  299. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  300. - core: fix crashes when devices are unplugged during operation (rh #553953)
  301. - cdma: prefer primary port for status/registration queries
  302. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  303. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  304. - gsm: fix Nokia N80 network scan parsing
  305. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  306. - core: fix apparent hangs by limiting retried serial writes
  307. - gsm: ensure modem state is reset when disabled
  308. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  309. - sierra: fix CDMA registration detection in some cases (rh #547513)
  310. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  311. - sierra: ensure CDMA device is powered up when trying to use it
  312. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  313. - zte: handle unsolicited messages better during probing
  314. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  315. - cdma: fix signal strength reporting on some devices
  316. - cdma: better registration state detection when dialing (ex Sierra 5275)
  317. - option: always use the correct tty for dialing commands
  318. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  319. - core: fix reconnect after manual disconnect (rh #541314)
  320. - core: fix various segfaults during registration
  321. - core: fix probing of various modems on big-endian architectures (ie PPC)
  322. - core: implement modem states to avoid duplicate operations
  323. - hso: fix authentication for Icera-based devices like iCON 505
  324. - zte: use correct port for new devices
  325. - nozomi: fix detection
  326. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  327. - Update to latest git
  328. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  329. - cdma: wait for network registration before trying to connect
  330. - gsm: add cell access technology reporting
  331. - gsm: allow longer-running network scans
  332. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  333. - nokia: don't power down phones on disconnect
  334. - hso: fix disconnection/disable
  335. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  336. - Fixes for Motorola and Ericsson devices
  337. - Fixes for CDMA "serving-system" command parsing
  338. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  339. - Fix a typo in one of the udev rules files
  340. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  341. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  342. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  343. - Fix source repo location
  344. - Fix directory ownership
  345. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  346. - Initial version