geany-plugins-vl.spec 34 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909910911912913914915916917918919920921922923924925926927928929930931932933934935936937938939940941942943944945946947948949950951952953954955956957958959960961962963964965966967968969970971972973974975976977978979980981982983984985986987988989990991992993
  1. %global geany_plug_docdir %{_defaultdocdir}/%{name}-%{version}
  2. %global req_geany_ver 0.21
  3. Name: geany-plugins
  4. Version: 1.23
  5. Release: 1%{?_dist_release}
  6. Summary: Plugins for Geany
  7. Summary(ja): Geany のプラグイン集
  8. Group: Development/Tools
  9. License: GPLv3
  10. URL: http://plugins.geany.org/
  11. Source0: http://plugins.geany.org/geany-plugins/geany-plugins-%{version}.tar.bz2
  12. #Patch0: fix_installation_path_of_geanylatex_documents.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: ctpl-devel >= 0.2
  15. #BuildRequires: devhelp-devel
  16. BuildRequires: enchant-devel
  17. BuildRequires: geany-devel >= %{req_geany_ver}
  18. BuildRequires: gettext
  19. BuildRequires: gdk-pixbuf2-devel
  20. BuildRequires: glib2-devel
  21. BuildRequires: gpgme-devel
  22. BuildRequires: gtk2-devel
  23. BuildRequires: gtkspell-devel
  24. BuildRequires: intltool
  25. BuildRequires: libtool
  26. BuildRequires: libsoup-devel >= 2.4
  27. BuildRequires: lua-devel
  28. BuildRequires: libxml2-devel >= 2.6.27
  29. BuildRequires: pango-devel
  30. BuildRequires: pkgconfig
  31. BuildRequires: python-docutils
  32. BuildRequires: vala-devel
  33. BuildRequires: vte-devel
  34. BuildRequires: WebKit-gtk-devel
  35. Requires: %{name}-addons %{name}-geanydoc %{name}-geanylatex
  36. Requires: %{name}-geanylipsum %{name}-geanylua %{name}-geanyprj %{name}-geanysendmail
  37. Requires: %{name}-geanyvc %{name}-shiftcolumn %{name}-spellcheck
  38. Requires: %{name}-codenav %{name}-treebrowser %{name}-geanyextrasel
  39. Requires: %{name}-geanyinsertnum %{name}-pretty-printer %{name}-geanygendoc
  40. Requires: %{name}-updatechecker %{name}-webhelper
  41. Requires: %{name}-debugger %{name}-xmlsnippets %{name}-geanymacro %{name}-geanynumberedbookmarks
  42. Requires: %{name}-geanypg %{name}-gproject %{name}-tableconvert
  43. Requires: %{name}-geanyminiscript %{name}-geniuspaste %{name}-multiterm
  44. %description
  45. Plugins for Geany. Plugins included are:
  46. * Addons (Various small Addons)
  47. * Code navigation (Navigate through your source code easily)
  48. * Commander (Provides a command panel for rapid access to any action)
  49. * Debugger (Enables debugging in Geany)
  50. * Geanydoc (Call specific documentation from within Geany)
  51. * Geanyextrasel (Additional features for selecting code)
  52. * GeanyGenDoc (Automatically generate documentation source code)
  53. #* GeanyGDB (Integration with GDB)
  54. * Geanyinsertnum (Insert huge number ranges with small efforts)
  55. * GeanyLaTeX (Improved Support for LaTeX documents)
  56. * GeanyLipsum (Inserting blocks of Lorem Ipsum text)
  57. * Geanylua (Support for Scripting with Lua)
  58. * GeanyMacro (User defined Macros for Geany)
  59. * GeanyMiniScript (A tool to apply a script on a text selection or current document(s))
  60. * GeanyNumberedBookmarks (Provide users with 10 numbered Bookmarks)
  61. * GeniusPaste (Paste your code on your favorite pastebin)
  62. * GeanyPG (Encrypt, decrypt and verify signatures with GnuPG)
  63. * Geanyprj (Alternate project management for Geany)
  64. * GeanySendMail (Sending of documents from within Geany)
  65. * GeanyVC (Support for various Version Control Systems)
  66. * GProject (Extension of Geany's Project Management)
  67. * Markdown (provides a real-time preview of rendered Markdown)
  68. * MultiTerm (Multi-tabbed virtual terminal emulator)
  69. * Pretty-Print (XML Pretty Printer)
  70. * Scope (graphical GDB front-end with the normal functions)
  71. * Shiftcolumn (Moving blocks of text horizontally)
  72. * Spellcheck (Spell checking of documents or marked text)
  73. * Tableconvert (Helps on converting a tabulator separated selection into a table)
  74. * Treebrowser (Alternate file browser with tree view of folders)
  75. * Updatechecker (Automatically check for Geany updates)
  76. * Webhelper (Preview and Debug Web documents from within Geany using WebKit)
  77. * XMLSnippets (Extends XML/HTML tag autocompletion provided by Geany)
  78. This package is meta package to install all geany-plugins.
  79. %description -l ja
  80. Geany のプラグインです。プラグインには以下のものが含まれています。
  81. * Addons (色々な小さなアドオン)
  82. * Code navigation (ソースコード間を簡単に移動)
  83. * Commander (任意のアクションに迅速にアクセスするためのコマンドパネルを提供)
  84. * Debugger (Geany でデバッグを有効化)
  85. * Geanydoc (geany から固有のドキュメントを呼び出す)
  86. * Geanyextrasel (コード選択のための追加機能)
  87. * GeanyGenDoc (ソースコードから自動的にドキュメントの元を生成)
  88. #* GeanyGDB (GDB 統合環境を提供)
  89. * GeanyLaTex (LaTeX ドキュメントのサポートを改善)
  90. * GeanyLipsum (Lorem Ipsum テキストのブロックを挿入)
  91. * GeanySendMail (Geany からドキュメントの送信を許可)
  92. * GeanyVC (色々なバージョン管理システムのサポート)
  93. * GProject (Geany のプロジェクト管理拡張)
  94. * Geanyinsertnum (僅かな労力で膨大な範囲の番号を挿入)
  95. * Geanylua (lua スクリプトのサポートを提供)
  96. * GeanyMacro (Geany のユーザー定義マクロ)
  97. * GeanyMiniScript (A tool to apply a script on a text selection or current document(s))
  98. * GeanyNumberedBookmarks (ユーザーに 10 個の番号付ブックマークを提供)
  99. * GeniusPaste (お気に入りの pastebin からコードを貼り付け)
  100. * GeanyPG (GnuPG で暗号化・復号化及び署名を検証する)
  101. * Geanyprj (geany の代替プロジェクト管理)
  102. * Markdown (provides a real-time preview of rendered Markdown)
  103. * MultiTerm (マルチタブの仮想端末エミュレーター)
  104. * Scope (graphical GDB front-end with the normal functions)
  105. * Shiftcolumn (テキストブロックを水平方向に移動)
  106. * Spellcheck (ドキュメントのスペルチェック)
  107. * Tableconvert (テーブルにタブで区切られた選択項目を変換する際役立つ)
  108. * Treebrowser (フォルダの内容をツリービューする代替ファイルブラウザ)
  109. * Pretty-Print (XML Pretty Printer)
  110. * Updatechecker (Geany の更新を自動的にチェック)
  111. * Webhelper (WebKit を使い Geany から Web ドキュメントのプレビューとデバッグを実行)
  112. * XMLSnippets (Geany により提供される拡張 XML/HTML タグの自動補完)
  113. このパッケージは、geany-plugins をすべてインストールするための
  114. メタパッケージです。
  115. %package common
  116. Summary: Common files used by all geany plugins
  117. Summary(ja): すべての Geany プラグインに用いられる共通ファイル
  118. Group: Development/Tools
  119. Requires: geany >= %{req_geany_ver}
  120. %description common
  121. This package contains some common files which are used by every Geany plugin,
  122. e.g. language translations.
  123. %description common -l ja
  124. このパッケージには、例えば翻訳ファイルなどの
  125. すべての Geany プラグイン で用いられる共通ファイルが含まれています。
  126. %package addons
  127. Summary: Miscellaneous Addons for Geany
  128. Summary(ja): Geany のその他のアドオン
  129. Group: Development/Tools
  130. Requires: geany >= %{req_geany_ver}
  131. Requires: geany-plugins-common = %{version}-%{release}
  132. Obsoletes: geany-plugin-addons
  133. %description addons
  134. This plugins consists of various small addons too small to justify their own
  135. plugin, but are useful to have. The following functionality is implemented:
  136. * Doclist: This addon places a new item in the toolbar and when clicked offers
  137. a menu listing all open files plus the 'Close All' and 'Close Other
  138. Documents' menu items. This can be useful to quickly access open files and
  139. switch to them.
  140. * OpenURI: Adds 'Open URI' and 'Copy URI' menu items to the editor menu when
  141. the word under the cursor looks like a URI. 'Open URI' uses the browser
  142. command configured in Geany to open it.
  143. * Tasks:The tasks plugin goes through a file being edited and picks out lines
  144. with "TODO" or "FIXME" in them. It collects the text after those words and
  145. puts them in a new "Tasks" tab in the message window. Clicking on a task in
  146. that tab takes you to the line in the file where the task was defined.
  147. * Systray: Adds a status icon to the notification area (systray) and provides
  148. a simple popup menu with some basic actions. It can also be used to quickly
  149. show and hide the Geany main window.
  150. %package codenav
  151. Summary: Navigate through your source code easily
  152. Summary(ja): ソースコード間を簡単に移動
  153. Group: Development/Tools
  154. Requires: geany >= %{req_geany_ver}
  155. Requires: geany-plugins-common = %{version}-%{release}
  156. %description codenav
  157. This plugin adds some facilities for navigating in the code.
  158. Actually, it will make it possible to:
  159. - switch between header and implementation
  160. - go to a file by typing its name
  161. %package commander
  162. Summary: provides a command panel for rapid access to any action
  163. Summary(ja): 任意のアクションに迅速にアクセスするためのコマンドパネルを提供
  164. Group: Development/Tools
  165. Requires: geany >= %{req_geany_ver}
  166. Requires: geany-plugins-common = %{version}-%{release}
  167. %description commander
  168. Commander is a plugin for Geany that provides a command panel
  169. for rapid access to any action.
  170. %package debugger
  171. Summary: enables debugging in Geany
  172. Group: Development/Tools
  173. Requires: geany-plugins-common = %{version}-%{release}
  174. Requires: vte >= 0.24
  175. Obsoletes: geany-plugin-gdb
  176. Obsoletes: geany-plugins-geanygdb < %{version}-%{release}
  177. %description debugger
  178. Plugin enables debugging in Geany. Currently supports GDB only, but was
  179. developed with multiple debuggers support in mind, so the other backends
  180. support is planned as well.
  181. %package geanydoc
  182. Summary: Call documentation from within Geany
  183. Summary(ja): Geany 内からドキュメントを呼び出す
  184. Group: Development/Tools
  185. Requires: geany >= %{req_geany_ver}
  186. Requires: geany-plugins-common = %{version}-%{release}
  187. %description geanydoc
  188. Geanydoc allows you to execute specific commands on the word under the cursor.
  189. This word is passed as an argument to the command. The output of the command
  190. can either be placed into a special buffer called "DOC" or can be used to
  191. execute an external program. Geanydoc is intended to be used for searching
  192. through API documentation.
  193. %package geanyextrasel
  194. Summary: Additional features for selecting code
  195. Summary(ja): コード選択のための追加機能
  196. Group: Development/Tools
  197. Requires: geany >= %{req_geany_ver}
  198. Requires: geany-plugins-common = %{version}-%{release}
  199. %description geanyextrasel
  200. Geanyextrasel provides some special features for selecting code, e.g. from
  201. opening brace to closed brace and so on. This plugin will be very useful for
  202. you if you're a programmer and working with much sourcecodes.
  203. #%package geanygdb
  204. #Summary: Debugger Plugin for Geany using GDB
  205. #Summary(ja): GDB を使った Geany のデバッガプラグイン
  206. #Group: Development/Tools
  207. #Requires: geany >= %{req_geany_ver}
  208. #Requires: geany-plugins-common = %{version}-%{release}
  209. #Requires: gdb
  210. #Obsoletes: geany-plugin-gdb
  211. #%description geanygdb
  212. #GeanyGDB plugin provides an integrated debugging environment for the
  213. #GNU debugger (gdb).
  214. #%description geanygdb -l ja
  215. #GeanyGDB プラグインは GNU debugger (gdb) のための
  216. #統合的デバッグ環境を提供します。
  217. %package geanygendoc
  218. Summary: Automatically generate documentation source code
  219. Group: Development/Tools
  220. Requires: geany >= %{req_geany_ver}
  221. Requires: geany-plugins-common = %{version}-%{release}
  222. %description geanygendoc
  223. GeanyGenDoc is a plugin for Geany that aims to automatically generate
  224. documentation comment basis from the source code.
  225. You may also want to install the following packages which enable
  226. some extra features:
  227. - Docutils (http://docutils.sourceforge.net/) -- or another implementation of
  228. rst2html -- is needed to (re)generate the HTML manual.
  229. %package geanyinsertnum
  230. Summary: Insert huge number ranges with small efforts
  231. Summary(ja): 僅かな労力で膨大な範囲の番号を挿入
  232. Group: Development/Tools
  233. Requires: geany >= %{req_geany_ver}
  234. Requires: geany-plugins-common = %{version}-%{release}
  235. %description geanyinsertnum
  236. Geanyinsertnum replaces a (possibly zero-width) rectangular selection with
  237. integer numbers, using start/step/base etc. specified by the user. For
  238. practical reasons, the number of lines is limited to 500000.
  239. %package geanylatex
  240. Summary: to improve LaTeX support plugin for Geany
  241. Summary(ja): Geany のための LaTeX サポート改善プラグイン
  242. Group: Development/Tools
  243. Requires: geany >= %{req_geany_ver}
  244. Requires: geany-plugins-common = %{version}-%{release}
  245. Requires: texlive
  246. Obsoletes: geany-plugin-latex
  247. %description geanylatex
  248. This plugin improves LaTeX support in Geany. It provides several templates for
  249. new documents, help with adding labels and inserting special characters,
  250. and much more.
  251. %description geanylatex -l ja
  252. このプラグインは Geany で LaTeX のサポートを改善するプラグインです。
  253. 新しい文書のためのいくつかのテンプレート、
  254. ラベルの追加や特殊文字の挿入機能などを提供します。
  255. %package geanylipsum
  256. Summary: Lorem Ipsum generator for Inserting Placeholder Text
  257. Group: Development/Tools
  258. Requires: geany >= %{req_geany_ver}
  259. Requires: geany-plugins-common = %{version}-%{release}
  260. %description geanylipsum
  261. GeanyLipsum is a Lorem Ipsum generator for inserting placeholder text into a
  262. document.
  263. %package geanylua
  264. Summary: Support developing Lua Scripting for Geany
  265. Summary(ja): Geany で Lua スクリプト開発をサポート
  266. Group: Development/Tools
  267. Requires: geany >= %{req_geany_ver}
  268. Requires: geany-plugins-common = %{version}-%{release}
  269. Requires: lua
  270. %description geanylua
  271. This plugin provides extensive support for developing in the lua programming
  272. language.
  273. %description geanylua -l ja
  274. このプラグインは、lua プログラミング言語で開発するための
  275. 広範なサポートを提供します。
  276. %package geanymacro
  277. Summary: User defined Macros for Geany
  278. Group: Development/Tools
  279. Requires: geany-plugins-common = %{version}-%{release}
  280. %description geanymacro
  281. GeanyMacro is a plugin to provide user defined macros for Geany. It started
  282. out as part of the ConText feature parity plugin, which was split into
  283. individual plugins to better suit Geany's ethos of being as light as
  284. possible while allowing users to select which features they want to add to
  285. the core editor. The idea was taken from a Text Editor for Windows called
  286. ConText.
  287. This plugin alows you to record and use your own macros. Macros are
  288. sequences of actions that can then be repeated with a single key
  289. combination. So if you had dozens of lines where you wanted to delete the
  290. last 2 characters, you could simple start recording, press End, Backspace,
  291. Backspace, down line and then stop recording. Then simply trigger the macro
  292. and it would automaticaly edit the line and move to the next. You could then
  293. just repeatedly trigger the macro to do as many lines as you want.
  294. %package geanyminiscript
  295. Summary: Geany Mini-Script filter plugin
  296. Group: Development/Tools
  297. Requires: geany-plugins-common = %{version}-%{release}
  298. %description geanyminiscript
  299. gms is a Geany Mini-Script filter plugin.
  300. %package geanynumberedbookmarks
  301. Summary: Provide users 10 numbered Bookmarks
  302. Group: Development/Tools
  303. Requires: geany-plugins-common = %{version}-%{release}
  304. %description geanynumberedbookmarks
  305. GeanyNumberedBookmarks is a plugin to provide users with 10 numbered
  306. bookmarks (in addition to the usual bookmarks). It started out as part of
  307. the ConText feature parity plugin, which was split into individual plugins
  308. to better suit Geany's ethos of being as light as possible while allowing
  309. users to select which features they want to add to the core editor. The idea
  310. was taken from a Text Editor for Windows called ConText.
  311. Normally if you had more than one bookmark, you would have to cycle through
  312. them until you reached the one you wanted. With this plugin you can go
  313. straight to the bookmark that you want with a single key combination.
  314. %package geanypg
  315. Summary: encrypt, decrypt and verify signatures with GnuPG
  316. Group: Development/Tools
  317. Requires: geany-plugins-common = %{version}-%{release}
  318. Requires: gpgme
  319. %description geanypg
  320. GeanyPG is a plugin for Geany that allows the user to encrypt, decrypt and
  321. verify signatures with GnuPG.
  322. %package geanyprj
  323. Summary: Provides an alternate project management tool for Geany
  324. Summary(ja): Geany で代替プロジェクト管理ツールを提供
  325. Group: Development/Tools
  326. Requires: geany >= %{req_geany_ver}
  327. Requires: geany-plugins-common = %{version}-%{release}
  328. %description geanyprj
  329. Geanyprj provides an alternate project management approach to Geany's built-in
  330. project facility. The idea is to be less a "session manager" as the built-in
  331. project management does: It allows/requires you to manually open and close
  332. project and allows you to store project files in different locations from
  333. project sources.
  334. Geanyprj takes a different approach:
  335. It never saves session information, so that project files can be stored in
  336. version control without constant noise from changes of opened files or cursor
  337. position. You also will never have to open/close projects manually. If a
  338. *.geanyprj file is found somewhere up in path it will be opened automatically.
  339. %package geanysendmail
  340. Summary: Send E-Mails from within Geany
  341. Summary(ja): Geany 内から E-Mail を送信するプラグイン
  342. Group: Development/Tools
  343. Requires: geany >= %{req_geany_ver}
  344. Requires: geany-plugins-common = %{version}-%{release}
  345. %description geanysendmail
  346. GeanySendMail is a little plugin to send a document as attachment using the
  347. preferred mail client from inside Geany. It is similar to the envelope symbol
  348. of most office tools and requires a mail client that supports remote calls.
  349. %package geanyvc
  350. Summary: Version Control plugin for Geany
  351. Summary(ja): Geany のバージョン管理プラグイン
  352. Group: Development/Tools
  353. Requires: geany >= %{req_geany_ver}
  354. Requires: geany-plugins-common = %{version}-%{release}
  355. Obsoletes: geany-plugin-vc
  356. Provides: geanyvc = %{version}-%{release}
  357. %description geanyvc
  358. Geanyvc is a plugin that provides a uniform way of accessing different version
  359. control systems from within the Geany IDE. Currently, support for the following
  360. version control systems is provided:
  361. * Bazaar
  362. * Git
  363. * Mercurial
  364. * Subversion
  365. * SVK
  366. * CVS
  367. %description geanyvc -l ja
  368. Geanyvc は Geany IDE から異なるバージョン管理システムにアクセスする
  369. 均一的方法を提供するプラグインです。
  370. 現在、サポートするバージョン管理システムは以下の通りです。
  371. * Bazaar
  372. * Git
  373. * Mercurial
  374. * Subversion
  375. * SVK
  376. * CVS
  377. %package geniuspaste
  378. Summary: allows the user to paste the code from Geany into five different pastebins
  379. Group: Development/Tools
  380. Requires: geany-plugins-common = %{version}-%{release}
  381. %description geniuspaste
  382. This plugin allows the user to paste the code from Geany into five different
  383. pastebins. At the moment it supports this services:
  384. * codepad.org
  385. * tinypaste.com
  386. * pastebin.geany.org
  387. * dpaste.de
  388. * sprunge.us
  389. %package gproject
  390. Summary: Extension of Geany's project management
  391. Group: Development/Tools
  392. Requires: geany-plugins-common = %{version}-%{release}
  393. %description gproject
  394. GProject is an extension of Geany's project management displaying a tree of
  395. files belonging to the project in the sidebar. In addition, it enables quick
  396. swapping between header and source files, searching project files by name
  397. and more. The plugin was created with big projects in mind so everything
  398. works fast enough even with projects consisting of hundreds of thousands of
  399. files.
  400. %package markdown
  401. Summary: provides a real-time preview of rendered Markdown
  402. Group: Development/Tools
  403. Requires: geany-plugins-common = %{version}-%{release}
  404. %description markdown
  405. This plugin provides a real-time preview of rendered Markdown, that is,
  406. `Markdown <http://daringfireball.net/projects/markdown>`_ converted to HTML
  407. and inserted into an HTML template and loaded into a
  408. `WebKit <http://www.webkit.org>`_ view.
  409. %package multiterm
  410. Summary: supports multiple terminals
  411. Group: Development/Tools
  412. Requires: geany-plugins-common = %{version}-%{release}
  413. %description multiterm
  414. MultiTerm is similar to Geany's built-in VTE terminal except that it
  415. supports multiple terminals in tabs and supports different shells in
  416. each of the terminal tabs.
  417. %package pretty-printer
  418. Summary: XML pretty printing plugin for Geany
  419. Group: Development/Tools
  420. Requires: geany >= %{req_geany_ver}
  421. Requires: geany-plugins-common = %{version}-%{release}
  422. Requires: libxml2 >= 2.6.27
  423. Obsoletes: %{name}-pretty-print
  424. %description pretty-printer
  425. Plugin for Geany to easily beautify XML code.
  426. %package scope
  427. Summary: graphical GDB front-end with the normal functions
  428. Group: Development/Tools
  429. Requires: geany >= %{req_geany_ver}
  430. Requires: geany-plugins-common = %{version}-%{release}
  431. Requires: gdb
  432. %description scope
  433. Scope is a graphical GDB front-end with the normal functions you would
  434. expect (stepping, breakpoints...), and a few notable features:
  435. - The comminication between Scope and gdb is asynchronous.
  436. - You can enter any gdb command, at any time (of course, for the command to
  437. be executed, gdb must be[come] available).
  438. - All gdb I/O (along with some other messages) is displayed in a
  439. terminal-like "Debug Console".
  440. Whenever you find the GUI lacking, simply switch to that console and work
  441. directly with gdb.
  442. - 7-bit/Locale/UTF-8 support for values.
  443. %package shiftcolumn
  444. Summary: Move Blocks of Text horizontally
  445. Summary(ja): テキストブロックを水平方向に移動
  446. Group: Development/Tools
  447. Requires: geany >= %{req_geany_ver}
  448. Requires: geany-plugins-common = %{version}-%{release}
  449. %description shiftcolumn
  450. Shiftcolumn allows you to move blocks of text horizontally in Geany.
  451. %description shiftcolumn -l ja
  452. Shiftcolumn は Geany 内でテキストブロックを水平方向に移動させることが
  453. できます。
  454. %package spellcheck
  455. Summary: Spellcheck Text in Geany using the Enchant Library
  456. Summary(ja): Enchant ライブラリを使い Geany でスペルチェック
  457. Group: Development/Tools
  458. Requires: geany >= %{req_geany_ver}
  459. Requires: geany-plugins-common = %{version}-%{release}
  460. Requires: enchant
  461. %description spellcheck
  462. Spellcheck checks the selected text (or the whole document) with the spellcheck
  463. library Enchant.
  464. %description spellcheck -l ja
  465. Spellcheck は、選択したテキスト(または文書全体)のスペルチェックを
  466. スペルチェックライブラリの Enchant で行います。
  467. %package treebrowser
  468. Summary: Alternate file browser plugin providing a tree view of directories.
  469. Summary(ja): ディレクトリのツリービューを提供する代替ファイルブラウザプラグイン
  470. Group: Development/Tools
  471. Requires: geany >= %{req_geany_ver}
  472. Requires: geany-plugins-common = %{version}-%{release}
  473. %description treebrowser
  474. The tree browser plugin for Geany provides an alternate way to browse through
  475. your files. It displays files and directories in a tree view and has more
  476. features than the file browser plugin delivered with Geany itself.
  477. %package tableconvert
  478. Summary: Helps on converting a tabulator separated selection into a table
  479. Group: Development/Tools
  480. Requires: geany-plugins-common = %{version}-%{release}
  481. %description tableconvert
  482. Tableconvert is a plugin which helps on converting a tabulator separated
  483. selection into a table.
  484. %package updatechecker
  485. Summary: Automatically check for Geany updates
  486. Summary(ja): Geany の更新を自動的にチェック
  487. Group: Development/Tools
  488. Requires: geany-plugins-common = %{version}-%{release}
  489. %description updatechecker
  490. UpdateChecker is a plugin for Geany, which is able to check whether there is
  491. a more recent version of Geany available.
  492. %package webhelper
  493. Summary: Preview and Debug Web documents from within Geany using WebKit
  494. Summary(ja): WebKit を使い Geany から Web ドキュメントのプレビューとデバッグを実行
  495. Group: Development/Tools
  496. Requires: geany-plugins-common = %{version}-%{release}
  497. %description webhelper
  498. WebHelper is a plugin for Geany that provides some web development
  499. facilities, such as a web page preview and some debugging tools (web
  500. inspector).
  501. Prominent features:
  502. * A basic web view, allowing to display any web page (using WebKit)
  503. * Possible automatic reloading of the web view upon document saving
  504. * A web inspector/debugging tool for the web view's content (including a
  505. JavaScript console, a viewer and editor of processed HTML and CSS, a network
  506. usage analysis tool and many more, thanks to WebKit).
  507. %package xmlsnippets
  508. Summary: Extends XML/HTML tag autocompletion provided by Geany
  509. Group: Development/Tools
  510. Requires: geany-plugins-common = %{version}-%{release}
  511. %description xmlsnippets
  512. This plugin extends XML/HTML tag autocompletion provided by Geany. It
  513. automatically inserts a matching snippet after you type an opening tag.
  514. %prep
  515. %setup -q
  516. #%patch0 -p1
  517. %build
  518. %configure --docdir=%{geany_plug_docdir}
  519. make %{?_smp_mflags}
  520. %install
  521. rm -rf $RPM_BUILD_ROOT
  522. make install -p DESTDIR=$RPM_BUILD_ROOT
  523. # Remove static library *.la files
  524. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f '{}' \;
  525. # Remove zero-length files
  526. find $RPM_BUILD_ROOT -type f -empty -delete
  527. # copy geanylatex document images
  528. cp -pr geanylatex/doc/img/ $RPM_BUILD_ROOT%{geany_plug_docdir}/geanylatex/
  529. %find_lang %{name}
  530. %clean
  531. rm -rf $RPM_BUILD_ROOT
  532. %files
  533. %files common -f %{name}.lang
  534. %defattr(-,root,root,-)
  535. %dir %{_libdir}/%{name}/
  536. %dir %{_datadir}/%{name}/
  537. %files addons
  538. %defattr(-,root,root,-)
  539. %doc %{geany_plug_docdir}/addons
  540. %{_libdir}/geany/addons.so
  541. %files codenav
  542. %defattr(-,root,root,-)
  543. %doc %{geany_plug_docdir}/commander
  544. %{_libdir}/geany/commander.so
  545. %files commander
  546. %defattr(-,root,root,-)
  547. %doc %{geany_plug_docdir}/codenav
  548. %{_libdir}/geany/codenav.so
  549. %files debugger
  550. %defattr(-,root,root,-)
  551. %doc %{geany_plug_docdir}/debugger
  552. %{_datadir}/%{name}/debugger/
  553. %{_libdir}/geany/debugger.so
  554. %files geanydoc
  555. %defattr(-,root,root,-)
  556. %doc %{geany_plug_docdir}/geanydoc/
  557. %{_libdir}/geany/geanydoc.so
  558. %files geanyextrasel
  559. %defattr(-,root,root,-)
  560. %doc %{geany_plug_docdir}/geanyextrasel/
  561. %{_libdir}/geany/geanyextrasel.so
  562. #%files geanygdb
  563. #%defattr(-,root,root,-)
  564. #%doc %{geany_plug_docdir}/geanygdb/
  565. #%{_libdir}/geany/geanygdb.so
  566. #%{_libexecdir}/geany-plugins/geanygdb/ttyhelper
  567. %files geanygendoc
  568. %defattr(-,root,root,-)
  569. %doc %{geany_plug_docdir}/geanygendoc/
  570. %{_libdir}/geany/geanygendoc.so
  571. %{_datadir}/%{name}/geanygendoc/
  572. %files geanyinsertnum
  573. %defattr(-,root,root,-)
  574. %doc %{geany_plug_docdir}/geanyinsertnum/
  575. %{_libdir}/geany/geanyinsertnum.so
  576. %files geanylatex
  577. %defattr(-,root,root,-)
  578. %doc %{geany_plug_docdir}/geanylatex/
  579. %{_libdir}/geany/geanylatex.so
  580. %files geanylipsum
  581. %defattr(-,root,root,-)
  582. %doc %{geany_plug_docdir}/geanylipsum/
  583. %{_libdir}/geany/geanylipsum.so
  584. %files geanylua
  585. %defattr(-,root,root,-)
  586. %doc %{geany_plug_docdir}/geanylua/
  587. %{_libdir}/geany/geanylua.so
  588. %{_datadir}/%{name}/geanylua/
  589. %{_libdir}/%{name}/geanylua/
  590. %files geanymacro
  591. %defattr(-,root,root,-)
  592. %doc %{geany_plug_docdir}/geanymacro/
  593. %{_libdir}/geany/geanymacro.so
  594. %files geanyminiscript
  595. %defattr(-,root,root,-)
  596. %doc %{geany_plug_docdir}/geanyminiscript/
  597. %{_libdir}/geany/geanyminiscript.so
  598. %files geanynumberedbookmarks
  599. %defattr(-,root,root,-)
  600. %doc %{geany_plug_docdir}/geanynumberedbookmarks/
  601. %{_libdir}/geany/geanynumberedbookmarks.so
  602. %files geanypg
  603. %defattr(-,root,root,-)
  604. %doc %{geany_plug_docdir}/geanypg/
  605. %{_libdir}/geany/geanypg.so
  606. %files geanyprj
  607. %defattr(-,root,root,-)
  608. %doc %{geany_plug_docdir}/geanyprj/
  609. %{_libdir}/geany/geanyprj.so
  610. %files geanysendmail
  611. %defattr(-,root,root,-)
  612. %doc %{geany_plug_docdir}/geanysendmail/
  613. %{_libdir}/geany/geanysendmail.so
  614. %files gproject
  615. %defattr(-,root,root,-)
  616. %doc %{geany_plug_docdir}/gproject/
  617. %{_datadir}/icons/hicolor/16x16/apps/gproject-*.png
  618. %{_libdir}/geany/gproject.so
  619. %files geanyvc
  620. %defattr(-,root,root,-)
  621. %doc %{geany_plug_docdir}/geanyvc/
  622. %{_libdir}/geany/geanyvc.so
  623. %files geniuspaste
  624. %defattr(-,root,root,-)
  625. %doc %{geany_plug_docdir}/geniuspaste/
  626. %{_libdir}/geany/geniuspaste.so
  627. %files markdown
  628. %defattr(-,root,root,-)
  629. %doc %{geany_plug_docdir}/markdown/
  630. %{_libdir}/geany/markdown.so
  631. %files multiterm
  632. %defattr(-,root,root,-)
  633. %doc %{geany_plug_docdir}/multiterm/
  634. %{_libdir}/geany/multiterm.so
  635. %files pretty-printer
  636. %defattr(-,root,root,-)
  637. %{_libdir}/geany/pretty-printer.so
  638. %files scope
  639. %defattr(-,root,root,-)
  640. %doc %{geany_plug_docdir}/scope/
  641. %{_libdir}/geany/scope.so
  642. %{_datadir}/%{name}/scope/
  643. %files shiftcolumn
  644. %defattr(-,root,root,-)
  645. %doc %{geany_plug_docdir}/shiftcolumn/
  646. %{_libdir}/geany/shiftcolumn.so
  647. %files spellcheck
  648. %defattr(-,root,root,-)
  649. %doc %{geany_plug_docdir}/spellcheck/
  650. %{_libdir}/geany/spellcheck.so
  651. %files tableconvert
  652. %defattr(-,root,root,-)
  653. %doc %{geany_plug_docdir}/tableconvert/
  654. %{_libdir}/geany/tableconvert.so
  655. %files treebrowser
  656. %defattr(-,root,root,-)
  657. %doc %{geany_plug_docdir}/treebrowser/
  658. %{_libdir}/geany/treebrowser.so
  659. %files updatechecker
  660. %defattr(-,root,root,-)
  661. %doc %{geany_plug_docdir}/updatechecker/
  662. %{_libdir}/geany/updatechecker.so
  663. %files webhelper
  664. %defattr(-,root,root,-)
  665. %doc %{geany_plug_docdir}/webhelper/
  666. %{_libdir}/geany/webhelper.so
  667. %files xmlsnippets
  668. %defattr(-,root,root,-)
  669. %doc %{geany_plug_docdir}/xmlsnippets/
  670. %{_libdir}/geany/xmlsnippets.so
  671. %changelog
  672. * Sat Mar 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.23-1
  673. - new upstream release
  674. - deleted Patch0
  675. - added new plugins
  676. - Commander, Markdown, Scope
  677. * Fri Jul 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
  678. - new upstream release
  679. - added BuildRequires: vala-devel
  680. - added new plugins
  681. - GeanyMiniScript, GeniusPaste, MultiTerm
  682. - added Patch0 to fix installation path of geanylatex documents
  683. - renamed pretty-print to pretty-printer
  684. - obsoleted geany-plugins-geanygdb to provide same function as geany-plugins-debugger
  685. * Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.21-2
  686. - added BuildRequires: vte-devel, WebKit-gtk-devel, gtk2-devel, glib2-devel,
  687. gdk-pixbuf2-devel, pango-devel, python-docutils
  688. - fixed %%changelog in Sat Oct 29 2011
  689. * Sat Oct 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.21-1
  690. - new upstream release
  691. - added new plugins
  692. - Debugger, GeanyPG, GeanyMacro, GeanyNumberedBookmarks, GProject, Tableconvert, XMLSnippets
  693. - added BuildRequires: gpgme-devel
  694. * Sun Jan 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.20-1
  695. - new upstream release
  696. - added geany-plugins-updatechecker and geany-plugins-webhelper
  697. * Sun Aug 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-3
  698. - added geany-plugins-geanygendoc
  699. - added BuildRequires: ctpl-devel >= 0.2
  700. - changed geany-plugins-latex Requires: tetex to Requires: texlive
  701. - removed zero-length documentation files
  702. * Sun Jul 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-2
  703. - correct license to GPLv3+
  704. - added BuildRequires: libxml2-devel >= 2.6.27
  705. - added Requires: geany-plugins-codenav, geany-plugins-treebrowser,
  706. geany-plugins-geanyextrasel, geany-plugins-geanyinsertnum, geany-plugins-pretty-print
  707. * Mon Jun 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-1
  708. - new upstream release
  709. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-3
  710. - fixed Requires geany-plugins
  711. - applied new naming policy to spec
  712. * Thu Jan 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-2
  713. - fixed Obsoletes geany-plugin-addons, geany-plugin-gdb, geany-plugin-latex, geany-plugin-vc
  714. (see [BTS:VineLinux:0894])
  715. - proved Summary(ja)
  716. * Wed Nov 18 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-1
  717. - initial build for Vine Linux (instead of now provided some geany-plugins)
  718. * Sat Oct 31 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.18-1
  719. - update to new upstream release
  720. * Sun Aug 16 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-6
  721. - build against and require geany 0.18
  722. * Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.17.1-5
  723. - Use bzipped upstream tarball.
  724. * Sat Jul 25 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-4
  725. - write BuildRequires at the beginning of this file
  726. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-3
  727. - remove Requires: geany from the main package
  728. - change Group to Development/Tools
  729. - add release to the geanyvc Provides
  730. - entirely remove %%files stanza for the main package
  731. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-2
  732. - fix the required geany version also in the subpackages
  733. - remove the requires to sub-packages to avoid building the metapackage since
  734. all geany plugins also can be installed by something like
  735. 'yum install geany-plugins-*'
  736. - fix the requires of geany-plugins-common to include the release
  737. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-1
  738. - bump upstream version to 0.17.1
  739. - fix required geany version to be 0.16 at the present
  740. * Sat Jul 18 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-5
  741. - add Requires for metapackage
  742. - rename subpackages back to geany-plugins-* instead of geany-plugin-*
  743. * Fri Jul 17 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-4
  744. - readd the geany_plug_docdir global to fix the versioned directory issue for
  745. documentation files
  746. - replace geany-plugins with %%{name} to be more consistent with macro usage
  747. - remove zero-length documentation files
  748. - fix the changelog
  749. - remove static *.la-files
  750. - split up packages
  751. * Wed Jul 15 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-3
  752. - add %%{_datadir}/geany-plugins/geanylua/ to %%files-section
  753. * Wed Jul 15 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-2
  754. - fix %%files-section again, thanks to Jonathan for the hint.
  755. * Tue Jul 14 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-1
  756. - update URL to plugins.geany.org
  757. * Tue Jul 14 2009 Jonathan G. Underwood <jonathan.underwood@gmail.com> - 0.17-0.2
  758. - Add Obsoletes for geanyvc
  759. - Add more BuildRequires and Requires
  760. * Tue Jul 14 2009 Jonathan G. Underwood <jonathan.underwood@gmail.com> - 0.17-0.1
  761. - Update to 0.17 (first upstream release of tarball)
  762. - Fix handling of docs
  763. - Spec file cleanups
  764. * Mon Jun 22 2009 Pingou <pingou@pingoured.fr> 0.1-1
  765. - First RPM for Fedora