tk-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. %define majorver 8.5
  2. %define minorver 15
  3. Summary: A Tcl/Tk development environment: tk
  4. Summary(ja): Tcl/Tk 開発環境: tk
  5. Name: tk
  6. Version: %{majorver}.%{minorver}
  7. Release: 2%{?_dist_release}
  8. Group: Development/Languages
  9. License: TCL
  10. URL: http://tcl.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  12. # patches from Red Hat Enterprise Linux tk-8.5.7-6.el6
  13. Patch101: tk8.5-make.patch
  14. Patch102: tk8.5-conf.patch
  15. # this patch isn't needed since tk8.6b1
  16. Patch103: tk-seg_input.patch
  17. # fixes sigsegv if there is no font seen by fontconfig (#606671)
  18. Patch105: tk-8.5.7-nofont-sigsegv.patch
  19. Buildroot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: autoconf
  21. BuildRequires: libX11-devel
  22. BuildRequires: libXft-devel
  23. BuildRequires: tcl-devel = %{version}
  24. Requires: tcl >= %{majorver}
  25. Provides: libtk%{majorver}.so
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %description
  29. Tk is a X Windows widget set designed to work closely with the tcl
  30. scripting language. It allows you to write simple programs with full
  31. featured GUI's in only a little more time then it takes to write a
  32. text based interface. Tcl/Tk applications can also be run on Windows
  33. and Macintosh platforms.
  34. %description -l ja
  35. Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
  36. System のウィジェットセットです。 テキストベースのインターフェースを
  37. 採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
  38. ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
  39. のプラットフォームで実行することもできます。
  40. %package devel
  41. Summary: Tk graphical toolkit development files
  42. Summary(ja): Tk ツールキットの開発環境
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. Requires: tcl-devel = %{version}
  46. Requires: libX11-devel
  47. Requires: libXft-devel
  48. %description devel
  49. Tk is a X Windows widget set designed to work closely with the tcl
  50. scripting language. It allows you to write simple programs with full
  51. featured GUI's in only a little more time then it takes to write a
  52. text based interface. Tcl/Tk applications can also be run on Windows
  53. and Macintosh platforms.
  54. The package contains the development files and man pages for tk.
  55. %prep
  56. %setup -n %{name}%{version} -q
  57. %patch101 -p1 -b .make
  58. %patch102 -p1 -b .conf
  59. %patch103 -p1 -b .seg
  60. %patch105 -p1 -b .nofont-sigsegv
  61. %build
  62. cd unix
  63. autoconf
  64. %configure
  65. make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TK_LIBRARY=%{_datadir}/%{name}%{majorver}
  69. ln -s wish%{majorver} $RPM_BUILD_ROOT%{_bindir}/wish
  70. # for linking with -l%{name}
  71. ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  72. mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic/ttk,unix}
  73. find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
  74. ( cd $RPM_BUILD_ROOT/%{_includedir}
  75. for i in *.h ; do
  76. [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
  77. done
  78. )
  79. # remove buildroot traces
  80. sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
  81. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tkAppInit.c
  82. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/prolog.ps
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %post -p /sbin/ldconfig
  86. %postun -p /sbin/ldconfig
  87. %files
  88. %defattr(-,root,root,-)
  89. %doc README changes license.terms
  90. %{_bindir}/wish*
  91. %{_datadir}/tk%{majorver}
  92. %{_libdir}/libtk%{majorver}.so
  93. %{_libdir}/tk%{majorver}
  94. %{_libdir}/tkConfig.sh
  95. %{_mandir}/man1/*
  96. %{_mandir}/mann/*
  97. %files devel
  98. %defattr(-,root,root)
  99. %{_includedir}/*
  100. %{_libdir}/libtk.so
  101. %{_libdir}/libtkstub%{majorver}.a
  102. %{_libdir}/tkConfig.sh
  103. %{_mandir}/man3/*
  104. %changelog
  105. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-2
  106. - split development files into devel subpackage
  107. - added BR: libXft-devel
  108. * Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-1
  109. - new upstream release
  110. - drop obsolete patche (Patch104)
  111. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
  112. - update to 5.8.7: sync Red Hat Enterprise Linux 6 tk-8.4.19-4vl6
  113. - update License: TCL
  114. - drop obsolete patches
  115. - lib-perm patch (Patch2)
  116. - lastevent patch (Patch3)
  117. - tkBind patch (Patch4)
  118. - add some patches from RHEL tk-8.5.7-6.el6
  119. - make patch (Patch101)
  120. - conf patch (Patch102)
  121. - seg_input patch (Patch103)
  122. - color patch (Patch104)
  123. - nofont sigsegv patch (Patch105)
  124. - add some documents
  125. - update build and install section: sync RHEL tk-8.5.7-6.el6
  126. * Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
  127. - added "BuildRequires: imake".
  128. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
  129. - rebuilt with rpm-4.8.1-3
  130. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
  131. - rebuilt with tcl-8.4.19-2
  132. - dropt Patch4: tk-8.4.18-tkBind.patch
  133. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  134. - new upstream release
  135. - add Patch3,4 to fix bug (broken if built with xproto-7.x)
  136. * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
  137. - spec in utf-8
  138. * Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  139. - rebuild with xorg-x11-7.3
  140. - remove Requires: XFree86-libs
  141. - add BuildRequires: libX11-devel
  142. - use autoconf instead of autoconf217
  143. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  144. - updated tk to 8.4.18
  145. - included CVE-2008-0553
  146. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  147. - updated tk to 8.4.16
  148. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  149. - updated tk to 8.4.15
  150. - rebuilt with new toolchain
  151. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  152. - updated tk to 8.4.13
  153. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  154. - updated tk to 8.4.12
  155. - updated tk-%%{version}-lib-perm.patch
  156. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
  157. - dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
  158. - replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
  159. - dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
  160. - dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
  161. * Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
  162. - added tk-8.4.6-tkUnixWm.patch
  163. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  164. - updated tk to 8.4.6
  165. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  166. - syncd with fedora
  167. * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
  168. - add private header files needed to build tix in /usr/include/tk-private
  169. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
  170. - removed rpath (patch 3)
  171. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  172. - new package split out from tcltk
  173. - update to tk 8.4.5 (#88429)
  174. - filtered changelog for tk
  175. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  176. - remove build remnants from tkConfig.sh
  177. * Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
  178. - fix buildrequires and requires section
  179. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  180. - update based on BitWalk's tcltk-8.4.2-83bw
  181. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  182. - splite source package
  183. - add include files
  184. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  185. - expand some macros.. (FIXME)
  186. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  187. - use %configure macros
  188. - add Patch 47,50
  189. * Thu May 31 2001 <sagami@vinelinux.org>
  190. - 8.0.5_jp-10
  191. - unexpand old %%{configure}, new one causes build failure
  192. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  193. - install manpages into %%{_mandir} and mode 644
  194. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  195. - 8.0.5_jp-9
  196. - modified %install section to handle compressed man pages
  197. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  198. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  199. - changed default fonts
  200. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  201. - added defattr
  202. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  203. - added some symlinks, such as libtcl8.0.so.
  204. - obsoletes version number using _jp, now 8.0.5-31vl1
  205. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  206. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  207. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  208. - fix tclX symlinks.
  209. - compile on systems where SIGPWR == SIGLOST.
  210. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  211. - update tcl/tk to 8.0.5.
  212. - avoid "containing" in Tix (#2332).
  213. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  214. - use /usr/bin/write in kibitz (#1320).
  215. - use cirrus.sprl.umich.edu in weather (#1926).
  216. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  217. - auto rebuild in the new build environment (release 28)
  218. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  219. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  220. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  221. - expect does unaligned access on alpha (#989)
  222. - upgrade tcl/tk/tclX to 8.0.4
  223. - upgrade expect to 5.28.
  224. - add itcl 3.0.1
  225. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  226. - call libtoolize to allow building on the arm
  227. - build for glibc 2.1
  228. - strip binaries
  229. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  230. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  231. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  232. - expect: mkpasswd needs delay before sending password (problem #576)
  233. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  234. - translations modified for de, fr, tr
  235. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  236. - fixed expect binaries exec permissions
  237. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  238. - updated to Tix 4.1.0.006
  239. - updated version numbers of tcl/tk to relflect includsion of p2
  240. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  241. - updated tcl/tk to patch level 2
  242. - updated tclX to 8.0.2
  243. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  244. - fixed filelist for tix... replacing path to the expect binary in scripts
  245. was leaving junk files around.
  246. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  247. - added patch to remove libieee test in configure.in for tcl and tk.
  248. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  249. solution for all systems
  250. - fixed src urls
  251. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  252. - removed version numbers from descriptions
  253. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  254. - updated to tcl/tk 8.0 and related versions of packages
  255. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  256. - built against glibc
  257. - fixed dangling tclx/tkx symlinks