jasper-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: jasper
  3. Summary: implementation of the JPEG-2000 standard, Part 1
  4. Version: 1.900.1
  5. Release: 8%{?_dist_release}
  6. Group: Applications/Graphics
  7. License: Modified BSD (see LICENSE)
  8. URL: http://www.ece.uvic.ca/~mdadams/jasper/
  9. Source: %{name}-%{version}.zip
  10. # Security fixes
  11. Patch100: jasper-1.900.1_CVE-2007-2721.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: libjpeg-devel unzip
  14. BuildRequires: freeglut-devel
  15. Requires: %{name}-libs = %{version}-%{release}
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %description
  19. JasPer is a collection of software (i.e., a library and application
  20. programs) for the coding and manipulation of images. This software
  21. can handle image data in a variety of formats. One such format
  22. supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
  23. %package devel
  24. Summary: Include Files and Documentation for jasper
  25. Group: Development/Libraries
  26. Requires: %{name}-libs = %{version}-%{release}
  27. Requires: libjpeg-devel
  28. %description devel
  29. This package contains libjasper, a library implementing the JPEG-2000
  30. image compression standard Part 1.
  31. %package libs
  32. Summary: Runtime libraries for %{name}
  33. Group: System Environment/Libraries
  34. %description libs
  35. This package contains runtime libraries for JasPer.
  36. # compat32
  37. %package -n compat32-%{name}-devel
  38. Summary: Include Files and Documentation for jasper
  39. Group: Development/Libraries
  40. Requires: %{name}-libs = %{version}-%{release}
  41. Requires: compat32-libjpeg-devel
  42. %description -n compat32-%{name}-devel
  43. This package contains libjasper, a library implementing the JPEG-2000
  44. image compression standard Part 1.
  45. %package -n compat32-%{name}-libs
  46. Summary: Runtime libraries for %{name}
  47. Group: System Environment/Libraries
  48. %description -n compat32-%{name}-libs
  49. This package contains runtime libraries for JasPer.
  50. %prep
  51. %setup -T -c %{name}-%{version}
  52. cd ..
  53. unzip %{SOURCE0}
  54. cd %{name}-%{version}
  55. # security fixes
  56. %patch100 -p1 -b .CVE-2007-2721
  57. %build
  58. ./configure --prefix=%{_prefix} --libdir=%{_libdir} --mandir=%{_mandir} \
  59. --enable-shared --disable-static
  60. make
  61. %install
  62. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  63. make install DESTDIR=$RPM_BUILD_ROOT
  64. # remove .la
  65. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  66. %clean
  67. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  68. %post libs -p /sbin/ldconfig
  69. %postun libs -p /sbin/ldconfig
  70. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  71. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  72. %files
  73. %defattr(-,root,root)
  74. %doc COPYRIGHT ChangeLog INSTALL LICENSE NEWS README doc
  75. %{_bindir}/*
  76. %{_mandir}/man1/*
  77. %files libs
  78. %defattr(-,root,root)
  79. %{_libdir}/libjasper*.so.*
  80. %files devel
  81. %defattr(-,root,root)
  82. %{_includedir}/jasper
  83. %{_libdir}/libjasper*.so
  84. # compat32
  85. %if %{build_compat32}
  86. %files -n compat32-%{name}-libs
  87. %defattr(-,root,root)
  88. %{_libdir}/libjasper*.so.*
  89. %files -n compat32-%{name}-devel
  90. %defattr(-,root,root)
  91. %{_libdir}/libjasper*.so
  92. %endif
  93. %changelog
  94. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
  95. - rebuilt with current VineSeed
  96. * Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
  97. - added compat32 subpackage for x86_64 arch support.
  98. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
  99. - splited out runtime library to sub package
  100. - enable opengl again, add BuildRequires: freeglut-devel
  101. * Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
  102. - remove .la
  103. - add --disable-static to configure option
  104. * Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
  105. - added Patch0 from VinePlus/4.0
  106. * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
  107. - add patch100 for fix CVE-2007-2721
  108. - add Vendor/Distributin Tag
  109. * Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
  110. - remove BuildPrereq: freeglut-devel and Requires freeglut
  111. - add --disable-opengl to configure option
  112. * Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
  113. - add BuildPreReq: unzip (used in the %%pre section)
  114. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
  115. - new upstream release
  116. * Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
  117. - new upstream release
  118. - changed Group to System Environment/Libraries
  119. - added --mandir=%{_mandir}
  120. - added %post and %postun section
  121. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
  122. - added --libdir=%{_libdir} configure option
  123. * Tue Sep 5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
  124. - build with freeglut
  125. - change BuildPrereq and Requires
  126. * Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
  127. - new upstream version (jasper-1.701.0)
  128. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
  129. - rebuild for VineSeedPlus
  130. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
  131. - source upgrade
  132. - change spec to build for VineLinux
  133. * Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
  134. - spec file created