123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269 |
- Summary: A cron-like program that can run jobs lost during downtime.
- Name: anacron
- Version: 2.3
- Release: 31%{?_dist_release}
- License: GPL
- Group: System Environment/Base
- Source: ftp://ftp.debian.org/debian/pool/main/a/anacron/%{name}_%{version}.orig.tar.gz
- Source1: anacrontab
- Source2: anacron.init
- Patch0: anacron-2.3-mk-incl.patch
- Patch1: anacron-2.3-mail-content-type-77108.patch
- Patch2: anacron-2.3-gregor.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
- Requires: /bin/sh
- Requires: crontabs
- Requires(post): chkconfig
- Requires(preun): chkconfig
- Requires(preun): initscripts
- Requires(postun): initscripts
- %description
- Anacron (like `anac(h)ronistic') is a periodic command scheduler. It
- executes commands at intervals specified in days. Unlike cron, it
- does not assume that the system is running continuously. It can
- therefore be used to control the execution of daily, weekly and
- monthly jobs (or anything with a period of n days), on systems that
- don't run 24 hours a day. When installed and configured properly,
- Anacron will make sure that the commands are run at the specified
- intervals as closely as machine-uptime permits.
- This package is pre-configured to execute the daily jobs of the Red
- Hat Linux system. You should install this program if your system isn't
- powered on 24 hours a day to make sure the maintenance jobs of other
- Red Hat Linux packages are executed each day.
- %prep
- %setup -q
- %patch0 -p1 -b .incl
- %patch1 -p1 -b .charset
- %patch2 -p1 -b .gregor
- %build
- make CFLAGS="$RPM_OPT_FLAGS"
- %install
- mkdir -p $RPM_BUILD_ROOT/{etc/,usr/sbin/,%{_mandir}/man5,%{_mandir}/man8/}
- mkdir -p $RPM_BUILD_ROOT/var/spool/anacron/
- #
- cp anacron $RPM_BUILD_ROOT/usr/sbin
- cp anacron.8 $RPM_BUILD_ROOT/%{_mandir}/man8/
- cp anacrontab.5 $RPM_BUILD_ROOT/%{_mandir}/man5/
- cp %SOURCE1 $RPM_BUILD_ROOT/etc
- for i in cron.daily cron.weekly cron.monthly;do
- mkdir -p $RPM_BUILD_ROOT/etc/$i/
- cat << EOF > $RPM_BUILD_ROOT/etc/$i/0anacron
- #!/bin/sh
- #
- # anacron's cron script
- #
- # This script updates anacron time stamps. It is called through run-parts
- # either by anacron itself or by cron.
- #
- # The script is called "0anacron" to assure that it will be executed
- # _before_ all other scripts.
- anacron -u $i
- EOF
- chmod +x $RPM_BUILD_ROOT/etc/$i/0anacron
- done
- #
- #for i in `find $RPM_BUILD_ROOT/ -type 'f' -perm '+a=x'`;do
- # file $i|grep -q "not stripped" && strip $i
- #done
- mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d/
- install -c -m755 %SOURCE2 $RPM_BUILD_ROOT/etc/rc.d/init.d/anacron
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/chkconfig --add anacron
- %preun
- if [ "$1" = "0" ]; then
- service anacron stop >/dev/null 2>&1
- /sbin/chkconfig --del anacron
- fi
- %postun
- if [ "$1" -ge "1" ]; then
- service anacron condrestart >/dev/null 2>&1
- fi
- %files
- %defattr(-,root,root,0755)
- %doc COPYING README
- %config /etc/anacrontab
- %dir /var/spool/anacron/
- %config /etc/rc.d/init.d/*
- /%{_mandir}/man5/*
- /%{_mandir}/man8/*
- /usr/sbin/anacron
- %config /etc/cron.daily/0anacron
- %config /etc/cron.monthly/0anacron
- %config /etc/cron.weekly/0anacron
- %changelog
- * Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-31
- - fix typo..
- * Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-30
- - rebuild for Vine 6
- - use Requires({post,preun,postun}) instead of PreReq
- * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.3-29vl5
- - applied new versioning policy
- * Sat Jul 08 2006 Shu KONNO <owa@bg.wakwak.com> 2.3-29vl2
- - added anacron-2.3-gregor.patch
- * Wed Jul 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-29vl1
- - rebuild for Vine Linux
- * Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-29
- - don't require vixie-cron (#21176) [reported by Gerald Teschl]
- - in init script don't remove /var/lock/subsys/anacron when stopping (#58462)
- - exit init script with actual exit status (#44600) [reported by Enrico Scholz]
- * Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-28
- - add a Content-Type header to mails giving the charset encoding (#77108)
- * Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-27
- - in init script do not touch /var/lock/subsys/anacron when starting (#58462)
- - require crontabs (#21176)
- - update source url
- * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- - rebuilt
- * Wed Dec 11 2002 Tim Powers <timp@redhat.com> 2.3-24
- - rebuild on all arches
- * Fri Aug 23 2002 Jens Petersen <petersen@redhat.com> 2.3-23
- - delay the start of anacron by 60min to make startup more pleasant (#68304)
- - at startup run jobs serially and nice 19 to reduce load (#65870, #68304)
- - spec file now in utf-8
- - dont install non-existant NEWS file
- - silence make include warnings
- * Fri Jul 19 2002 Akira TAGOH <tagoh@redhat.com> 2.3-22
- - fix the stripped binary issue.
- * Mon Jul 08 2002 Bill Huang <bhuang@redhat.com>
- - Update "Copyright" to "License" in spec file
- * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Thu May 23 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
- - Bump release + rebuild.
- * Tue Apr 3 2001 Crutcher Dunnavant <crutcher@redhat.com>
- - add dependancy to vixie-cron (for /usr/bin/run-parts)
- * Tue Feb 13 2001 Tim Waugh <twaugh@redhat.com>
- - killproc is a shell function and can't be passed as a parameter
- (bug #27150).
- * Mon Feb 5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- - Fix i18n in initscript ("Stopping anacron" wasn't translated)
- (#26076)
- * Fri Feb 2 2001 Trond Eivind Glomsrød <teg@redhat.com>
- - i18nize initscript
- * Thu Dec 7 2000 Crutcher Dunnavant <crutcher@redhat.com>
- - rebuild in rebuild cycle.
- * Mon Oct 30 2000 Matt Wilson <msw@redhat.com>
- - touch /var/lock/subsys/anacron to prevent excess startage during
- init level change
- * Wed Aug 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - Shut down earlier to prevent NFS mounted /usr filesystems from causing
- problems (Bug #16257)
- * Fri Aug 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - Start it later so services some cron scripts may depend on are running
- (Bug #15335)
- * Thu Aug 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - Fix up initscript (Bug #15123 and an unreported bug)
- * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
- - move initscript back
- * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
- - automatic rebuild
- * Mon Jul 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - Fix up initscripts (Bug #13625)
- * Tue Jul 4 2000 Matt Wilson <msw@redhat.com>
- - Prereq: /sbin/chkconfig
- * Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
- - move initscript to /etc/init.d, fix up post/preun/postun scripts.
- * Sun Jun 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - 2.3
- * Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
- - use %%{_mandir}
- * Fri Mar 03 2000 Tim Powers <timp@redhat.com>
- - fixed startup script so that it doesn't put stuff in /var/lock/subsys.
- Complains since anacronda turns itself off when it is run, and the file in
- /var/lock/subsys isn't removed.
-
- * Mon Feb 28 2000 Tim Powers <timp@redhat.com>
- - fixed startup script, now it actually stops, gives status and restarts.
- Fixes bug #9835
- * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
- - handle compressed manpages
- * Fri Feb 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - rebuild to get compressed man pages
- - mark /etc/cron.daily/... as config files
- * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
- - fix annoying defines
- - rebuild to update description and group
- * Thu Jan 6 2000 Bernhard Rosenkränzer <bero@redhat.com>
- - initial Red Hat package
- * Wed Dec 29 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
- - Remove cron.hourly check (unusefull).
- * Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
- - 2.1 from debian.
- - Fix typo in initscripts.
- * Thu Jul 22 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
- - Fix wrong entries in anacrontab.
- - Add a /etc/rc.sysinit/ script
- * Tue Apr 27 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
- - Fix bug with /var/spool/anacron/
- * Sat Apr 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
- - First version mainly inspired from the Debian package.
|