123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249 |
- %bcond_without bootstrap
- # uncomment to enable bootstrap mode
- %if %{with bootstrap}
- %define bootstrap 1
- %endif
- %if !0%{?bootstrap}
- %global docs 1
- %global tests 1
- %endif
- Name: extra-cmake-modules
- Summary: Additional modules for CMake build system
- Version: 5.23.0
- Release: 3%{?_dist_release}
- License: BSD
- URL: https://quickgit.kde.org/?p=extra-cmake-modules.git
- Vendor: Project Vine
- Distribution: Vine Linux
- %global versiondir %(echo %{version} | cut -d. -f1-2)
- %global revision %(echo %{version} | cut -d. -f3)
- %if %{revision} >= 50
- %global stable unstable
- %else
- %global stable stable
- %endif
- Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{name}-%{version}.tar.xz
- BuildArch: noarch
- BuildRequires: cmake
- #BuildRequires: kf5-rpm-macros
- #Requires: kf5-rpm-macros
- %if 0%{?docs}
- # qcollectiongenerator
- BuildRequires: qt5-qttools-devel
- # sphinx-build
- BuildRequires: python2-sphinx
- %endif
- %description
- Additional modules for CMake build system needed by KDE Frameworks.
- %prep
- %autosetup -p1
- %build
- mkdir %{_target_platform}
- pushd %{_target_platform}
- CFLAGS="${CFLAGS:-%optflags}"; export CFLAGS;
- CXXFLAGS="${CXXFLAGS:-%optflags}"; export CXXFLAGS;
- FFLAGS="${FFLAGS:-%optflags%{?_fmoddir: -I%_fmoddir}}"; export FFLAGS;
- %{?__global_ldflags:LDFLAGS="${LDFLAGS:-%__global_ldflags}"; export LDFLAGS;}
- cmake .. \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
- -DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \
- -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
- -DLIB_INSTALL_DIR:PATH=%{_libdir} \
- -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
- -DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
- %if "%{?_lib}" == "lib64"
- %{?_cmake_lib_suffix64} \
- %endif
- %{?_cmake_skip_rpath} \
- -DBUILD_SHARED_LIBS:BOOL=ON \
- -DBUILD_TESTING:BOOL=%{?tests:ON}%{!?tests:OFF}
- popd
- make %{?_smp_mflags} -C %{_target_platform}
- %install
- make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
- %check
- %if 0%{?tests}
- export CTEST_OUTPUT_ON_FAILURE=1
- make test ARGS="--output-on-failure --timeout 300" -C %{_target_platform}
- %endif
- %files
- %doc README.rst
- %license COPYING-CMAKE-SCRIPTS
- %{_datadir}/ECM/
- %if 0%{?docs}
- %{_docdir}/ECM/html/
- %{_mandir}/man7/ecm*.7*
- %endif
- %changelog
- * Sun Jul 3 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.23.0-3
- - initial build for Vine Linux.
- * Tue Jun 07 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.23.0-2
- - support bootstrap, add docs/tests
- * Tue Jun 07 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.23.0-1
- - 5.23.0, relax kf5-rpm-macros dep
- * Mon May 16 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.22.0-1
- - KDE Frameworks 5.22.0
- * Mon Apr 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.21.0-2
- - Update URL
- * Mon Apr 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.21.0-1
- - KDE Frameworks 5.21.0
- * Mon Mar 14 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.20.0-1
- - KDE Frameworks 5.20.0
- * Thu Feb 11 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.19.0-1
- - KDE Frameworks 5.19.0
- * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.18.0-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Thu Jan 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.18.0-2
- - use kf5-rpm-macros, update URL, use %%license
- * Sun Jan 03 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.18.0-1
- - KDE Frameworks 5.18.0
- * Sun Dec 13 2015 Helio Chissini de Castro <helio@kde.org> - 5.17.0-2
- - Adapt epel cmake3 changes
- * Tue Dec 08 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.17.0-1
- - KDE Frameworks 5.17.0
- * Sun Nov 08 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.16.0-1
- - KDE Frameworks 5.16.0
- * Thu Oct 08 2015 Daniel Vrátil <dvratil@redhat.com> - 5.15.0-1
- - KDE Frameworks 5.15.0
- * Wed Sep 16 2015 Daniel Vrátil <dvratil@redhat.com> - 5.14.0-1
- - KDE Frameworks 5.14.0
- * Wed Aug 19 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-1
- - KDE Frameworks 5.13.0
- * Wed Aug 19 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-1
- - KDE Frameworks 5.13.0
- * Tue Aug 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-0.1
- - KDE Frameworks 5.13
- * Thu Jul 09 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.12.0-1
- - 5.12.0, update URL (to reference projects.kde.org), .spec cosmetics
- * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.11.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Wed Jun 10 2015 Daniel Vrátil <dvratil@redhat.com> - 5.11.0-1
- - KDE Frameworks 5.11.0
- * Mon May 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.10.0-1
- - KDE Frameworks 5.10.0
- * Tue Apr 07 2015 Daniel Vrátil <dvratil@redhat.com> - 5.9.0-1
- - KDE Frameworks 5.9.0
- * Mon Mar 16 2015 Daniel Vrátil <dvratil@redhat.com> - 1.8.0-1
- - extra-cmake-modules 1.8.0 (KDE Frameworks 5.8.0)
- * Fri Feb 13 2015 Daniel Vrátil <dvratil@redhat.com> - 1.7.0-1
- - extra-cmake-modules 1.7.0 (KDE Frameworks 5.7.0)
- * Mon Jan 12 2015 Daniel Vrátil <dvratil@redhat.com> - 1.6.1-1
- - Update to 1.6.1 which includes upstream fix for kde#341717
- * Sun Jan 11 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.6.0-3
- - Use upstream version of the kde#342717 patch by Alex Merry
- * Sun Jan 11 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.6.0-2
- - Do not unset old-style variables in KDEInstallDirs.cmake, it breaks projects
- using GNUInstallDirs for some parts and KDEInstallDirs for others (kde#342717)
- * Thu Jan 08 2015 Daniel Vrátil <dvratil@redhat.com> - 1.6.0-1
- - extra-cmake-modules 1.6.0 (KDE Frameworks 5.6.0)
- * Thu Dec 11 2014 Daniel Vrátil <dvratil@redhat.com> - 1.5.0-1
- - extra-cmake-modules 1.5.0 (KDE Frameworks 5.5.0)
- * Mon Nov 03 2014 Daniel Vrátil <dvratil@redhat.com> - 1.4.0-1
- - extra-cmake-modules 1.4.0 (KDE Frameworks 5.4.0)
- * Tue Oct 07 2014 Daniel Vrátil <dvratil@redhat.com> - 1.3.0-1
- - extra-cmake-modules 1.3.0 (KDE Frameworks 5.3.0)
- * Tue Sep 16 2014 Daniel Vrátil <dvratil@redhat.com> - 1.2.1-1
- - extra-cmake-modules 1.2.1 (KDE Frameworks 5.2.0)
- * Mon Sep 15 2014 Daniel Vrátil <dvratil@redhat.com> - 1.2.0-1
- - extra-cmake-modules 1.2.0 (KDE Frameworks 5.2.0)
- * Wed Aug 06 2014 Daniel Vrátil <dvratil@redhat.com> - 1.1.0-1
- - extra-cmake-modules 1.1.0 (KDE Frameworks 5.1.0)
- * Thu Jul 10 2014 Daniel Vrátil <dvratil@redhat.com> - 1.0.0-1
- - extra-cmake-modules 1.0.0 (KDE Frameworks 5.0.0)
- * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.14-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
- * Tue Jun 03 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.14-2
- - Strip architecture check from a CMake-generated file to fix noarch build
- * Tue Jun 03 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.14-1
- - extra-cmake-modules 0.0.14 (KDE Frameworks 4.100.0)
- * Mon May 05 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.13-1
- - extra-cmake-modules 0.0.13 (KDE Frameworks 4.99.0)
- * Fri Apr 11 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.12-3
- - Remove debug_package, add %%{?dist} to Release
- * Fri Apr 11 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.12-2
- - Don't depend on kf5-filesystem
- * Mon Mar 31 2014 Jan Grulich <jgrulich@redhat.com> 0.0.12-1
- - Update to KDE Frameworks 5 Beta 1 (4.98.0)
- * Wed Mar 05 2014 Jan Grulich <jgrulich@redhat.com> 0.0.11-1
- - Update to KDE Frameworks 5 Alpha 2 (4.97.0)
- * Wed Feb 12 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.10-1
- - Update to KDE Frameworks 5 Alpha 1 (4.96.0)
- * Wed Feb 05 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.10-0.1.20140205git
- - Update to pre-relase snapshot of 0.0.10
- * Tue Feb 04 2014 Lubomir Rintel <lkundrak@v3.sk> - 0.0.9-1
- - Update to Jan 7 release
- * Mon Sep 16 2013 Lubomir Rintel <lkundrak@v3.sk> - 0.0.9-0.1.20130013git5367954
- - Initial packaging
|