mdadm-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317
  1. %define _tmpfilesdir %{_sysconfdir}/tmpfiles.d
  2. %define _udevrulesdir /lib/udev/rules.d
  3. Summary: Utilities for Linux md devices (software RAID arrays)
  4. Summary(ja): Linux の MD デバイス(ソフトウエアRAIDアレイ)用のユーティリティ
  5. Name: mdadm
  6. Version: 4.0
  7. Release: 1%{?_dist_release}
  8. Source: https://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
  9. Source1: mdmonitor.init
  10. Source2: raid-check
  11. Source3: mdadm.rules
  12. Source4: mdadm-raid-check-sysconfig
  13. Source5: mdadm-cron
  14. Source6: mdmonitor.service
  15. Source7: mdadm.conf
  16. Source8: mdadm_event.conf
  17. Patch93: add-Wimplicit-fallthrough-0-in-Makefile.patch
  18. Patch94: forced-type-conversion-to-avoid-truncation.patch
  19. Patch95: replace-snprintf-with-strncpy-at-some-places.patch
  20. Patch96: specify-enough-length-when-write-to-buffer.patch
  21. Patch97: mdadm-3.3-udev.patch
  22. Patch98: mdadm-2.5.2-static.patch
  23. URL: http://www.kernel.org/pub/linux/utils/raid/mdadm/
  24. License: GPL
  25. Group: System Environment/Base
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. Obsoletes: mdctl,raidtools
  28. Requires: smtpdaemon
  29. BuildRequires: glibc-static
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. %description
  33. mdadm is used to create, manage, and monitor Linux MD (software RAID)
  34. devices. As such, it provides similar functionality to the raidtools
  35. package. However, mdadm is a single program, and it can perform
  36. almost all functions without a configuration file, though a configuration
  37. file can be used to help with some common tasks.
  38. %prep
  39. %setup -q
  40. # Fedora customization patches
  41. %patch93 -p1 -b .fallthrough
  42. %patch94 -p1 -b .forced
  43. %patch95 -p1 -b .replace
  44. %patch96 -p1 -b .buffer
  45. %patch97 -p1 -b .udev
  46. %patch98 -p1 -b .static
  47. %build
  48. make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
  49. %install
  50. rm -rf %{buildroot}
  51. #make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=%{_sbindir} SYSTEMD_DIR=%{_unitdir} install install-systemd
  52. make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin install
  53. install -Dp -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/raid-check
  54. install -Dp -m 644 %{SOURCE3} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
  55. install -Dp -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/raid-check
  56. install -Dp -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/cron.d/raid-check
  57. # tmpfile
  58. mkdir -p %{buildroot}%{_tmpfilesdir}
  59. install -m 0644 %{SOURCE7} %{buildroot}%{_tmpfilesdir}/%{name}.conf
  60. mkdir -p %{buildroot}%{_localstatedir}/run/
  61. install -d -m 0710 %{buildroot}%{_localstatedir}/run/%{name}/
  62. # initscript
  63. mkdir -p %{buildroot}%{_initdir}
  64. install -m755 %{SOURCE1} %{buildroot}%{_initdir}/mdmonitor
  65. # systemd
  66. #mkdir -p %{buildroot}%{_unitdir}
  67. #install -m644 %{SOURCE6} %{buildroot}%{_unitdir}
  68. # abrt
  69. #mkdir -p %{buildroot}/etc/libreport/events.d
  70. #install -m644 %{SOURCE8} %{buildroot}/etc/libreport/events.d
  71. %clean
  72. rm -rf %{buildroot}
  73. %post
  74. /sbin/chkconfig --add mdmonitor
  75. %preun
  76. if [ "$1" = 0 ]; then
  77. service mdmonitor stop > /dev/null 2>&1 ||:
  78. /sbin/chkconfig --del mdmonitor
  79. fi
  80. if [ -e %{_initrddir}/mdmpd ]; then
  81. service mdmpd stop > /dev/null 2>&1 ||:
  82. /sbin/chkconfig --del mdmpd
  83. fi
  84. %postun
  85. if [ "$1" -ge "1" ]; then
  86. service mdmonitor condrestart > /dev/null 2>&1
  87. fi
  88. %files
  89. %defattr(-,root,root)
  90. %doc TODO ChangeLog mdadm.conf-example COPYING misc/*
  91. /sbin/*
  92. %{_sbindir}/*
  93. %{_initdir}/*
  94. %{_mandir}/man*/md*
  95. %{_udevrulesdir}/*
  96. %config(noreplace) %{_sysconfdir}/sysconfig/*
  97. %config(noreplace) %{_sysconfdir}/cron.d/*
  98. %dir %{_localstatedir}/run/%{name}/
  99. %config(noreplace) %{_tmpfilesdir}/%{name}.conf
  100. %changelog
  101. * Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0-1
  102. - new upstream release.
  103. * Fri Jan 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
  104. - new upstream release.
  105. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-4
  106. - rebuild with VineSeed environment
  107. * Mon Apr 18 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-3
  108. - added BR: glibc-static
  109. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-2
  110. - rebuilt with rpm-4.8.1-3
  111. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.9-1
  112. - new upstream release
  113. * Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1vl5
  114. - applied new versioning policy, spec in utf-8
  115. * Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
  116. - new upstream release
  117. * Wed Aug 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
  118. - initial build for Vine Linux
  119. * Mon Aug 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.3-1
  120. - Update to 2.5.3 which upstream calls a "bug fix" release
  121. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.2-1.1
  122. - rebuild
  123. * Fri Jul 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.2-1
  124. - Update to 2.5.2
  125. - Remove auto default patch as upstream now has a preferred default auto method
  126. * Wed Mar 8 2006 Peter Jones <pjones@redhat.com> - 2.3.1-3
  127. - fix build on ppc64
  128. * Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-2
  129. - fix build on ppc
  130. * Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
  131. - update to 2.3.1 to fix raid5 (#184284)
  132. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2.1
  133. - bump again for double-long bug on ppc(64)
  134. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2
  135. - rebuilt for new gcc4.1 snapshot and glibc changes
  136. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  137. - rebuilt
  138. * Mon Dec 05 2005 Warren Togami <wtogami@redhat.com> 2.2-1
  139. - 2.2 upgrade (#167897)
  140. - disable diet because we don't ship it anymore
  141. and we don't actually use mdassemble now
  142. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-4.fc4
  143. - Make the mdmonitor init script use the pid-file option, major cleanup
  144. of the script now possible (#134459)
  145. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-3.fc4
  146. - Put back the obsoletes: raidtools that was present in 1.11.0-1.fc4
  147. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-2.fc4
  148. - Change the default auto= mode so it need not be on the command line to
  149. work with udev, however it is still supported on the command line (#132706)
  150. - Add a man page (from Luca Berra) for mdassemble
  151. * Wed May 11 2005 Doug Ledford <dledford@redhat.com> - 1.11.0-1.fc4
  152. - Upgrade to 1.11.0
  153. * Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.9.0-3.fc4
  154. - fix mdmonitor initscript (#144717)
  155. * Mon Mar 21 2005 Doug Ledford <dledford@redhat.com> 1.9.0-2
  156. - Build mdadm.static and mdassemble (static as well) to be used in initrd
  157. images
  158. * Wed Mar 09 2005 Doug Ledford <dledford@redhat.com> 1.9.0-1
  159. - Initial upgrade to 1.9.0 and update of doc files
  160. - Fix an s390 build error
  161. * Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2
  162. - Remove /etc/mdadm.conf from the file list. Anaconda will write one out
  163. if it's needed.
  164. * Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1
  165. - Update to newer upstream version
  166. - Make mdmpd work on kernels that don't have the event interface patch
  167. * Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11
  168. - Create a directory /var/run/mdadm to contain mdadm.pid
  169. - This cleans up SELinux problem
  170. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  171. - rebuilt
  172. * Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9
  173. - Fix Makefile and build method to satisfy bz #123769
  174. - Add mdmpd man page, update mdmpd version to 0.3 - bz #117160
  175. - Make sure mdadm --monitor closes all md device files so that md devices
  176. can be stopped while mdadm is still running - bz #119532
  177. * Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8
  178. - remove unneeded patch, can use --run instead
  179. * Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7
  180. - add patch with reallyforce mode on creation to be used by anaconda
  181. * Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
  182. - Fix a bug in the %postun scriptlet related to downgrading to a version
  183. of mdadm that doesn't include the mdmpd daemon.
  184. * Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
  185. - Disable service mdmpd by default to avoid [Failed] messages on
  186. current 2.6 kernels. Possibly re-enable it by default once the
  187. 2.6 kernels have the md event interface.
  188. * Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4
  189. - Update mdmonitor script to start daemon more cleanly
  190. - Repackage mdmpd tarball to include gcc-3.4 changes and to make
  191. mdmpd properly daemonize at startup instead of forking and leaving
  192. the child attached to the terminal.
  193. * Thu Mar 4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3
  194. - ship /var/run/mpmpd (#117497)
  195. * Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2
  196. - Add a default MAILADDR line to the mdadm.conf file installed by default
  197. (Bugzilla #92447)
  198. - Make it build with gcc-3.4
  199. * Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1
  200. - Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>)
  201. * Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1
  202. - fix problem with recovery thread sleeping in mdmpd
  203. * Fri Nov 14 2003 Doug Ledford <dledford@redhat.com>
  204. - sync upstream
  205. - add mdmpd package into mdadm package
  206. * Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1
  207. - sync upstream
  208. * Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1
  209. - sync upstream
  210. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1
  211. - update for rebuild
  212. * Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8
  213. - fix references to %%install in the changelog so that it will build
  214. * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7
  215. - Rebuild
  216. * Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com>
  217. - Changed RPM Group to System Environment/Base
  218. * Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com>
  219. - minor cleanups to the text, conditionalize rm -rf
  220. - added mdmonitor init script
  221. * Fri May 10 2002 <neilb@cse.unsw.edu.au>
  222. - update to 1.0.0
  223. - Set CXFLAGS instead of CFLAGS
  224. * Sat Apr 6 2002 <neilb@cse.unsw.edu.au>
  225. - change %%install to use "make install"
  226. * Fri Mar 15 2002 <gleblanc@localhost.localdomain>
  227. - beautification
  228. - made mdadm.conf non-replaceable config
  229. - renamed Copyright to License in the header
  230. - added missing license file
  231. - used macros for file paths
  232. * Fri Mar 15 2002 Luca Berra <bluca@comedia.it>
  233. - Added Obsoletes: mdctl
  234. - missingok for configfile
  235. * Tue Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au>
  236. - Add md.4 and mdadm.conf.5 man pages
  237. * Fri Mar 08 2002 Chris Siebenmann <cks@cquest.utoronto.ca>
  238. - builds properly as non-root.
  239. * Fri Mar 08 2002 Derek Vadala <derek@cynicism.com>
  240. - updated for 0.7, fixed /usr/share/doc and added manpage
  241. * Tue Aug 07 2001 Danilo Godec <danci@agenda.si>
  242. - initial RPM build