chromium-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. # norootforbuild
  5. #% define with_system_icu 1
  6. %define svn_rev 43947
  7. Name: chromium
  8. Summary: Google's opens source browser project
  9. Summary(ja): Googleのオープンソースウェブブラウザ
  10. #'
  11. Version: 5.0.372.0
  12. Release: 1%{?_dist_release}
  13. License: BSD
  14. Group: Applications/Internet
  15. Source0: %{name}.%{version}.svn%{svn_rev}.tar.lzma
  16. ## The following are included for source reasons only
  17. # Custom build tools for chromium, hammer is a fancy front-end for scons
  18. Source1: http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
  19. %{?nosrc:NoSource: 0}
  20. %{?nosrc:NoSource: 1}
  21. # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
  22. Source2: repack_chromium_archive.sh
  23. # Script used to create the tar.lzma archive from a checked out source
  24. #Source3: pack_chromium_source.sh
  25. Source3: pack_chromium_source-vine.sh
  26. #Source10: chromium.desktop
  27. Source10: chromium-vine.desktop
  28. # Patch template which adds vendor to user agent
  29. ##!!Source20: chromium-vendor.patch.in
  30. Source20: chromium-vendor-vine.patch.in
  31. ##!!Source30: master_preferences
  32. Source30: master_preferences.vine
  33. Provides: chromium-browser = %{version}
  34. #Obsoletes: chromium-browser < %{version}
  35. ## Start Patches
  36. # Many changes to the gyp system so we can use system libraries
  37. # My first ever patch set. I hope I did well.
  38. Patch3: chromium-gyp-system-02-icu.patch
  39. Patch4: chromium-no-sqlite-debug.patch
  40. Patch5: chromium-gyp-system-04-nss-nspr.patch
  41. Patch7: chromium-codechanges-nss-nspr.patch
  42. Patch8: chromium-codechanges-zlib.patch
  43. Patch9: chromium-drop-sse.patch
  44. Patch10: chromium-fix-wrapper.patch
  45. Patch11: chromium-fix-home-kde4-path.patch
  46. Patch12: chromium-no-test-sources.patch
  47. Patch13: chromium-no-courgette.patch
  48. Patch14: chromium-master-prefs-path.patch
  49. Patch15: chromium-media-probe.patch
  50. Patch16: chromium-icu-code-changes.patch
  51. Patch17: chromium-system-glew.patch
  52. Patch18: chromium-system-expat.patch
  53. Patch19: chromium-system-zlib.patch
  54. Patch20: chromium-noffmpeg.patch
  55. Patch21: chromium-system-old-ffmpeg-way.patch
  56. Patch22: chromium-libpng14.patch
  57. # Vine
  58. #Patch40: chromium-5.0.353-no-ffmpeg-vine.patch
  59. ## Gentoo patches
  60. # Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
  61. #Patch50: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
  62. BuildRequires: gcc gcc-c++
  63. %if %{?_dist_release} == "vl5"
  64. BuildRequires: libstdc++34 libstdc++34-devel
  65. %elseif %{?_dist_release} == "vl6"
  66. BuildRequires: libstdc++ libstdc++-devel
  67. %endif
  68. BuildRequires: libevent
  69. ##!!BuildRequires: pkg-config
  70. BuildRequires: python
  71. ##!!BuildRequires: python-xml
  72. BuildRequires: python-pyxml
  73. BuildRequires: perl bison flex gperf
  74. ##!!BuildRequires: wdiff
  75. ##!!BuildRequires: update-desktop-files
  76. BuildRequires: desktop-file-utils
  77. BuildRequires: lzma
  78. ##!!BuildRequires: mozilla-nss-devel
  79. BuildRequires: nss-devel
  80. ##!!BuildRequires: alsa-devel
  81. BuildRequires: alsa-lib-devel
  82. BuildRequires: gtk2-devel
  83. BuildRequires: glib2-devel
  84. BuildRequires: cairo-devel >= 1.6
  85. ##!!BuildRequires: mozilla-nspr-devel
  86. BuildRequires: nspr-devel
  87. ##!!BuildRequires: gconf2-devel
  88. BuildRequires: GConf2-devel
  89. BuildRequires: freetype2-devel
  90. ##!!BuildRequires: dbus-1-devel
  91. BuildRequires: dbus-devel
  92. BuildRequires: libxslt-devel
  93. BuildRequires: libxml2-devel
  94. BuildRequires: libjpeg-devel
  95. BuildRequires: zlib-devel
  96. BuildRequires: libpng-devel
  97. ##!!BuildRequires: libbz2-devel
  98. BuildRequires: bzip2-devel
  99. %if %{?_dist_release} == "vl6"
  100. BuildRequires: fdupes
  101. %endif
  102. ##!!BuildRequires: libexpat-devel
  103. BuildRequires: expat-devel
  104. BuildRequires: glew-devel
  105. ##!!BuildRequires: Mesa-devel
  106. BuildRequires: mesa-libGLU-devel
  107. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  108. BuildRequires: libevent-devel
  109. ##Vine Linux
  110. BuildRequires: libXScrnSaver-devel
  111. #BuildRequires: gle-devel
  112. #BuildRequires: webkit-gtk-devel
  113. #BuildRequires: scons
  114. %ifarch x86_64
  115. Requires: nspluginwrapper
  116. %endif
  117. ##!!Requires: alsa
  118. Requires: alsa-lib
  119. # shouldn't be required to name all dependencies
  120. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  121. ## Recommends the ffmpeg libraries (available from packman)
  122. #Recommends: libavcodec52 libavformat52 libavutil50
  123. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  124. %description
  125. Chromium is the open-source project behind Google Chrome.
  126. We invite you to join us in our effort to help build a safer, faster,
  127. and more stable way for all Internet users to experience the web,
  128. and to create a powerful platform for developing a new generation of
  129. web applications.
  130. %description -l ja
  131. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  132. 私たちは、ウェブを体験しているすべてのインターネットユーザに対して
  133. より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
  134. ウェブアプリケーションの新しい世代を発展させるように
  135. 強力なプラットホームを作成するために、
  136. 私たちの取り組みで私たちに加わるようにあなたを誘います。
  137. %prep
  138. [ -d %{name} ] && %__rm -rf %{name}
  139. lzma -cd %{SOURCE0} | tar xf -
  140. %setup -D -T -n %{name}
  141. # use system libicu only if >= 4.0
  142. %{?with_system_icu:%patch3 -p1}
  143. %patch4 -p1
  144. %patch5 -p1
  145. %patch7 -p1
  146. %patch8 -p1
  147. %patch9 -p1
  148. %patch10 -p1
  149. %patch11 -p1
  150. %patch12 -p1
  151. %patch13 -p1
  152. %patch14 -p1
  153. %patch15 -p0
  154. %{?with_system_icu:%patch16 -p1}
  155. %patch17 -p1
  156. %patch18 -p1
  157. %patch19 -p1
  158. %patch20 -p1
  159. %patch21 -p1
  160. %patch22 -p1
  161. # apply vendor patch after substitution
  162. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  163. %build
  164. ## create make files
  165. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  166. for i in src/build/common.gypi; do
  167. %__sed -i "s|'-march=pentium4',||g" $i
  168. %__sed -i "s|'-msse2',||g" $i
  169. %__sed -i "s|'-mfpmath=sse',||g" $i
  170. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  171. %__sed -i "s|'-m32',||g" $i
  172. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  173. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  174. done
  175. # '
  176. pushd src
  177. ./build/gyp_chromium -f make build/all.gyp \
  178. -Duse_system_ffmpeg=1 \
  179. -Duse_system_zlib=1 \
  180. -Duse_system_libpng=1 \
  181. -Duse_system_bzip2=1 \
  182. -Duse_system_libjpeg=1 \
  183. -Duse_system_libxml=1 \
  184. -Duse_system_libxslt=1 \
  185. -Duse_system_libevent=1 \
  186. %{?with_system_icu:-Duse_system_icu=1} \
  187. %{!?with_system_icu:-Duse_system_icu=0} \
  188. %ifarch %{ix86}
  189. -Dtarget_arch=ia32 \
  190. %endif
  191. %ifarch x86_64
  192. -Dtarget_arch=x64 \
  193. %endif
  194. %if %{?_dist_release} == "vl6"
  195. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  196. %endif
  197. -Drelease_extra_cflags=-fPIC \
  198. ;
  199. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  200. #%__make -r -j5 chrome BUILDTYPE=Release
  201. %__make %{?_smp_mflags} chrome BUILDTYPE=Release
  202. popd
  203. %install
  204. %{__rm} -rf %{buildroot}
  205. ## Create install directories
  206. %{__mkdir_p} %{buildroot}%{_libdir}/%{name}
  207. %{__mkdir_p} %{buildroot}%{_bindir}
  208. %{__mkdir_p} %{buildroot}%{_datadir}/applications
  209. %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
  210. %{__mkdir_p} %{buildroot}%{_mandir}/man1
  211. %{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
  212. # chromium 'make' deposits us back at the top level build directory
  213. pushd src/out/Release
  214. ls -l
  215. # clean somechromium-codechanges-zlib.patch
  216. # clean debug junk
  217. %{__rm} -rf obj/ mksnapshot obj.target obj.host
  218. find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
  219. # clean NaCl stuff... maybe NaCl will be in its own package in the future.
  220. %{__rm} -f ncdecode_table ncdecode_tablegen
  221. # clean other temporary binaries used in the compilation of chromium
  222. %{__rm} -f protoc xdg-settings
  223. %{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
  224. # Man page
  225. [ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
  226. %__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
  227. # Add startup file with plugins enabled
  228. %{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
  229. #!/bin/bash
  230. %{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
  231. EOF
  232. # # link to browser plugin path. Plugin patch doesn't work. Why?
  233. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  234. # pushd %{buildroot}%{_libdir}/%{name}
  235. # %{__ln_s} %{_libdir}/browser-plugins plugins
  236. # popd
  237. pushd %{buildroot}%{_libdir}/%{name}
  238. %ifarch x86_64
  239. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  240. %else
  241. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  242. %endif
  243. #touch %{buildroot}%{_libdir}/libavcodec.so.52
  244. #%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  245. #touch %{buildroot}%{_libdir}/libavformat.so.52
  246. #%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  247. #touch %{buildroot}%{_libdir}/libavutil.so.50
  248. #%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  249. popd
  250. # Install desktop-related files
  251. %__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
  252. %__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
  253. desktop-file-install --vendor Vine \
  254. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  255. --delete-original \
  256. --mode 644 \
  257. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  258. # Install the master_preferences file
  259. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
  260. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
  261. ## install o3d plugin
  262. #pushd src/o3d/build/out/Release
  263. #%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
  264. %clean
  265. %{__rm} -rf %{buildroot}
  266. %files
  267. %defattr(-,root,root)
  268. %doc src/AUTHORS src/LICENSE
  269. %dir %{_libdir}/%{name}
  270. %attr(0755,root,root) %{_bindir}/%{name}
  271. %{_mandir}/man1/*
  272. %{_datadir}/applications/*%{name}.desktop
  273. %{_datadir}/pixmaps/%{name}.png
  274. %{_libdir}/%{name}/*
  275. %config %{_sysconfdir}/%{name}
  276. #%{_libdir}/browser-plugins/*
  277. #%exclude %{_libdir}/libavcodec.so.52
  278. #%exclude %{_libdir}/libavutil.so.50
  279. #%exclude %{_libdir}/libavformat.so.52
  280. %changelog
  281. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  282. - updated to snapshot 5.0.372.0 r43947
  283. - added BuildRequires: glew-devel
  284. - changed Group tag to Applications/Internet
  285. - added Summary(ja) and %%description -l ja
  286. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  287. - updated to snapshot 5.0.365.0 r42966
  288. - merged 5.0.353.0-4vl5
  289. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  290. - build on Vine Linux 5.1
  291. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  292. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  293. - updated to snapshot 5.0.364.0 r42779
  294. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  295. - updated to snapshot 5.0.359.0 r42116
  296. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  297. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  298. - fixed master_preferences.vine, little
  299. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  300. - fixed to install master_preferences
  301. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  302. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  303. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  304. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  305. - updated to snapshot 5.0.353.0 r41449
  306. * Wed Mar 10 2010 bgmerrell@novell.com
  307. - Add master_preferences source file and install it to /etc/chromium.
  308. - Create a new patch (chromium-master-prefs-path.patch) which tells
  309. chromium to look in /etc/chromium for the master_preferences file
  310. (instead of looking in the default directory, which is the same
  311. directory as the 'chrome' binary).
  312. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  313. - updated to snapshot 5.0.335.0 r39556
  314. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  315. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  316. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  317. - updated to snapshot 5.0.330.0 r39074
  318. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  319. - use_system_ffmpeg
  320. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  321. - added Requires: nspluginwrapper
  322. - fixed a symbolic link of plugins directory with nspluginwrapper
  323. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  324. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  325. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  326. - added BuildRequires: mesa-libGLU-devel
  327. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  328. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  329. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  330. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  331. - Update to 4.0.260
  332. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  333. - Update to 4.0.259
  334. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  335. - Update to 4.0.258
  336. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  337. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  338. changed to having an built-in v8
  339. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  340. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  341. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  342. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  343. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  344. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  345. - update to newer svn snapshot
  346. + Obsoletes fwrite patch (included upstream)
  347. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  348. - update to newer svn snapshot
  349. + Requires newer version of v8
  350. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  351. - do not force SSE on x86 (drop-sse.patch)
  352. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  353. - Update to newer svn snapshot
  354. - Fixed spec file in order to build
  355. - Included patch to build with system zlib
  356. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  357. - package renamed to chromium
  358. - cleaned up spec file
  359. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  360. - v8 is now built as a separate package, and is required
  361. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  362. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  363. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  364. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  365. - initial build
  366. #% changelog
  367. * Sun Jan 24 2010 prusnak@suse.cz
  368. - added vendor to user agent (chromium-vendor.patch.in)
  369. * Sun Nov 29 2009 prusnak@suse.cz
  370. - added --enable-sync to wrapper to enable bookmark sync
  371. * Fri Nov 13 2009 tittiatcoke@gmail.com
  372. - update to 247.0 svn 31928
  373. * Fri Oct 30 2009 tittiatcoke@gmail.com
  374. - update to 229.0 svn 30454
  375. + Fix regression where popups and app frames lost their titlebars.
  376. + Makes it so that when a folder is open on the bookmark bar
  377. and the mouse moves over another folder, the menu for that
  378. folder is shown.
  379. + Lazily create the find bar.
  380. + Polish to the gmail checker sample.
  381. * New, crisper icons that are exactly 19x19
  382. * Add a loading animation at the beginning before Gmail
  383. responds.
  384. * Fix a bug where we sometimes don't update the UI after a
  385. logout/login cycle.
  386. + Refactor widget methods to support desktop notifications,
  387. including GTK stubs.
  388. + Find-in-page should not ding while deleting characters.
  389. + Add SSL wrapper for linux and mac. This allows notifier to
  390. use chrome's SSL layer instead of OpenSSL.
  391. + Add three of the six extensions to PAC that Internet Explorer supports.
  392. + WebSocket support in chromium. (Run with --enable-web-sockets
  393. enables WebSocket features.)
  394. + Do not allow GTK File Chooser dialogs to return directories.
  395. + Fix the notifier SSL layer to make notifications work for
  396. Linux Bookmark sync.
  397. + linux: don't override mouse selection behavior in omnibox
  398. * Sun Oct 25 2009 tittiatcoke@gmail.com
  399. - Update to 224.4 svn 30027
  400. + First cut at new page and browser action docs based
  401. on new API. Deleted old stuff.
  402. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  403. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  404. + Minimize dependency of user scripts
  405. + Fixup the flip_framer eof-handling semantics now that we have
  406. the FIN bit in place
  407. + app depends on x11 because of active_window_watcher_x
  408. + Adding two images for the new Extension managment UI
  409. + Removing hard-coded Chrome Frame output path
  410. + Rearrange clipboard code
  411. + Fix crash bug when attempting to download a url with unsupported scheme,
  412. e.g. 'data:', by 'Alt + Click'
  413. + GTK: Change text for extension download UI
  414. + Ignore invalid urls on command line
  415. + Make dropped tabs animate from where they were dropped.
  416. + Make room for the full width of the tab placeholder.
  417. + Make tab dragging as smooth as glass.
  418. + Remove an annoying NOTIMPLEMNETED
  419. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  420. + If we're in the middle of a drag, don't allow the user to middle
  421. click to close or right click for the context menu
  422. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  423. + Remove +x bit from files that shouldn't have it
  424. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  425. + Adding new image needed for the managment UI
  426. + Fix a race bug where content scripts would not apply to the first page load
  427. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  428. + Fix bubbles deactivating the opaque frame
  429. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  430. + ake all pepper plugins default to windowless and transparent
  431. + Add styles for printing
  432. + Implement the new extension management UI
  433. + Add support for to automation interface load install and load extensions
  434. + GTK: theme the info bar border
  435. + Update V8 to version 1.3.16.1
  436. + Introduce WebSecurityPolicy for security related methods
  437. + New button scheme...borders are separate from the inner contents so
  438. that they can be highlighted / depressed independently
  439. + When opening Chrome maximized with an application window already
  440. running, the Chrome window was not activated
  441. + Fix compatibility problems with FileZilla FTP Server
  442. + Remove the extension shelf on Linux
  443. + Fix the proxy host and port string to start with http:// if it does not already
  444. + Enable HTML5 databases for all extension renderer processes