rhythmbox-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 0.13.1
  8. Release: 1%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: libgpod-devel
  15. BuildRequires: libgnomeui-devel >= 2.18.0
  16. BuildRequires: brasero-devel
  17. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  18. BuildRequires: gettext, rarian-compat
  19. BuildRequires: totem-pl-parser-devel
  20. BuildRequires: sqlite3-devel
  21. BuildRequires: libffi-devel
  22. BuildRequires: gnome-vfs2-devel >= 2.18.0
  23. BuildRequires: avahi-glib-devel >= 0.6
  24. BuildRequires: libmusicbrainz-devel >= 2.1.0
  25. BuildRequires: libnotify-devel
  26. BuildRequires: libsexy-devel
  27. BuildRequires: libgudev1-devel
  28. BuildRequires: libsoup-devel
  29. BuildRequires: dbus-devel >= 1.0
  30. BuildRequires: dbus-glib-devel
  31. BuildRequires: gnome-doc-utils >= 0.3.2
  32. BuildRequires: python-devel, pygtk2-devel
  33. BuildRequires: check >= 0.8.2
  34. BuildRequires: intltool >= 0.35.0
  35. BuildRequires: gstreamer-python
  36. BuildRequires: popt-devel
  37. BuildRequires: lirc
  38. BuildRequires: libmtp-devel
  39. BuildRequires: libgnome-keyring-devel >= 2.30.0
  40. BuildRequires: gnome-media-devel
  41. BuildRequires: libSM-devel
  42. Requires: libgpod
  43. Requires: libnotify
  44. Requires: libsexy
  45. Requires: lirc
  46. Requires: libmtp
  47. Requires: libgnomeui
  48. Requires: brasero
  49. Requires: gnome-python gnome-vfs2
  50. Requires: gnome-themes
  51. Requires: libgnome-keyring
  52. Requires: gstreamer-python
  53. %if %{enable_DLNA_UPnP}
  54. Requires: python-Coherence
  55. %endif
  56. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  57. Requires: scrollkeeper GConf2
  58. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  59. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  60. # # respectively.
  61. # Requires: self-build-gstreamer-plugins-ffmpeg
  62. # Requires: self-build-gstreamer-plugins-ugly
  63. %description
  64. Rhythmbox is an integrated music management application based on the powerful
  65. GStreamer media framework. It has a number of features, including an easy to
  66. use music browser, searching and sorting, comprehensive audio format support
  67. through GStreamer, Internet Radio support, playlists and more.
  68. Rhythmbox is extensible through a plugin system.
  69. %description -l ja
  70. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  71. 統合音楽管理アプリケーションです。
  72. 見やすいユーザインターフェースを備え、検索や整列ができ、
  73. GStreamer により数多くの音声フォーマットをサポート、
  74. インターネットラジオをサポート、プレイリスト管理などの
  75. 数多くの特徴を持ちます。
  76. %package devel
  77. Summary: Development tools for rhythmbox applications.
  78. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  79. Group: Development/Libraries
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: pkgconfig
  82. Requires: glib2-devel
  83. Requires: gtk2-devel
  84. Requires: libsoup-devel
  85. Requires: gnome-media-devel
  86. Requires: totem-pl-parser-devel
  87. Requires: gstreamer-devel
  88. %description devel
  89. Header files and libraries for building a extension library for the rhythmbox.
  90. %description devel -l ja
  91. %prep
  92. %setup -q
  93. # autoreconf -i
  94. # Use the installed louie, not the one in Coherence
  95. find plugins/coherence/upnp_coherence/ -type f \
  96. -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
  97. %build
  98. # work around a gstreamer bug
  99. /usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
  100. %configure --with-ipod \
  101. --with-mtp \
  102. --with-dbus \
  103. --with-mdns=avahi \
  104. --with-libnautilus-burn \
  105. --with-cd-burning \
  106. --with-metadata-helper \
  107. --enable-lirc \
  108. --enable-python \
  109. --disable-vala \
  110. --disable-browser-plugin \
  111. --disable-static \
  112. --disable-scrollkeeper \
  113. --disable-schemas-install \
  114. --without-hal
  115. %__make %{?_smp_mflags}
  116. %install
  117. %__rm -rf $RPM_BUILD_ROOT
  118. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  119. %__make install DESTDIR=$RPM_BUILD_ROOT
  120. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  121. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  122. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  123. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  124. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  125. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  126. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  127. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  128. ## Don't package DLNA/UPnP plugin
  129. %if !%{enable_DLNA_UPnP}
  130. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  131. %endif
  132. %find_lang %{name}
  133. # Don't package api docs
  134. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  135. # Don't package scrollkeeper catalogs
  136. %__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
  137. # And don't package vala
  138. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  139. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  140. # save space by linking identical images in translated docs
  141. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  142. for f in $helpdir/C/figures/*.png; do
  143. b="$(basename $f)"
  144. for d in $helpdir/*; do
  145. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  146. g="$d/figures/$b"
  147. if [ -f "$g" ]; then
  148. if cmp -s $f $g; then
  149. %__rm "$g"; ln -s "../../C/figures/$b" "$g"
  150. fi
  151. fi
  152. fi
  153. done
  154. done
  155. %clean
  156. %__rm -rf $RPM_BUILD_ROOT
  157. %post
  158. /sbin/ldconfig
  159. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  160. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
  161. update-desktop-database -q
  162. scrollkeeper-update -q
  163. touch --no-create %{_datadir}/icons/hicolor
  164. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  165. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  166. fi
  167. %preun
  168. if [ "$1" -eq 0 ]; then
  169. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  170. gconftool-2 --makefile-uninstall-rule \
  171. %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
  172. fi
  173. %postun
  174. /sbin/ldconfig
  175. update-desktop-database -q
  176. scrollkeeper-update -q
  177. touch --no-create %{_datadir}/icons/hicolor
  178. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  179. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  180. fi
  181. %files -f %{name}.lang
  182. %defattr(-, root, root)
  183. %doc AUTHORS COPYING ChangeLog README NEWS
  184. %{_sysconfdir}/gconf/schemas/rhythmbox.schemas
  185. %{_bindir}/*
  186. %{_libdir}/lib*.so.*
  187. %{_libdir}/rhythmbox/plugins
  188. %{_datadir}/applications/rhythmbox.desktop
  189. %{_datadir}/applications/rhythmbox-device.desktop
  190. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
  191. %{_datadir}/gnome/help/rhythmbox
  192. %{_datadir}/icons/*
  193. %{_datadir}/omf/rhythmbox
  194. %{_datadir}/rhythmbox
  195. %{_mandir}/man1/*
  196. %{_libexecdir}/rhythmbox-metadata
  197. %files devel
  198. %defattr(-, root, root)
  199. %{_includedir}/%{name}/*
  200. %{_libdir}/*.so
  201. %{_libdir}/pkgconfig/*.pc
  202. %changelog
  203. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  204. - new upstream release
  205. - fix %files (add rhythmbox-device.desktop)
  206. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  207. - new upstream release
  208. - change BuildRequires: gnome-media-devel instead of gnome-media
  209. - add devel package
  210. - drop Patch0
  211. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  212. - new upstream release
  213. - drop Patch1, Patch2, Patch3
  214. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  215. - change Requires: nautilus-cd-burner -> brasero
  216. - change BuildRequires: hal-devel -> libgudev1-devel
  217. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  218. - change Requires: gnome-keyring -> libgnome-keyring
  219. - add configure option (--without-hal)
  220. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  221. - rebuilt with new environment
  222. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  223. - new upstream release
  224. - dropped upstreamed/obsolete patches
  225. - added patches applied Fedora development
  226. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  227. - new upstream release
  228. - added configure options:
  229. --disable-vala
  230. --disable-browser-plugin
  231. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  232. - added Japanese description
  233. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  234. - new upstream release
  235. - dropped rb-disable-power-plugin-by-default.patch
  236. - added BuildRequires:
  237. - libSM-devel
  238. - gnome-media
  239. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  240. - rebuild with libgpod-0.7.2
  241. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  242. - new upstream release
  243. - corrected License tag
  244. - dropped rhythmbox-0.11.6-libmtp.patch
  245. - added BuildRequires:
  246. - sqlite3-devel
  247. - libffi-devel
  248. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  249. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  250. - applied rhythmbox-0.11.6-libmtp.patch
  251. - added Requires:
  252. - libgpod
  253. - libnotify
  254. - libsexy
  255. - lirc
  256. - libmtp
  257. - libgnomeui
  258. - nautilus-cd-burner
  259. - gstreamer-python
  260. - gnome-vfs2
  261. - gnome-themes
  262. - gnome-keyring
  263. - python-Coherence, if enable_DLNA_UPnP = 1
  264. - added BuildRequires:
  265. - libnotify-devel
  266. - libsexy-devel
  267. - lirc
  268. - libmtp-devel
  269. - gnome-vfs2-devel, instead of gnome-vfs2
  270. - gnome-keyring-devel
  271. - dropped --with-internal-libsexy in configure options
  272. - added in configure options:
  273. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  274. - added %%preun to remove the schema
  275. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  276. - new upstream release
  277. - changed to --with-metadata-helper in configure options
  278. - added BuildRequires:
  279. - gstreamer-python
  280. - intltool >= 0.35.0
  281. - popt-devel
  282. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  283. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  284. - rebuilt with python-2.5.2
  285. - applied new versioning policy
  286. - spec in utf-8
  287. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  288. - rebuilt with libgpod-0.6.0
  289. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  290. - new upstream release
  291. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  292. - new upstream release
  293. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  294. - rebuilt with new toolchain and libgpod-0.4.2
  295. - add BuildRequires: dbus-glib-devel
  296. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  297. - new upstream release
  298. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  299. - rebuilt for VineSeed
  300. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  301. - new upstream release
  302. - added --enable-python option to %%configure
  303. - added Requires: gnome-python
  304. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  305. - new upstream release
  306. - built with libsoup 2.2.99
  307. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  308. - added --with-cd-burner to configure
  309. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  310. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  311. - add BuildRequires:
  312. - gnome-doc-utils >= 0.3.2
  313. - python-devel
  314. - pygtk2-devel
  315. - check >= 0.8.2
  316. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  317. - rebuild with gnutls-1.4.1
  318. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  319. - new upstream release
  320. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  321. - new upstream release
  322. - run scrollkeeper-update at %post and %postun
  323. - added BuildRequires: libnotify-devel
  324. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  325. - new upstream release (dropped patch0)
  326. - added --without-metadata-helper at configure
  327. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  328. - Initial build for Vine Linux based on FC pacakge
  329. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  330. - add patch from James "Doc" Livingston to stop a hang
  331. for new users (bug 183883)
  332. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  333. - bump again for double-long bug on ppc(64)
  334. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  335. - rebuilt for new gcc4.1 snapshot and glibc changes
  336. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  337. - Update to 0.9.3.1
  338. - Use gstreamer (0.10)
  339. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  340. - Remove hack for 173869, as its no longer needed.
  341. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  342. - 0.9.3
  343. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  344. - Newer CVS snapshot
  345. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  346. - Update to latest CVS
  347. - Add hack to workaround bug #173869
  348. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  349. - Rebuild, now that gstreamer08-plugins has been fixed
  350. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  351. - bonobo multilib issue (bug 156982)
  352. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  353. - rebuild with ipod support
  354. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  355. - rebuilt again
  356. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  357. - rebuilt
  358. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  359. - rebuild
  360. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  361. - rebuild for new dbus
  362. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  363. - Update to 0.9.2
  364. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  365. - Update to 0.9.1
  366. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  367. - Add configure flags --with-bonobo --with-dbus
  368. - BR nautilus-cd-burner-devel
  369. - New upstream CVS snapshot for testing
  370. - Drop IDL file and ui .xml
  371. - Add dbus service file
  372. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  373. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  374. * Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  375. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  376. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  377. cell renderer for playback icon (no longer necessary) and
  378. changes the rating renderer to work with non-b&w icons
  379. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  380. - Rebuild for GCC4
  381. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  382. - New upstream version
  383. - Remove librb-nautilus-context-menu.so, killed upstream
  384. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  385. - PreReq desktop-file-utils >= 0.9
  386. * Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  387. - New upstream version
  388. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  389. - Fix postun to use correct syntax, thanks Nils Philippsen
  390. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  391. - New upstream version
  392. - Call update-desktop-database in post and postun
  393. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  394. - New upstream version
  395. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  396. - rebuilt
  397. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  398. - New upstream version
  399. - Remove backported patches
  400. - Gratuitiously bump various BuildRequires versions
  401. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  402. - Remove code to unregister GConf schema for now (Closes: #122532)
  403. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  404. - Apply tiny patch from 0.8 arch to fix GConf key used
  405. for initial sorting
  406. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  407. - Apply patch from 0.8 arch tree to fix a number of memleaks
  408. * Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  409. - Update to 0.8.3: fixes showstopper bug with internet radio
  410. * Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  411. - Update to 0.8.2
  412. - Fix Source url
  413. - Add smp_mflags
  414. - Bump BuildRequires on gstreamer to 0.8.1
  415. * Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  416. - Uninstall GConf schemas on removal
  417. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  418. - Update to 0.8.1
  419. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  420. - Update to 0.8.0
  421. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  422. - Update to 0.7.2
  423. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  424. - Remove BuildRequires on autoconf and libvorbis-devel
  425. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  426. - New major version - I know we are past major version slush, but
  427. this should have been done two weeks ago along with the GNOME 2.6
  428. upload. As upstream author as well, I believe this version is
  429. good enough for FC2.
  430. - Remove --disable-mp3
  431. - Remove id3, flac variables
  432. - Remove GStreamer major version patch
  433. - Fix typo in description
  434. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  435. - rebuild for new gstreamer
  436. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  437. - update to 0.6.8
  438. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  439. - rebuilt
  440. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  441. - update to 0.6.7
  442. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  443. - rebuilt
  444. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  445. - New upstream version
  446. - Don't re-run the autotools; upstream incorporates newer versions.
  447. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  448. - new version
  449. - remove smp_flags
  450. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  451. - remove the initial iradio channels as they all are mp3 based.
  452. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  453. - Fix category from Development/Libraries to Applications/Multimedia.
  454. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  455. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  456. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  457. - Removed unnecessary date expansion define.
  458. - Updated description, including mp3 reference removal.
  459. - Added libid3tag and flac optional support for convenient rebuild.
  460. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  461. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  462. - new version
  463. - use %{_sysconfdir} instead of /etc
  464. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  465. - rebuilt
  466. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  467. - gave up on other archs for the Beta
  468. - new version
  469. - remove werror and add missing files
  470. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  471. - update to newer cvs snap
  472. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  473. - update to cvs snap
  474. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  475. - use %%(lang)
  476. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  477. - fix post to actually install the schema
  478. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  479. - Added gconf file
  480. - Added i18n directory
  481. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  482. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  483. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  484. - removed bonobo dependency
  485. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  486. - created new spec file