self-build-broadcom-wl-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181
  1. %define pkgname broadcom-wl
  2. %define name self-build-%{pkgname}
  3. %define oname hybrid-portsrc
  4. %define over %(echo %{version} | tr . _)
  5. %define downloadurl https://docs.broadcom.com/docs-and-downloads/docs/linux_sta
  6. %ifarch %{ix86}
  7. %define source0path %{downloadurl}/hybrid-v35-nodebug-pcoem-%{over}.tar.gz
  8. %endif
  9. %ifarch x86_64
  10. %define source0path %{downloadurl}/hybrid-v35_64-nodebug-pcoem-%{over}.tar.gz
  11. %endif
  12. Summary: Package to automatically build %{pkgname} rpm package
  13. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  14. Name: %{name}
  15. Version: 6.30.223.271
  16. Release: 3%{?_dist_release}
  17. Source0: %{pkgname}-vl.spec
  18. Source1: blacklist-broadcom.conf
  19. Source100: broadcom-wl-kernel318.patch
  20. # Patches from Debian-sid
  21. Source101: 14-rdtscl.patch
  22. Source102: 15-linux47.patch
  23. Source103: 16-linux48.patch
  24. Source104: 17-fix-kernel-warnings.patch
  25. Source105: 18-linux411.patch
  26. Source106: 19-linux412.patch
  27. License: Freeware and GPLv2 with exception
  28. Group: Restricted Software
  29. Requires(pre): self-build-setup >= 0.7-1
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. ExclusiveArch: %{ix86} x86_64
  32. %description
  33. Proprietary hybrid driver for Broadcom wireless adapters.
  34. If you install this package, it automaticaly downloads source
  35. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  36. And the created rpm packages are automatically installed
  37. if installation is executed by apt-get command or synaptic
  38. package manager.
  39. [Note]
  40. This package requires many other packages to compile
  41. targetsoftware. So it consume more disk space than usual.
  42. Also installation takes logner time because of compilation.
  43. (This will take a few minutes to quarter or half of an hour,
  44. depends on building environment)
  45. [About self-build package]
  46. For some kind of software, distributing of binary package
  47. may viorate the patent or law. Therefore we chose self-build
  48. packge, create binary package on your machine, for such kind
  49. of softwares instead of distributing binary package.
  50. Please obey the national law when you use the created binary
  51. packages. And if you want to use the softwares using patented
  52. thechnology, it may be required to get a permission, make an
  53. agreement or purchas a license. Please consider it with your
  54. purpose or way of use and take appropriate action.
  55. %description -l ja
  56. Broadcom ワイヤレスアダプタ用のプロプライエタリドライバです。
  57. このパッケージをインストールすると、自動的にソースコードを
  58. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  59. の rpm パッケージを作成します。
  60. また apt-get コマンドや synaptic パッケージマネージャから実行
  61. した場合は、作成された rpm パッケージのインストールも自動的に
  62. 行います。
  63. [注意]
  64. コンパイルに必要な多くの関連パッケージを要求するので通常より
  65. ディスクの領域を多く消費します。
  66. またインストール時にコンパイルを行うため、通常より時間がかか
  67. る場合があります。(環境にもよりますが数分から数十分程度)
  68. [self-build パッケージについて]
  69. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  70. 違反する可能性があるものがあります。その為、このような問題が
  71. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  72. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  73. ジという方法を採っています。
  74. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  75. アのライセンス、および利用する国の各種法令に従ってください。
  76. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  77. センスの購入などが必要となる場合がありますので、利用する目的
  78. や形態に応じて各自で判断し適切な対応を取ってください。
  79. %install
  80. rm -rf %{buildroot}
  81. install -d %{buildroot}%{_datadir}/%{name}
  82. install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
  83. #install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/%{name}
  84. sed -e 's|##VERSION##|%{version}|g' -e 's|##RELEASE##|%{release}|g' \
  85. %{SOURCE0} > %{buildroot}%{_datadir}/%{name}/%{pkgname}-vl.spec
  86. # %{__install} -m 644 %{SOURCE100} \
  87. # $RPM_BUILD_ROOT/%{_datadir}/%{name}
  88. %{__install} -m 644 \
  89. %{SOURCE101} %{SOURCE102} %{SOURCE103} \
  90. %{SOURCE104} %{SOURCE105} %{SOURCE106} \
  91. $RPM_BUILD_ROOT/%{_datadir}/%{name}
  92. %clean
  93. rm -rf %{buildroot}
  94. %posttrans
  95. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{source0path}"
  96. /usr/lib/rpm/pre-allocate-rpm.sh dkms-%{pkgname}-%{version}-%{release}
  97. %files
  98. %defattr(-,root,root)
  99. %{_datadir}/%{name}/*
  100. %changelog
  101. * Tue Dec 05 2017 Toshiaki Ara <ara_t@384.jp> 6.30.223.271-3
  102. - add patches for build with kernel 4.12
  103. * Wed Nov 22 2017 Toshiaki Ara <ara_t@384.jp> 6.30.223.271-2
  104. - change download URL
  105. * Sat Oct 31 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.30.223.271-1
  106. - new upstream release.
  107. - dropped SOURCE100.
  108. - fixed date of changelog.
  109. * Sun Aug 2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.30.223.248-2
  110. - added Source100 to build with kernel 3.18
  111. * Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.30.223.248-1
  112. - new upstream release
  113. - dropped SOURCE2
  114. - updated dmks.conf
  115. * Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.100.82.112-1
  116. - new upstream release.
  117. - dropped an old patch.
  118. - added SOURCE2 to compile for kernel-3.2.x.
  119. * Tue Oct 4 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-3
  120. - update SOURCE1 (see: http://www.broadcom.com/docs/linux_sta/bcma.txt)
  121. * Sun Aug 14 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-2
  122. - add a patch to fix build failure on linux > 2.6.37
  123. * Sat Jan 01 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-1
  124. - new upstream release
  125. * Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-2
  126. - add Source2 to fix build failure on kernel >= 2.6.35
  127. (https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/590924)
  128. * Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-1
  129. - new upstream release
  130. * Wed Sep 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9.3-1
  131. - new upstream release
  132. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-3
  133. - fix to ensure Source0 has correct version/release numbers
  134. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-2
  135. - add ExclusiveArch
  136. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-1
  137. - initial build for Vine Linux