totem-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566
  1. # define versions
  2. %define _glib_ver 2.42.0
  3. %define _gtk_ver 3.14.0
  4. %define _gnomeicon_ver 3.12.0
  5. %define _gnome_doc_utils_ver 0.20.0
  6. %define _dbus_ver 1.6.0
  7. %define _gst_ver 1.2.0
  8. %define _gstpb_ver 1.2.0
  9. %define _gstpg_ver 1.2.0
  10. %define _gstpbad_ver 1.2.0
  11. %define _xulrunner_ver 1.9
  12. %define _nautilus_ver 3.14.0
  13. %define _shared_mime_info_ver 0.17
  14. %define _unique_ver 1.0
  15. %define _totem_pl_parser_ver 3.4.4
  16. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  17. Summary: Movie player for GNOME 3
  18. Summary(ja): GNOME3 用動画プレイヤー
  19. Name: totem
  20. Version: 3.14.2
  21. Release: 1%{?_dist_release}
  22. License: GPL
  23. Group: Applications/Multimedia
  24. URL: http://www.gnome.org/projects/totem/
  25. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.14/%{name}-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: Takemikaduchi
  30. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  31. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  32. BuildRequires: dbus-devel >= %{_dbus_ver}
  33. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  34. BuildRequires: gnome-desktop3-devel
  35. BuildRequires: gettext
  36. BuildRequires: perl-XML-Parser
  37. BuildRequires: iso-codes
  38. BuildRequires: yelp-tools
  39. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  40. BuildRequires: grilo-devel
  41. BuildRequires: bluez-libs-devel >= 4.15
  42. BuildRequires: lirc
  43. BuildRequires: unique-devel >= %{_unique_ver}
  44. BuildRequires: python-devel
  45. BuildRequires: pylint
  46. BuildRequires: pygobject3-devel
  47. BuildRequires: libpeas-devel
  48. BuildRequires: libXtst-devel
  49. BuildRequires: gsettings-desktop-schemas-devel
  50. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  51. BuildRequires: vala
  52. BuildRequires: gstreamer1-devel >= %{_gst_ver}
  53. BuildRequires: gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  54. BuildRequires: gstreamer1-plugins-good >= %{_gstpg_ver}
  55. BuildRequires: gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
  56. BuildRequires: clutter-gtk-devel
  57. BuildRequires: clutter-gst-devel
  58. BuildRequires: libmx-devel
  59. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  60. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  61. Requires: gstreamer1 >= %{_gst_ver}
  62. Requires: gstreamer1-plugins-base >= %{_gstpb_ver}
  63. Requires: gstreamer1-plugins-good >= %{_gstpg_ver}
  64. Requires: gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
  65. Requires: iso-codes
  66. Obsoletes: nautilus-media
  67. Obsoletes: %{name}-gstreamer < 2.30.1-2
  68. Obsoletes: %{name}-xine < 2.30.1-2
  69. Obsoletes: %{name}-common < 2.30.1-3
  70. Obsoletes: %{name}-mozilla < 3.14.0
  71. Provides: nautilus-media
  72. Provides: %{name}-common = %{version}-%{release}
  73. Requires(post): ldconfig, desktop-file-utils
  74. Requires(postun): ldconfig, desktop-file-utils
  75. %description
  76. Totem is simple movie player for the Gnome desktop. It features a
  77. simple playlist, a full-screen mode, seek and volume controls, as well as
  78. a pretty complete keyboard navigation.
  79. %package devel
  80. Summary: Plugin writer's documentation for totem
  81. Group: Development/Libraries
  82. Requires: %{name} = %{version}-%{release}
  83. %description devel
  84. The %{name}-devel package contains API documentation for
  85. developing developing plugins for %{name}.
  86. %prep
  87. %setup -q
  88. %build
  89. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
  90. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  91. %configure \
  92. --enable-python \
  93. --enable-vala \
  94. --enable-nautilus
  95. make %{?_smp_mflags}
  96. %install
  97. rm -rf $RPM_BUILD_ROOT
  98. make install DESTDIR=$RPM_BUILD_ROOT
  99. # remove unneeded files
  100. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  101. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  102. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  103. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  104. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  105. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  106. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  107. # remove unused file
  108. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  109. %__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
  110. %find_lang %{name} --with-gnome
  111. # save space by linking identical images in translated docs
  112. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  113. for f in $helpdir/C/figures/*.png; do
  114. b="$(basename $f)"
  115. for d in $helpdir/*; do
  116. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  117. g="$d/figures/$b"
  118. if [ -f "$g" ]; then
  119. if cmp -s $f $g; then
  120. rm "$g"; ln -s "../../C/figures/$b" "$g"
  121. fi
  122. fi
  123. fi
  124. done
  125. done
  126. %clean
  127. %__rm -rf %{buildroot}
  128. %post
  129. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  130. touch %{_datadir}/icons/hicolor
  131. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  132. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  133. fi
  134. %postun
  135. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  136. touch %{_datadir}/icons/hicolor
  137. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  138. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  139. fi
  140. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  141. %posttrans
  142. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  143. %files -f %{name}.lang
  144. %defattr(-,root,root,-)
  145. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  146. %{_bindir}/totem
  147. %{_bindir}/totem-audio-preview
  148. %{_bindir}/totem-video-thumbnailer
  149. %{_datadir}/GConf/gsettings/opensubtitles.convert
  150. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  151. %{_datadir}/GConf/gsettings/totem.convert
  152. %{_datadir}/appdata/org.gnome.Totem.appdata.xml
  153. %{_datadir}/applications/org.gnome.Totem.desktop
  154. %{_datadir}/dbus-1/services/org.gnome.Totem.service
  155. %{_datadir}/glib-2.0/schemas/*.xml
  156. %{_datadir}/icons/*/*/*/*
  157. %{_datadir}/thumbnailers/totem.thumbnailer
  158. %{_datadir}/%{name}
  159. %{_datadir}/gtk-doc/html/totem
  160. %{_libdir}/libtotem.so.*
  161. %{_libdir}/girepository-1.0/*.typelib
  162. %dir %{_libdir}/totem
  163. %dir %{_libdir}/totem/plugins
  164. %{_libdir}/totem/plugins/apple-trailers/
  165. %{_libdir}/totem/plugins/autoload-subtitles
  166. %{_libdir}/totem/plugins/brasero-disc-recorder
  167. %{_libdir}/totem/plugins/chapters
  168. %{_libdir}/totem/plugins/dbus
  169. %{_libdir}/totem/plugins/gromit
  170. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  171. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  172. %{_libdir}/totem/plugins/lirc
  173. %{_libdir}/totem/plugins/media-player-keys
  174. %{_libdir}/totem/plugins/ontop
  175. %{_libdir}/totem/plugins/opensubtitles
  176. %{_libdir}/totem/plugins/properties
  177. %{_libdir}/totem/plugins/pythonconsole
  178. %{_libdir}/totem/plugins/recent
  179. %{_libdir}/totem/plugins/rotation
  180. %{_libdir}/totem/plugins/screensaver
  181. %{_libdir}/totem/plugins/screenshot
  182. %{_libdir}/totem/plugins/skipto
  183. %{_libdir}/totem/plugins/save-file/libsave-file.so
  184. %{_libdir}/totem/plugins/save-file/save-file.plugin
  185. %{_libdir}/totem/plugins/vimeo
  186. %{_libdir}/nautilus/extensions-3.0/*.so*
  187. %{_mandir}/man1/*
  188. %files devel
  189. %defattr(-, root, root,-)
  190. %{_includedir}/totem
  191. %{_libdir}/libtotem.so
  192. %{_libdir}/pkgconfig/totem.pc
  193. %{_datadir}/gir-1.0/Totem-1.0.gir
  194. %{_datadir}/gtk-doc/html/totem
  195. %changelog
  196. * Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  197. - new upstream release
  198. * Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
  199. - new upstream release
  200. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
  201. - new upstream release
  202. - add BuildRequires: gnome-desktop3-devel
  203. - remove BuildRequires: xulrunner-devel
  204. - remove %%{name}-mozilla subpackage
  205. * Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  206. - new upstream release
  207. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  208. - new upstream release
  209. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  210. - new upstream release
  211. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
  212. - rebuild with VineSeed environment
  213. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  214. - new upstream release
  215. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  216. - new upstream release
  217. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  218. - new upstream release
  219. - add BuildRequires: yelp-tools, vala
  220. - change configure option (--enable-vala)
  221. * Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  222. - new upstream release
  223. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  224. - new upstream release
  225. - change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
  226. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  227. - new upstream release
  228. - add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
  229. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  230. - new upstream release
  231. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  232. - add configure option (--disable-vegas-plugin)
  233. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  234. - new upstream release
  235. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  236. - new upstream release
  237. - add BuildRequires: pylint
  238. - remove BuildRequires: libgdata-devel
  239. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  240. - new upstream release
  241. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  242. - new upstream release
  243. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  244. - new upstream release
  245. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  246. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  247. - new upstream release
  248. - change BuildRequires: gtk3-devel instead of gtk2-devel
  249. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  250. clutter-gst-devel, libmx-devel
  251. - change configure option (--disable-vala)
  252. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  253. - new upstream release
  254. - fix %files
  255. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  256. - new upstream release
  257. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  258. - clean up spec file
  259. - remove totem-common and merged to totem main package.
  260. - add Obsoletes: totem-common
  261. - remove unneeded BR: and R:
  262. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  263. - libmusicbrainz, alternatives
  264. - remove explicit dependency
  265. - gtk2, glib2, dbus
  266. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  267. - add R: gstreamer-plugins-good
  268. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  269. - rebuild with libgdata (add youtube plugin)
  270. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  271. - add Obsolete: totem-gstreamer, totem-xine)
  272. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  273. - new upstream release
  274. - chagnge _gst_ver from 0.10.19 to 0.10.29
  275. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  276. - new upstream release
  277. - drop totem-tracker package
  278. - add BuildRequires: unique-devel
  279. - remove BuildRequires: hal-devel
  280. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  281. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  282. - remove unneeded autoreconf
  283. - add BR: lirc
  284. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  285. - new upstream release
  286. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  287. - remove bemused plugin
  288. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  289. - new upstream release
  290. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  291. - added tracker video search sub-package
  292. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  293. - new upstream release
  294. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  295. - new upstream release
  296. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  297. - remove libxine dependency from totem-common
  298. - build xine backend with minimum dependency
  299. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  300. - add BR: bluez-libs-devel >= 4.15
  301. - fix typo in %%postun xine
  302. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  303. - rebuild with bluez-libs-devel-4.15
  304. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  305. - new upstream release
  306. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  307. - new upstream release
  308. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  309. - new upstream release
  310. - add patch1 to build with xulrunner-1.9
  311. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  312. - new upstream release
  313. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  314. - new upstream release
  315. - disabled devel package (replaced by totem-pl-parser-devel)
  316. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  317. - new upstream release
  318. - update version macros
  319. - enable browser plugins on x86_64
  320. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  321. - new upstream release
  322. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  323. - upstream release
  324. - drop obsolete ja.po.patch (patch0)
  325. - revert change of 1.4.4-0vl2
  326. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  327. - upstream release
  328. - enable browser plugins (exclude x86_64 arch)
  329. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  330. - upstream release
  331. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  332. - update configure options
  333. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  334. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  335. - fix mistranslation (patch0)
  336. - add icon symlink
  337. - add BuildRequires: gstreamer-plugins-good
  338. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  339. - upstream release
  340. - update %%_glib_ver, %%_xine_ver
  341. - add BuildRequires: hal
  342. - update %%configure options
  343. - update %%files
  344. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  345. - upstream release
  346. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  347. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  348. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  349. - upstream release
  350. - drop obsolete patch0
  351. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  352. - upstream release
  353. - add patch0 to build with intltool-0.35
  354. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  355. - upstream release
  356. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  357. - upstream release
  358. - update alternatives entry
  359. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  360. - upstream release
  361. - drop fix-sort-function.patch (was merged to upstream, #331426)
  362. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  363. - rebuild with gnome-2.14rc
  364. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  365. - upstream release
  366. - add macros
  367. - _gtk_ver, _glib_ver
  368. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  369. - _dbus_ver
  370. - _gst_ver, gstpb_ver, _xine_ver
  371. - add fix-sort-function.patch to build with glib < 2.9.1
  372. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  373. - upstream release
  374. - add BuildRequires:
  375. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  376. - gnome-vfs2-devel >= 2.9.92
  377. - dbus-devel >= 0.35
  378. - use gstreamer-0.10 as backend for totem-gstreamer
  379. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  380. - use gstreamer08 instead of gstreamer
  381. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  382. - upstream release
  383. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  384. - fix missing links
  385. - update file list
  386. - update update-alternatives scripts
  387. - fix totem-gstreamer's %%postun script
  388. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  389. - upstream release
  390. - add BuildRequires: iso-codes, libmusicbrainz-devel
  391. - add Requires: iso-codes, libmusicbrains to -common package
  392. - remove BuildRequires: nautilus-cd-burner
  393. - remove Requires: nautilus-cd-burner from -common package
  394. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  395. - totem-gstreamer obsoletes nautilus-media
  396. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  397. - upstream release
  398. - add Requires(post,postun): alternatives for gstreamer,xine
  399. - add Requires(postun,triggers): alternatives for common
  400. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  401. - upstream release
  402. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  403. - build xine backend
  404. - move common files to common package
  405. - move GStreamer related files to gstreamer package
  406. - install xine related files to xine package
  407. - fix scripts
  408. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  409. - upstream release
  410. - update URL
  411. - move *.{a,la} to devel package
  412. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  413. - fix %%{post,preun} script (video-thumbnail.schemas)
  414. - sync with Fedora Core's 1.0.1-1
  415. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  416. - Update to upstream version 1.0.1
  417. - Break out devel package
  418. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  419. - add %%{post,pre}un script
  420. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  421. - initial build for Vine Linux
  422. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  423. - fix %%post
  424. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  425. - Obsolete nautilus-media
  426. - Install property page and thumbnailer
  427. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  428. - Update to 0.101
  429. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  430. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  431. missing menu entry (144088)
  432. - Remove workaround for desktop file being misinstalled, fixed
  433. by above patch
  434. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  435. - New upstream version 0.100
  436. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  437. - update to 0.99.22
  438. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  439. - Add patch to remove removed items from package from help
  440. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  441. - New upstream 0.99.19
  442. - Fixes crasher with CD playback (see NEWS)
  443. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  444. - Call update-desktop-database in post
  445. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  446. - update to 0.99.18
  447. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  448. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>