libcap-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Library for getting and setting POSIX.1e capabilities
  3. Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
  4. Name: libcap
  5. Version: 2.27
  6. Release: 1%{?_dist_release}
  7. License: LGPLv2
  8. Group: System Environment/Libraries
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Source: https://mirrors.edge.kernel.org/pub/linux/libs/security/linux-privs/libcap2/%{name}-%{version}.tar.xz
  12. Source1: getpcaps.8
  13. # Patch0: libcap-2.16-headerfix.patch
  14. Patch1: %{name}-2.25-buildflags.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: libattr-devel
  17. BuildRequires: pam-devel
  18. %description
  19. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  20. draft 15 capabilities.
  21. %package devel
  22. Summary: Development files for libcap
  23. Summary(ja): libcap の開発用ファイル
  24. Group: Development/Libraries
  25. Requires: %{name} = %{version}-%{release}
  26. %description devel
  27. Development files (Headers, libraries for static linking, etc) for libcap.
  28. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  29. draft 15 capabilities.
  30. Install libcap-devel if you want to develop or compile applications using
  31. libcap.
  32. %package static
  33. Summary: static library of libcap
  34. Summary(ja): libcap のスタティックライブラリ
  35. Group: Development/Libraries
  36. Requires: %{name}-devel = %{version}-%{release}
  37. %description static
  38. This package includes the static library of libpcap
  39. # compat32
  40. %package -n compat32-%{name}
  41. Summary: Library for getting and setting POSIX.1e capabilities
  42. Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
  43. Group: System Environment/Libraries
  44. %description -n compat32-%{name}
  45. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  46. draft 15 capabilities.
  47. %package -n compat32-%{name}-devel
  48. Summary: Development files for libcap
  49. Summary(ja): libcap の開発用ファイル
  50. Group: Development/Libraries
  51. Requires: compat32-%{name} = %{version}-%{release}
  52. Requires: %{name}-devel = %{version}-%{release}
  53. %description -n compat32-%{name}-devel
  54. Development files (Headers, libraries for static linking, etc) for libcap.
  55. libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
  56. draft 15 capabilities.
  57. Install libcap-devel if you want to develop or compile applications using
  58. libcap.
  59. %prep
  60. %setup -q
  61. # %patch0 -p1
  62. %patch1 -p1
  63. %build
  64. # libcap can not be build with _smp_mflags:
  65. make PREFIX=%{_prefix} LIBDIR=%{_libdir} SBINDIR=%{_sbindir} \
  66. INCDIR=%{_includedir} MANDIR=%{_mandir} COPTFLAG="$RPM_OPT_FLAGS"
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. make install RAISE_SETFCAP=no \
  70. DESTDIR=${RPM_BUILD_ROOT} \
  71. LIBDIR=/%{_lib} \
  72. SBINDIR=%{_sbindir} \
  73. INCDIR=%{_includedir} \
  74. MANDIR=%{_mandir}/ \
  75. PKGCONFIGDIR=%{_libdir}/pkgconfig/ \
  76. COPTFLAG="$RPM_OPT_FLAGS"
  77. mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man{2,3,8}
  78. #mv -f doc/*.2 ${RPM_BUILD_ROOT}/%{_mandir}/man2/
  79. mv -f doc/*.3 ${RPM_BUILD_ROOT}/%{_mandir}/man3/
  80. chmod +x $RPM_BUILD_ROOT/%{_lib}/*.so.*
  81. # need to build init.lxc.static
  82. mv %{buildroot}/%{_lib}/libcap.a %{buildroot}/%{_libdir}/libcap.a
  83. cp -f %{SOURCE1} %{buildroot}/%{_mandir}/man8/
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post -p /sbin/ldconfig
  87. %postun -p /sbin/ldconfig
  88. %post -n compat32-%{name} -p /sbin/ldconfig
  89. %postun -n compat32-%{name} -p /sbin/ldconfig
  90. %files
  91. %defattr(-,root,root)
  92. %license License
  93. %doc doc/capability.notes
  94. /%{_lib}/*.so.*
  95. %{_sbindir}/*
  96. %{_mandir}/man1/*
  97. %{_mandir}/man8/*
  98. /%{_lib}/security/pam_cap.so
  99. %files devel
  100. %defattr(-,root,root)
  101. %{_includedir}/*
  102. /%{_lib}/*.so
  103. %{_libdir}/pkgconfig/*
  104. %{_mandir}/man3/*
  105. %files static
  106. %defattr(-,root,root)
  107. %{_libdir}/*.a
  108. # compat32
  109. %if %{build_compat32}
  110. %files -n compat32-%{name}
  111. %defattr(-,root,root)
  112. /%{_lib}/*.so.*
  113. %files -n compat32-%{name}-devel
  114. %defattr(-,root,root)
  115. /%{_lib}/*.so
  116. %endif
  117. %changelog
  118. * Mon Sep 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.27-1
  119. - new upstream release.
  120. * Sun Jun 26 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.25-1
  121. - new upstream release.
  122. - added Source1.
  123. - added libcap-static.
  124. * Thu Jul 9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.24-1
  125. - new upstream release
  126. - change tarfile format
  127. - change flags in install section
  128. - add patch1, drop patch0 (patch1 from fedora)
  129. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-4
  130. - rebuild with VineSeed environment
  131. * Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-3
  132. - add BuildRequires: pam-devel
  133. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-2
  134. - rebuilt with current VineSeed
  135. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16-1
  136. - new upstream release
  137. - remove compat library (libpcap-1.10)
  138. * Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.06-2
  139. - added compat32 package for x86_64 arch support
  140. * Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-1
  141. - source updated
  142. - built with libattr 2.4.41
  143. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl2
  144. - rebuilt
  145. * Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl1
  146. - initial build for Vine Linux based on FC package
  147. * Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 1.10-22
  148. - build with gcc-4
  149. * Wed Feb 09 2005 Karsten Hopp <karsten@redhat.de> 1.10-21
  150. - rebuilt
  151. * Tue Aug 31 2004 Phil Knirsch <pknirsch@redhat.com> 1.10-20
  152. - Fix wrong typedef in userland patch (#98801)
  153. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  154. - rebuilt
  155. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  156. - rebuilt
  157. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  158. - rebuilt
  159. * Tue Jan 27 2004 Karsten Hopp <karsten@redhat.de> 1.10-17
  160. - use _manpath
  161. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  162. - rebuilt
  163. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  164. - rebuilt
  165. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 1.10-14
  166. - set execute bits on library so that requires are generated.
  167. * Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 1.10-13
  168. - Removed %%name macro sillyness from package Summary, description text, etc.
  169. - Removed archaic Prefix: tag
  170. - lib64 fixes everywhere to use _lib, _libdir, etc
  171. - Removed deletion of RPM_BUILD_DIR from %%clean section
  172. - Added -q flag to setup macro
  173. - Severely cleaned up spec file, and removed usage of perl
  174. * Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.10-12
  175. - CFLAGS was using COPTFLAG variable, not COPTFLAGS
  176. - build with -fpic
  177. - apply the IA-64 patch everywhere, use capget/capset from glibc,
  178. not directly as _syscall (as it is broken on IA-32 with -fpic)
  179. - reenable alpha
  180. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  181. - automated rebuild
  182. * Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-10
  183. - Exclude alpha for now, apparent gcc bug.
  184. * Fri Nov 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-6
  185. - Fix sys/capabilities.h header (#55727)
  186. - Move to /lib, some applications seem to be using this rather early
  187. (#55733)
  188. * Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  189. - Add post,postun scripts
  190. * Tue Jul 10 2001 Jakub Jelinek <jakub@redhat.com>
  191. - don't build libcap.so.1 with ld -shared, but gcc -shared
  192. * Wed Jun 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  193. - Rebuild - it was missing for alpha
  194. * Wed Jun 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  195. - add s390/s390x support
  196. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-1
  197. - initial RPM
  198. - fix build on ia64