json-c-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define pkg_version 0.9
  3. %define pkg_release 2%{?_dist_release}
  4. Summary: A JSON implementation in C
  5. Name: json-c
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. Source0: http://oss.metaparadigm.com/json-c/%{name}-%{version}.tar.gz
  9. License: MIT
  10. Group: System Environment/Libraries
  11. URL: http://oss.metaparadigm.com/json-c/
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: Takemikaduchi
  16. %description
  17. JSON-C implements a reference counting object model that allows you to easily
  18. construct JSON objects in C, output them as JSON formatted strings and parse
  19. JSON formatted strings back into the C representation of JSON objects.
  20. %package devel
  21. Summary: Development files for json-c
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: pkgconfig
  25. %description devel
  26. This package contains the libraries and header files that are needed
  27. for writing applications that are using json-c.
  28. %package doc
  29. Summary: Documentation for json-c
  30. Group: Documentation
  31. Requires: %{name} = %{version}-%{release}
  32. BuildArch: noarch
  33. %description doc
  34. This package contains documentation for json-c.
  35. %package -n compat32-%{name}
  36. Summary: A JSON implementation in C
  37. Group: System Environment/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. %description -n compat32-%{name}
  40. JSON-C implements a reference counting object model that allows you to easily
  41. construct JSON objects in C, output them as JSON formatted strings and parse
  42. JSON formatted strings back into the C representation of JSON objects.
  43. %package -n compat32-%{name}-devel
  44. Summary: Development files for json-c
  45. Group: Development/Libraries
  46. Requires: compat32-%{name} = %{version}-%{release}
  47. Requires: pkgconfig
  48. %description -n compat32-%{name}-devel
  49. This package contains the libraries and header files that are needed
  50. for writing applications that are using json-c.
  51. %prep
  52. %setup -q
  53. %build
  54. %configure --disable-static
  55. %{__make} %{?_smp_mflags}
  56. %install
  57. %{__rm} -rf $RPM_BUILD_ROOT
  58. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  59. %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.la
  60. %clean
  61. %{__rm} -rf $RPM_BUILD_ROOT
  62. %post -p /sbin/ldconfig
  63. %postun -p /sbin/ldconfig
  64. %post -n compat32-%{name} -p /sbin/ldconfig
  65. %postun -n compat32-%{name} -p /sbin/ldconfig
  66. %files
  67. %defattr(-,root,root,-)
  68. %doc COPYING ChangeLog COPYING NEWS README README.html
  69. %{_libdir}/libjson.so.*
  70. %files devel
  71. %defattr(-,root,root,-)
  72. %{_includedir}/json/*
  73. %{_libdir}/libjson.so
  74. %{_libdir}/pkgconfig/json.pc
  75. %files doc
  76. %defattr(-,root,root,-)
  77. %doc doc/html/*
  78. %if %{build_compat32}
  79. %files -n compat32-%{name}
  80. %defattr(-,root,root,-)
  81. %{_libdir}/libjson.so.*
  82. %files -n compat32-%{name}-devel
  83. %defattr(-,root,root,-)
  84. %{_libdir}/libjson.so
  85. %{_libdir}/pkgconfig/json.pc
  86. %endif
  87. %changelog
  88. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-2
  89. - create compat32 sub packages
  90. * Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-1
  91. - initial build for Vine Linux