akonadi-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271
  1. %define _qt4_ver 4.6.3
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_version})
  4. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  5. Name: akonadi
  6. Summary: PIM Storage Service
  7. Summary(ja): PIM ストレージサービス
  8. Version: 1.4.0
  9. Release: 3%{?_dist_release}
  10. Group: System Environment/Libraries
  11. License: LGPLv2+
  12. URL: http://download.akonadi-project.org/
  13. Source0: http://download.akonadi-project.org/akonadi-%{version}.tar.bz2
  14. # shrink default initial db size a bit (approx 140mb->28mb)
  15. %define mysql_conf_timestamp 20100209
  16. Patch1: akonadi-1.1.1-mysql_conf.patch
  17. ## upstream patches
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: cmake >= 2.6.0
  20. BuildRequires: qt4-devel >= 4.5.0
  21. BuildRequires: automoc4
  22. BuildRequires: MySQL-devel
  23. BuildRequires: MySQL-server
  24. # for xsltproc
  25. BuildRequires: libxslt
  26. BuildRequires: shared-mime-info
  27. BuildRequires: libboost-devel libboost-program-options
  28. BuildRequires: soprano-devel >= 2.5.0
  29. BuildRequires: sqlite3-devel
  30. BuildRequires: libICE-devel libXext-devel
  31. # when/if akonadi grows support for other backends, consider splitting
  32. # these similar to how phonon is done currently.
  33. Requires: qt4-MySQL
  34. # not *strictly* required, but we need a functional default configuration
  35. #Requires: mysql-server
  36. Requires(post): /sbin/ldconfig
  37. Requires(postun): /sbin/ldconfig
  38. %description
  39. %{summary}.
  40. Requires an available instance of mysql server at runtime.
  41. Akonadi can spawn a per-user one automatically if the mysql-server
  42. package is installed on the machine.
  43. See also: %{_sysconfdir}/akonadi/mysql-global.conf
  44. %package sqlite
  45. Summary: a sliglty adjusted QSQLITE driver for akonadi
  46. Group: System Environment/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: qt4 = %{_qt4_version}
  49. %description sqlite
  50. %{summary}.
  51. %package devel
  52. Summary: Developer files for %{name}
  53. Group: Development/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. %description devel
  56. %{summary}.
  57. %prep
  58. %setup -q
  59. %patch1 -p1 -b .mysql_conf
  60. touch -d %{mysql_conf_timestamp} server/src/storage/mysql-global.conf
  61. %build
  62. %ifarch x86_64
  63. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  64. %endif
  65. mkdir -p %{_target_platform}
  66. pushd %{_target_platform}
  67. %cmake \
  68. -DCONFIG_INSTALL_DIR=%{_sysconfdir} \
  69. -DINSTALL_QSQLITE_IN_QT_PREFIX:PATH=%{_qt4_plugindir} \
  70. ..
  71. popd
  72. make %{?_smp_mflags} -C %{_target_platform}
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  76. mkdir -p $RPM_BUILD_ROOT%{_datadir}/akonadi/agents
  77. touch -d %{mysql_conf_timestamp} $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-local.conf
  78. %clean
  79. rm -rf $RPM_BUILD_ROOT
  80. %post -p /sbin/ldconfig
  81. %posttrans
  82. update-mime-database %{_datadir}/mime &> /dev/null || :
  83. %postun
  84. /sbin/ldconfig ||:
  85. if [ $1 -eq 0 ] ; then
  86. update-mime-database %{_datadir}/mime &> /dev/null ||:
  87. fi
  88. %files
  89. %defattr(-,root,root,-)
  90. %doc AUTHORS lgpl-license
  91. %dir %{_sysconfdir}/akonadi
  92. %config(noreplace) %{_sysconfdir}/akonadi/mysql-global.conf
  93. %config(noreplace) %{_sysconfdir}/akonadi/mysql-global-mobile.conf
  94. %config(noreplace) %{_sysconfdir}/akonadi/mysql-local.conf
  95. %{_bindir}/akonadi_control
  96. %{_bindir}/akonadi_rds
  97. %{_bindir}/akonadictl
  98. %{_bindir}/akonadiserver
  99. %{_libdir}/libakonadi*.so.1*
  100. %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.*.xml
  101. %{_datadir}/dbus-1/services/org.freedesktop.Akonadi.*.service
  102. %{_datadir}/mime/packages/akonadi-mime.xml
  103. %{_datadir}/akonadi
  104. %files sqlite
  105. %defattr(-,root,root,-)
  106. %{_qt4_plugindir}/sqldrivers/libqsqlite3.so
  107. %files devel
  108. %defattr(-,root,root,-)
  109. %{_includedir}/akonadi
  110. %{_libdir}/pkgconfig/akonadi.pc
  111. %{_libdir}/libakonadi*.so
  112. %{_libdir}/cmake/Akonadi
  113. %changelog
  114. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.4.0-3
  115. - rebuilt with libboost-1.45.0
  116. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.0-2
  117. - rebuilt with rpm-4.8.1
  118. * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.0-1
  119. - new upstream release
  120. - added BR: sqlite3-devel
  121. - added sqlite subpackage
  122. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  123. - new upstream release
  124. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  125. - updated Patch1
  126. - added BR: MySQL-server
  127. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> - 1.3.1-2
  128. - added qmake path to PATH (if x86_64)
  129. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-1
  130. - new upstream release
  131. - built with new toolchain
  132. * Thu Sep 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.1-1
  133. - new upstream release
  134. * Wed Sep 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 1.2.0-4
  135. - use %%cmake macro
  136. - removed MySQL-server from BuildRequires:
  137. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-3
  138. - fixed Requires
  139. * Sat Aug 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-2
  140. - Initial build for Vine
  141. * Thu Jul 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 1.2.0-1
  142. - Akonadi 1.2.0
  143. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.95-2
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  145. * Thu Jun 25 2009 Than Ngo <than@redhat.com> - 1.1.95-1
  146. - 1.1.95
  147. * Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.90-1
  148. - akonadi-1.1.90
  149. * Tue May 26 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.85-3
  150. - akonadi.pc.cmake: s/AKONADI_LIB_VERSION_STRING/AKONADI_VERSION_STRING/
  151. * Tue May 12 2009 Than Ngo <than@redhat.com> 1.1.85-2
  152. - fix rpm file list
  153. * Wed May 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.85-1
  154. - akonadi-1.1.85
  155. * Thu Apr 30 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.2-1
  156. - akonadi-1.1.2
  157. - optimize scriptlets a bit
  158. * Wed Feb 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-6
  159. - rev startup patch
  160. - BR: cmake >= 2.6.0
  161. - preserve timestamp's on mysql*.conf's
  162. * Tue Feb 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-5
  163. - own %%_sysconfig/akonadi/mysql-local.conf
  164. - startup patch: reset conf only when needed, and clear mysql log file on update
  165. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-4
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  167. * Fri Feb 20 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-3
  168. - shrink default db initial size a bit (approx 140mb->28mb)
  169. - drop extraneous RPATH-cmake baggage
  170. * Wed Jan 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-1
  171. - 1.1.1
  172. * Sun Jan 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.0-1
  173. - 1.1.0
  174. * Tue Dec 16 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.81-1
  175. - 1.0.81
  176. * Mon Dec 08 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.80-3
  177. - restore Requires: mysql-server
  178. * Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.80-2
  179. - own /usr/share/akonadi and /usr/share/akonadi/agents (#473595)
  180. * Wed Nov 26 2008 Than Ngo <than@redhat.com> - 1.0.80-1
  181. - 1.0.80
  182. * Wed Oct 22 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-4
  183. - drop Requires: mysql-server (for now), mention in %%description
  184. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-3
  185. - Requires: mysql-server
  186. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-2
  187. - BR: mysql-server
  188. - Requires: qt4-mysql
  189. - cleanup spec
  190. * Wed Jul 23 2008 Than Ngo <than@redhat.com> - 1.0.0-1
  191. - 1.0.0
  192. * Wed Jun 18 2008 Rex Dieter <rdieter@fedoraproject.org> 0.82.0-1
  193. - akonadi-0.82.0
  194. * Tue Jun 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.2.20080526svn812787
  195. - BR automoc, drop automoc hack
  196. * Mon May 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.1.20080526svn812787
  197. - update to revision 812787 from KDE SVN (to match KDE 4.1 Beta 1)
  198. - restore builtin automoc4 for now
  199. - update file list, require pkgconfig in -devel (.pc file now included)
  200. * Mon May 5 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-2
  201. - -devel: remove bogus Requires: pkgconfig
  202. * Sat May 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-1
  203. - first Fedora package