attr-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Utilities for managing filesystem extended attributes
  3. Name: attr
  4. Version: 2.4.43
  5. Release: 2%{?_dist_release}
  6. Conflicts: xfsdump < 2.0.0
  7. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  8. Source: ftp://oss.sgi.com/projects/xfs/cmd_tars/attr_%{version}-1.tar.gz
  9. Patch1: attr-2.2.0-multilib.patch
  10. Patch2: attr-2.4.32-build.patch
  11. License: GPL
  12. URL: http://oss.sgi.com/projects/xfs/
  13. Group: System Environment/Base
  14. BuildRequires: autoconf, libtool >= 1.5, gettext
  15. %description
  16. A set of tools for manipulating extended attributes on filesystem
  17. objects, in particular getfattr(1) and setfattr(1).
  18. An attr(1) command is also provided which is largely compatible
  19. with the SGI IRIX tool of the same name.
  20. %package -n libattr
  21. Summary: Dynamic library for extended attribute support
  22. Group: System Environment/Libraries
  23. License: LGPL
  24. %description -n libattr
  25. This package contains the libattr.so dynamic library which contains
  26. the extended attribute system calls and library functions.
  27. %package -n libattr-devel
  28. Summary: Extended attribute static libraries and headers
  29. Group: Development/Libraries
  30. License: LGPL
  31. Requires: libattr = %{version}-%{release}
  32. %description -n libattr-devel
  33. This package contains the libraries and header files needed to
  34. develop programs which make use of extended attributes.
  35. For Linux programs, the documented system call API is the
  36. recommended interface, but an SGI IRIX compatibility interface
  37. is also provided.
  38. Currently only ext2, ext3 and XFS support extended attributes.
  39. The SGI IRIX compatibility API built above the Linux system calls is
  40. used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
  41. You should install libattr-devel if you want to develop programs
  42. which make use of extended attributes. If you install libattr-devel,
  43. you'll also want to install attr.
  44. # compat32
  45. %package -n compat32-libattr
  46. Summary: Dynamic library for extended attribute support
  47. Group: System Environment/Libraries
  48. License: LGPL
  49. %description -n compat32-libattr
  50. This package contains the libattr.so dynamic library which contains
  51. the extended attribute system calls and library functions.
  52. %package -n compat32-libattr-devel
  53. Summary: Extended attribute static libraries and headers
  54. Group: Development/Libraries
  55. License: LGPL
  56. Requires: libattr-devel = %{version}-%{release}
  57. Requires: compat32-libattr = %{version}-%{release}
  58. %description -n compat32-libattr-devel
  59. This package contains the libraries and header files needed to
  60. develop programs which make use of extended attributes.
  61. For Linux programs, the documented system call API is the
  62. recommended interface, but an SGI IRIX compatibility interface
  63. is also provided.
  64. Currently only ext2, ext3 and XFS support extended attributes.
  65. The SGI IRIX compatibility API built above the Linux system calls is
  66. used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
  67. You should install libattr-devel if you want to develop programs
  68. which make use of extended attributes. If you install libattr-devel,
  69. you'll also want to install attr.
  70. %prep
  71. %setup -q
  72. # We need to turn off executable permissions on the script in %doc
  73. # because we don't want to drag perl into the base. Users advanced
  74. # enough to have used ACLs before they were added to the distro can
  75. # figure out how to chmod and how to install perl. :-)
  76. %patch1 -p1 -b .multilib
  77. %patch2 -p1 -b .build
  78. autoconf
  79. %build
  80. # attr abuses libexecdir
  81. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  82. make LIBTOOL="libtool --tag=CC"
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. make install DESTDIR=$RPM_BUILD_ROOT
  86. make install-dev DESTDIR=$RPM_BUILD_ROOT
  87. make install-lib DESTDIR=$RPM_BUILD_ROOT
  88. # get rid of libattr.la
  89. rm -f $RPM_BUILD_ROOT/%{_libdir}/libattr.la
  90. # fix links to shared libs and permissions
  91. rm -f $RPM_BUILD_ROOT/%{_libdir}/libattr.so
  92. ln -sf ../../%{_lib}/libattr.so $RPM_BUILD_ROOT/%{_libdir}/libattr.so
  93. chmod 0755 $RPM_BUILD_ROOT/%{_lib}/libattr.so.*.*.*
  94. %find_lang %{name}
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %post -n libattr -p /sbin/ldconfig
  98. %postun -n libattr -p /sbin/ldconfig
  99. %post -n compat32-libattr -p /sbin/ldconfig
  100. %postun -n compat32-libattr -p /sbin/ldconfig
  101. %files -f %{name}.lang
  102. %defattr(-,root,root)
  103. %doc doc
  104. %{_bindir}/attr
  105. %{_bindir}/getfattr
  106. %{_bindir}/setfattr
  107. %{_mandir}/man1/attr.1*
  108. %{_mandir}/man1/getfattr.1*
  109. %{_mandir}/man1/setfattr.1*
  110. %{_mandir}/man5/attr.5*
  111. %files -n libattr-devel
  112. %defattr(-,root,root)
  113. /%{_lib}/libattr.so
  114. %{_includedir}/attr
  115. %{_libdir}/libattr.*
  116. %{_mandir}/man2/*attr.2*
  117. %{_mandir}/man3/attr_*.3.*
  118. %files -n libattr
  119. /%{_lib}/libattr.so.*
  120. # compat32
  121. %if %{build_compat32}
  122. %files -n compat32-libattr-devel
  123. %defattr(-,root,root)
  124. /%{_lib}/libattr.so
  125. %{_libdir}/libattr.*
  126. %files -n compat32-libattr
  127. /%{_lib}/libattr.so.*
  128. %endif
  129. %changelog
  130. * Wed Jul 15 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.43-2
  131. - added compat32 package for x86_64 arch support
  132. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.43-1
  133. - new upstream release
  134. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.41-2
  135. - initial build for Vine Linux
  136. * Tue Feb 13 2008 Zdenek Prikryl <zprikryl@redhat.com> 2.4.41-1
  137. - New version 2.4.41
  138. - Removed useless attr-2.0.8-docperms.patch
  139. * Wed Oct 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.39-1
  140. - New version 2.4.39
  141. - Resolves #284121
  142. * Tue Oct 30 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-2
  143. - Removed explicit Requires(post + postun)
  144. - Resolves #225290
  145. * Tue Jul 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-1
  146. - New version 2.4.38
  147. - Resolves #245415
  148. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.4.32-2
  149. - add disttag
  150. - remove trailing dot from summary
  151. - fix buildroot
  152. - -devel package requires same libattr version
  153. - change prereq to Requires(post)
  154. - escape macro in changelog
  155. - replace absolute link with relative link (libattr.so)
  156. - use %%doc macro
  157. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.32-1.1
  158. - rebuild
  159. * Wed Jul 5 2006 Thomas Woerner <twoerne@redhat.com> 2.4.32-1
  160. - new version 2.4.32
  161. - fixes segmentation fault in attr, which affects #189106
  162. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.4.28-2
  163. - rebuild for -devel deps
  164. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.2
  165. - bump again for double-long bug on ppc(64)
  166. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.1
  167. - rebuilt for new gcc4.1 snapshot and glibc changes
  168. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.4.28-1
  169. - new version 2.4.28
  170. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  171. - rebuilt
  172. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.4.24-2
  173. - spec file cleanup
  174. - mark po files as lang specific
  175. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  176. - 2.4.24
  177. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.23-1
  178. - update to 2.4.23
  179. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.16-6
  180. - get rid of *.la files
  181. - remove duplicate doc files
  182. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.4.16-4
  183. - Rebuild
  184. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.16-3
  185. - Build requires libtool >= 1.5
  186. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-2
  187. - Make libattr.so.* executable.
  188. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-1
  189. - Update to latest upstream version.
  190. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.4.1-6
  191. - Fix bug #125304 (Steve Grubb: build requires gettext)
  192. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  193. - rebuilt
  194. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-4
  195. - Add missing %%defattr
  196. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-3
  197. - Add /usr/include/attr to files manifest
  198. - Fix location of doc files, add main doc dir to files manifest
  199. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  200. - rebuilt
  201. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  202. - rebuilt
  203. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.4.1-2
  204. - Fix libtool
  205. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.4.1-1
  206. - update to attr-2.4.1
  207. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.0-1
  208. - update/rebuild
  209. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.8-6
  210. - set execute bits on library so that requires are generated.
  211. * Thu Nov 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.8-5
  212. - Redo multilib patch to work everywhere
  213. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.8-4
  214. - Added fix to install libs in correct directory on 64bit machine
  215. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-3
  216. - Made the package only own the one directory that is unique to it:
  217. /usr/include/attr
  218. * Wed Jun 26 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-2
  219. - get perl out of base with attr-2.0.8-docperms.patch
  220. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-1
  221. - Initial Red Hat package
  222. Made as few changes as possible relative to upstream packaging to
  223. make it easier to maintain long-term. This means that some of
  224. the techniques used here are definitely not standard Red Hat
  225. techniques. If you are looking for an example package to fit
  226. into Red Hat Linux transparently, this would not be the one to
  227. pick.
  228. - attr-devel -> libattr-devel