gnash-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. # ghelp/omf/scrollkeeper support
  3. # not working as of version 0.8.7
  4. %define scrollkeeper 0
  5. # kde and klash support
  6. %define kde_support 0
  7. Name: gnash
  8. Version: 0.8.7
  9. Release: 3%{?_dist_release}
  10. Summary: GNU flash movie player
  11. Group: Applications/Multimedia
  12. License: GPLv3+
  13. URL: http://www.gnu.org/software/gnash/
  14. Source0: http://ftp.gnu.org/gnu/gnash/%{version}/%{name}-%{version}.tar.bz2
  15. Source1: http://www.getgnash.org/gnash-splash.swf
  16. Source2: gnash.desktop
  17. # register KComponentData properly in KDE 4 KPart
  18. Patch0: gnash-0.8.3-fix-kde4-port.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: libxml2-devel libpng-devel libjpeg-devel libogg-devel
  21. BuildRequires: libboost-devel curl-devel freetype-devel fontconfig-devel
  22. BuildRequires: libboost-date-time libboost-serialization libboost-thread
  23. BuildRequires: SDL-devel
  24. BuildRequires: agg-devel
  25. %if %{kde_support}
  26. #BuildRequires: kde-filesystem
  27. BuildRequires: kdelibs-devel
  28. %endif
  29. BuildRequires: gtkglext-devel
  30. BuildRequires: docbook2X
  31. #BuildRequires: %{_bindir}/docbook2pdf
  32. BuildRequires: gstreamer-devel >= 0.10%
  33. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  34. %if %{scrollkeeper}
  35. BuildRequires: scrollkeeper
  36. %endif
  37. BuildRequires: giflib-devel
  38. BuildRequires: gettext
  39. BuildRequires: desktop-file-utils
  40. BuildRequires: speex-devel
  41. BuildRequires: gstreamer-plugins-base-devel
  42. BuildRequires: pygtk2-devel
  43. BuildRequires: libtool-ltdl-devel
  44. BuildRequires(check): dejagnu
  45. %if %{scrollkeeper}
  46. Requires(post): scrollkeeper
  47. Requires(postun): scrollkeeper
  48. %endif
  49. Requires(post): /sbin/ldconfig
  50. Requires(postun): /sbin/ldconfig
  51. Requires(post): /sbin/install-info
  52. Requires(preun): /sbin/install-info
  53. %description
  54. Gnash is capable of reading up to SWF v9 files and opcodes, but primarily
  55. supports SWF v7, with better SWF v8 and v9 support under heavy development.
  56. Gnash includes initial parser support for SWF v8 and v9. Not all
  57. ActionScript 2 classes are implemented yet, but all of the most heavily
  58. used ones are. Many ActionScript 2 classes are partially implemented;
  59. there is support for all of the commonly used methods of each
  60. class.
  61. %package plugin
  62. Summary: Web-client flash movie player plugin
  63. Requires: %{name} = %{version}-%{release}
  64. # this doesn't prevent wrong dependencies, in case a package
  65. # provides %%{_libdir}/mozilla/plugins (like kdebase for konqueror)
  66. # and another unrelated webbrowser is installed, like w3m-el.
  67. # Moreover konqueror could provide webclient some day
  68. Requires: %{_libdir}/mozilla/plugins webclient
  69. Group: Applications/Internet
  70. %description plugin
  71. The gnash flash movie player plugin for firefox or mozilla.
  72. %if %{kde_support}
  73. %package klash
  74. Summary: Konqueror flash movie player plugin
  75. Requires: %{name} = %{version}-%{release}
  76. Group: Applications/Multimedia
  77. %description klash
  78. The gnash flash movie player plugin for Konqueror.
  79. %endif
  80. %package cygnal
  81. Summary: Streaming media server
  82. Requires: %{name} = %{version}-%{release}
  83. Group: Applications/Multimedia
  84. %description cygnal
  85. Cygnal is a streaming media server that's Flash aware.
  86. %package devel
  87. Summary: Gnash header files
  88. Requires: %{name} = %{version}-%{release}
  89. Group: Development/Libraries
  90. %description devel
  91. Gnash header files can be used to write external Gnash extensions or to embed
  92. the Gnash GTK+ widget into a C/C++ application.
  93. %package -n python-gnash
  94. Summary: Gnash Python bindings
  95. Requires: %{name} = %{version}-%{release}
  96. Group: Applications/Multimedia
  97. %description -n python-gnash
  98. Python bindings for the Gnash widget. Can be used to embed Gnash into any PyGTK
  99. application.
  100. %prep
  101. %setup -q
  102. %patch0 -p1 -b .fix-kde4
  103. %if %{kde_support}
  104. # Hack as autoreconf breaks build
  105. sed -i -e 's!kapp.h!kapplication.h!g' configure
  106. sed -i -e 's!libkdeui.la!libkdeui.so!g' configure
  107. # Currently kde4-gnash (from kde4 branch) links against various KDE libraries,
  108. # but only needs Qt -- remove the superfluous linkage
  109. sed -i -e 's!\$(KDE4_LIBS)!!g' gui/Makefile.in
  110. %endif
  111. # we don't want any builtin ltdl built, configure wants always either
  112. # ltdl-install or ltdl-convenience, hack that out
  113. sed -i -e 's/test x"\${enable_ltdl_convenience-no}" != xno/false/g' configure
  114. # and don't build the loader part of libltdl either
  115. sed -i -e 's/\$(LT_DLLOADERS)//g' libltdl/Makefile.in
  116. # link to the system libltdl instead of the bundled one
  117. # this is hardcoded in the makefiles, so --without-included-ltdl doesn't help
  118. sed -i -e 's!\$(top_builddir)/libltdl/libltdlc.la!-lltdl!g' \
  119. */Makefile.in */*/Makefile.in
  120. # delete bundled libltdl stuff to make sure it's not used
  121. rm -f libltdl/*.[ch] libltdl/*/*.[ch]
  122. iconv -f latin1 -t utf8 < AUTHORS > AUTHORS.utf8
  123. touch -r AUTHORS AUTHORS.utf8
  124. mv AUTHORS.utf8 AUTHORS
  125. %build
  126. %configure --disable-static --with-npapi-plugindir=%{_libdir}/mozilla/plugins \
  127. --enable-docbook --enable-ghelp --enable-media=GST \
  128. --disable-dependency-tracking --disable-rpath \
  129. --enable-cygnal \
  130. --enable-sdkinstall \
  131. --enable-python \
  132. %if %{kde_support}
  133. --enable-gui=gtk,kde4,sdl,fb \
  134. --with-kde4-prefix=%{_kde4_prefix} \
  135. --with-kde4-lib=%{_kde4_libdir}/kde4/devel \
  136. --with-kde4-incl=%{_kde4_includedir} \
  137. %else
  138. --enable-gui=gtk,sdl,fb \
  139. %endif
  140. --without-included-ltdl
  141. %if %{kde_support}
  142. # make sure the Qt 4 moc etc. tools are found
  143. export PATH=%{_qt4_prefix}/bin:$PATH
  144. #doesn't work currently: %%{?_smp_mflags}
  145. # override KDE4_LIBS because configure doesn't detect it properly
  146. make KDE4_LIBS='-L%{_kde4_libdir}/kde4/devel -lkparts -lkdeui -lkdecore'
  147. %else
  148. #doesn't work currently: %%{?_smp_mflags}
  149. make
  150. %endif
  151. %install
  152. rm -rf $RPM_BUILD_ROOT
  153. make install install-plugins \
  154. DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' \
  155. %if %{kde_support}
  156. KDE4_PLUGINDIR=%{_kde4_libdir}/kde4 \
  157. KDE4_SERVICESDIR=%{_kde4_datadir}/kde4/services \
  158. KDE4_CONFIGDIR=%{_kde4_configdir} \
  159. KDE4_APPSDATADIR=%{_kde4_appsdir}/klash
  160. %endif
  161. rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.la
  162. %if %{kde_support}
  163. # KDE 4 doesn't need the .la file anymore, thankfully
  164. rm $RPM_BUILD_ROOT%{_kde4_libdir}/kde4/libklashpart.la
  165. %endif
  166. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  167. rm -rf __dist_docs
  168. mkdir __dist_docs
  169. mv $RPM_BUILD_ROOT%{_datadir}/doc/gnash/* __dist_docs/
  170. rmdir $RPM_BUILD_ROOT%{_datadir}/doc/gnash
  171. cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/gnash/
  172. mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
  173. # a wrapper to avoid gnash erroring out if there is no argument.
  174. # Instead open gnash-splash.swf.
  175. # this should not be needed in the next version.
  176. # FIXME: Do we still need this with 0.8.7?
  177. cat > $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper << EOF
  178. #! /bin/sh
  179. if [ "z\$1" = 'z' ]; then
  180. gnash %{_datadir}/gnash/gnash-splash.swf
  181. else
  182. gnash "\$@"
  183. fi
  184. EOF
  185. chmod a+x $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper
  186. sed -e 's;/usr/libexec;%{_libexecdir};' %{SOURCE2} > gnash.desktop
  187. mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
  188. desktop-file-install --vendor="fedora" \
  189. --dir=$RPM_BUILD_ROOT%{_datadir}/applications/ \
  190. gnash.desktop
  191. mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  192. cp -p ./gui/images/GnashG.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  193. %find_lang %{name}
  194. %clean
  195. rm -rf $RPM_BUILD_ROOT
  196. %post
  197. /sbin/ldconfig
  198. %if %{scrollkeeper}
  199. scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
  200. %endif
  201. /sbin/install-info %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  202. /sbin/install-info %{_infodir}/gnash_user.info %{_infodir}/dir || :
  203. update-desktop-database &> /dev/null || :
  204. touch --no-create %{_datadir}/icons/hicolor
  205. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  206. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  207. fi
  208. %preun
  209. if [ $1 = 0 ]; then
  210. /sbin/install-info --delete %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  211. /sbin/install-info --delete %{_infodir}/gnash_user.info %{_infodir}/dir || :
  212. fi
  213. %postun
  214. /sbin/ldconfig
  215. %if %{scrollkeeper}
  216. scrollkeeper-update -q || :
  217. %endif
  218. update-desktop-database &> /dev/null || :
  219. touch --no-create %{_datadir}/icons/hicolor
  220. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  221. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  222. fi
  223. %files -f %{name}.lang
  224. %defattr(-,root,root,-)
  225. %doc README AUTHORS COPYING NEWS
  226. %doc __dist_docs/*
  227. %config(noreplace) %{_sysconfdir}/gnashpluginrc
  228. %config(noreplace) %{_sysconfdir}/gnashrc
  229. %{_bindir}/dumpshm
  230. %{_bindir}/fb-gnash
  231. %{_bindir}/flvdumper
  232. %{_bindir}/gtk-gnash
  233. %{_bindir}/sdl-gnash
  234. %{_bindir}/soldumper
  235. %{_bindir}/gnash
  236. %{_bindir}/gprocessor
  237. %{_bindir}/findmicrophones
  238. %{_bindir}/findwebcams
  239. %dir %{_libdir}/gnash
  240. %{_libdir}/gnash/*.so*
  241. %{_mandir}/man1/gnash.1*
  242. %{_mandir}/man1/dumpshm.1*
  243. %{_mandir}/man1/gprocessor.1*
  244. %{_mandir}/man1/soldumper.1*
  245. %{_mandir}/man1/flvdumper.1*
  246. %{_mandir}/man1/findmicrophones.1*
  247. %{_mandir}/man1/findwebcams.1*
  248. %{_mandir}/man1/gtk-gnash.1*
  249. %{_infodir}/gnash*
  250. %{_datadir}/gnash/
  251. %{_datadir}/icons/hicolor/32x32/apps/*.png
  252. %{_datadir}/applications/*.desktop
  253. %{_libexecdir}/gnash-wrapper
  254. %if %{scrollkeeper}
  255. %{_datadir}/omf/gnash/
  256. %endif
  257. %files plugin
  258. %defattr(-,root,root,-)
  259. %{_libdir}/mozilla/plugins/libgnashplugin.so
  260. %if %{kde_support}
  261. %files klash
  262. %defattr(-,root,root,-)
  263. %{_kde4_bindir}/kde4-gnash
  264. %{_kde4_libdir}/kde4/libklashpart.so
  265. %{_kde4_appsdir}/klash/
  266. %{_kde4_datadir}/kde4/services/klash_part.desktop
  267. %{_mandir}/man1/kde4-gnash.1*
  268. %endif
  269. %files cygnal
  270. %defattr(-,root,root,-)
  271. %config(noreplace) %{_sysconfdir}/cygnalrc
  272. %{_bindir}/cygnal
  273. %{_mandir}/man1/cygnal.1*
  274. %{_mandir}/man1/rtmpget.1*
  275. %dir %{_libdir}/cygnal
  276. %{_libdir}/cygnal/plugins/*.so*
  277. %files devel
  278. %defattr(-,root,root,-)
  279. %{_includedir}/gnash/
  280. %{_libdir}/pkgconfig/gnash.pc
  281. %files -n python-gnash
  282. %defattr(-,root,root,-)
  283. %{python_sitearch}/gtk-2.0/*
  284. %changelog
  285. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 0.8.7-3
  286. - rebuilt with libboost-1.45.0
  287. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.7-2
  288. - rebuilt with rpm-4.8.1 for pkg-config
  289. * Wed Mar 17 2010 IWAI, Masaharu <iwai@alib.jp> 0.8.7-1
  290. - initial build for Vine Linux: based Fedora 0.8.7-1.fc14
  291. * Sat Feb 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.7-1
  292. - update to 0.8.7
  293. - make scrollkeeper a conditional (still disabled as it's not working)
  294. - drop gnash-0.8.3-manual.patch, should no longer be needed
  295. - drop gnash-0.8.6-python-install-dir.patch, fixed upstream
  296. * Fri Feb 12 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-13
  297. - delete bundled libltdl stuff to make sure it's not used
  298. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-12
  299. - don't build libltdlc.a
  300. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-11
  301. - --without-included-ltdl (CVE-2009-3736)
  302. * Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-10
  303. - Rebuild for new Boost (1.41.0)
  304. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-9
  305. - Add missing Epoch to Requires
  306. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-8
  307. - Install icon to the correct place (#551621)
  308. * Wed Dec 30 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-7
  309. - One more try at using the correct dir
  310. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-6
  311. - Patch was reversed
  312. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-5
  313. - Patch Makefile.in, not Makefile.am
  314. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-4
  315. - Pick up python modules from the right dir
  316. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-3
  317. - Install python modules in the right dir
  318. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-2
  319. - Add cygnal plugins
  320. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-1
  321. - Update to 0.8.6, increase epoch.
  322. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.8.20090910bzr11506
  323. - update to HEAD
  324. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.7.20090910bzr11505
  325. - update to HEAD
  326. * Mon Aug 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.6.20090809bzr11401
  327. - don't package headers in -widget, only in -devel (no duplicate files)
  328. - own %%{_includedir}/gnash/ in -devel
  329. - add missing %%defattr for -devel and -widget
  330. - make -devel and -widget require the main package (with exact VR)
  331. - fix -devel group and description
  332. - rename gnash-widget to python-gnash as per the naming guidelines
  333. * Sun Aug 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.5.20090809bzr11401
  334. - use %%{_includedir}, not %%{_prefix}/include
  335. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.4.20090809bzr11401
  336. - Install the python module in the sitearch dir
  337. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11401
  338. - One more 64bit fix
  339. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11400
  340. - Fix the packaging in 64bits
  341. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.2.20090809bzr11400
  342. - upload the .swf file
  343. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.1.20090809bzr11400
  344. - merge upstream changes into the spec
  345. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-5
  346. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  347. * Fri May 22 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-4
  348. - rebuild for new Boost
  349. * Fri Mar 06 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-3
  350. - explicitly link the KlashPart against the libraries it uses
  351. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-2
  352. - add missing speex-devel and gstreamer-plugins-base-devel BR
  353. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-1
  354. - update to 0.8.5
  355. - remove use_kde3_executable_hack
  356. - remove autoreconf
  357. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.8.4-7
  358. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  359. * Thu Dec 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-6
  360. - rebuild for new boost
  361. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-5
  362. - add missing portions of KDE 4 port from upstream kde4 branch
  363. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-4
  364. - add 3 more patches from bero to fix the KDE 4 viewer executable
  365. - disable use_kde3_executable hack
  366. * Sun Oct 19 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-3
  367. - add a desktop file
  368. * Sat Oct 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-2
  369. - update KDE 4 patch (undo the backporting and use original patch)
  370. - patch to make autoreconf work
  371. - add missing BR giflib-devel, gettext
  372. - omit unrecognized --with-qtdir
  373. * Sat Oct 18 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-1
  374. - update to 0.8.4
  375. * Thu Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-6
  376. - use the KDE 3 executable with the KDE 4 KPart for now (making this conditional
  377. so it can easily be disabled or removed once the KDE 4 executable is fixed)
  378. * Thu Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-5
  379. - register KComponentData properly in KDE 4 KPart
  380. * Wed Oct 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-4
  381. - KDE 4 port of klash by Benjamin Wolsey and Bernhard Rosenkränzer
  382. * Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> 0.8.3-3
  383. - include %%_libdir/gnash directory
  384. * Wed Jun 25 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-2
  385. - add glib in the link, thanks Daniel Drake (#452767)
  386. * Sun Jun 22 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-1
  387. - update to 0.8.3
  388. * Wed Apr 9 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-3
  389. - ship libklashpart (#441601)
  390. * Mon Mar 10 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-2
  391. - don't ship libltdl.so.3 (#436725)
  392. * Fri Mar 7 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-1
  393. - update to 0.8.2
  394. * Sat Oct 27 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-6
  395. - add patch from Martin Stransky to fix wrapped plugin #281061
  396. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-5
  397. - info files are empty, don't install them
  398. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-4
  399. - omf/scrollkeeper doc is broken, remove it
  400. * Fri Sep 7 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-3
  401. - better documentation generation
  402. * Wed Sep 5 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-2
  403. - update to 0.8.1
  404. - agg is now the default renderer
  405. * Fri Aug 3 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-2
  406. - rebuild for boost soname change
  407. * Sun Jun 17 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-1
  408. - update to 0.8.0
  409. * Wed May 9 2007 Patrice Dumas <pertusus@free.fr> 0.7.2-2
  410. - fix CVE-2007-2500 (fix 239213)
  411. * Sat Nov 6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
  412. - update for 0.7.2 release.
  413. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
  414. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  415. * Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
  416. - plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
  417. temporarily, but there is no better solution yet) #207613
  418. * Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
  419. - add defattr for klash
  420. - add warnings in the description about stability
  421. * Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
  422. - remove superfluous buildrequires autoconf
  423. - rename last patch to gnash-plugin-tempfile-dir.patch
  424. - add README.fedora to plugin to explain tmpdirs
  425. * Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
  426. - source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
  427. - add plugin-tempfile-dir.patch for plugin to use a safe tempdir
  428. * Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
  429. - buildrequire autotools (Michael Knox)
  430. * Fri Jun 2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
  431. - add gnash-continue_on_info_install_error.patch to avoid
  432. - buildrequire libXmu-devel
  433. * Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
  434. - configure with --disable-rpath
  435. - buildrequire docbook2X
  436. - remove devel files
  437. * Sun May 7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
  438. - update to 0.7.1 alpha release
  439. * Sat Apr 22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
  440. - install the info file. Various tweaks for my system based on
  441. Patrice's latest patch,
  442. * Fri Feb 3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-1
  443. - initial packaging