tcpdump-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519
  1. %define tcpdump_ver 4.9.2
  2. %define libpcap_ver 1.7.3
  3. %{!?_licensedir:%global license %%doc}
  4. Summary: A network traffic monitoring tool.
  5. Summary(ja): ネットワークのトラフィックをモニタするツール
  6. Name: tcpdump
  7. Version: %{tcpdump_ver}
  8. %define tcpdump_dir tcpdump-%{tcpdump_ver}
  9. %define tcpslice_dir tcpslice
  10. Release: 1%{?_dist_release}
  11. Epoch: 1
  12. Group: Applications/System
  13. # XXX epoch is necessary to obsolete tcpdump-3.4a5
  14. License: BSD
  15. URL: http://www.tcpdump.org/
  16. Source0: http://www.tcpdump.org/release/tcpdump-%{tcpdump_ver}.tar.gz
  17. Source1: ftp://ftp.ee.lbl.gov/tcpslice-1.2a3.tar.gz
  18. Patch0001: 0001-icmp6-print-Reachable-Time-and-Retransmit-Time-from-.patch
  19. Patch0002: 0002-Use-getnameinfo-instead-of-gethostbyaddr.patch
  20. Patch0003: 0003-Drop-root-priviledges-before-opening-first-savefile-.patch
  21. Patch0004: 0004-tcpslice-update-tcpslice-patch-to-1.2a3.patch
  22. Patch0005: 0005-tcpslice-remove-unneeded-include.patch
  23. Patch0006: 0006-tcpslice-don-t-test-the-pointer-but-pointee-for-NULL.patch
  24. Patch0007: 0007-Introduce-nn-option.patch
  25. Patch0008: 0008-Don-t-print-out-we-dropped-root-we-are-always-droppi.patch
  26. %define tcpslice_dir tcpslice-1.2a3
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. BuildRequires: glibc-kernheaders >= 2.2.0
  29. BuildRequires: openssl-devel
  30. BuildRequires: libpcap-devel >= %{libpcap_ver}
  31. BuildRequires: autoconf, automake
  32. BuildRequires: git
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: daisuke, shaolin, Takemikaduchi
  36. %description
  37. Tcpdump is a command-line tool for monitoring network traffic.
  38. Tcpdump can capture and display the packet headers on a particular
  39. network interface or on all interfaces. Tcpdump can display all of the
  40. packet headers, or just the ones that match particular criteria.
  41. Install tcpdump if you need a program to monitor network traffic.
  42. %description -l ja
  43. tcpdump はネットワークのトラフィックをモニタする、コマンドライン
  44. ベースのツールです。tcpdump はあるネットワークインターフェイス
  45. もしくは全てのネットワークインターフェイス上のパケットのヘッダを
  46. キャプチャして表示することができます。tcpdump は全てのパケットの
  47. ヘッダを表示することもできますし、ある規則に合致するものだけを
  48. 表示することもできます。
  49. ネットワークのトラフィックをモニタする必要がある場合、tcpdump を
  50. インストールしてください。
  51. %prep
  52. %autosetup -a 1 -S git
  53. %build
  54. export CFLAGS="$RPM_OPT_FLAGS $(getconf LFS_CFLAGS) -fno-strict-aliasing"
  55. pushd %{tcpslice_dir}
  56. # update config.{guess,sub}
  57. automake -a -f 2> /dev/null || :
  58. %configure
  59. make %{?_smp_mflags}
  60. popd
  61. %configure --with-crypto --with-user=tcpdump --without-smi
  62. make %{?_smp_mflags}
  63. %install
  64. rm -rf %{buildroot}
  65. mkdir -p %{buildroot}%{_libdir}
  66. mkdir -p %{buildroot}%{_mandir}/man{3,8}
  67. mkdir -p %{buildroot}%{_sbindir}
  68. pushd %{tcpslice_dir}
  69. install -m755 tcpslice ${RPM_BUILD_ROOT}%{_sbindir}
  70. install -m644 tcpslice.1 ${RPM_BUILD_ROOT}%{_mandir}/man8/tcpslice.8
  71. popd
  72. install -m755 tcpdump ${RPM_BUILD_ROOT}%{_sbindir}
  73. install -m644 tcpdump.1 ${RPM_BUILD_ROOT}%{_mandir}/man8/tcpdump.8
  74. # fix section numbers
  75. sed -i 's/\(\.TH[a-zA-Z ]*\)[1-9]\(.*\)/\18\2/' \
  76. ${RPM_BUILD_ROOT}%{_mandir}/man8/*
  77. %clean
  78. rm -rf %{buildroot}
  79. %pre
  80. groupadd -g 72 tcpdump 2> /dev/null ||:
  81. useradd -u 72 -g 72 -s /sbin/nologin -M -r \
  82. -d / tcpdump 2> /dev/null ||:
  83. exit 0
  84. %files
  85. %defattr(-,root,root)
  86. %license LICENSE
  87. %doc README.md CHANGES CREDITS
  88. %{_sbindir}/tcpdump
  89. %{_sbindir}/tcpslice
  90. %{_mandir}/man8/tcpslice.8*
  91. %{_mandir}/man8/tcpdump.8*
  92. %changelog
  93. * Sun Sep 17 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1:4.9.2-1
  94. - new upstream release.
  95. - dropped all patches.
  96. - imported patches from rawhide.
  97. - updated %%SOURCE1.
  98. * Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:4.7.4-2
  99. - rebuild with openssl-1.0.2g
  100. * Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:4.7.4-1
  101. - new upstream release
  102. * Sun Mar 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:4.7.3-1
  103. - new upstream release
  104. - update Patch10 (tcpdump-4.7.3-portnumbers.patch)
  105. - update Patch21 (tcpdump-4.7.3-isis-dos.patch)
  106. - remove Patch16,17,22
  107. * Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:4.5.1-1
  108. - new upstream release
  109. * Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:4.3.0-1
  110. - new upstream release
  111. * Thu Mar 22 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1:4.1.1-4
  112. - rebuild
  113. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:4.1.1-3
  114. - rebuild with openssl-1.0.0c
  115. * Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.1.1-2
  116. - removed pcap header direction
  117. - added URL tag
  118. * Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.1.1-1
  119. - new upstream release
  120. - updated Patch10
  121. - built with new toolchain
  122. * Sat Apr 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.0.0-2
  123. - spec in UTF-8
  124. - added BuildRequires: libpcap-devel instead of libpcap
  125. - changed Group to Applications/System
  126. * Thu Oct 30 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:4.0.0-1
  127. - new upstream release with libpcap 1.0.0
  128. * Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:3.9.8-2
  129. - built again with libpcap-0.9.8 for sure this time
  130. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.8-1vl5
  131. - new upstream release
  132. * Sat Sep 1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.7-0vl1
  133. - new upstream release
  134. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.6-0vl1
  135. - new upstream release
  136. * Mon May 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:3.9.3-0vl3
  137. - rebuilt with new toolchain
  138. * Fri Aug 26 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.3-0vl2
  139. - dropped --with-user option
  140. * Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.3-0vl1
  141. - new upstream release
  142. - some patches are imported from fedora package
  143. - build with libpcap 0.9.3
  144. - changed BuildRequire kernel-headers to glibc-kernheaders
  145. * Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.8.3-0vl1
  146. - new upstream release
  147. - some patches are imported from fedora package
  148. * Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.7.2-0vl1
  149. - updated to 3.7.2
  150. - fixed patches based on Redhat Rawhide
  151. - rebuild with libpcap-0.7.2
  152. - s/Copyright/License/
  153. * Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl2
  154. - split out libpcap, Requires: libpcap
  155. * Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl1
  156. - update to new upstream release tcpdump 3.7.1, arpwatch 0.7.1
  157. - drop unneeded patches
  158. - use autoconf213, automake14
  159. - split out arpwatch
  160. * Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl2
  161. - add patch16 to fix print_bgp security bug
  162. - errata 20030221-3
  163. * Wed Jun 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl1
  164. - merged with 3.6.2-13
  165. - fix buffer overflow for errata
  166. * Thu May 16 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-13
  167. - added official 3.6.3 fix
  168. - fixed 6.2 compat #63113
  169. * Wed Jan 23 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-12
  170. - tcpdump-3.6.2-snaplen.patch added to fix #55145
  171. * Tue Dec 18 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-10
  172. - took old purge patch for filters
  173. - fixed #54225,#58346
  174. - drop root by default #49635
  175. - fixed #54593
  176. - fixed #57711
  177. * Thu Oct 25 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
  178. - 3.6.2-9vl1
  179. - used PRM macros
  180. - changed File Name to Package Name in Prereq tag
  181. - marged 3.6.2-9 (RedHat7.2)
  182. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  183. - 3.4-19vl2
  184. - use better macros
  185. * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
  186. - add libpcap-0.4-guy-gerald.patch to fix the timeout problem (by Ethereal)
  187. - add Japanese summarys and descriptions
  188. - modify spec file to build as a normal user
  189. * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  190. - Compile shared libpcap with -fPIC (Bug #6342)
  191. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  192. - fix descriptions
  193. - man pages are compressed
  194. * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
  195. - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
  196. - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
  197. - add getprotobyname lookup (#6725).
  198. - getservbyname port lookup appears functional (#7569).
  199. - remove uid 2090 backdoor (sorry Dave) (#7116).
  200. * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
  201. - fox the pcap.h header
  202. * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
  203. - prevent segfault on obscure spoofed ip header (#4634).
  204. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  205. - add defattr to arpwatch (#4591).
  206. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  207. - initscript munging
  208. * Sun Aug 8 1999 Jeff Johnson <jbj@redhat.com>
  209. - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
  210. * Tue Aug 3 1999 Jeff Johnson <jbj@redhat.com>
  211. - include A. Kuznetsov's patches to libpcap/tcpdump.
  212. - added arpsnmp to package (#3258).
  213. - arp2ethers written for different of awk (#4326).
  214. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  215. - auto rebuild in the new build environment (release 10)
  216. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  217. - strip binaries.
  218. * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
  219. - autoconf fixes for arm
  220. * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
  221. - libpcap description typo.
  222. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  223. - fix arpwatch summary line.
  224. * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
  225. - enable arpwatch
  226. * Mon Aug 3 1998 Jeff Johnson <jbj@redhat.com>
  227. - separate package for libpcap.
  228. - update tcpdump to 3.4, libpcap to 0.4.
  229. - added arpwatch (but disabled for now)
  230. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  231. - translations modified for de, fr, tr
  232. * Sat May 2 1998 Alan Cox <alan@rehat.com>
  233. - Added the SACK printing fix so you can dump Linux 2.1+.
  234. * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
  235. - updated to release 3.4a5
  236. - uses a buildroot and %attr
  237. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  238. - built against glibc
  239. * Fri Aug 31 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-9
  240. - took better fix for #52654 from tcpdump cvs
  241. * Thu Aug 30 2001 Harald Hoyer <harald@redhat.de> 11:3.6.2-8
  242. - fixed #52654
  243. * Thu Jul 19 2001 Harald Hoyer <harald@redhat.de> 10:3.6.2-7
  244. - added shared library to libpcap (#47174)
  245. - afs printing security patch (#49294)
  246. * Wed Jun 20 2001 Harald Hoyer <harald@redhat.de>
  247. - use initgroups, instead of setgroups
  248. * Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
  249. - added dropgroup patches (#44563)
  250. * Mon May 07 2001 Harald Hoyer <harald@redhat.de>
  251. - switched to Pekka's tcpdump-3.6.2 package
  252. - incremented epoch
  253. * Sat Apr 14 2001 Pekka Savola <pekkas@netcore.fi>
  254. - fix building of tcpslice on glibc 2.2.2 (time.h)
  255. - disable /etc/init.d requirement and fix %post scripts in arpwatch
  256. * Wed Feb 14 2001 Harald Hoyer <harald@redhat.de>
  257. - glibc sys/time -> time include patch
  258. * Wed Feb 7 2001 Trond Eivind Glomsr <teg@redhat.com>
  259. - Add space to this check
  260. * Wed Feb 07 2001 Harald Hoyer <harald@redhat.com>
  261. - added check for presence of /etc/sysconfig/arpwatch (#23172)
  262. * Wed Feb 7 2001 Pekka Savola <pekkas@netcore.fi>
  263. - update to 3.6.2, 0.6.2 and new CVS of tcpslice.
  264. - i18n'ize arpwatch init script
  265. * Fri Feb 2 2001 Trond Eivind Glomsr <teg@redhat.com>
  266. - i18nize initscript
  267. * Mon Jan 29 2001 Harald Hoyer <harald@redhat.com>
  268. - fixed EINTR stopping for e.g. SIGSTOP. (#22008)
  269. - added -u option for tcpdump (#20231)
  270. - new arpwatch version (#23172)
  271. - added "all" and "one" interface for -i (#20907)
  272. - added arpwatch sysconfig (#23172)
  273. * Mon Jan 22 2001 Harald Hoyer <harald@redhat.com>
  274. - more (potential) overflows in libpcap. #21373
  275. - documentation fix for #20906
  276. * Sun Jan 14 2001 Pekka Savola <pekkas@netcore.fi>
  277. - use --enable-ipv6
  278. - Add two patches from CVS to enhance 802.2 printing, and more importantly,
  279. to be able to specify 'no stp'
  280. * Sat Jan 13 2001 Pekka Savola <pekkas@netcore.fi>
  281. - Make SMB printing output a lot more quiet unless in verbose mode.
  282. - Make -n resolve port/protocol numbers but not hostnames, -nn for no
  283. resolving at all
  284. - Separate droproot patch from a more generic man/usage fix one
  285. - Add non-promiscuous mode -by default patch, but don't apply it by default
  286. * Thu Jan 11 2001 Pekka Savola <pekkas@netcore.fi>
  287. - Update to tcpdump 3.6.1 and libpcap 0.6.1 releases.
  288. * Mon Jan 8 2001 Pekka Savola <pekkas@netcore.fi>
  289. - Update to 20010108 CVS, disable some upstreamed patches.
  290. - Change some additional .1 pages to .8.
  291. - Add droproot patch, some --usage and man page fixes.
  292. * Mon Jan 1 2001 Pekka Savola <pekkas@netcore.fi>
  293. - Initial packaging with latest tcpdump.org CVS tcpdump-3.6 and libpcap-0.6.
  294. - add earlier print-domain.c, the latest is segfaulting
  295. - don't unnecesessarily include snprintf.o, it didn't compile with gcc 2.96 anyway
  296. - don't use savestr, require openssl, tweak tweak tweak
  297. - add tcpslice, patch it a bit for egcs detection
  298. * Sun Dec 31 2000 Pekka Savola <pekkas@netcore.fi>
  299. - tcpdump: spice up the manpage about interfaces
  300. - tcpdump: add 'all' and 'any' keywords to -i, saner default behaviour.
  301. - upgrade arpwatch to 2.1a10
  302. * Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
  303. - more (potential) overflows in libpcap.
  304. * Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
  305. - eliminate still more buffer overflows (from FreeBSD) (#20069).
  306. * Thu Nov 2 2000 Jeff Johnson <jbj@redhat.com>
  307. - eliminate more buffer overflows (from FreeBSD) (#20069).
  308. - 802.1q ether type incorrect (#19850).
  309. - add -u flag to drop arpwatch privs (#19696).
  310. * Sun Oct 15 2000 Jeff Johnson <jbj@redhat.com>
  311. - updated ethercodes.dat
  312. * Thu Oct 12 2000 Jeff Johnson <jbj@redhat.com>
  313. - fix arpwatch tmp race (#18943).
  314. * Fri Aug 11 2000 Bill Nottingham <notting@redhat.com>
  315. - fix condrestart
  316. * Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
  317. - correct arpsnmp man pages (#15442).
  318. - don't print harmless ENOPROTOOPT message (#13518).
  319. * Fri Aug 4 2000 Jeff Johnson <jbj@redhat.com>
  320. - rebuild with final kernel headers (#13518).
  321. * Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
  322. - add STP patch (#14112).
  323. * Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
  324. - source /etc/init.d/functions
  325. - back out /etc/init.d/arpwatch, place file in /etc/rc.d
  326. - move initscript to /etc/init.d
  327. - changed initscript to use start() and stop() functions
  328. - added condrestart to init script
  329. - added %%post %%preun %%postun scripts to register arpwatch script
  330. - added Prereq: for all things needed in post/preun/postun
  331. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  332. - automatic rebuild
  333. * Tue Jul 11 2000 Jeff Johnson <jbj@redhat.com>
  334. - updated man page and help (pekkas@netcore.fi) (#10739 et al).
  335. * Sun Jun 18 2000 Jeff Johnson <jbj@redhat/com>
  336. - FHS packaging.
  337. * Tue May 9 2000 Bill Nottingham <notting@redhat.com>
  338. - minor tweaks for ia64 (prototypes)
  339. * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  340. - Compile shared libpcap with -fPIC (Bug #6342)
  341. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  342. - fix descriptions
  343. - man pages are compressed
  344. * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
  345. - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
  346. - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
  347. - add getprotobyname lookup (#6725).
  348. - getservbyname port lookup appears functional (#7569).
  349. - remove uid 2090 backdoor (sorry Dave) (#7116).
  350. * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
  351. - fox the pcap.h header
  352. * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
  353. - prevent segfault on obscure spoofed ip header (#4634).
  354. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  355. - add defattr to arpwatch (#4591).
  356. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  357. - initscript munging
  358. * Sun Aug 8 1999 Jeff Johnson <jbj@redhat.com>
  359. - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
  360. * Tue Aug 3 1999 Jeff Johnson <jbj@redhat.com>
  361. - include A. Kuznetsov's patches to libpcap/tcpdump.
  362. - added arpsnmp to package (#3258).
  363. - arp2ethers written for different of awk (#4326).
  364. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  365. - auto rebuild in the new build environment (release 10)
  366. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  367. - strip binaries.
  368. * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
  369. - autoconf fixes for arm
  370. * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
  371. - libpcap description typo.
  372. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  373. - fix arpwatch summary line.
  374. * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
  375. - enable arpwatch
  376. * Mon Aug 3 1998 Jeff Johnson <jbj@redhat.com>
  377. - separate package for libpcap.
  378. - update tcpdump to 3.4, libpcap to 0.4.
  379. - added arpwatch (but disabled for now)
  380. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  381. - translations modified for de, fr, tr
  382. * Sat May 2 1998 Alan Cox <alan@rehat.com>
  383. - Added the SACK printing fix so you can dump Linux 2.1+.
  384. * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
  385. - updated to release 3.4a5
  386. - uses a buildroot and %attr
  387. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  388. - built against glibc