apr-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431
  1. %define aprver 1
  2. # Arches on which the multilib apr.h hack is needed:
  3. %define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
  4. Name: apr
  5. Summary: Apache Portable Runtime library
  6. Summary(ja): Apache ポータブルランタイムライブラリ
  7. Version: 1.5.1
  8. Release: 1%{?_dist_release}
  9. Group: System Environment/Libraries
  10. License: Apache Software License
  11. URL: http://apr.apache.org/
  12. Source0: %{name}-%{version}.tar.bz2
  13. Source1: apr-wrapper.h
  14. Patch2: apr-0.9.7-deepbind.patch
  15. Patch3: apr-1.2.2-locktimeout.patch
  16. Patch4: apr-1.2.2-libdir.patch
  17. Patch5: apr-1.3.3-pkgconf.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: autoconf, libtool, python, doxygen
  20. BuildRequires: libuuid-devel
  21. Conflicts: subversion < 0.20.1-2
  22. Obsoletes: apache2-apr
  23. %description
  24. The mission of the Apache Portable Runtime (APR) is to provide a
  25. free library of C data structures and routines, forming a system
  26. portability layer to as many operating systems as possible,
  27. including Unices, MS Win32, BeOS and OS/2.
  28. %package devel
  29. Summary: APR library development kit
  30. Summary(ja): APR ライブラリ開発キット
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. Conflicts: subversion-devel < 0.20.1-2
  34. Obsoletes: apache2-apr-devel
  35. %description devel
  36. This package provides the support files which can be used to
  37. build applications using the APR library. The mission of the
  38. Apache Portable Runtime (APR) is to provide a free library of
  39. C data structures and routines.
  40. %prep
  41. %setup -q
  42. %patch2 -p1 -b .deepbind
  43. %patch3 -p1 -b .locktimeout
  44. %patch4 -p1 -b .libdir
  45. %patch5 -p1 -b .pkgconf
  46. %build
  47. # regenerate configure script etc.
  48. ./buildconf
  49. # Forcibly prevent detection of shm_open (which then picks up but
  50. # does not use -lrt).
  51. export ac_cv_search_shm_open=no
  52. %configure \
  53. --includedir=%{_includedir}/apr-%{aprver} \
  54. --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
  55. --with-devrandom=/dev/urandom \
  56. --disable-static \
  57. CC=gcc CXX=g++
  58. make %{?_smp_mflags} && make dox
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. make install DESTDIR=$RPM_BUILD_ROOT
  62. # Move docs to more convenient location
  63. rm -rf html
  64. mkdir -p html
  65. cp -pr docs/dox/html/* html/
  66. # mv docs/dox/html html
  67. # Trim exported dependecies
  68. sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
  69. $RPM_BUILD_ROOT%{_libdir}/libapr*.la
  70. sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/ */ /g}' \
  71. $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
  72. %ifarch %{multilib_arches}
  73. # Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
  74. # packages:
  75. mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
  76. $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
  77. install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
  78. %endif
  79. # Unpackaged files:
  80. rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
  81. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  82. %check
  83. # Fail if LFS support isn't present in a 32-bit build, since this
  84. # breaks ABI and the soname doesn't change: see #254241
  85. if grep 'define SIZEOF_VOIDP 4' include/apr.h \
  86. && ! grep off64_t include/apr.h; then
  87. cat config.log
  88. : LFS support not present in 32-bit build
  89. exit 1
  90. fi
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %post -p /sbin/ldconfig
  94. %postun -p /sbin/ldconfig
  95. %files
  96. %defattr(-,root,root,-)
  97. %doc CHANGES LICENSE NOTICE
  98. %{_libdir}/libapr-%{aprver}.so.*
  99. %files devel
  100. %defattr(-,root,root,-)
  101. %doc docs/APRDesign.html docs/canonical_filenames.html
  102. %doc docs/incomplete_types docs/non_apr_programs
  103. %doc --parents html
  104. %{_bindir}/apr-%{aprver}-config
  105. #{_libdir}/libapr-%{aprver}.a
  106. %{_libdir}/libapr-%{aprver}.so
  107. %{_libdir}/pkgconfig/*.pc
  108. %dir %{_libdir}/apr-%{aprver}
  109. %dir %{_libdir}/apr-%{aprver}/build
  110. %{_libdir}/apr-%{aprver}/build/*
  111. %dir %{_includedir}/apr-%{aprver}
  112. %{_includedir}/apr-%{aprver}/*.h
  113. %changelog
  114. * Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-1
  115. - update to 1.5.1
  116. * Sat Oct 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.5-1
  117. - new upstream release
  118. * Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
  119. - new upstream release
  120. - built with rpm-4.8.1
  121. - removed static libraries from devel package
  122. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
  123. - rebuilt with new toolchain
  124. * Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
  125. - new upstream release
  126. * Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
  127. - new upstream release with security fix (CVE-2009-2412)
  128. * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
  129. - new upstream release
  130. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
  131. - new upstream release
  132. - updated Patch5
  133. * Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
  134. - new upstream release
  135. - removed Patch1 and 6
  136. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
  137. - removed *.la files from devel package
  138. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
  139. - new upstream release
  140. - added Patch2 and 6 from Fedora
  141. * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
  142. - add fix for use of %%pI with psprintf
  143. * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
  144. - use RTLD_DEEPBIND in apr_dso_open by default
  145. * Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  146. - new upstream release
  147. * Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  148. - new upstream release
  149. * Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
  150. - remove Requires: gcc = %%(gcc -dumpversion)
  151. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
  152. - rebuilt with new toolchain
  153. * Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  154. - new upstream release
  155. * Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
  156. - initial build for Vine Linux based on FC package
  157. * Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
  158. - fix another multilib conflict (#192659)
  159. * Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
  160. - BR e2fsprogs-devel for libuuid
  161. * Mon May 8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
  162. - use multilib parallel-installation wrapper hack for apr.h
  163. * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
  164. - fix installbuilddir in apr-1-config
  165. * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
  166. - update to 1.2.7
  167. - use pkg-config in apr-1-config to make it libdir-agnostic
  168. * Thu Apr 6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
  169. - update to 1.2.6
  170. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
  171. - bump again for double-long bug on ppc(64)
  172. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
  173. - rebuilt for new gcc4.1 snapshot and glibc changes
  174. * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
  175. - fix namespace pollution (r354824, r355464)
  176. * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
  177. - fix build with recent glibc (#176911)
  178. * Tue Jan 3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
  179. - rebuilt again
  180. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  181. - rebuilt
  182. * Fri Dec 9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
  183. - rebuild for new gcc
  184. * Thu Dec 8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
  185. - add apr_file_seek() fixes from upstream (r326593, r326597)
  186. * Wed Dec 7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
  187. - apr-1-config: strip more exports (#175124)
  188. * Tue Dec 6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
  189. - avoid linking against -lrt
  190. - don't print -L${libdir} in --libs output
  191. - don't export -lcrypt/-luuid in .la file
  192. * Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
  193. - update to 1.2.2
  194. * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
  195. - use RTLD_DEEPBIND in apr_dso_open by default
  196. * Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
  197. - update to 0.9.7
  198. * Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
  199. - rebuild for new gcc
  200. * Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
  201. - don't override CFLAGS at build time
  202. - allow setting TCP_NODELAY and TCP_CORK concurrently
  203. - use _exit() not exit() in child if exec*() fails (upstream #30913)
  204. * Fri Sep 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
  205. - add from 0.9.x branch:
  206. * fix for apr_{uid,gid}_* error handling (r239592)
  207. * fix for apr_file_ write flushing (r267192)
  208. - add backport for use of readdir64_r (r265032, r265681, r265684)
  209. * Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
  210. - rebuild
  211. * Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
  212. - fix apr_procattr_child_*_set error handling
  213. * Tue Mar 1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
  214. - have apr-devel depend on specific version of gcc
  215. - add NOTICE to docdir
  216. * Wed Feb 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
  217. - update to 0.9.6
  218. * Wed Feb 2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
  219. - don't disable sendfile on s390 (IBM LTC, #146891)
  220. * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
  221. - really fix apr-config --srcdir
  222. * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
  223. - fix apr-config --srcdir again
  224. * Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
  225. - update to 0.9.5
  226. * Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
  227. - rebuild
  228. * Wed Sep 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
  229. - have -devel require apr of same V-R
  230. * Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
  231. - backport fixes from HEAD:
  232. * correct implementation of nested mutexes
  233. * support for POSIX semaphores on LP64 platforms
  234. * Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
  235. - rebuild for another attempt at using sem_open
  236. * Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
  237. - move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
  238. * Thu Jul 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
  239. - rebuild
  240. * Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
  241. - rebuild now /dev/shm is mounted
  242. * Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
  243. - add fix for cleanup structure reuse (part of upstream #23567)
  244. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  245. - rebuilt
  246. * Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
  247. - add support for setuid/setgid/sticky bits (Andr辿 Malo)
  248. - add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
  249. * Mon Jun 7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
  250. - enable posixsem and process-shared pthread mutex support, but
  251. ensure that sysvsem remains the default mechanism
  252. * Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
  253. - entirely remove 2Gb file size limit from apr_file_copy();
  254. fixes "svnadmin hotcopy" on repos with >2Gb strings table
  255. - work around getnameinfo bugs with v4-mapped addresses
  256. - fix apr_time_exp_get() for dates in 2038 (Philip Martin)
  257. * Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
  258. - use APR_LARGEFILE in apr_file_{copy,append}
  259. * Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
  260. - add APR_LARGEFILE flag
  261. * Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
  262. - fix configure check for mmap of /dev/zero
  263. - just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
  264. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
  265. - rebuilt
  266. * Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
  267. - undocument apr_dir_read() ordering constraint and fix tests
  268. * Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
  269. - rebuilt without -Wall -Werror
  270. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
  271. - rebuilt
  272. * Tue Feb 3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
  273. - define apr_off_t as int/long/... to prevent it changing
  274. with _FILE_OFFSET_BITS on 32-bit platforms
  275. * Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
  276. - add apr_temp_dir_get fixes from HEAD
  277. * Thu Jan 8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
  278. - ensure that libapr is linked against libpthread
  279. - don't link libapr against -lnsl
  280. * Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
  281. - -devel package no longer requires libtool
  282. * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
  283. - disable tests on x86_64 (#97611)
  284. * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
  285. - update to 0.9.4, enable tests
  286. - ensure that libresolv is not used
  287. * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
  288. - use /dev/urandom (#103049)
  289. * Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
  290. - add back CC=gcc, CXX=g++
  291. * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
  292. - rebuild
  293. * Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
  294. - work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
  295. * Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
  296. - support --cc and --cpp arguments in apr-config
  297. * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
  298. - force libtool to use CC=gcc, CXX=g++
  299. * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
  300. - fix libtool location in apr_rules.mk
  301. * Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
  302. - use AI_ADDRCONFIG in getaddrinfo() support (#73350)
  303. - include a working libtool script rather than relying on
  304. /usr/bin/libtool (#97695)
  305. * Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
  306. - don't use /usr/bin/libtool
  307. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  308. - rebuilt
  309. * Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
  310. - add fix for psprintf memory corruption (CAN-2003-0245)
  311. - remove executable bit from apr_poll.h
  312. * Thu May 1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
  313. - link libapr against libpthread
  314. - make apr-devel conflict with old subversion-devel
  315. - fix License
  316. * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
  317. - run ldconfig in post/postun
  318. * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
  319. - patch test suite to not care if IPv6 is disabled
  320. * Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
  321. - initial build