aspell-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485
  1. %define _noVersionedDependencies 1
  2. %define ver 0.60.6.1
  3. %define rel 1
  4. Summary: A spelling checker.
  5. Summary(ja): スペルチェッカ
  6. Name: aspell
  7. Version: %{ver}
  8. Release: %{rel}%{?_dist_release}
  9. License: LGPL
  10. Group: Applications/Text
  11. URL: http://aspell.net/
  12. Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
  13. Source10: %{name}-install.sh
  14. Source11: %{name}-remove.sh
  15. Source12: %{name}-init.el
  16. Source100: aspell.conf
  17. Patch1003: aspell-0.60.3-install_info.patch
  18. Patch1005: aspell-0.60.5-fileconflict.patch
  19. Patch1007: aspell-0.60.5-pspell_conf.patch
  20. Patch1008: aspell-0.60.6-zero.patch
  21. Patch1009: aspell-0.60.6-mp.patch
  22. BuildRequires: gcc-c++ gettext ncurses-devel pkgconfig
  23. BuildRequires: chrpath
  24. Requires(post): %{_syssbindir}/install-info
  25. Requires(preun): %{_syssbindir}/install-info
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. Provides: pspell
  28. Obsoletes: ispell, pspell
  29. %description
  30. GNU Aspell is a spell checker designed to eventually replace Ispell. It can
  31. either be used as a library or as an independent spell checker. Its main
  32. feature is that it does a much better job of coming up with possible
  33. suggestions than just about any other spell checker out there for the
  34. English language, including Ispell and Microsoft Word. It also has many
  35. other technical enhancements over Ispell such as using shared memory for
  36. dictionaries and intelligently handling personal dictionaries when more
  37. than one Aspell process is open at once.
  38. %package devel
  39. Summary: Static libraries and header files for Aspell development.
  40. Group: Development/Libraries
  41. Requires: aspell = %{version}-%{release}
  42. Obsoletes: pspell-devel
  43. %description devel
  44. Aspell is a spelling checker. The aspell-devel package includes the
  45. static libraries and header files needed for Aspell development.
  46. %package el
  47. Summary: Emacs lisp for aspell
  48. Group: Applications/Editors/Emacs
  49. Requires: aspell = %{version}-%{release}
  50. Requires: emacsen-common
  51. %description el
  52. Aspell is a spelling checker. The aspell-el package includes the
  53. elisp for using aspell within emacsen.
  54. %prep
  55. %setup -q
  56. %patch1003 -p1 -b .iinfo
  57. %patch1005 -p1 -b .fc
  58. %patch1007 -p1 -b .mlib
  59. %patch1008 -p1 -b .zero
  60. %patch1009 -p1 -b .ai
  61. iconv -f windows-1252 -t utf-8 manual/aspell.info -o manual/aspell.info.aux
  62. mv manual/aspell.info.aux manual/aspell.info
  63. %build
  64. %configure --disable-rpath
  65. make %{?_smp_mflags}
  66. cp scripts/aspell-import examples/aspell-import
  67. chmod 644 examples/aspell-import
  68. cp manual/aspell-import.1 examples/aspell-import.1
  69. %install
  70. rm -rf %{buildroot}
  71. %makeinstall
  72. mv %{buildroot}%{_libdir}/aspell-*/ispell %{buildroot}%{_bindir}
  73. mv %{buildroot}%{_libdir}/aspell-*/spell %{buildroot}%{_bindir}
  74. chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//nroff-filter.so
  75. chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//sgml-filter.so
  76. chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//context-filter.so
  77. chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//email-filter.so
  78. chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//tex-filter.so
  79. chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//texinfo-filter.so
  80. chrpath --delete %{buildroot}%{_bindir}/aspell
  81. chrpath --delete %{buildroot}%{_libdir}/libpspell.so.*
  82. rm -f %{buildroot}%{_libdir}/libaspell.la
  83. rm -f %{buildroot}%{_libdir}/libpspell.la
  84. rm -f %{buildroot}%{_libdir}/aspell-0.60/*-filter.la
  85. rm -f %{buildroot}%{_bindir}/aspell-import
  86. rm -f %{buildroot}%{_mandir}/man1/aspell-import.1*
  87. # Add by H.Irokawa(2004.02.23)
  88. mkdir -p %{buildroot}%{_sysconfdir}
  89. install -m 644 %{SOURCE100} %{buildroot}%{_sysconfdir}/aspell.conf
  90. mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/aspell
  91. mkdir -p %{buildroot}%{_prefix}/lib/emacsen-common/packages/install
  92. mkdir -p %{buildroot}%{_prefix}/lib/emacsen-common/packages/remove
  93. install -m 644 %{SOURCE12} %{buildroot}/usr/share/emacs/site-lisp/%{name}
  94. # install script( bytecompile el and install elc , remove )
  95. %_installemacsenscript %{name} %{SOURCE10}
  96. %_removeemacsenscript %{name} %{SOURCE11}
  97. rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
  98. %find_lang %{name}
  99. %post
  100. /sbin/ldconfig
  101. # info
  102. if [ "$1" = 0 ] ; then
  103. %{_syssbindir}/install-info %{_infodir}/aspell.info.gz %{_infodir}/dir
  104. fi
  105. %post devel
  106. /sbin/ldconfig
  107. # info
  108. if [ "$1" = 0 ] ; then
  109. %{_syssbindir}/install-info %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
  110. fi
  111. %post el
  112. if [ "$1" = 2 ]; then
  113. %_emacsenPackageRemove %{name}
  114. fi
  115. %_addemacsenlist %{name}
  116. %_emacsenPackageInstall %{name}
  117. %postun
  118. /sbin/ldconfig
  119. %preun
  120. if [ $1 = 0 ]; then
  121. %{_syssbindir}/install-info --delete %{_infodir}/aspell.info.gz %{_infodir}/dir
  122. fi
  123. %preun devel
  124. if [ $1 = 0 ]; then
  125. %{_syssbindir}/install-info --delete %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
  126. fi
  127. %preun el
  128. if [ "$1" = 0 ]; then
  129. %_emacsenPackageRemove %{name}
  130. %_removeemacsenlist %{name}
  131. fi
  132. %clean
  133. rm -rf %{buildroot}
  134. %files -f %{name}.lang
  135. %defattr(-,root,root)
  136. %config(noreplace) %{_sysconfdir}/aspell.conf
  137. %doc README TODO COPYING examples/aspell-import examples/aspell-import.1
  138. %dir %{_libdir}/aspell-0.60
  139. %{_bindir}/a*
  140. %{_bindir}/ispell
  141. %{_bindir}/pr*
  142. %{_bindir}/run-with-aspell
  143. %{_bindir}/spell
  144. %{_bindir}/word-list-compress
  145. %{_libdir}/lib*.so.*
  146. %{_libdir}/aspell-0.60/*
  147. %{_infodir}/aspell.*
  148. %{_mandir}/man1/aspell.1.*
  149. %{_mandir}/man1/run-with-aspell.1*
  150. %{_mandir}/man1/word-list-compress.1*
  151. %{_mandir}/man1/prezip-bin.1.*
  152. %files devel
  153. %defattr(-,root,root)
  154. %{_bindir}/pspell-config
  155. %{_includedir}/aspell.h
  156. %{_includedir}/pspell
  157. %{_infodir}/aspell-dev.info*
  158. %{_libdir}/lib*spell.so
  159. %{_libdir}/pkgconfig/aspell.pc
  160. %{_mandir}/man1/pspell-config.1*
  161. %files el
  162. %{_datadir}/emacs/site-lisp/%{name}/
  163. %{_prefix}/lib/emacsen-common/packages/install/%{name}
  164. %{_prefix}/lib/emacsen-common/packages/remove/%{name}
  165. %changelog
  166. * Tue Mar 06 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.60.6.1-1
  167. - updated to 0.60.6.1
  168. - import Patch1009 from Fedora
  169. * Tue May 3 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-2
  170. - update aspell.conf (Source100)
  171. * Sat Apr 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-1
  172. - new upstream release
  173. - sync Fedora 0.60.6-14
  174. - split English dictionary package: create aspell-en package
  175. - drop unnecessary patches
  176. - prefix patch (Patch0)
  177. - fix compress patch (Patch1)
  178. - add some patches (Patch1003, 1005, 1007, 1008)
  179. - create aspell.pc file
  180. - update files
  181. - add post, preun scripts for info file
  182. - add Requires(post,preun) for installing info file
  183. - noreplace aspell.conf
  184. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.50.5-1vl5
  185. - applied new versioning policy, spec in utf-8
  186. * Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl3
  187. - rebuilt with new toolchain
  188. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl2
  189. - changed aspell-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  190. * Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.5-0vl1
  191. - upgrade to new upstream
  192. - drop aspell-0.50.3-gcc33.patch
  193. - update prefix.patch
  194. * Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl8
  195. - merged with errata package
  196. * Wed Oct 6 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.50.3-0vl5.1
  197. - added aspell-compress-bug.patch (CAN-2004-0548).
  198. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl7
  199. - fixed typo (s/%postun el/%preun el/)
  200. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl6
  201. - split elisp-related files into the aspell-el subpackage
  202. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl5
  203. - add PreReq: emacsen-common
  204. * Mon Feb 23 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.50.3-0vl4
  205. - add /etc/aspell.conf
  206. - modded aspell-init.el(Japanese blended English spell check)
  207. * Wed Feb 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl3
  208. - add %{_bindir}/{ispell,spell} for compatibility script
  209. - enable site-start.d stuff
  210. * Mon Nov 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.3-0vl2
  211. - fixed spec file character code to EUC-JP
  212. * Wed Jun 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl1
  213. - build for Vine Linux
  214. - merge aspell-en
  215. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  216. - rebuilt
  217. * Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-10
  218. - rebuild again to fix libpspell deps
  219. * Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-9
  220. - remove ExcludeArch
  221. * Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 7:0.50.3-8
  222. - fix build with gcc 3.3
  223. * Wed May 22 2003 Adrian Havill <havill@redhat.com> 0.50.3-7
  224. - require aspell-en for upgrades
  225. * Sun May 11 2003 Jeremy Katz <katzj@redhat.com> 6:0.50.3-6
  226. - -devel should obsolete pspell-devel
  227. * Tue May 6 2003 Joe Orton <jorton@redhat.com> 0.50.3-5
  228. - include libpspell.so in devel package
  229. * Wed May 1 2003 Adrian Havill <havill@redhat.com> 0.50.3-4
  230. - removed .la files
  231. * Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-3
  232. - Changed the header for provides, obsoletes, epoch
  233. - fixed config prefix in dirs.h
  234. * Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-1
  235. - upgrade to 0.50.3
  236. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  237. - rebuilt
  238. * Fri Nov 8 2002 Tim Powers <timp@redhat.com>
  239. - fix broken pspell epoch dep
  240. - create $RPM_BUILD_ROOT/usr/bin by hand
  241. - remove /usr/doc
  242. - fix hardcoding of /usr/lib so that we can build on x86_64
  243. * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.33.7.1-16
  244. - require pspell and pspell-devel using the proper epoch
  245. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
  246. - rebuilt with gcc-3.2 (we hope)
  247. * Mon Jul 22 2002 Tim Powers <timp@redhat.com> 0.33.7.1-14
  248. - rebuild using gcc-3.2-0.1
  249. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
  250. - automated rebuild
  251. * Thu Jun 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-12
  252. - Rebuild to make it work again... #66708
  253. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  254. - automated rebuild
  255. * Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-10
  256. - Rebuild
  257. * Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-9
  258. - Disable evil patch
  259. * Mon Jan 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-8
  260. - Build on more archs (doh)
  261. * Tue Jan 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-7
  262. - Make it compile with new compiler (evil workaround)
  263. * Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-5
  264. - Rebuild
  265. - Unexclude alpha
  266. * Fri Dec 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-3
  267. - Rebuild
  268. - Don't build on alpha
  269. * Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
  270. - "make it work with gcc 3.1" ;)
  271. * Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-1
  272. - 0.33.7.1, which is a "make it work with gcc 3" release
  273. * Wed Sep 12 2001 Tim Powers <timp@redhat.com>
  274. - rebuild with new gcc and binutils
  275. * Thu Aug 9 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7-1
  276. - 0.33.7 bugfix release. Requested by the author, it fixes
  277. coredumps in sug-mode and when not using typo-analyses.
  278. It also contains code cleanups so it compiles with -ansi
  279. - should fix coredump on IA64 (#49746)
  280. * Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
  281. - Add the .la files in the main package - used for dynamic loading
  282. * Sun Jun 3 2001 Trond Eivind Glomsrød <teg@redhat.com>
  283. - 0.33.6.3, which includes the fix made yesterday
  284. * Sat Jun 2 2001 Trond Eivind Glomsrød <teg@redhat.com>
  285. - Make it search for directories in the correct location
  286. * Wed May 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
  287. - No more workarounds at the specfile level
  288. * Tue May 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
  289. - Use custom ltmain.sh to work around buggy bundled libtool
  290. * Sun May 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
  291. - 0.33.6
  292. - use standard %%configure macro - it works now.
  293. * Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
  294. - Rebuild with new libltdl
  295. * Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
  296. - 0.33.5
  297. * Thu Nov 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
  298. - use new emacs init scheme for Emacs and XEmacs
  299. * Wed Nov 22 2000 Trond Eivind Glomsrød <teg@redhat.com>
  300. - .32.6
  301. * Sat Aug 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
  302. - .32.5 bugfix release (also contains improved documentation),
  303. obsolete old patch
  304. - the compatibility scripts are now part of the package itself
  305. - clean up build procedure
  306. - remove manual.aux file from docs (#16424)
  307. * Sun Aug 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
  308. - .32.1 bugfix release, obsolete old patch
  309. - rename to 0.32.1
  310. - add patch from author to change his email address
  311. - add spell and ispell compatibility scripts
  312. * Fri Aug 04 2000 Trond Eivind Glomsrød <teg@redhat.com>
  313. - rebuild
  314. * Tue Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
  315. - remember to obsolete ispell
  316. - build the Canadian and British dictionaries here now,
  317. as part of the main package. Same package names and
  318. descriptions.
  319. * Mon Jul 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
  320. - .32
  321. - remove old patches, add a patch since namespace isn't
  322. polluted as much anymore (as opposed to older toolchain)
  323. * Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
  324. - rebuild
  325. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  326. - automatic rebuild
  327. * Tue Jul 4 2000 Jakub Jelinek <jakub@redhat.com>
  328. - Rebuild with new C++
  329. * Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
  330. - use RPM_OPT_FLAGS, not just -O0
  331. - dont include .la-files
  332. * Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
  333. - excludearch ia64
  334. * Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
  335. - patch to work around compiler bug(?) wrt. inline functions
  336. - use CFLAGS and CXXFLAGS
  337. - set them to -O0 to work around YACB
  338. - copy libtool files for IA64 support
  339. * Sun Jun 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
  340. - update to .31.1. My patch was upstreamed and is no longer needed.
  341. - new patch added so DESTDIR works properly
  342. * Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
  343. - (this entry includes some old ones...)
  344. - update to .31
  345. - added patch to make it compile with a pickier compiler
  346. - include /usr/share/pspell
  347. * Mon May 1 2000 Tim Powers <timp@redhat.com>
  348. - updated to .30.1
  349. - used build fixes from Ryan Weaver's 0.30.1-1 package on sourceforge
  350. - updated URL, download/ftp location
  351. - removed redundant define's at top of spec file
  352. * Thu Jul 8 1999 Tim Powers <timp@redhat.com>
  353. - built for Powertools 6.1
  354. - removed %serial definitions from spec file to make versioning
  355. consistant with the other packages we ship.
  356. - changed build root path
  357. - general spec file cleanups
  358. * Tue Mar 2 1999 Ryan Weaver <ryanw@infohwy.com>
  359. [aspell-.27.2-2]
  360. - Changes from .27.1 to .27.2 (Mar 1, 1999)
  361. - Fixed a major bug that caused aspell to dump core when used
  362. without any arguments
  363. - Fixed another major bug that caused aspell to do nothing when used
  364. in interactive mode.
  365. - Added an option to exit in Aspell's interactive mode.
  366. - Removed some old documentation files from the distribution.
  367. - Minor changes on to the section on using Aspell with egcs.
  368. - Minor changes to remove -Wall warnings.