expat-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name expat
  3. %define version 2.0.1
  4. %define release 8%{?_dist_release}
  5. Summary: Expat is an XML 1.0 parser written in C
  6. Summary(ja): C で書かれた XML 1.0 パーサ
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. License: MIT/X
  11. Group: Applications/Text
  12. URL: http://www.libexpat.org/
  13. Source: http://download.sourceforge.net/expat/%{name}-%{version}.tar.gz
  14. Patch100: expat-2.0.1-CVE-2009-3560-revised.patch
  15. Patch110: expat-2.0.1_CVE-2009-3720.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. Requires: lib%{name} = %{version}-%{release}
  18. BuildRequires: libtool
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. This is Expat, a C library for parsing XML, written by James Clark.
  23. Expat is a stream-oriented XML parser. This means that you register
  24. handlers with the parser before starting the parse. These handlers
  25. are called when the parser discovers the associated structures in the
  26. document being parsed. A start tag is an example of the kind of
  27. structures for which you may register handlers.
  28. %package -n lib%{name}
  29. Summary: Runtime library of expat
  30. Summary(ja): Expat のための実行ライブラリ
  31. Group: System Environment/Libraries
  32. %description -n lib%{name}
  33. This package contains the runtime, shared library of expat, the C
  34. library for parsing XML.
  35. %description -n lib%{name} -l ja
  36. Expat を動作させるために必用となるライブラリです.
  37. %package devel
  38. Summary: Development environment for the expat XML parser
  39. Summary(ja): expat XML パーサ用開発環境
  40. Group: Development/Libraries
  41. Requires: lib%{name} = %{version}-%{release}
  42. %description devel
  43. Development environment for the expat XML parser
  44. %description devel -l ja
  45. expat XML パーサ用開発環境です.
  46. ## to build compat32 for x86_64 architecture support
  47. %package -n compat32-lib%{name}
  48. Summary: Runtime library of expat
  49. Summary(ja): Expat のための実行ライブラリ
  50. Group: System Environment/Libraries
  51. Requires: lib%{name} = %{version}-%{release}
  52. %description -n compat32-lib%{name}
  53. This package contains the runtime, shared library of expat, the C
  54. library for parsing XML.
  55. %description -n compat32-lib%{name} -l ja
  56. Expat を動作させるために必用となるライブラリです.
  57. %package -n compat32-%{name}-devel
  58. Summary: Development environment for the expat XML parser
  59. Summary(ja): expat XML パーサ用開発環境
  60. Group: Development/Libraries
  61. Requires: %{name}-devel = %{version}-%{release}
  62. Requires: compat32-lib%{name} = %{version}-%{release}
  63. %description -n compat32-%{name}-devel
  64. Development environment for the expat XML parser
  65. %description -n compat32-%{name}-devel -l ja
  66. expat XML パーサ用開発環境です.
  67. %prep
  68. %setup -q
  69. %patch100 -p1 -b .CVE-2009-3560
  70. %patch110 -p1 -b .CVE-2009-3720
  71. %build
  72. export CFLAGS="$RPM_OPT_FLAGS -fPIC"
  73. %configure --enable-shared
  74. make %{?_smp_mflags}
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. rm -f examples/*.dsp
  78. chmod 644 README COPYING Changes doc/* examples/*
  79. make DESTDIR=$RPM_BUILD_ROOT install
  80. rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %post -n lib%{name} -p /sbin/ldconfig
  84. %postun -n lib%{name} -p /sbin/ldconfig
  85. %post -n compat32-lib%{name} -p /sbin/ldconfig
  86. %postun -n compat32-lib%{name} -p /sbin/ldconfig
  87. %files
  88. %defattr(-,root,root)
  89. %doc COPYING Changes README
  90. %{_bindir}/xmlwf
  91. %{_mandir}/man1/xmlwf.1*
  92. %files -n lib%{name}
  93. %defattr(-,root,root)
  94. %doc COPYING Changes README
  95. %{_libdir}/libexpat.so.*
  96. %files devel
  97. %defattr(-,root,root)
  98. %doc COPYING Changes README doc/* examples
  99. %{_includedir}/*
  100. %{_libdir}/libexpat.a
  101. %{_libdir}/libexpat.so
  102. ## to build compat32 for x86_64 architecture support
  103. %if %{build_compat32}
  104. %files -n compat32-lib%{name}
  105. %defattr(-,root,root)
  106. %{_libdir}/libexpat.so.*
  107. %files -n compat32-%{name}-devel
  108. %defattr(-,root,root)
  109. %{_libdir}/libexpat.a
  110. %{_libdir}/libexpat.so
  111. %endif
  112. %changelog
  113. * Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
  114. - update patch100 to regrassion fix (same as debian bug #561658)
  115. - add Vendor and Distribution tags
  116. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
  117. - rebuilt with rpm-4.8.1-3
  118. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
  119. - rebuilt with gcc-4.4.3-3 on ppc
  120. * Mon Feb 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
  121. - rebuilt with new toolchains (for VineSeed)
  122. * Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
  123. - add patch110 for fix CVE-2009-3720 (xml parser)
  124. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
  125. - add Patch100 for fix CVE-2009-3560 (xml parser)
  126. * Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
  127. - added Requires: tag to compat32-* sub-packages.
  128. - removed unnecessary %%configure CC='gcc -m32' option
  129. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
  130. - applied new versioning policy and spec in utf-8
  131. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
  132. - removed %%if !%%{build_compat32} case condition
  133. * Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
  134. - new upstream release
  135. - drop Patch0
  136. - drop .la
  137. - chmod 644 the documentation
  138. - strip DSP files from examples
  139. - update description and drop description-ja
  140. - add -fPIC
  141. * Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
  142. - rebuilt
  143. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
  144. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  145. * Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
  146. - added compat32* packages for x86_64 architecture support
  147. * Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
  148. - add missing header file (expat_external.h) to %%files.
  149. * Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
  150. - updated/revised Patch1 (%%install will fail without this patch)
  151. * Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
  152. - new upstream release
  153. -- dropped patch1
  154. * Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
  155. - updated to 1.95.7
  156. - changed URL and Group
  157. - fixed License to MIT/X (based on rpm package at sourceforge)
  158. * Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
  159. - version up to 1.95.6
  160. - drop expat-xmlwf-dynamiclink.patch (Patch0)
  161. - add expat-1.95.6-mandir.patch for installing manpage (Patch0)
  162. - add manpage (xmlwf.1)
  163. * Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
  164. - fixed license ( s/MPL or GPL/distributable/ )
  165. - use License tag
  166. * Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
  167. - new sub-package libexpat.
  168. - added BuildPreReq: libtool
  169. * Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
  170. - updated to 1.95.2 release
  171. * Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  172. - 1.95.1-3vl1
  173. - based on 1.95.1-3mdk from Mandrake 8.0
  174. - added Japanese summary and description
  175. - modified spec macros for Vine
  176. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
  177. - real version is 1.95.1
  178. - reenable optimisations
  179. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
  180. - release .
  181. * Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
  182. - Don't try to use optimizations
  183. - Bzip2 sources
  184. * Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
  185. - first version