self-build-audacious-plugins-extra-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. %define pkgname audacious-plugins-extra
  2. %define name self-build-%{pkgname}
  3. %define version 2.3
  4. %define release 2%{?_dist_release}
  5. %define sourceurl0 http://distfiles.atheme.org/audacious-plugins-%{version}.tgz
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPLv2
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.8
  15. Requires(post): self-build-faad2
  16. Requires(post): self-build-ffmpeg
  17. Requires(post): self-build-lame
  18. Requires(post): self-build-libmad
  19. Requires(post): audacious-devel >= 2.3-1
  20. Requires(post): glib2-devel >= 2.8.0
  21. Requires(post): gtk2-devel >= 2.10.0
  22. Requires(post): pango-devel >= 1.8.0
  23. Requires(post): mcs-devel
  24. Requires(post): dbus-devel
  25. Requires(post): dbus-glib-devel
  26. Requires(post): libogg-devel >= 1.0
  27. Requires(post): libvorbis-devel >= 1.0
  28. Requires(post): flac-devel >= 1.2.0
  29. Requires: audacious-libs >= 2.3-1
  30. Requires: glib2 >= 2.8.0
  31. Requires: gtk2 >= 2.10.0
  32. Requires: pango >= 1.8.0
  33. BuildArch: noarch
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  35. Obsoletes: self-build-audacious-mad < %{version}-%{release}
  36. Packager: inagaki
  37. %description
  38. This package contains input plugins that enable playback of MP3/TTA/WMA
  39. files and a output plugins tha enable encode MP3 files in Audacious.
  40. If you install this package, it automaticaly downloads source
  41. code ,compile it, and create rpm packages of audacious-aac, audacious-ffmpeg,
  42. audacious-mad and audacious-lame.
  43. And the created rpm packages are automatically installed
  44. if installation is executed by apt-get command or synaptic
  45. package manager.
  46. [Note]
  47. This package requires many other packages to compile
  48. targetsoftware. So it consume more disk space than usual.
  49. Also installation takes logner time because of compilation.
  50. (This will take a few minutes to quarter or half of an hour,
  51. depends on building environment)
  52. [About self-build package]
  53. For some kind of software, distributing of binary package
  54. may viorate the patent or law. Therefore we chose self-build
  55. packge, create binary package on your machine, for such kind
  56. of softwares instead of distributing binary package.
  57. Please obey the national law when you use the created binary
  58. packages. And if you want to use the softwares using patented
  59. thechnology, it may be required to get a permission, make an
  60. agreement or purchas a license. Please consider it with your
  61. purpose or way of use and take appropriate action.
  62. %description -l ja
  63. Audacious で MP3 ファイルの再生を可能にするプラグインです。
  64. このパッケージをインストールすると、自動的にソースコードを
  65. ダウンロードしてコンパイルし、audacious-aac, audacious-ffmpeg,
  66. audacious-mad および audacious-lame の rpm パッケージを作成します。
  67. また apt-get コマンドや synaptic パッケージマネージャから実行
  68. した場合は、作成された rpm パッケージのインストールも自動的に
  69. 行います。
  70. [注意]
  71. コンパイルに必要な多くの関連パッケージを要求するので通常より
  72. ディスクの領域を多く消費します。
  73. またインストール時にコンパイルを行うため、通常より時間がかか
  74. る場合があります。(環境にもよりますが数分から数十分程度)
  75. [self-build パッケージについて]
  76. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  77. 違反する可能性があるものがあります。その為、このような問題が
  78. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  79. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  80. ジという方法を採っています。
  81. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  82. アのライセンス、および利用する国の各種法令に従ってください。
  83. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  84. センスの購入などが必要となる場合がありますので、利用する目的
  85. や形態に応じて各自で判断し適切な対応を取ってください。
  86. %prep
  87. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  88. %install
  89. %{__rm} -rf ${RPM_BUILD_ROOT}
  90. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  91. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  92. %clean
  93. %{__rm} -rf ${RPM_BUILD_ROOT}
  94. %posttrans
  95. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}"
  96. %files
  97. %defattr(-,root,root)
  98. %{_datadir}/%{name}
  99. %changelog
  100. * Sat Jun 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-2
  101. - added aac, ffaudio, filewriter_mp3 plugins
  102. - Obsoletes: self-build-audacious-mad < 2.3-1
  103. * Sat May 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-1
  104. - new upstream release
  105. * Thu Aug 13 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-2
  106. - fixed Requires(post)
  107. * Sun Aug 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-1
  108. - initial bulid