self-build-chromium-ffmpeg-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. %define pkgname chromium-ffmpeg
  2. %define name self-build-%{pkgname}
  3. %define version 20.0.1132.54
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://gsdview.appspot.com/chromium-browser-official/chromium-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. Source100: chromium-ffmpeg-20.0.1132.54-drop-dependencies-base-gyp.patch
  13. License: BSD
  14. Group: Restricted Software
  15. Obsoletes: %{pkgname} < %{version}
  16. Obsoletes: self-build-%{pkgname} < %{version}-%{release}
  17. Requires(post): self-build-setup >= 0.9.9
  18. # (build)requies of target package.
  19. Requires: chromium >= %{version}
  20. #Requires(post): libgnome-keyring-devel
  21. Requires(post): zlib-devel
  22. BuildArch: noarch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. Packager: munepi
  25. %description
  26. FFMPEG library built from the chromium sources.
  27. If you install this package, it automaticaly downloads source
  28. code, compile it, and create rpm packages of
  29. %{pkgname}-%{version}.
  30. And the created rpm packages are automatically installed
  31. if installation is executed by apt-get command or synaptic
  32. package manager.
  33. [Note]
  34. This package requires many other packages to compile
  35. targetsoftware. So it consume more disk space than usual.
  36. Also installation takes logner time because of compilation.
  37. (This will take a few minutes to quarter or half of an hour,
  38. depends on building environment)
  39. [About self-build package]
  40. For some kind of software, distributing of binary package
  41. may viorate the patent or law. Therefore we chose self-build
  42. packge, create binary package on your machine, for such kind
  43. of softwares instead of distributing binary package.
  44. Please obey the national law when you use the created binary
  45. packages. And if you want to use the softwares using patented
  46. thechnology, it may be required to get a permission, make an
  47. agreement or purchas a license. Please consider it with your
  48. purpose or way of use and take appropriate action.
  49. %description -l ja
  50. chromium のソースから FFMPEG ライブラリをビルドします。
  51. このパッケージをインストールすると、自動的にソースコードをダ
  52. ウンロードしてコンパイルし、%{pkgname}-%{version}
  53. の rpm パッケージを作成します。
  54. また apt-get コマンドや synaptic パッケージマネージャから実行
  55. した場合は、作成された rpm パッケージのインストールも自動的に
  56. 行います。
  57. [注意]
  58. コンパイルに必要な多くの関連パッケージを要求するので通常より
  59. ディスクの領域を多く消費します。
  60. またインストール時にコンパイルを行うため、通常より時間がかか
  61. る場合があります。(環境にもよりますが数分から数十分程度)
  62. [self-build パッケージについて]
  63. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  64. 違反する可能性があるものがあります。その為、このような問題が
  65. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  66. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  67. ジという方法を採っています。
  68. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  69. アのライセンス、および利用する国の各種法令に従ってください。
  70. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  71. センスの購入などが必要となる場合がありますので、利用する目的
  72. や形態に応じて各自で判断し適切な対応を取ってください。
  73. %prep
  74. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  75. %install
  76. %{__rm} -rf ${RPM_BUILD_ROOT}
  77. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  78. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  79. %{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  80. %clean
  81. %{__rm} -rf ${RPM_BUILD_ROOT}
  82. %posttrans
  83. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 412000
  84. %files
  85. %defattr(-,root,root)
  86. %{_datadir}/%{name}/*
  87. %changelog
  88. * Thu Jun 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 20.0.1132.54-1
  89. - updated to 20.0.1132.54
  90. # * Sun Jun 17 2012 Munehiro Yamamoto <munepi@vinelinux.org> 19.0.1084.50-2
  91. # - added Requires(post): libgnome-keyring-devel
  92. * Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 19.0.1084.50-1
  93. - updated to 19.0.1084.50
  94. - applied chromium-ffmpeg-19.0.1084.50-drop-dependencies-base-gyp.patch
  95. * Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
  96. - initial build