ffmpeg-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371
  1. #TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
  2. #TODO: add make test to %%check section
  3. #% define svndate 20100625
  4. %define with_faac 1
  5. %define with_vaapi 1
  6. %define with_libvpx 1
  7. #% define enable_avconv 1
  8. %define use_prebuilt_man 1
  9. %global major_version 0.11
  10. Summary: Digital VCR and streaming server
  11. Name: ffmpeg
  12. Version: %{major_version}.1
  13. Release: 1%{?svndate:.%svndate}%{?_dist_release}
  14. Source: http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  15. # pre-built man files
  16. #$ tar Jcvf ~/rpm/SOURCES/ffmpeg/ffmpeg-0.10-doc.tar.xz ffmpeg-0.10/doc/*.html ffmpeg-0.10/doc/*.pod ffmpeg-0.10/doc/*.1
  17. %{?use_prebuilt_man:Source90: ffmpeg-%{version}-doc.tar.xz}
  18. %if 0%{?_with_amr:1}
  19. License: GPLv3+
  20. %else
  21. License: GPLv2+
  22. %endif
  23. Group: Applications/Multimedia
  24. URL: http://ffmpeg.org/
  25. BuildRequires: bzip2-devel
  26. BuildRequires: celt-devel
  27. ##BuildRequires: dirac-devel
  28. BuildRequires: freetype2-devel
  29. BuildRequires: gsm-devel
  30. BuildRequires: imlib2-devel
  31. BuildRequires: libdc1394-devel
  32. BuildRequires: libogg-devel
  33. BuildRequires: libass-devel
  34. %{!?_without_cdio:BuildRequires: libcdio-devel}
  35. #libcrystalhd is currently broken
  36. %{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
  37. BuildRequires: libraw1394-devel
  38. BuildRequires: librtmp-devel >= 2.3
  39. BuildRequires: libtheora-devel
  40. %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
  41. BuildRequires: libvdpau-devel
  42. BuildRequires: libvorbis-devel
  43. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.6}
  44. BuildRequires: libXvMC-devel
  45. %{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
  46. %{!?_without_openal:BuildRequires: openal-soft-devel}
  47. %{?_with_opencv:BuildRequires: opencv-devel}
  48. %{?_with_openjpeg:BuildRequires: openjpeg-devel}
  49. ##BuildRequires: schroedinger-devel
  50. BuildRequires: SDL-devel
  51. BuildRequires: speex-devel
  52. %{!?use_prebuilt_man:BuildRequires: texi2html}
  53. BuildRequires: zlib-devel
  54. BuildRequires: yasm
  55. # *-devel packages provided by other self-build-* should only be listed
  56. # in self-build-%{name}.spec as PreReq.
  57. #BuildRequires: a52dec-devel
  58. #BuildRequires: faac-devel
  59. #BuildRequires: lame-devel
  60. #BuildRequires: libdca-devel
  61. #BuildRequires: x264-devel >= 0.0.0-18.20111216
  62. #BuildRequires: xvidcore-devel
  63. Requires: %{name}-libs = %{version}-%{release}
  64. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  65. Obsoletes: ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
  66. %description
  67. FFMpeg is a complete and free Internet live audio and video
  68. broadcasting solution for Linux/Unix. It also includes a digital
  69. VCR. It can encode in real time in many formats including MPEG1 audio
  70. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  71. %package libs
  72. Summary: Libraries for %{name}
  73. Group: System Environment/Libraries
  74. %description libs
  75. FFMpeg is a complete and free Internet live audio and video
  76. broadcasting solution for Linux/Unix. It also includes a digital
  77. VCR. It can encode in real time in many formats including MPEG1 audio
  78. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  79. This package contains the libraries for %{name}.
  80. %package devel
  81. Summary: Development package for %{name}
  82. Group: Development/Libraries
  83. Requires: %{name}-libs = %{version}-%{release}
  84. Requires: pkgconfig
  85. %description devel
  86. FFMpeg is a complete and free Internet live audio and video
  87. broadcasting solution for Linux/Unix. It also includes a digital
  88. VCR. It can encode in real time in many formats including MPEG1 audio
  89. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  90. This package contains development files for %{name}.
  91. %prep
  92. %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
  93. %{?use_prebuilt_man:tar -C .. -xf %{SOURCE90}}
  94. %build
  95. %ifarch ppc
  96. # compile with -mlongcall on ppc/ppc64 (rf804)
  97. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  98. %endif
  99. ./configure \
  100. --prefix=%{_prefix} \
  101. --incdir=%{_includedir}/%{name} \
  102. --shlibdir=%{_libdir} \
  103. --libdir=%{_libdir} \
  104. --mandir=%{_mandir} \
  105. --arch=%{_target_cpu} \
  106. %ifarch %{ix86}
  107. --cpu=%{_target_cpu} \
  108. %endif
  109. %ifarch ppc
  110. --cpu=g3 \
  111. --enable-pic \
  112. %endif
  113. --enable-runtime-cpudetect \
  114. --extra-cflags="$RPM_OPT_FLAGS" \
  115. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
  116. --enable-bzlib \
  117. %{!?_with_crystalhd:--disable-crystalhd} \
  118. --enable-zlib \
  119. %{?_with_frei0r:--enable-frei0r} \
  120. --enable-gnutls \
  121. --enable-libass \
  122. %{!?_without_cdio:--enable-libcdio} \
  123. --enable-libcelt \
  124. --enable-libdc1394 \
  125. %{?_with_libdirac:--enable-libdirac} \
  126. %{?with_faac:--enable-libfaac --enable-nonfree} \
  127. --enable-libfreetype \
  128. --enable-libgsm \
  129. --enable-libmp3lame \
  130. %{!?_without_openal:--enable-openal} \
  131. %{?_with_opencv:--enable-libopencv} \
  132. %{?_with_openjpeg:--enable-libopenjpeg} \
  133. --enable-librtmp \
  134. --enable-libspeex \
  135. --enable-libtheora \
  136. --enable-libvorbis \
  137. %{?with_libvpx:--enable-libvpx} \
  138. --enable-libx264 \
  139. --enable-libxvid \
  140. \
  141. --enable-x11grab \
  142. --enable-avfilter \
  143. --enable-postproc \
  144. --enable-pthreads \
  145. --disable-static \
  146. --enable-shared \
  147. --enable-gpl \
  148. %{?use_prebuilt_man:--disable-doc} \
  149. --disable-debug \
  150. --disable-stripping \
  151. \
  152. %{?enable_avconv:--enable-avconv} \
  153. ;
  154. %__make %{?_smp_mflags}
  155. %__make alltools
  156. %install
  157. %__make install DESTDIR=$RPM_BUILD_ROOT
  158. ## install tool/qt-faststart
  159. %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
  160. ## install man
  161. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  162. %__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  163. %clean
  164. %{__rm} -rf $RPM_BUILD_ROOT
  165. %post libs -p /sbin/ldconfig
  166. %postun libs -p /sbin/ldconfig
  167. %files
  168. %defattr(-,root,root,-)
  169. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  170. %{?enable_avconv:%{_bindir}/avconv}
  171. %{_bindir}/ffmpeg
  172. %{_bindir}/ffplay
  173. %{_bindir}/ffprobe
  174. %{_bindir}/ffserver
  175. %{_bindir}/qt-faststart
  176. %{?enable_avconv:%{_mandir}/man1/avconv.1*}
  177. %{_mandir}/man1/ffmpeg.1*
  178. %{_mandir}/man1/ffplay.1*
  179. %{_mandir}/man1/ffprobe.1*
  180. %{_mandir}/man1/ffserver.1*
  181. %{_datadir}/ffmpeg
  182. %files libs
  183. %defattr(-,root,root,-)
  184. %{_libdir}/lib*.so.*
  185. %files devel
  186. %defattr(-,root,root,-)
  187. %doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
  188. %{_includedir}/ffmpeg
  189. %{_libdir}/pkgconfig/lib*.pc
  190. %{_libdir}/lib*.so
  191. %changelog
  192. * Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
  193. - new upstream release
  194. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
  195. - new upstream release
  196. * Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
  197. - new upstream release
  198. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  199. - new upstream release
  200. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  201. - new upstream release
  202. - enable CELT decoding via libcelt
  203. - enable FreeType support
  204. - drop faad2 support (dropped upstream)
  205. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  206. - change release to sync with self-build-ffmpeg-vl.spec
  207. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  208. - new upstream release
  209. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  210. - new upstream release
  211. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  212. - required latest x264 build
  213. - added BuildRequires: librtmp-devel >= 2.3
  214. - build PIC objects on PPC
  215. #- add qt-faststart tool
  216. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  217. - new upstream release
  218. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  219. - change release to sync with self-build-ffmpeg-vl.spec
  220. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  221. - added BuildRequires: libvpx-devel >= 0.9.1
  222. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  223. - new upstream release
  224. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  225. - bumped version to pre-0.6
  226. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  227. - updated source snapshot 20100410
  228. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  229. - change release to sync with self-build-ffmpeg-vl.spec
  230. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  231. - change release to sync with self-build-ffmpeg-vl.spec
  232. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  233. - updated source snapshot 20100401
  234. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  235. - updated source snapshot 20100326
  236. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  237. - change release to sync with self-build-ffmpeg
  238. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  239. - updated source snapshot 20100216
  240. - rebuild with recent x264-devel
  241. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  242. - added BuildRequires: libvdpau-devel
  243. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  244. - change release to sync with self-build-ffmpeg
  245. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  246. - change release to sync with self-build-ffmpeg
  247. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  248. - applied ffmpeg-0.5-disable-texi2html.patch
  249. - dropped BuildRequires: texi2html
  250. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  251. - change release to sync with self-build-ffmpeg
  252. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  253. - corrected release number
  254. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  255. - new upstream release
  256. - added BuildRequires:
  257. - speex-devel
  258. - bzip2-devel
  259. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  260. - 20090227 snapshot
  261. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  262. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  263. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  264. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  265. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  266. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  267. - 20090202 snapshot
  268. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  269. - 20090110 snapshot
  270. - dropped some patches
  271. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  272. - source updated (r15488)
  273. - fixed License: GPLv2+
  274. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  275. - added BuildRequires: yasm (only %%ix86)
  276. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  277. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  278. - spec in utf8
  279. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  280. - change release to sync with self-build-ffmpeg
  281. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  282. - drop "Patch100: ffmpeg-vine.patch".
  283. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  284. - build with new versioning policy
  285. - change to use svn export from svn checkout on post install
  286. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  287. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  288. - [self-build-ffmpeg.spec]
  289. For all pre-required package that is provied by self-build,
  290. changed to its self-build package
  291. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  292. - initial build for Vine Linux 4.2
  293. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  294. ### end of file