self-build-gstreamer-plugins-ugly-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182
  1. %define pkgname gstreamer-plugins-ugly
  2. %define major 0.10
  3. %define _gst_ver 0.10.26
  4. %define _gstpb_ver 0.10.26
  5. %define version 0.10.19
  6. %define release 1%{?_dist_release}
  7. %define sourceurl http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
  8. Summary: Package to automatically build %{pkgname} rpm package
  9. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  10. Name: self-build-%{pkgname}
  11. Version: %{version}
  12. Release: %{release}
  13. Source0: %{pkgname}-vl.spec
  14. Source101: gstreamer-plugins-ugly-x264.patch
  15. License: LGPLv2+
  16. Group: Restricted Software
  17. Requires(post): self-build-setup >= 0.9.9
  18. # (build)requies of target package.
  19. Requires(post): libogg-devel, libtheora-devel, libvorbis-devel
  20. Requires(post): gstreamer-devel >= %{_gst_ver}
  21. Requires(post): gstreamer-plugins-base-devel >= %{_gstpb_ver}
  22. #Requires(post): gtk-doc >= 1.3
  23. Requires(post): python >= 2.1, python-pyxml
  24. Requires(post): glib2-devel >= 2.6
  25. Requires(post): twolame-devel
  26. Requires(post): liboil-devel >= 0.3.0
  27. Requires(post): libcdio-devel >= 0.82
  28. Requires(post): libdvdread-devel
  29. Requires(post): PyXML
  30. Requires(post): self-build-libmad >= 0.15
  31. Requires(post): libid3tag-devel >= 0.15
  32. Requires(post): self-build-ffmpeg
  33. Requires(post): self-build-x264
  34. Requires(post): self-build-libmpeg2
  35. Requires(post): self-build-a52dec
  36. Requires(post): self-build-lame
  37. Requires(post): self-build-libmad
  38. BuildArch: noarch
  39. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  40. Packager: munepi
  41. %description
  42. gstreamer-plugins-ugly is a set of ugly plugins for Gstreamer
  43. streaming-media framework.
  44. If you install this package, it automaticaly downloads source
  45. code, compile it, and create rpm packages of
  46. %{pkgname}-%{version}.
  47. And the created rpm packages are automatically installed
  48. if installation is executed by apt-get command or synaptic
  49. package manager.
  50. [Note]
  51. This package requires many other packages to compile
  52. targetsoftware. So it consume more disk space than usual.
  53. Also installation takes logner time because of compilation.
  54. (This will take a few minutes to quarter or half of an hour,
  55. depends on building environment)
  56. [About self-build package]
  57. For some kind of software, distributing of binary package
  58. may viorate the patent or law. Therefore we chose self-build
  59. packge, create binary package on your machine, for such kind
  60. of softwares instead of distributing binary package.
  61. Please obey the national law when you use the created binary
  62. packages. And if you want to use the softwares using patented
  63. thechnology, it may be required to get a permission, make an
  64. agreement or purchas a license. Please consider it with your
  65. purpose or way of use and take appropriate action.
  66. %description -l ja
  67. gstreamer-plugins-ugly は GStreamer ストリーミングメディア
  68. フレームワーク用 ugly プラグイン集です。
  69. このパッケージをインストールすると、自動的にソースコードを
  70. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  71. の rpm パッケージを作成します。
  72. また apt-get コマンドや synaptic パッケージマネージャから実行
  73. した場合は、作成された rpm パッケージのインストールも自動的に
  74. 行います。
  75. [注意]
  76. コンパイルに必要な多くの関連パッケージを要求するので通常より
  77. ディスクの領域を多く消費します。
  78. またインストール時にコンパイルを行うため、通常より時間がかか
  79. る場合があります。(環境にもよりますが数分から数十分程度)
  80. [self-build パッケージについて]
  81. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  82. 違反する可能性があるものがあります。その為、このような問題が
  83. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  84. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  85. ジという方法を採っています。
  86. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  87. アのライセンス、および利用する国の各種法令に従ってください。
  88. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  89. センスの購入などが必要となる場合がありますので、利用する目的
  90. や形態に応じて各自で判断し適切な対応を取ってください。
  91. %prep
  92. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  93. %install
  94. %{__rm} -rf ${RPM_BUILD_ROOT}
  95. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  96. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  97. %{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  98. %clean
  99. %{__rm} -rf ${RPM_BUILD_ROOT}
  100. %posttrans
  101. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 83000
  102. %files
  103. %defattr(-,root,root)
  104. %{_datadir}/%{name}
  105. %changelog
  106. * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
  107. - new upstream relase
  108. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
  109. - new upstream relase
  110. - built with new x264
  111. - License: LGPLv2+
  112. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
  113. - new upstream relase
  114. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
  115. - new upstream relase
  116. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
  117. - new upstream relase
  118. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
  119. - new upstream relase
  120. - renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
  121. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
  122. - new upstream relase
  123. * Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
  124. - new upstream relase
  125. - added Requires(post): self-build-libmpeg2
  126. - enable mpeg2dec with libmpeg2-devel in %%configure
  127. - check version between original spec and self-build spec in %%prep
  128. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
  129. - avoided to execute self-build-rpm.sh on RPM transaction
  130. - moved %%post actions to %%posttrans
  131. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
  132. - added BuildArch: noarch
  133. - dropped PreReq: gtk-doc >= 1.3
  134. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
  135. - new upstream relase
  136. * Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
  137. - changed to PreReq: self-build-libmad >= 0.15 from libmad-devel
  138. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
  139. - new upstream relase
  140. * Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
  141. - initial build for Vine Linux.