self-build-libmad-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. %define pkgname libmad
  2. %define name self-build-%{pkgname}
  3. %define version 0.15.1b
  4. %define release 7%{?_dist_release}
  5. # define sourceurl0 ftp://ftp.mars.org/pub/mpeg/%{pkgname}-%{version}.tar.gz
  6. %define sourceurl0 http://prdownloads.sourceforge.net/mad/%{pkgname}-%{version}.tar.gz
  7. Summary: Package to automatically build %{pkgname} rpm package
  8. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. Source0: %{pkgname}-vl.spec
  13. License: GPL
  14. Group: Restricted Software
  15. Requires(post): self-build-setup >= 0.9.9
  16. Requires(post): gcc-c++
  17. BuildArch: noarch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. Packager: munepi
  20. %description
  21. MAD (libmad) is a high-quality MPEG audio decoder. It currently supports
  22. MPEG-1 and the MPEG-2 extension to Lower Sampling Frequencies, as well as
  23. the so-called MPEG 2.5 format. All three audio layers (Layer I, Layer II,
  24. and Layer III a.k.a. MP3) are fully implemented.
  25. MAD does not yet support MPEG-2 multichannel audio (although it should be
  26. backward compatible with such streams) nor does it currently support AAC.
  27. If you install this package, it automaticaly downloads source
  28. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  29. And the created rpm packages are automatically installed
  30. if installation is executed by apt-get command or synaptic
  31. package manager.
  32. [Note]
  33. This package requires many other packages to compile
  34. targetsoftware. So it consume more disk space than usual.
  35. Also installation takes logner time because of compilation.
  36. (This will take a few minutes to quarter or half of an hour,
  37. depends on building environment)
  38. [About self-build package]
  39. For some kind of software, distributing of binary package
  40. may viorate the patent or law. Therefore we chose self-build
  41. packge, create binary package on your machine, for such kind
  42. of softwares instead of distributing binary package.
  43. Please obey the national law when you use the created binary
  44. packages. And if you want to use the softwares using patented
  45. thechnology, it may be required to get a permission, make an
  46. agreement or purchas a license. Please consider it with your
  47. purpose or way of use and take appropriate action.
  48. %description -l ja
  49. MAD (libmad) is a high-quality MPEG audio decoder. It currently supports
  50. MPEG-1 and the MPEG-2 extension to Lower Sampling Frequencies, as well as
  51. the so-called MPEG 2.5 format. All three audio layers (Layer I, Layer II,
  52. and Layer III a.k.a. MP3) are fully implemented.
  53. MAD does not yet support MPEG-2 multichannel audio (although it should be
  54. backward compatible with such streams) nor does it currently support AAC.
  55. このパッケージをインストールすると、自動的にソースコードを
  56. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  57. パッケージを作成します。
  58. また apt-get コマンドや synaptic パッケージマネージャから実行
  59. した場合は、作成された rpm パッケージのインストールも自動的に
  60. 行います。
  61. [注意]
  62. コンパイルに必要な多くの関連パッケージを要求するので通常より
  63. ディスクの領域を多く消費します。
  64. またインストール時にコンパイルを行うため、通常より時間がかか
  65. る場合があります。(環境にもよりますが数分から数十分程度)
  66. [self-build パッケージについて]
  67. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  68. 違反する可能性があるものがあります。その為、このような問題が
  69. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  70. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  71. ジという方法を採っています。
  72. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  73. アのライセンス、および利用する国の各種法令に従ってください。
  74. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  75. センスの購入などが必要となる場合がありますので、利用する目的
  76. や形態に応じて各自で判断し適切な対応を取ってください。
  77. %prep
  78. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  79. %install
  80. %{__rm} -rf ${RPM_BUILD_ROOT}
  81. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  82. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  83. %clean
  84. %{__rm} -rf ${RPM_BUILD_ROOT}
  85. %posttrans
  86. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 20000
  87. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  88. %{pkgname}-devel-%{version}-%{release}
  89. %files
  90. %defattr(-,root,root)
  91. %{_datadir}/%{name}
  92. %changelog
  93. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-7
  94. - renamed %%{Source0} to libmad-vl.spec
  95. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-6
  96. - rebuild with new toolchain
  97. * Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-5
  98. - changed to download from http://prdownloads.sourceforge.net/mad in %%sourceurl0
  99. - check version between original spec and self-build spec in %%prep
  100. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.15.1b-4
  101. - added BuildArch: noarch
  102. - avoided to execute self-build-rpm.sh on RPM transaction
  103. - moved %%post actions to %%posttrans
  104. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.15.1b-3
  105. - initial bulid for self-build