self-build-mplayer-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467
  1. %global with_faac 1
  2. %global with_vaapi 1
  3. %global with_libvpx 1
  4. # define with_ffmpeg 1
  5. %global ffmpegver 0.11.1
  6. %global pkgname mplayer
  7. %global name self-build-%{pkgname}
  8. %global version 1.1
  9. #% global svndate 20120525
  10. %global release 1%{?svndate:.%svndate}%{?_dist_release}
  11. %global source0path MPlayer/releases/MPlayer-%{version}.tar.xz
  12. %global source1url http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
  13. Summary: Package to automatically build %{pkgname} rpm package
  14. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  15. Name: %{name}
  16. Version: %{version}
  17. Release: %{release}
  18. Source0: %{pkgname}-vl.spec
  19. Source10: mplayer-snapshot-vine.sh
  20. Source11: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.8.tar.bz2
  21. Source12: http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.5.tar.bz2
  22. Source13: http://www.mplayerhq.hu/MPlayer/skins/standard-1.9.tar.bz2
  23. Source14: http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
  24. Source102: %{pkgname}-1.1-config-vine.patch
  25. Source108: %{pkgname}-1.1-manlinks.patch
  26. Source114: %{pkgname}-1.1-nodvdcss.patch
  27. Source118: %{pkgname}-1.1-ffmpeg.patch
  28. License: GPLv2+
  29. Group: Restricted Software
  30. Obsoletes: mplayer < %{version}-%{release}
  31. Obsoletes: self-build-mplayer < %{version}-%{release}
  32. Requires(post): self-build-setup >= 0.9.9
  33. %{?svndate:Requires(post): subversion}
  34. # (build)requies of target package.
  35. Requires(post): SDL-devel
  36. Requires(post): aalib-devel
  37. Requires(post): alsa-lib-devel
  38. Requires(post): cdparanoia-devel
  39. Requires(post): desktop-file-utils
  40. Requires(post): libdvdnav-devel
  41. Requires(post): enca-devel
  42. Requires(post): freetype2-devel >= 2.0.9
  43. Requires(post): fribidi-devel
  44. Requires(post): fontconfig-devel
  45. Requires(post): giflib-devel
  46. Requires(post): gtk2-devel
  47. Requires(post): mesa-libGL-devel
  48. Requires(post): libXinerama-devel
  49. Requires(post): libXScrnSaver-devel
  50. Requires(post): libXv-devel
  51. Requires(post): libXvMC-devel
  52. Requires(post): libXxf86dga-devel
  53. Requires(post): libXxf86vm-devel
  54. Requires(post): libass-devel
  55. Requires(post): libpng-devel
  56. Requires(post): libjpeg-devel
  57. Requires(post): libdvdread
  58. Requires(post): libmpcdec-devel >= 1.2.1
  59. Requires(post): librtmp-devel >= 2.3
  60. Requires(post): speex-devel >= 1.1
  61. %{?with_vaapi:Requires(post):libva-devel}
  62. Requires(post): libvdpau-devel
  63. Requires(post): libvorbis-devel
  64. %{?with_libvpx:Requires(post): libvpx-devel >= 0.9.6}
  65. Requires(post): lzo-devel >= 2
  66. Requires(post): pulseaudio-lib-devel
  67. Requires(post): speex-devel >= 1.1
  68. Requires(post): twolame-devel
  69. Requires(post): xorg-x11-devel
  70. Requires(post): yasm
  71. Requires(post): zlib-devel
  72. Requires(post): self-build-mplayer-codecs
  73. ##!!Requires(post): self-build-libdvdcss
  74. Requires(post): self-build-faac
  75. Requires(post): self-build-faad2 >= 2.6.1
  76. Requires(post): self-build-lame
  77. Requires(post): self-build-libdca
  78. Requires(post): self-build-libmad
  79. Requires(post): self-build-x264 >= 0.120
  80. Requires(post): self-build-xvidcore >= 0.9.2
  81. Requires(post): self-build-libmpeg2
  82. Requires: TrueType-vlgothic
  83. Requires: mesa-libGL
  84. BuildArch: noarch
  85. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  86. Packager: munepi
  87. %description
  88. MPlayer can play most standard video formats out of the box and almost
  89. all others with the help of external codecs.
  90. MPlayer currently works best from the command line, but visual feedback
  91. for many functions is available from its onscreen status display (OSD),
  92. which is also used for displaying subtitles.
  93. MPlayer also has a GUI with skin support and several unofficial alternative
  94. graphical frontends are available.
  95. MEncoder is a command line video encoder for advanced users that can
  96. be built from the MPlayer source tree. Unofficial graphical frontends
  97. exist but arenot included.
  98. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  99. support for some newer codecs are not yet inpmlemented.
  100. You should install mplayer-codecs package if you want to play videos
  101. using those new codecs.
  102. Additional function is automatically included if following
  103. packages are installed in advance.
  104. samba-libsmbclient-devel: SMB file system support
  105. [Note]
  106. This package requires many other packages to compile
  107. targetsoftware. So it consume more disk space than usual.
  108. Also installation takes logner time because of compilation.
  109. (This will take a few minutes to quarter or half of an hour,
  110. depends on building environment)
  111. [About self-build package]
  112. For some kind of software, distributing of binary package
  113. may viorate the patent or law. Therefore we chose self-build
  114. packge, create binary package on your machine, for such kind
  115. of softwares instead of distributing binary package.
  116. Please obey the national law when you use the created binary
  117. packages. And if you want to use the softwares using patented
  118. thechnology, it may be required to get a permission, make an
  119. agreement or purchas a license. Please consider it with your
  120. purpose or way of use and take appropriate action.
  121. %description -l ja
  122. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  123. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  124. で再生できます。
  125. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
  126. は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
  127. 面上で確認できます。
  128. MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
  129. 非公式なフロントエンドも利用できます。
  130. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  131. 非公式な GUI フロントエンドもありますが、このパッケージには含まれて
  132. いません。
  133. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  134. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  135. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  136. をインストールする必要があります。
  137. このパッケージより前に以下の関連パッケージをインストールして
  138. おくと、%{pkgname} が対応できる機能が自動的に追加されます。
  139. samba-libsmbclient-devel: SMB ファイルシステムのサポート
  140. [注意]
  141. コンパイルに必要な多くの関連パッケージを要求するので通常より
  142. ディスクの領域を多く消費します。
  143. またインストール時にコンパイルを行うため、通常より時間がかか
  144. る場合があります。(環境にもよりますが数分から数十分程度)
  145. [self-build パッケージについて]
  146. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  147. 違反する可能性があるものがあります。その為、このような問題が
  148. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  149. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  150. ジという方法を採っています。
  151. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  152. アのライセンス、および利用する国の各種法令に従ってください。
  153. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  154. センスの購入などが必要となる場合がありますので、利用する目的
  155. や形態に応じて各自で判断し適切な対応を取ってください。
  156. %prep
  157. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  158. %install
  159. %{__rm} -rf ${RPM_BUILD_ROOT}
  160. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  161. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  162. %{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  163. %{__install} -m 644 \
  164. %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} \
  165. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  166. %{__install} -m 644 \
  167. %{SOURCE102} %{SOURCE108} %{SOURCE114} %{SOURCE118} \
  168. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  169. %clean
  170. %{__rm} -rf ${RPM_BUILD_ROOT}
  171. %posttrans
  172. ## official tarball
  173. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  174. http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
  175. %{source1url} \
  176. 1368000
  177. exit 0
  178. ## svn checkout
  179. # set locale
  180. case $LANG in
  181. ja*)LOCALE=ja ;;
  182. *) LOCALE=C ;;
  183. esac
  184. GetSrc_C(){
  185. echo -n " "
  186. echo "Download source file with Subversion..."
  187. }
  188. GetSrc_ja(){
  189. echo -n " "
  190. echo "Subversion を用いてソースファイルをダウンロードしています..."
  191. }
  192. GetSrc_$LOCALE
  193. # svn checkout
  194. . /etc/self-build.conf
  195. (cd $TEMP_DIR
  196. su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
  197. %__mv %{pkgname}-export-%{svndate}.tar.xz %{_datadir}/%{name}/ || exit 1
  198. )
  199. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  200. http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} 1368000
  201. %files
  202. %defattr(-,root,root)
  203. %{_datadir}/%{name}
  204. %changelog
  205. * Wed Jun 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-1
  206. - updated to 1.1
  207. - built with ffmpeg-0.11.1
  208. - added some skins
  209. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
  210. - updated snapshot 20120525 with ffmpeg 0.11
  211. - dropped Requires(post): self-build-libdvdcss
  212. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
  213. - updated snapshot 20111217 (with ffmpeg 0.9)
  214. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
  215. - s/self-build-libdvdnav/libdvdnav/
  216. * Fri Oct 7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
  217. - updated %%source1path
  218. - update to 1.8
  219. * Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
  220. - dropped Requires(post): esound-devel
  221. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
  222. - new upstream release
  223. - ready for Vine Linux 6
  224. - revived support for Vine Linux 5
  225. - added Requires(post):
  226. - libass-devel
  227. - librtmp-devel >= 2.3
  228. - speex-devel >= 1.1
  229. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
  230. - added BuildRequires:
  231. - aalib-devel
  232. - enca-devel
  233. - lzo-devel
  234. - speex-devel
  235. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  236. - updated fixed %{name}-config.patch
  237. - applied %{name}-config-20100709-vine.patch
  238. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  239. - unpacked source archives
  240. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  241. - updated source snapshot 20100709
  242. - renamed %%Source10 to mplayer-snapshot-vine.sh
  243. - added Requires(post): libva-devel, libvpx-devel >= 0.9.1
  244. - dropped vl4 support
  245. - updated %%description
  246. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  247. - updated source snapshot 20100621
  248. - added Requires(post): libXinerama-devel
  249. - dropped vl4 support
  250. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  251. - updated source snapshot 20100401
  252. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  253. - updated source snapshot 20100317
  254. - renamed %%{Source0} to mplayer-vl.spec
  255. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  256. - updated source snapshot 20100216
  257. - dropped obsolete patches
  258. - added Requires(post): libvdpau-devel libXScrnSaver-devel
  259. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  260. - update mplayer-config-20091215-vine.patch
  261. - update mplayer-20091215-x86_32-compile.patch
  262. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  263. - source snapshot 20091031
  264. - updated mplayer-20091031-x86_32-compile.patch
  265. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  266. - source snapshot 20091003
  267. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  268. - added some if conditions for "vl6"
  269. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  270. - source snapshot 20090905
  271. - added settings for vl6
  272. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  273. - source snapshot 20090821
  274. - replaced BR: libungif-devel with BR: giflib-devel
  275. - mentioned VDPAU support in %%description
  276. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  277. - source snapshot 20090722
  278. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  279. - source snapshot 20090702
  280. - check version between original spec and self-build spec in %%prep
  281. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  282. - source snapshot 20090611
  283. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  284. - added Requires: TrueType-vlgothic
  285. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  286. - source snapshot 20090522
  287. - build with x264 >= 0.0.0-9.20090522
  288. - updated mplayer-20090502-nodvdcss.patch
  289. - avoided to execute self-build-rpm.sh on RPM transaction
  290. - moved %%post actions to %%posttrans
  291. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  292. - added PreReq: self-build-mplayer-codecs
  293. * Tue May 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  294. - added BuildArch: noarch
  295. - source snapshot 20090502
  296. - updated mplayer-20090503-x86_32-compile.patch
  297. - updated mplayer-20090502-nodvdcss.patch
  298. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  299. - included source archives:
  300. - mplayer-export-20090327.tar.bz2
  301. - Blue-1.7.tar.bz2
  302. - applied mplayer-config-vine.patch
  303. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  304. - source snapshot 20090327
  305. - updated mplayer-20090327-x86_32-compile.patch
  306. - updated mplayer-20090325-nodvdcss.patch
  307. - dropped gmplayer-about-vine.patch
  308. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  309. - source snapshot 20090206
  310. - dropped mplayer-man-zh_CN.patch
  311. - updated mplayer-20090206-nodvdcss.patch
  312. - changed to PreReq: self-build-faad2 from faad2-devel
  313. - added PreReq: self-build-libmad
  314. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  315. - source snapshot 20090131
  316. - fixed %%files section
  317. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  318. - fixed %%post: added rm -f "$pwd"/%{pkgname}-export-%{svndate}.tar.bz2
  319. * Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  320. - source snapshot
  321. - update mplayer-nodvdcss.patch: mplayer-20090122-nodvdcss.patch
  322. - added PreReq:
  323. - faad2-devel
  324. - libmpcdec-devel
  325. - twolame-devel
  326. - yasm
  327. - self-build-libdvdcss
  328. - self-build-libdvdnav
  329. - self-build-faac
  330. - self-build-lame
  331. - self-build-libdca
  332. - self-build-x264 >= 0.0.0-4.20090110
  333. - self-build-xvidcore >= 0.9.2
  334. - move %%define source0Exists() from %%post section to header
  335. - fixed %%post section: clean up source archive
  336. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  337. - source snapshot
  338. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  339. --disable-faad-internal in configure options
  340. - dropped gmplayer-add-flv-extension.patch
  341. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  342. - source snapshot
  343. - fixed License
  344. - added some patches from RPM Fusion
  345. - updated gmplayer-about-vine.patch for 20081001 snapshot
  346. - added BuildRequires: libdvdread
  347. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  348. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  349. in configure options
  350. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  351. - added PreReq: subversion
  352. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  353. - fixed License
  354. - added some devel packages to support OpenGL
  355. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  356. - spec in utf8
  357. - fix sybolic link of subfont for vl5
  358. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  359. - add "Source105: CVE-2008-1558.patch".
  360. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  361. - build with new versioning policy.
  362. - add "Source200: gmplayer-about-vine.patch".
  363. - add "Source201: gmplayer-add-flv-extension.patch".
  364. - fix <BTS:VineLinux:603>.
  365. - add ">= 0.7-1vl4" to "PreReq: self-build-setup".
  366. - add mirror URLs to self-build-rpm.sh.
  367. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  368. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  369. CVE-2008-0629, CVE-2008-0630)
  370. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  371. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  372. - change source download URL. <BTS:VineLinux:603>
  373. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  374. - fix CONFDIR for make install in mplayer.spec. <BTS:wishes:33>
  375. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  376. - initial build for Vine Linux.