self-build-xvidcore-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148
  1. %define pkgname xvidcore
  2. %define name self-build-%{pkgname}
  3. %define version 1.3.2
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://downloads.xvid.org/downloads/%{pkgname}-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPLv2+
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.9.9
  15. # (build)requies of target package.
  16. Requires(post): nasm >= 2.0
  17. BuildArch: noarch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. Packager: munepi
  20. %description
  21. xvidcore is the free reimplementation of the OpenDivX video codec.
  22. If you install this package, it automaticaly downloads source
  23. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  24. And the created rpm packages are automatically installed
  25. if installation is executed by apt-get command or synaptic
  26. package manager.
  27. [Note]
  28. This package requires many other packages to compile
  29. targetsoftware. So it consume more disk space than usual.
  30. Also installation takes logner time because of compilation.
  31. (This will take a few minutes to quarter or half of an hour,
  32. depends on building environment)
  33. [About self-build package]
  34. For some kind of software, distributing of binary package
  35. may viorate the patent or law. Therefore we chose self-build
  36. packge, create binary package on your machine, for such kind
  37. of softwares instead of distributing binary package.
  38. Please obey the national law when you use the created binary
  39. packages. And if you want to use the softwares using patented
  40. thechnology, it may be required to get a permission, make an
  41. agreement or purchas a license. Please consider it with your
  42. purpose or way of use and take appropriate action.
  43. %description -l ja
  44. xvidcore は OpenDivX プロジェクトによるビデオコーデックを
  45. オープンソースで開発継続されているものです。
  46. このパッケージをインストールすると、自動的にソースコードを
  47. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  48. パッケージを作成します。
  49. また apt-get コマンドや synaptic パッケージマネージャから実行
  50. した場合は、作成された rpm パッケージのインストールも自動的に
  51. 行います。
  52. [注意]
  53. コンパイルに必要な多くの関連パッケージを要求するので通常より
  54. ディスクの領域を多く消費します。
  55. またインストール時にコンパイルを行うため、通常より時間がかか
  56. る場合があります。(環境にもよりますが数分から数十分程度)
  57. [self-build パッケージについて]
  58. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  59. 違反する可能性があるものがあります。その為、このような問題が
  60. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  61. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  62. ジという方法を採っています。
  63. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  64. アのライセンス、および利用する国の各種法令に従ってください。
  65. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  66. センスの購入などが必要となる場合がありますので、利用する目的
  67. や形態に応じて各自で判断し適切な対応を取ってください。
  68. %prep
  69. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  70. %install
  71. %{__rm} -rf ${RPM_BUILD_ROOT}
  72. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  73. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  74. %clean
  75. %{__rm} -rf ${RPM_BUILD_ROOT}
  76. %posttrans
  77. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 34000
  78. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  79. %{pkgname}-devel-%{version}-%{release}
  80. %files
  81. %defattr(-,root,root)
  82. %{_datadir}/%{name}
  83. %changelog
  84. * Sat Jun 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.2-1
  85. - new upstream release
  86. - dropped upstreamed noexec stack patch
  87. * Sat Dec 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-1
  88. - added BuildArch: noarch
  89. - updated xvidcore-vl.spec
  90. - new upstream release
  91. - applied a rebase noexec-stack patch from RPM Fusion development
  92. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-4
  93. - renamed %%{Source0} to xvidcore-vl.spec
  94. * Fri Jun 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-3
  95. - dropped BuildArch: noarch
  96. (because if BuildArch: noarch, %%ifarch is invalid)
  97. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-2
  98. - added BuildArch: noarch
  99. - avoided to execute self-build-rpm.sh on RPM transaction
  100. - moved %%post actions to %%posttrans
  101. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.1-1
  102. - new upstream release
  103. - dropped xvidcore-1.1.3_bitstream.patch
  104. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-3
  105. - spec in utf8
  106. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.1.3-2
  107. - run pre-allocate-rpm.sh in %%post
  108. - set PreReq: self-build-setup >= 0.8
  109. * Fri Apr 11 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-1vl4
  110. - build with new versioning policy
  111. - apply xvidcore-1.1.3_bitstream.patch
  112. * Tue Feb 19 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.3-0vl1
  113. - initial build for Vine Linux 4.2
  114. ### end of file